Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
X.Org & Fonts
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
sidewinder
n00b
n00b


Joined: 23 Jan 2004
Posts: 4

PostPosted: Thu Apr 22, 2004 6:22 am    Post subject: X.Org & Fonts Reply with quote

I emerged X.Org after removing XFree86 & everything is fine except for the way my fonts are being rendered. My fonts look extremely sucky. At the Gnome Menu Applications -> Preferences -> Font they all look fine (in the preview window, when they're a huge size at a small size, they look bad), but in Applications like Mozilla Firefox/Thunderbird they don't render correctly. Especially the Luxi Fonts look extremely bad. Bitstream fonts look fine though, but I prefer Luxi to Bitstream.

Any ideas on how this can be rectified/corrected ? I can't actually figure out what exactly is causing the fonts ot be rendered this bad....
Back to top
View user's profile Send private message
Regor
Guru
Guru


Joined: 06 Aug 2002
Posts: 545
Location: 39° 2' 48" N, 120° 59' 2" W

PostPosted: Thu Apr 22, 2004 10:27 am    Post subject: Reply with quote

I had some font ugliness problems with xorg-x11 that were the result of using the xtt X module. Check to see if you have a line like this in your XF86Config/xorg.conf.:
Code:
Load        "xtt"


If you have such a line either remove it or comment it out and restart X.
_________________
Sometimes the appropriate response to reality is to go insane.
-Philip K. Dick, Valis
Back to top
View user's profile Send private message
Boohbah
Apprentice
Apprentice


Joined: 17 Oct 2003
Posts: 250
Location: Seattle

PostPosted: Thu Apr 22, 2004 10:41 am    Post subject: Reply with quote

I had font weirdness with xorg also, due to a change in the font directories. Check your xorg.conf and make sure your font paths start with /usr/share/fonts.
_________________
Never try to explain computers to a layman. It's easier to explain sex to a virgin.
-- Robert Heinlein

(Note, however, that virgins tend to know a lot about computers.)
Back to top
View user's profile Send private message
sidewinder
n00b
n00b


Joined: 23 Jan 2004
Posts: 4

PostPosted: Thu Apr 22, 2004 11:05 am    Post subject: Reply with quote

My font paths are all fine, coz I set them.

I'll try xtt.
Back to top
View user's profile Send private message
clar77
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 210
Location: Charm City, MD

PostPosted: Thu Apr 22, 2004 2:27 pm    Post subject: Reply with quote

I had to give a:
Code:

fc-cache -fv


as well as changing the path mentioned above after installing x.org, now I have all my fonts back :)
_________________
Pointless screenshots
My dogs :)
Back to top
View user's profile Send private message
snakattak3
Guru
Guru


Joined: 11 Dec 2002
Posts: 468
Location: Seattle

PostPosted: Fri Apr 23, 2004 7:02 am    Post subject: Reply with quote

I'm having problems too. I've emerge corefonts, sharefonts. Here is my font section in xorg.conf
Code:
    FontPath   "/usr/share/fonts/local/"
    FontPath   "/usr/share/fonts/misc/"
    FontPath   "/usr/share/fonts/75dpi/:unscaled"
    FontPath   "/usr/share/fonts/100dpi/:unscaled"
    FontPath   "/usr/share/fonts/Speedo/"
    FontPath   "/usr/share/fonts/Type1/"
    FontPath   "/usr/share/fonts/truetype/"
    FontPath   "/usr/share/fonts/freefont/"
    FontPath   "/usr/share/fonts/TTF/"
    FontPath    "/usr/share/fonts/75dpi/"
    FontPath    "/usr/share/fonts/100dpi/"
    FontPath    "/usr/share/fonts/CID/"

    #My Fonts
    FontPath   "/usr/share/fonts/ttf-bitstream-vera/"
    FontPath   "/usr/share/fonts/artwiz/"
    FontPath   "/usr/share/fonts/freefont/"
    FontPath   "/usr/share/fonts/ttf/ja/aqua"
Nothing looks out of the ordinary in /etc/fonts/fonts.conf and /etc/fonts/local.conf. But take a look at some fonts in konqueror, when before they were fine. I've also ran
Code:
fc-cache -fv
as root. I can post more, but I have no Idea where to continue. All the fonts were fine with XFree86. Also, xtt is commented out in xorg.conf
_________________
Ban Reality TV!
Adopt an Unanswered Post
Back to top
View user's profile Send private message
clar77
Apprentice
Apprentice


Joined: 02 Feb 2004
Posts: 210
Location: Charm City, MD

PostPosted: Fri Apr 23, 2004 10:53 am    Post subject: Reply with quote

are the fonts properly cached ? also did you run mkfontscale&&mkfontdir in the directory with the fonts.

This gave me headaches for a few days too.
_________________
Pointless screenshots
My dogs :)
Back to top
View user's profile Send private message
tactless
l33t
l33t


Joined: 14 Jul 2002
Posts: 642
Location: Mitzpe Adi, Israel

PostPosted: Fri Apr 23, 2004 12:12 pm    Post subject: Reply with quote

Those are the Luxi fonts with hinting turned on, which does look rather horrid. If you like hinting, use other fonts... try messing with /etc/fonts/fonts.conf to get them not to be hinted (default for xfree).
_________________
Tactless

"If it wasn't for fog, the world would run at a really crappy framerate."

Jabber: tactless@amessage.info
Back to top
View user's profile Send private message
shredz
Apprentice
Apprentice


Joined: 05 Feb 2004
Posts: 215
Location: Antwerp

PostPosted: Fri Apr 23, 2004 1:00 pm    Post subject: Reply with quote

re-emerging fontconfig and freetype fixed the problem here
Back to top
View user's profile Send private message
snakattak3
Guru
Guru


Joined: 11 Dec 2002
Posts: 468
Location: Seattle

PostPosted: Fri Apr 23, 2004 6:59 pm    Post subject: Reply with quote

Man. I've tried all that too. The Luxi fonts are still looking crappy like in that screenshot. I've given up, and have switched to another font. But please post any more suggestions. I'm always willing to give it a go.
_________________
Ban Reality TV!
Adopt an Unanswered Post
Back to top
View user's profile Send private message
fourwood
Apprentice
Apprentice


Joined: 17 May 2003
Posts: 197

PostPosted: Fri Apr 23, 2004 7:07 pm    Post subject: Reply with quote

I'm not sure if this is the same problem, but I feel bad making a new thread about XOrg font issues.

Since switching to XOrg, a few fonts have been different than usual. The only two programs I've noticed this is in Emacs and VMWare. I have screenshots of what they look like now, but since I'm no longer running XFree I can't get before shots.

http://ucsu.colorado.edu/~woodcm/emacsfont.png
http://ucsu.colorado.edu/~woodcm/vmwarefont.png

The fonts are generally bigger, and I don't think Emacs is using the same font as it used to. I've changed font paths in xorg.conf and /etc/fonts/local.conf, reemerged fontconfig and freetype, and made sure xtt wasn't being loaded, but to no avail. Does anyone know what's going on here?
Back to top
View user's profile Send private message
icedank
Apprentice
Apprentice


Joined: 15 Apr 2004
Posts: 190

PostPosted: Fri Apr 23, 2004 9:15 pm    Post subject: Reply with quote

snakattak3 wrote:

FontPath "/usr/share/fonts/ttf-bitstream-vera/"


Huh. I'm not sure, but seems that bitstream-vera is already in xorg :). You don't need separate package.
Back to top
View user's profile Send private message
snakattak3
Guru
Guru


Joined: 11 Dec 2002
Posts: 468
Location: Seattle

PostPosted: Fri Apr 23, 2004 9:31 pm    Post subject: Reply with quote

icedank wrote:
snakattak3 wrote:

FontPath "/usr/share/fonts/ttf-bitstream-vera/"


Huh. I'm not sure, but seems that bitstream-vera is already in xorg :). You don't need separate package.

Well, bitstream-vera isn't my problem. Its all the luxi fonts, and the other fonts in "/usr/share/fonts/TTF" directory. And i've done pretty much everything to get them looking right, to no avail.
_________________
Ban Reality TV!
Adopt an Unanswered Post
Back to top
View user's profile Send private message
sidewinder
n00b
n00b


Joined: 23 Jan 2004
Posts: 4

PostPosted: Mon Apr 26, 2004 6:53 pm    Post subject: Reply with quote

Yeah. Its the Luxi fonts that render badly. Especially in programs like Thunderbird & Firefox (as I've mentioned, in the Fonts Selection, they look fine)

I've tried everything mentioned, above...no avail. I've switched fonts too, hope someone can find out what's going on.
Back to top
View user's profile Send private message
j-kidd
Apprentice
Apprentice


Joined: 20 Feb 2003
Posts: 212

PostPosted: Tue Apr 27, 2004 12:25 am    Post subject: Reply with quote

icedank wrote:
snakattak3 wrote:

FontPath "/usr/share/fonts/ttf-bitstream-vera/"


Huh. I'm not sure, but seems that bitstream-vera is already in xorg :). You don't need separate package.

I found that VeraIt.ttf is missing in xorg. Does this happen to you?
Back to top
View user's profile Send private message
GenKreton
l33t
l33t


Joined: 20 Sep 2003
Posts: 828
Location: Cambridge, MA

PostPosted: Tue Apr 27, 2004 3:06 pm    Post subject: Reply with quote

none of the suggestions above have fixed luxi fonts. they work they are just really really ugly and fubar.
Back to top
View user's profile Send private message
icedank
Apprentice
Apprentice


Joined: 15 Apr 2004
Posts: 190

PostPosted: Tue Apr 27, 2004 5:46 pm    Post subject: Reply with quote

I have got another prob with fonts. When I start xfontsel and trying to select `monotype founadry` in it, X simply crashes. Probably, that's because of my `ru_RU.KOI8-R` locale...
Back to top
View user's profile Send private message
sebest
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 163
Location: Paris - France

PostPosted: Tue Apr 27, 2004 10:12 pm    Post subject: Reply with quote

i think i have the solution:
the problem is that there is 2 versions off luxi fonts: ttf and type1
the type1 are prettier.

So to fix thix you can remove the path
/usr/X11R6/lib/X11/fonts/TTF from your
/etc/fonts/local.conf (and XF86Config ?)
or just rm -rf /usr/X11R6/lib/X11/fonts/TTF

and the run as root fc-cache -vf
and check that it doesn't parse this folder /usr/X11R6/lib/X11/fonts/TTF

And now your luxi fonts should be beautifull.
_________________
--
Seb aka "Mr Est"
Back to top
View user's profile Send private message
snakattak3
Guru
Guru


Joined: 11 Dec 2002
Posts: 468
Location: Seattle

PostPosted: Tue Apr 27, 2004 11:14 pm    Post subject: Reply with quote

sebest wrote:
i think i have the solution:
the problem is that there is 2 versions off luxi fonts: ttf and type1
the type1 are prettier.

So to fix thix you can remove the path
/usr/X11R6/lib/X11/fonts/TTF from your
/etc/fonts/local.conf (and XF86Config ?)
or just rm -rf /usr/X11R6/lib/X11/fonts/TTF

and the run as root fc-cache -vf
and check that it doesn't parse this folder /usr/X11R6/lib/X11/fonts/TTF

And now your luxi fonts should be beautifull.

Oh how I wish that worked for me :( The /usr/X11R6/lib/X11/fonts/TTF is a symlink to /usr/share/fons/TTF on my system. Besides, before I even installed xorg, i removed almost every directory and file that came with X11, including the /usr/X11R6/lib/X11/fonts directory. I also don't have any luxi fonts in the Type1 directory. Should I?
_________________
Ban Reality TV!
Adopt an Unanswered Post
Back to top
View user's profile Send private message
sebest
Apprentice
Apprentice


Joined: 03 Jul 2002
Posts: 163
Location: Paris - France

PostPosted: Tue Apr 27, 2004 11:32 pm    Post subject: Reply with quote

luxi font type1 are called l04*.pfa
(example l048016t.pfa)

try fc-list | grep Luxi
_________________
--
Seb aka "Mr Est"
Back to top
View user's profile Send private message
slestak
Tux's lil' helper
Tux's lil' helper


Joined: 13 Jun 2003
Posts: 115

PostPosted: Wed Apr 28, 2004 1:35 am    Post subject: Reply with quote

sebest wrote:
i think i have the solution:
the problem is that there is 2 versions off luxi fonts: ttf and type1
the type1 are prettier.
.


This was my problem, ty so much man.
Back to top
View user's profile Send private message
snakattak3
Guru
Guru


Joined: 11 Dec 2002
Posts: 468
Location: Seattle

PostPosted: Wed Apr 28, 2004 5:30 am    Post subject: Reply with quote

sebest wrote:
luxi font type1 are called l04*.pfa
(example l048016t.pfa)

try fc-list | grep Luxi

Awesome. I just removed /usr/share/fonts/TTF and it works! Thanks, and thanks to everyone else for there suggestions.
_________________
Ban Reality TV!
Adopt an Unanswered Post
Back to top
View user's profile Send private message
GenKreton
l33t
l33t


Joined: 20 Sep 2003
Posts: 828
Location: Cambridge, MA

PostPosted: Thu Apr 29, 2004 4:28 am    Post subject: Reply with quote

amazing, you have NO idea HOW much I owe you for that tip. Bitstream drives me crazy...
Back to top
View user's profile Send private message
smn
n00b
n00b


Joined: 24 Jan 2004
Posts: 68
Location: Vienna, Austria

PostPosted: Thu Apr 29, 2004 6:26 pm    Post subject: Reply with quote

i tried every hint in here, nothing helps, my fonts still look like shit.
when i change rendering options in gnome font setup, nothing changes all options look the same, same for changes in hinting (except "none", whcih looks totaly fucked up) :\

btw can someone pls post a sample /etc/fonts/local.conf, mine looks like this (i have no clue how to set it up):
Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>
<!--
  Enable sub-pixel rendering
        <match target="font">
                <edit name="rgba" mode="assign"><const>rgb</const></edit>
        </match>
-->
</fontconfig>

edit: nm, found one here, gonna give it a try...
tia
Back to top
View user's profile Send private message
bengi
n00b
n00b


Joined: 11 Nov 2003
Posts: 67
Location: East Sussex, UK

PostPosted: Tue May 04, 2004 12:25 pm    Post subject: Reply with quote

Wow thanks guys, deleting /usr/share/fonts/TTF and rebooting sorted out font issues for me.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum