Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Porthole-0.3 Released!
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Gentoo Chat
View previous topic :: View next topic  
Author Message
dgt84
Guru
Guru


Joined: 27 May 2003
Posts: 355
Location: Germany => USA

PostPosted: Tue Mar 30, 2004 10:55 pm    Post subject: Porthole-0.3 Released! Reply with quote

Hello!

:!: Porthole has just reached version 0.3!
Porthole is a GTK-based frontend for Portage. It features a hierarchial view of packages and supports fast searches and dependency calculations. Porthole also supports basic emerge features (emerge, unmerge, sync, and upgrades).

Porthole is written in Python and is partially based on an earlier program called gportage, which has been discontinued in favour of Porthole.

Ebuilds can be found on the Porthole website. :wink:

A changelog can be found here!

As always, comments and bug reports are welcome!

Special thanks to everyone that was involved!
_________________
Lila themes | The Porthole Portage Frontend | SVG-Utils
Back to top
View user's profile Send private message
Jowilly
Guru
Guru


Joined: 22 Jun 2002
Posts: 319

PostPosted: Tue Mar 30, 2004 11:24 pm    Post subject: Reply with quote

Great ! :D
Back to top
View user's profile Send private message
charlieg
Advocate
Advocate


Joined: 30 Jul 2002
Posts: 2149
Location: Manchester UK

PostPosted: Wed Mar 31, 2004 1:26 am    Post subject: Reply with quote

Awesome. 8)
_________________
Want Free games?
Free Gamer - open source games list & commentary

Open source web-enabled rich UI platform: Vexi
Back to top
View user's profile Send private message
Genone
Retired Dev
Retired Dev


Joined: 14 Mar 2003
Posts: 9011
Location: beyond the rim

PostPosted: Wed Mar 31, 2004 6:01 am    Post subject: Reply with quote

Could you please fix bug 924100? It's one of the things that's stopping me from unmasking it.
Back to top
View user's profile Send private message
Pink
Veteran
Veteran


Joined: 24 Jul 2003
Posts: 1062

PostPosted: Wed Mar 31, 2004 7:46 am    Post subject: Reply with quote

Yeah!! Sync works, upgrade works - great job guys - I'm sure it's pure laziness doing it this way but what a great app :D

Huge difference from 0.2
Back to top
View user's profile Send private message
dgt84
Guru
Guru


Joined: 27 May 2003
Posts: 355
Location: Germany => USA

PostPosted: Wed Mar 31, 2004 7:56 am    Post subject: Reply with quote

Genone wrote:
Could you please fix bug 924100? It's one of the things that's stopping me from unmasking it.

Check out this commit from TiredOldCoder a few days before we released. It seems to be fixed, but we forgot to change the bug. I've set it's resolution to fixed but kept it open; I'll close it when I get confirmation from you that this is satisfactory.
_________________
Lila themes | The Porthole Portage Frontend | SVG-Utils
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2867
Location: Omnipresent

PostPosted: Wed Mar 31, 2004 8:24 am    Post subject: Reply with quote

Hmm, I get the following error:

Code:
Traceback (most recent call last):
  File "/usr/bin/porthole", line 41, in ?
    import utils
  File "/usr/lib/porthole/utils.py", line 32, in ?
    import datetime
ImportError: No module named datetime

A missing dependency? Too old python (2.2.3)?
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
ed0n
l33t
l33t


Joined: 23 Apr 2003
Posts: 638
Location: Prishtine/Kosove

PostPosted: Wed Mar 31, 2004 8:39 am    Post subject: Reply with quote

Code:

Traceback (most recent call last):
  File "/usr/bin/porthole", line 40, in ?
    import utils
  File "/usr/lib/porthole/utils.py", line 36, in ?
    from xmlmgr import XMLManager, XMLManagerError
  File "/usr/lib/porthole/xmlmgr.py", line 63, in ?
    from xml.dom.ext import PrettyPrint
ImportError: No module named ext

Am I missing another dependency?
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2541
Location: Richmond, BC, Canada

PostPosted: Wed Mar 31, 2004 8:52 am    Post subject: Reply with quote

From what I could find on my machine, python-2.2 does not have that lib module. look in the :

/usr/lib/python2.2/lib-dynload directory.

It does not show up there in mine, but it is included in:

/usr/lib/python-2.3/lib-dynload directory.

It looks like we need to up the python dependancy to version 2.3

That module is used in the build time estimating feature that has been added to porthole-0.3. It is one of the many features added this release. To see it set the pretend menu option then emerge a package that is already installed. It uses the recorded times from the emerge logs to estimate emerging any package upgrades. It provides fairly accurate results because the times used are the actual times it took to emerge the package on your machine previously. Most package upgrades do not differ greatly in build times.

Sorry, it can not estimate packages never before merged on your system.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
dgt84
Guru
Guru


Joined: 27 May 2003
Posts: 355
Location: Germany => USA

PostPosted: Wed Mar 31, 2004 9:30 am    Post subject: Reply with quote

Go ahead and try emerging Python-2.3 and if that fixes the problem, I will update the ebuilds. If you can't upgrade, or don't want to, let me know and maybe we can add some exception handling code so that it still works with older versions of Python.
I don't want to update the ebuild until we know what is causing both of the problems above.
_________________
Lila themes | The Porthole Portage Frontend | SVG-Utils
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2867
Location: Omnipresent

PostPosted: Wed Mar 31, 2004 11:21 am    Post subject: Reply with quote

dgt84 wrote:
Go ahead and try emerging Python-2.3 and if that fixes the problem, I will update the ebuilds. If you can't upgrade, or don't want to, let me know and maybe we can add some exception handling code so that it still works with older versions of Python.
I don't want to update the ebuild until we know what is causing both of the problems above.

Upgrading to 2.3.x fixes the "datetime" problem, and then running "/usr/sbin/python-updater" fixes the XML module problem.
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
ed0n
l33t
l33t


Joined: 23 Apr 2003
Posts: 638
Location: Prishtine/Kosove

PostPosted: Wed Mar 31, 2004 11:43 am    Post subject: Reply with quote

Hypnos wrote:
"/usr/sbin/python-updater"


I don't have that file.
Back to top
View user's profile Send private message
Hypnos
Advocate
Advocate


Joined: 18 Jul 2002
Posts: 2867
Location: Omnipresent

PostPosted: Wed Mar 31, 2004 11:48 am    Post subject: Reply with quote

ed0n wrote:
Hypnos wrote:
"/usr/sbin/python-updater"


I don't have that file.

It's in the newest ebuilds of Python 2.3.x ...
_________________
Personal overlay | Simple backup scheme
Back to top
View user's profile Send private message
ed0n
l33t
l33t


Joined: 23 Apr 2003
Posts: 638
Location: Prishtine/Kosove

PostPosted: Wed Mar 31, 2004 1:16 pm    Post subject: Reply with quote

I reemerged the python-3.3 and ran portage-updater but it still doesn't work:

Code:

Traceback (most recent call last):
  File "/usr/bin/porthole", line 40, in ?
    import utils
  File "/usr/lib/porthole/utils.py", line 43, in ?
    import pygtk; pygtk.require("2.0") # make sure we have the right version
  File "/usr/lib/python2.3/site-packages/pygtk.py", line 47, in require
    versions = _get_available_versions()
  File "/usr/lib/python2.3/site-packages/pygtk.py", line 34, in _get_available_versions
    for filename in os.listdir(dir):
OSError: [Errno 2] No such file or directory: '/usr/lib/python23.zip'
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2541
Location: Richmond, BC, Canada

PostPosted: Wed Mar 31, 2004 2:00 pm    Post subject: Reply with quote

what is the
Code:
emerge -pv python
output show for use flag settings?
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
ed0n
l33t
l33t


Joined: 23 Apr 2003
Posts: 638
Location: Prishtine/Kosove

PostPosted: Wed Mar 31, 2004 2:14 pm    Post subject: Reply with quote

Code:

[ebuild   R   ] dev-lang/python-2.3.3  +X +berkdb -bootstrap -build -doc +gdbm -ipv6 +ncurses +readline +ssl +tcltk -ucs2  0 kB
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2541
Location: Richmond, BC, Canada

PostPosted: Wed Mar 31, 2004 2:26 pm    Post subject: Reply with quote

that's the same as I have.

done some more checking... it is not installed by python2.3, a
Code:
qpkg -f /usr/lib/python23.zip
turns up nothing, looking at the /usr/lib dir in nautilus, it does not show up. BUT it shows in the python path browser in idle????? It isn't openable either.

got me on that one

in a terminal type "idle", then in the file menu click path browser, sounds like it won't be there. But check.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
ed0n
l33t
l33t


Joined: 23 Apr 2003
Posts: 638
Location: Prishtine/Kosove

PostPosted: Wed Mar 31, 2004 6:15 pm    Post subject: Reply with quote

Reemerging pygtk made it work.

Thanks.
Back to top
View user's profile Send private message
IWBCMAN
Guru
Guru


Joined: 25 Jun 2002
Posts: 474

PostPosted: Fri Apr 02, 2004 9:48 pm    Post subject: Reply with quote

I too had to reemerge pygtk to get porthole running-it seeems to work ok-but when I try to "Run Custom Command" this is the rror message that appears-no window opens up....
I checked to see if the porhole.glade file was actually installed-it is, it is in /usr/share/porthole.....

Code:

 
** (porthole:14476): WARNING **: `GtkTextSearchFlags' is not an enum type
 
(porthole:14476): libglade-WARNING **: could not find glade file 'porthole.glade'
Traceback (most recent call last):
  File "/usr/lib/porthole/mainwindow.py", line 593, in custom_run
    get_command = RunDialog(self.prefs, self.setup_command)
  File "/usr/lib/porthole/command.py", line 35, in __init__
    self.wtree = gtk.glade.XML(self.gladefile, "run_dialog")
RuntimeError: could not create GladeXML object
 


EDIT:

I just edited

/usr/lib/porthole/command.py

and changed "porthole.glade"

to

"/usr/share/porthole/porthole.glade"

and now the dialog comes up.....unfortunately I don't know python-I haven't programmed anything in 15 years-but this little hack seems to work-but it's probably not good hard-coding the path like that.....
Back to top
View user's profile Send private message
dgt84
Guru
Guru


Joined: 27 May 2003
Posts: 355
Location: Germany => USA

PostPosted: Fri Apr 02, 2004 11:18 pm    Post subject: Reply with quote

Okay, good feedback so far :)
I think tomorrow I will make a porthole-0.3-r1 ebuild with updated deps and a patch to fix the above problem.
_________________
Lila themes | The Porthole Portage Frontend | SVG-Utils
Back to top
View user's profile Send private message
bicolao
n00b
n00b


Joined: 05 Jan 2004
Posts: 50

PostPosted: Sat Apr 03, 2004 7:54 am    Post subject: Reply with quote

One thing i would like to see in porthole is that when you emerge a package, porthole allows you to select which USE flags you like ;)
_________________
Bi Cờ Lao
Back to top
View user's profile Send private message
dgt84
Guru
Guru


Joined: 27 May 2003
Posts: 355
Location: Germany => USA

PostPosted: Sat Apr 03, 2004 9:24 am    Post subject: Reply with quote

bicolao wrote:
One thing i would like to see in porthole is that when you emerge a package, porthole allows you to select which USE flags you like ;)

We have this planned, but can you think of a good interface for it? We need something that's easy to use, not too complicated, and it needs to fit in well with the rest of Porthole :?:

About the bug above, it's a one-liner. To fix it, change line 34 in /usr/lib/porthole/command.py to say this:
Code:
        self.gladefile = prefs.DATA_PATH + "porthole.glade"

I'm going to work on the ebuild now and try to update the Porthole site and submit the updated ebuild to bugs.gentoo.org.
_________________
Lila themes | The Porthole Portage Frontend | SVG-Utils
Back to top
View user's profile Send private message
metnik
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 167
Location: Italia

PostPosted: Sat Apr 03, 2004 12:42 pm    Post subject: Reply with quote

I tried to emerge gnome-vfs-sftp-0.1.2 with Porthole, but It writes some errors..

000005 /usr/sbin/ebuild.sh: line 13: rm: command not found
...
000151 ./usr/share/doc/gnome-vfs-sftp-0.1.2/AUTHORS.gz
000152 ./usr/share/doc/gnome-vfs-sftp-0.1.2/ChangeLog.gz
000153 >>> Done.
000154 >>> extracting info
000155 >>> extracting gnome-vfs-sftp-0.1.2
000156 [gnome-vfs-sftp-0.1.2] bash: line 1: bzip2: command not found
000157 [gnome-vfs-sftp-0.1.2] bash: line 1: tar: command not found
000158 !!! Error extracting /usr/portage/packages/All/gnome-vfs-sftp-0.1.2.tbz2
000159 *** process terminated ***

but with emerge everything works
_________________
<? L'esperto è colui che sa sempre più cose di un argomento sempre più ristretto; fino a sapere tutto di nulla ?>
Back to top
View user's profile Send private message
dol-sen
Developer
Developer


Joined: 30 Jun 2002
Posts: 2541
Location: Richmond, BC, Canada

PostPosted: Sat Apr 03, 2004 4:11 pm    Post subject: Reply with quote

I just emerged it fine with porthole, running it local mode.

How did you run porthole? How did you set it to emerge -- did you use the "Run Custom Command" dialog & ACCEPT_KEYWORDS= , or did you add the pkg to your package.unmask file?


BTW. for those that have not looked, in the run dialog popdown list for the command line. I have created a few persistent history items that contain some pretyped emerge variations for ACCEPT_KEYWORDS= & USE= that just need a little editing and filling in the blanks, but should save some typing. We will (I think) in the future create a configuration window that will allow you to set the default values for those persistent history items among other things. In the meantime, if you are on a different arch you will need to edit the /root/.porthole/prefs.xml file and change it to your arch & it will persist with your changes.
_________________
Brian
Porthole, the Portage GUI frontend irc@freenode: #gentoo-guis, #porthole, Blog
layman, gentoolkit, CoreBuilder, esearch...
Back to top
View user's profile Send private message
spb
Retired Dev
Retired Dev


Joined: 02 Jan 2004
Posts: 2135
Location: Cambridge, UK

PostPosted: Sat Apr 03, 2004 7:50 pm    Post subject: Reply with quote

Slight problem: it needs PyXML, but the ebuild doesn't know that.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo Chat All times are GMT
Goto page 1, 2, 3, 4, 5  Next
Page 1 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum