Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems emerging svgalib-1.9.17-r3
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
luizferp
n00b
n00b


Joined: 27 Jan 2004
Posts: 52
Location: Campinas, Brasil

PostPosted: Fri Jan 30, 2004 11:29 am    Post subject: problems emerging svgalib-1.9.17-r3 Reply with quote

Hi people,

Yesterday I tried to emerge kde and a problem occurred during the svgalib emerge. I don't know what can it be. I already emerged the linux-headers an the problems persists.

Code:

...
!!! ERROR: media-libs/svgalib-1.9.17-r3 failed.
!!! Function src_compile, Line 59, Exitcode 2
!!! Failed to build kernel module!


Does anybody knows what is happening?

Thanks.
Back to top
View user's profile Send private message
n3bul4
Apprentice
Apprentice


Joined: 04 Nov 2003
Posts: 173

PostPosted: Fri Jan 30, 2004 1:29 pm    Post subject: emerge problems Reply with quote

Maybe you haven't got the link /usr/src/linux pointing to your current kernel version. hope that helps
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1077
Location: Buchholz/GER

PostPosted: Sun Feb 01, 2004 9:18 am    Post subject: Reply with quote

Same problem here and a correct symlink linux -> /usr/src/linux-2.4.24 doesn't solve this problem.
What else can we do?
Back to top
View user's profile Send private message
cajzell
Apprentice
Apprentice


Joined: 07 Jan 2004
Posts: 176
Location: Falkenberg, Sweden

PostPosted: Sun Feb 01, 2004 10:40 am    Post subject: Reply with quote

Hello,

I had problem with this and resolved it by commenting out the following line in

/usr/portage/media-libs/svgalib/svgalib-1.9.17-r3.ebuild

# Get it to work with kernel 2.6
# epatch ${FILESDIR}/${P}-linux2.6.patch


Best Regards,

Caj Zell
Back to top
View user's profile Send private message
cryptosteve
Veteran
Veteran


Joined: 04 Jan 2004
Posts: 1077
Location: Buchholz/GER

PostPosted: Sun Feb 01, 2004 10:52 am    Post subject: Reply with quote

I solved the problem with installing kernel 2.6.2rc3 and recompile svgalib .. 8O
Back to top
View user's profile Send private message
walrusjuice
n00b
n00b


Joined: 02 Feb 2004
Posts: 3

PostPosted: Mon Feb 02, 2004 3:27 am    Post subject: Reply with quote

Apparently the problem comes from not having the kernel sources installed. I ran into the same problem while emerging KDE... then I installed the sources (gentoo-2.4.20-r6) with the same bad results, but then I recompiled the kernel and emerging svgalib worked flawlessly.
I think that the process of compiling the kernel creates some files that svgalib needs to compile.

Cheers.
Back to top
View user's profile Send private message
rryjew
n00b
n00b


Joined: 06 Feb 2004
Posts: 10

PostPosted: Sun Feb 08, 2004 2:03 pm    Post subject: How do I install the kernel sources? Reply with quote

walrusjuice wrote:
Apparently the problem comes from not having the kernel sources installed. I ran into the same problem while emerging KDE... then I installed the sources (gentoo-2.4.20-r6) with the same bad results, but then I recompiled the kernel and emerging svgalib worked flawlessly.
I think that the process of compiling the kernel creates some files that svgalib needs to compile.

Cheers.


I'm having the same problem when I try emerge KDE. Could you give me a step-by-step on how to fix this that a noob could follow.

Thanks dude.
Back to top
View user's profile Send private message
MasquedAvenger
Guru
Guru


Joined: 21 Aug 2003
Posts: 558
Location: Southern California

PostPosted: Sat Feb 14, 2004 12:43 am    Post subject: Reply with quote

Quote:
Hello,

I had problem with this and resolved it by commenting out the following line in

/usr/portage/media-libs/svgalib/svgalib-1.9.17-r3.ebuild

# Get it to work with kernel 2.6
# epatch ${FILESDIR}/${P}-linux2.6.patch



Correction: You must also comment out the modversions-h patch. Otherwise, that patch will fail to apply due to the lack of the patch you describe above, causing the emerge process to abort.

James
Back to top
View user's profile Send private message
gollum
n00b
n00b


Joined: 18 May 2002
Posts: 18

PostPosted: Thu Feb 19, 2004 9:57 am    Post subject: Reply with quote

In: /usr/portage/media-libs/svgalib/svgalib-1.9.17-r3.ebuild
Commented out:
Code:

        # Get it to work with kernel 2.6
#        epatch ${FILESDIR}/${P}-linux2.6.patch

        # Get modversions.h include right if we have CONFIG_MODVERSIONS set.
#        epatch ${FILESDIR}/${P}-modversions_h.patch

and it works perfect.

Thanks folks!
Back to top
View user's profile Send private message
mrcottonmouth
n00b
n00b


Joined: 12 Sep 2003
Posts: 8

PostPosted: Tue Feb 24, 2004 4:05 pm    Post subject: Thank you!!!! Reply with quote

Thank you!!!! Now it works. :D
Back to top
View user's profile Send private message
mrcottonmouth
n00b
n00b


Joined: 12 Sep 2003
Posts: 8

PostPosted: Tue Feb 24, 2004 4:07 pm    Post subject: Opps, not working Reply with quote

I spoke too soon, it failed. :cry:

In file included from main.c:18:
kernel25compat.h:1:1: warning: "minor" redefined
In file included from /usr/src/linux/include/linux/fs.h:16,
from /usr/src/linux/include/linux/capability.h:17,
from /usr/src/linux/include/linux/binfmts.h:6,
from /usr/src/linux/include/linux/sched.h:9,
from /usr/src/linux/include/linux/mm.h:22,
from /usr/src/linux/include/linux/slab.h:14,
from main.c:4:
/usr/src/linux/include/linux/kdev_t.h:81:1: warning: this is the location of the previous definition
make: *** [.depend] Error 1
make: Leaving directory `/var/tmp/portage/svgalib-1.9.17-r3/work/svgalib-1.9.17/kernel/svgalib_helper'

!!! ERROR: media-libs/svgalib-1.9.17-r3 failed.
!!! Function src_compile, Line 59, Exitcode 2
!!! Failed to build kernel module!
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3680
Location: London, UK

PostPosted: Tue Feb 24, 2004 6:56 pm    Post subject: Reply with quote

negative.. above solution didn't help... any hint?

[edit] I'm using gentoo-dev-sources 2.6.3-r1 and linux-headers-2.6.3-r1
this is my portage info:
Code:
Portage 2.0.50-r1 (default-x86-1.4, gcc-3.3.2, glibc-2.3.2-r9, 2.6.3-gentoo-r1)
=================================================================
System uname: 2.6.3-gentoo-r1 i686 Intel(R) Pentium(R) III Mobile CPU      1133MHz
Gentoo Base System version 1.4.3.13
Autoconf: sys-devel/autoconf-2.58-r1
Automake: sys-devel/automake-1.7.7
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-O3 -march=pentium3 -pipe -fomit-frame-pointer -fprefetch-loop-arrays -falign-functions=4 -fforce-addr"
CHOST="i686-pc-linux-gnu"
COMPILER="gcc3"
CONFIG_PROTECT="/etc /usr/X11R6/lib/X11/xkb /usr/kde/2/share/config /usr/kde/3/share/config /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
CXXFLAGS="-O3 -march=pentium3 -pipe -fomit-frame-pointer -fprefetch-loop-arrays -falign-functions=4 -fforce-addr"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs ccache sandbox"
GENTOO_MIRRORS="http://212.219.247.17/sites/www.ibiblio.org/gentoo/ http://212.219.247.16/sites/www.ibiblio.org/gentoo/ ftp://gentoo.inode.at/source/ http://gentoo.inode.at/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X aalib acpi acpi4linux alsa apache2 apm avi berkdb cdr crypt cups directfb dvd encode fbcon foomaticdb gdbm gif gimpprint gpm gtk gtk2 guile i8x0 icq imlib java jpeg libg++ libwww mad matrox mikmod mmx motif moznocompose moznoirc moznomail moznoxft mpeg mysql ncurses nls oggvorbis opengl oss pam pcmcia pdflib perl pic png pnp python qt quicktime radeon readline samba sdl slang spell sse ssl svg svga tcpd tiff truetype type1 unicode usb video_cards_radeon vim-with-x wxwindows x86 xinerama xml2 xmms xv zlib"


I searched bugs.gentoo.org and finded this: http://bugs.gentoo.org/show_bug.cgi?id=37812 but the patch won't apply giving me this output:
Code:
 * Applying kernel-headers26-compile.patch...

 * Failed Patch: kernel-headers26-compile.patch!
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/svgalib-1.9.17-r3/temp/kernel-headers26-compile.patch-10706.out


!!! ERROR: media-libs/svgalib-1.9.17-r3 failed.
!!! Function epatch, Line 322, Exitcode 0
!!! Failed Patch: kernel-headers26-compile.patch!

if anyone wants I'll open a bug otherwise I'll let my output viewable... let me know...
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
jdeca57
n00b
n00b


Joined: 20 Nov 2003
Posts: 3

PostPosted: Tue Feb 24, 2004 9:35 pm    Post subject: Reply with quote

I found that (re)compiling the actual kernel you use solved the problem. Nothing to do with sources, just compile the kernel. (see also an earlier post)
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3680
Location: London, UK

PostPosted: Wed Feb 25, 2004 12:06 am    Post subject: Reply with quote

I did recompile the actual kernel and tried to emerge svgalibs (without the kernel patch!) but the result is this:

Code:
...
make: Entering directory `/var/tmp/portage/svgalib-1.9.17-r3/work/svgalib-1.9.17/kernel/svgalib_helper'
rm -f *.ko *.o *~ core .depend *.bak *.orig
gcc -O2 -DLINUX -Dlinux -D__KERNEL__ -DMODULE  -nostdinc -iwithprefix include -DKBUILD_MODNAME="svgalib_helper" -I/var/tmp/portage/svgalib-1.9.17-r3/work/svgalib-1.9.17/kernel/svgalib_helper/include -I. -I/usr/src/linux/include -I/usr/src/linux/include/asm/mach-default -DSVGALIB_HELPER_MAJOR=209 -DMODVERSIONS -include /usr/src/linux/include/config/modversions.h -M *.c > .depend
In file included from main.c:24:
kernel26compat.h:5:40: missing binary operator before token "("
main.c:430:41: missing binary operator before token "("
main.c:442:41: missing binary operator before token "("
main.c:451:41: missing binary operator before token "("
make: *** [.depend] Error 1
make: Leaving directory `/var/tmp/portage/svgalib-1.9.17-r3/work/svgalib-1.9.17/kernel/svgalib_helper'

!!! ERROR: media-libs/svgalib-1.9.17-r3 failed.
!!! Function src_compile, Line 61, Exitcode 2
!!! Failed to build kernel module!



and with the kernel patch:

Code:
...
 * Applying kernel-headers26-compile.patch...

 * Failed Patch: kernel-headers26-compile.patch!
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/svgalib-1.9.17-r3/temp/kernel-headers26-compile.patch-16180.out


!!! ERROR: media-libs/svgalib-1.9.17-r3 failed.
!!! Function epatch, Line 322, Exitcode 0
!!! Failed Patch: kernel-headers26-compile.patch!



thanks anyway :(
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
rmorszeck
n00b
n00b


Joined: 05 Jan 2004
Posts: 74

PostPosted: Sat Feb 28, 2004 10:39 am    Post subject: Reply with quote

gollum wrote:
In: /usr/portage/media-libs/svgalib/svgalib-1.9.17-r3.ebuild
Commented out:
Code:

        # Get it to work with kernel 2.6
#        epatch ${FILESDIR}/${P}-linux2.6.patch

        # Get modversions.h include right if we have CONFIG_MODVERSIONS set.
#        epatch ${FILESDIR}/${P}-modversions_h.patch

and it works perfect.

Thanks folks!


Thx, this work perfect. Befor can't emerge xine-ui :)
_________________
All Systems with Gnome & Ethernet-Cards:
GentooLinux2005.1 (stage2, gentoo-dev-sources 2.6.12-r8), AthlonXP 2600+ DDR333/1024MB, NVidia5200@128MB
Back to top
View user's profile Send private message
atomical
n00b
n00b


Joined: 18 Jan 2004
Posts: 18
Location: Dresden

PostPosted: Wed Mar 03, 2004 11:46 am    Post subject: Reply with quote

jdeca57 wrote:
I found that (re)compiling the actual kernel you use solved the problem. Nothing to do with sources, just compile the kernel. (see also an earlier post)


This worked for me.
_________________
mfg, atomical
Back to top
View user's profile Send private message
GojiraST
n00b
n00b


Joined: 14 Mar 2003
Posts: 41
Location: Florida

PostPosted: Thu Mar 04, 2004 1:58 pm    Post subject: Reply with quote

I've done a recompile of kernel, and tried commenting out those lines in the ebuild, and I still get !!!

Code:

ERROR: media-libs/svgalib-1.9.17-r3 failed.
!!! Function src_compile, Line 59, Exitcode 2
!!! Failed to build kernel module!


This is with 2.6.3-gentoo-r1 SMP
Back to top
View user's profile Send private message
curmudgeon
Veteran
Veteran


Joined: 08 Aug 2003
Posts: 1354

PostPosted: Thu Mar 04, 2004 2:45 pm    Post subject: Reply with quote

Sorry to ask the really stupid question, but do you have
"Enable loadable module support" selected in your kernel
configuration?
Back to top
View user's profile Send private message
fuzzman
n00b
n00b


Joined: 04 Mar 2004
Posts: 1

PostPosted: Thu Mar 04, 2004 7:43 pm    Post subject: Reply with quote

I've been troubleshooting this all day. I'm also running 2.6.3 (did self compile-no genkernel).
Yes. "Enable loadable module support" is enabled.
I've tried using the source code to compile it manually with the same errors:

"In file included from main.c:24:
kernel26compat.h:5:40: missing binary operator before token "("
main.c:430:41: missing binary operator before token "("
main.c:442:41: missing binary operator before token "("
main.c:451:41: missing binary operator before token "("
make: *** [.depend] Error 1
make: Leaving directory `/var/tmp/portage/svgalib-1.9.17-r3/work/svgalib-1.9.17/kernel/svgalib_helper'

!!! ERROR: media-libs/svgalib-1.9.17-r3 failed.
!!! Function src_compile, Line 59, Exitcode 2
!!! Failed to build kernel module!

When building svgalibs from their website's code, I've encountered a different error pertaining to /lib/modules/2.6.3/build/include/asm/irq_vector.h not being found. I've ls'd and sure enough its not there. Recompiling kernel now to see if I've missed something
there. Any thoughts?

*edit: Try installing svgalibs-1.4.3-r4. It installed without any problems and kdemultimedia is now going on with the rest of the emerge.*
Back to top
View user's profile Send private message
GojiraST
n00b
n00b


Joined: 14 Mar 2003
Posts: 41
Location: Florida

PostPosted: Thu Mar 04, 2004 11:04 pm    Post subject: Reply with quote

Quote:
*edit: Try installing svgalibs-1.4.3-r4. It installed without any problems and kdemultimedia is now going on with the rest of the emerge.*


That did it. system doesn't want to upgrade to the apparent bad package either...

I'm able to emerge gnomemeeting and xine-ui as well now without any attempt to install the broken svgalib.

Thanks!
Back to top
View user's profile Send private message
Baruch
n00b
n00b


Joined: 04 Mar 2004
Posts: 4

PostPosted: Fri Mar 05, 2004 8:30 am    Post subject: Reply with quote

I have the same problem with gentoo-dev-sources (kernel 2.6.x), compiled with genkernel.
When trying to:
Code:
USE="bindist" emerge --usepkg kde

the same error with svgalib-1.9.17-r3 appears.

Any suggestion for newbies (= some steps to follow as workaround)?

(This seems to be a solved bug in Bugzilla Bug 40033 but the discussion is quite *difficult*. Does the last comment solve the problem? And after the modification what should we do?)

Thanks!
Back to top
View user's profile Send private message
zeek
Guru
Guru


Joined: 16 Nov 2002
Posts: 478
Location: Bantayan Island

PostPosted: Sat Mar 06, 2004 2:19 am    Post subject: Reply with quote

I had a similar problem and used the:
Code:
USE=build emerge svgalib

workaround.
Back to top
View user's profile Send private message
Baruch
n00b
n00b


Joined: 04 Mar 2004
Posts: 4

PostPosted: Wed Mar 10, 2004 2:43 pm    Post subject: Reply with quote

The workaround works perfectly.

Thank you.

Code:
USE=build emerge svgalib
Back to top
View user's profile Send private message
dacoool
n00b
n00b


Joined: 06 Oct 2003
Posts: 73

PostPosted: Wed Mar 10, 2004 8:43 pm    Post subject: Reply with quote

How can i emerge svgalib-1.4.3-r4 ??
emerge svgalib-1.4.3-r4 won't work


Quote:

The workaround works perfectly.

Thank you.
Quote:

USE=build emerge svgalib




THIS SOLUTION WORKS FINE WITH gentoo-2.6.3-dev-r1 & svgalib-1.9.17-r3 !!!

THANKS
_________________
just me....
Back to top
View user's profile Send private message
chimera26
n00b
n00b


Joined: 24 Mar 2004
Posts: 6

PostPosted: Wed Mar 24, 2004 3:14 pm    Post subject: Reply with quote

Quote:
USE=build emerge svgalib


Worked for me, too!

Thanks!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum