Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qmail User_over_quota._(#5.1.1)/
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
x-router.com
n00b
n00b


Joined: 27 Aug 2003
Posts: 17
Location: UK

PostPosted: Wed Jan 14, 2004 9:44 am    Post subject: qmail User_over_quota._(#5.1.1)/ Reply with quote

This has been driving me insane for days...

I've fresh installed qmail. Added fast forward. Created a local user called 'richard' added a .maildir chown'ed richard:users chmoded drwxr-xr-x

Mail delivery seems to be going fine but I always get a reject:

Code:

@4000000040041ab51018819c new msg 1403936
@4000000040041ab510189cf4 info msg 1403936: bytes 184 from <richard@x-router.com> qp 26948 uid 201
@4000000040041ab511c946ac starting delivery 35: msg 1403936 to local richard@businesswebsite.com
@4000000040041ab511c969d4 status: local 1/10 remote 0/20
@4000000040041ab51219cbf4 delivery 35: failure: User_over_quota._(#5.1.1)/


I don't have quotas on the file system (although I will want them later on) and as user 'richard' I can create files etc in that dir. If I remove the .maildir then delivery fails with a different error..

All the alias fast forwarding works fine, it's only local deliver that fails

My config files: (I've had to cut a lot of crap out as there are about 1000 domains. I'm trying to convert my sendmail cluster over)

Code:

uber qmail # cat rc
#!/bin/sh
 
exec env - PATH="/var/qmail/bin:$PATH" \
        qmail-start "`grep -v '^#' /var/qmail/control/defaultdelivery`"

uber control # cat me
uber.whitehorse.co.uk

uber control # cat locals | grep business
businesswebsite.net
businesswebsite.co.uk
businesswebsite.com
businesswebsite.tv
businesswebsite.info
businesswebsite.biz
centralbusinessagency.co.uk
centralbusinessagency.com

uber control # cat rcpthosts | grep business
businesswebsite.net
businesswebsite.co.uk
businesswebsite.com
businesswebsite.tv
businesswebsite.info
businesswebsite.biz
centralbusinessagency.co.uk
centralbusinessagency.com

uber control # cat defaultdelivery
# Uncomment the next line for .forward support
#|dot-forward .forward
./.maildir/

uber alias # cat .qmail-default
|fastforward -d /etc/aliases.cdb


Any help will be very welcome.[/code]
Back to top
View user's profile Send private message
x-router.com
n00b
n00b


Joined: 27 Aug 2003
Posts: 17
Location: UK

PostPosted: Wed Jan 14, 2004 10:45 am    Post subject: Reply with quote

Think I have figured it out.

Because I created the user dir before I installed qmail the /etc/skel qmail files wern't in there. So even tho I created .maildir there was no .qmail.

Why this would cause an over quote message tho is any bodies guess.

If i adduser -m it works fine.
Back to top
View user's profile Send private message
skunkworx
Guru
Guru


Joined: 02 Feb 2003
Posts: 420
Location: Planet Houston

PostPosted: Wed Jan 14, 2004 7:00 pm    Post subject: Reply with quote

The .qmail file shouldn't be necessary. An empty .qmail file tells qmail to use the default delivery instructions, which in this case is supposed to be the same thing as having no .qmail file at all.

My only guess is to check if you have quotas enabled anywhere on your server. Perhaps user richard has quota restrictions on a file system that qmail uses, and that is making qmail believe richard does not have enough room in his home directory. I wouldn't bet on this too highly, however, since qmail has a reputation of not making such pratfalls.

If you don't get any further help here, you can try the qmail mailing list. Links to subscription information and also to the older message archives are available at qmail.org.
Back to top
View user's profile Send private message
x-router.com
n00b
n00b


Joined: 27 Aug 2003
Posts: 17
Location: UK

PostPosted: Thu Jan 15, 2004 8:48 am    Post subject: Reply with quote

Quotas are not on this sytem atm. It was installed only to be a mail forwarder and all I have put on is qmail so far. I removed and created the user on the same file system.

I googled up this which seems to suggest someone is having the same problem:

http://msgs.securepoint.com/cgi-bin/get/qmail0312/264/1/1.html

One thing i notice is this:

Code:

uber bin # ls -al /home/richard/.maildir
total 20
drwx------    5 richard  users        4096 Jan 14 10:39 .
drwx------    3 richard  users        4096 Jan 14 10:39 ..
drwx------    2 richard  users        4096 Jan 14 10:39 cur
drwx------    2 richard  users        4096 Jan 14 15:16 new
drwx------    2 richard  users        4096 Jan 14 15:16 tmp


I had only created .maildir not these dirs inside. It would appear qmail needs them as well hence the -m.

I will experement a bit to see if this is the case.
Back to top
View user's profile Send private message
skunkworx
Guru
Guru


Joined: 02 Feb 2003
Posts: 420
Location: Planet Houston

PostPosted: Thu Jan 15, 2004 4:02 pm    Post subject: Reply with quote

Yes, the .maildir directory definitely needs the cur, new, and tmp directories within it. That's all part of the maildir format.

Missing those directories shouldn't have given you a quota error, however, I'm inclined to think that with the zillion patches the Gentoo ebuild throws into qmail, something along the way is causing the wrong error message to be displayed under these circumstances.

If you're feeling generous, here's something you can do in your experiments. Test a system user who doesn't have any .qmail files in his home directory, and see what message you get in the following situations: no .maildir directory at all, a .maildir directory without subdirectories, and then a properly formatted .maildir directory. If any one of those gives you the quota message, then you can file a bug report in Bugzilla for the maintainers (assuming a bug hasn't been filed already).

I'm assuming you're on the latest stable ebuild, 1.03-r13, but of course be sure you mention which ebuild you're using if you decide to file a bug report.
Back to top
View user's profile Send private message
ptman
n00b
n00b


Joined: 25 Dec 2002
Posts: 24
Location: Finland

PostPosted: Tue Feb 03, 2004 9:51 pm    Post subject: Confirmed Reply with quote

I can confirm this also. Same kind of situation. I installed qmail after creating the user, so the .maildir -directory wasn't complete.
_________________
Paul "ptman" Tötterman
Back to top
View user's profile Send private message
robbat2
Developer
Developer


Joined: 19 Feb 2003
Posts: 69

PostPosted: Sun Mar 07, 2004 11:32 pm    Post subject: Reply with quote

looking at the qmail source, it doesn't catch the special case of a broken Maildir structure (which should _never_ happen).

The code in question:
Code:

if (chdir(dir) == -1) { if (error_temp(errno)) _exit(1); _exit(2); }
if (maildir_getquota(dir, quotabuf) == 0) {
  if (user_over_maildirquota(dir,quotabuf)==1) {
   _exit(1);
  }
 }


so the chdir() succeeds, but the getquota check fails due to non-existance of the directories. (getquota first checks for a special quota file, if not exists then sum up the directory (cur/new/tmp) manually, which fails).

either use maildirmake to create the maildir directories, or create them properly. I strongly recommend using maildirmake, as then if you install courier-imap, it's maildirmake is pathed before the one from qmail, and you get it's special features (better quota stuff and more).
Back to top
View user's profile Send private message
jkroon
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 108
Location: South Africa

PostPosted: Tue Jan 11, 2005 11:08 am    Post subject: Reply with quote

I suspect the problem is with the maildir++ patch. I'm still reading but I suspect that somehow the quota doesn't get initialised properly if no quota is specified.

Actually specifying the quota is done by having some kind of maildirsize file (not sure whether this is the actual size used, size limit or size left - the maildir++ spec will probably have more info on that).

Will report back when I have more info.
_________________
There are 10 kinds of people in the world,
those who understand binary and who don't
Back to top
View user's profile Send private message
jkroon
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 108
Location: South Africa

PostPosted: Tue Jan 11, 2005 3:44 pm    Post subject: Reply with quote

Yea, backing out the maildir++ patch solved the problem for me. Well, at least I haven't had any more cases where I received User over quota warnings in a couple of hours now. This could be luck, but I had them at about 3 or 4 by the hour so I seriously doubt the problem will persist. I looked at the source for the patch a bit but not in enough depth yet to understand why this happens, will attempt to do so later.
_________________
There are 10 kinds of people in the world,
those who understand binary and who don't
Back to top
View user's profile Send private message
orange_juice
Guru
Guru


Joined: 16 Feb 2006
Posts: 588
Location: Athens - Greece

PostPosted: Sat Mar 25, 2006 4:02 pm    Post subject: Reply with quote

Hallo! Although I do not use quotas, I seem to be experiencing the same problem. How can I back out the maildir++ patch?

I have also noticed the following: This is the second gentoo-box I am building. The first one is with a kernel tailored strictly to this box. Q-mail works perfectly.

The second one I am currently building is running on genkernel. This is the one with the quota problem. However, there is nothing that relates to quota enabled in the kernel

Code:
grep QUOTA /usr/src/linux/.config
# CONFIG_XFS_QUOTA is not set
# CONFIG_QUOTA is not set
Back to top
View user's profile Send private message
orange_juice
Guru
Guru


Joined: 16 Feb 2006
Posts: 588
Location: Athens - Greece

PostPosted: Sat Mar 25, 2006 4:23 pm    Post subject: Reply with quote

I found the solution!

http://www.courier-mta.org/imap/?README.maildirquota.html

http://nixdoc.net/files/forum/about58233.html
Code:
maildirmake .maildir -q 10000000S
Back to top
View user's profile Send private message
jkroon
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 108
Location: South Africa

PostPosted: Sat Mar 25, 2006 4:56 pm    Post subject: Reply with quote

Haven't read those fully but the problem is the fact that FAM works way too damn well. See http://bugs.gentoo.org/show_bug.cgi?id=56124 for a thorough explanation of why the link-sync (not maildir++, maildir++ negates the need for the deliverquota from what I understand - I don't use quotas) patch caused problems. It's backed out of -r16 iirc. I was initially convinced that it was the maildir++ patch, I was, however, wrong. This is explained from about comment number 10 onwards in that bugreport. Especially comment 23 describes the problem in detail.
_________________
There are 10 kinds of people in the world,
those who understand binary and who don't
Back to top
View user's profile Send private message
orange_juice
Guru
Guru


Joined: 16 Feb 2006
Posts: 588
Location: Athens - Greece

PostPosted: Sat Mar 25, 2006 5:17 pm    Post subject: Reply with quote

According to those links, the problem springs from the quotas set while creating the /home/user/.maildir.

Code:
maildirmake .maildir -q 10000000S


What I did, is that I created the .maildir with the above command (logged as "user" in the /home/user directory, not "root") and everything is set to normal.

-q: sets the quota
10000000S = 10MB

Thank you for your help.

Kind regards
orange_juice
Back to top
View user's profile Send private message
jkroon
Tux's lil' helper
Tux's lil' helper


Joined: 15 Oct 2003
Posts: 108
Location: South Africa

PostPosted: Sat Mar 25, 2006 5:30 pm    Post subject: Reply with quote

different problem then. glad you solved it.
_________________
There are 10 kinds of people in the world,
those who understand binary and who don't
Back to top
View user's profile Send private message
orange_juice
Guru
Guru


Joined: 16 Feb 2006
Posts: 588
Location: Athens - Greece

PostPosted: Sun Mar 26, 2006 11:55 am    Post subject: Reply with quote

Seems to be so... I wish I could help but I am not so computer litterate... :roll:
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum