Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
rsync Probleme behoben (13.01.)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Tue Jan 13, 2004 10:37 am    Post subject: rsync Probleme behoben (13.01.) Reply with quote

------------------------------------------------

RSYNC SERVER WIEDER UP AND RUNNING

Syncen ist also wieder möglich.

------------------------------------------------


Hallo zusammen,

solltet ihr zur Zeit Probleme haben einen rsync zu machen, dann schätzt euch glücklich. Der Portagetree ist zur Zeit fehlerhaft. Bitte also nicht weiter versuchen zu syncen.

Der Fehler ist bekannt und es wird daran gearbeitet.

Entwarnung folgt.

--ian!
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins


Last edited by ian! on Sat Jan 17, 2004 10:09 pm; edited 2 times in total
Back to top
View user's profile Send private message
LE_Shatai
n00b
n00b


Joined: 13 Jan 2004
Posts: 20

PostPosted: Tue Jan 13, 2004 11:35 am    Post subject: erklärt dies mein Problem? Reply with quote

als ich vorhin ein
emerge sync
ausgeführt habe, bekam ich folgende Fehlermeldung:

>>> starting rsync with rsync://rsync.gentoo.org/gentoo-portage...
>>> checking server timestamps
rsync: failed to connect to 127.0.0.1: Connectino refused
rsync: error: error in socket IO (code 10) at clientserver.c (88)
>>> retry...

liegt das nun an mir oder an dem rsync problem, das ihr habt?
Wieso will der sich zum localhost verbinden?
oder will der auf dem localhost einen clientserver starten um den sync auszuführen?
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Tue Jan 13, 2004 11:40 am    Post subject: Reply with quote

Der Nameservereintrag von rsync.gentoo.org wurde auf 127.0.0.1 geändert um zu verhindern, daß Clients sich weiterhin den fehlerhaften Portagetree von einem rsync-Server holen.

--ian!
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
LE_Shatai
n00b
n00b


Joined: 13 Jan 2004
Posts: 20

PostPosted: Tue Jan 13, 2004 11:45 am    Post subject: Reply with quote

axo, verstehe....
tnx für die schnelle antwort :D

was denkt ihr wann das problem behoben sein wird?
Back to top
View user's profile Send private message
gerry
Apprentice
Apprentice


Joined: 01 Sep 2002
Posts: 249
Location: Bodensee

PostPosted: Tue Jan 13, 2004 11:52 am    Post subject: Reply with quote

danke für den hinweis.

jetzt weiss ich warum vorhin so viele dateien gelöscht wurden, wo mein tree grade mal drei tage alt war.
Back to top
View user's profile Send private message
Inte
Veteran
Veteran


Joined: 15 Jul 2003
Posts: 1387
Location: Mannheim, GER

PostPosted: Tue Jan 13, 2004 11:58 am    Post subject: Reply with quote

*grmpf* Schon zwei Tage ohne System. Gestern war unser lokaler rsync-Mirror down und heute ist der tree futsch. Dabei wollte ich doch nur mein System neu aufsetzen. :cry:

Gruß, Inte.
_________________
Gentoo Linux - Die Metadistribution
Back to top
View user's profile Send private message
sirro
Veteran
Veteran


Joined: 20 Jul 2003
Posts: 1471
Location: aachen.nrw.de.eu

PostPosted: Tue Jan 13, 2004 12:14 pm    Post subject: Reply with quote

Inte wrote:
*grmpf* Schon zwei Tage ohne System. Gestern war unser lokaler rsync-Mirror down und heute ist der tree futsch. Dabei wollte ich doch nur mein System neu aufsetzen. :cry:

Warum nicht einfach einen älteren Snapshot benutzen? (z.B.: älter=gestern) Zum Aufsetzen des Systems reichts das allemal, die Distfiles sind noch verfügbar.
Wenn rsync wieder funktioniert, dann einfach aktualisieren...
Back to top
View user's profile Send private message
MadEagle
n00b
n00b


Joined: 03 Jun 2002
Posts: 59
Location: Hamburg, Germany

PostPosted: Tue Jan 13, 2004 12:39 pm    Post subject: Notfallserver Reply with quote

"rsync1.be.gentoo.org" hat einen älteren Stand des Baums eingespielt, der von dort geholt werden kann. Er hat die Synchronisation mit rsync.gentoo.org abgeschaltet, solange das Problem besteht.

Macht aber nur Sinn für das Neuaufsetzen einer Maschine, der Stand des Baumes wird nicht aktualisiert, also ein Update ist nicht sinnvoll.

HTH, MadEagle
Back to top
View user's profile Send private message
Börni
n00b
n00b


Joined: 13 Jan 2004
Posts: 5

PostPosted: Tue Jan 13, 2004 3:22 pm    Post subject: Reply with quote

Phuuu, und ich dachte schon ich bin zu blöd dazu. ;)

Greets Börni
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 52

PostPosted: Tue Jan 13, 2004 6:45 pm    Post subject: Reply with quote

ja so lösen sich manche dinge von selbst.vielleicht könnte jemand den ordner /usr/portage/sys-kernel/gentoo-dev-sources/ als tar schicken das ich zumindest wieder mit den 2.6.1er weitermachn kann.

habs zu spät gelesen und da war restore schon geschehen.
und die kerneldatein auch weg :(

amarok@gmx.at

Danke de Amarok
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Tue Jan 13, 2004 7:17 pm    Post subject: Reply with quote

Entwarnung.
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
Thomas_K
n00b
n00b


Joined: 12 Jan 2004
Posts: 5
Location: Schwaebisch Hall

PostPosted: Tue Jan 13, 2004 7:41 pm    Post subject: emerge sync in der Nacht von 12. auf 13. Januar Reply with quote

Hallo,

ich habe für mein vor zwei Tagen aufgesetztes Gentoo in der Nacht vom 12. auf 13. (start etwa 23:30 bis schätzungsweise 04:00) ich ging um ca 02:00 schlafen bis dahin lief m.E alles rund) ein emerge sync
angestossen. Habe ich jetzt den fehlerhaften Portage Tree auf dem Rechner ?
Back to top
View user's profile Send private message
Amarok
n00b
n00b


Joined: 11 Nov 2003
Posts: 52

PostPosted: Tue Jan 13, 2004 7:45 pm    Post subject: Reply with quote

Danke an die beiden User.
alles bekommen

de Amarok

entwarnung auch schon gesehen
Back to top
View user's profile Send private message
b0fh
Guru
Guru


Joined: 16 Jun 2003
Posts: 425

PostPosted: Tue Jan 13, 2004 7:46 pm    Post subject: Reply with quote

ian! wrote:
Entwarnung.


Also mein rsync läuft irgendwie schon 30minuten, dauert normalerweise so 5. Normal nach dem Vorfall?
Back to top
View user's profile Send private message
Empire
Tux's lil' helper
Tux's lil' helper


Joined: 06 Aug 2003
Posts: 94
Location: Europe / Switzerland

PostPosted: Tue Jan 13, 2004 8:21 pm    Post subject: Reply with quote

b0fh wrote:
ian! wrote:
Entwarnung.


Also mein rsync läuft irgendwie schon 30minuten, dauert normalerweise so 5. Normal nach dem Vorfall?


Ich nehme mal an Ja, da anscheinend wichtige Files gelöscht wurden müssen die ja alle neu gezogen werden...
_________________
One of the great mistakes is to judge policies and
programs by their intentions rather than their results.
Milton Friedman
Back to top
View user's profile Send private message
iBormuth
n00b
n00b


Joined: 13 Jan 2004
Posts: 59

PostPosted: Tue Jan 13, 2004 9:26 pm    Post subject: Reply with quote

Super - alles wider gut ! Danke.

Vielleich könnte jemand (der dazu berechtigt ist) in den <Latest Site News> noch Entwarnung geben....

http://forums.gentoo.org/viewtopic.php?t=123981
Back to top
View user's profile Send private message
gwion
Apprentice
Apprentice


Joined: 15 May 2003
Posts: 212
Location: Helsinki

PostPosted: Wed Jan 14, 2004 2:57 am    Post subject: Reply with quote

also bei mir funktioniert es nicht (auf 2 verschiedenen rechnern).

wenn ich /usr/portage lösche kann ich emerge sync machen. allerdings werden nicht die neuesten pakete gefunden (zb das neue portage).

wenn ihc danach nochmal emerge sync probiere krieg ich wieder den timestamp error...

langsam beunruhigt mich das... ich wäre ungemein dankbar für hilfreiche vorschläge...
danke und lg,

gwion
_________________
But the best thing about being an older goth? The fact that no one tries to tell you "It's a phase!" anymore.
--
gwion@jabber.org
Back to top
View user's profile Send private message
tobimat80
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 272
Location: Trier - Germany

PostPosted: Wed Jan 14, 2004 7:12 am    Post subject: Reply with quote

Du könntest dir den aktuellsten portage snapshot von gentoo.org besorgen und den dann in /usr entpacken - emerge sync und alles müsste wieder laufen.
Oder ein emerge-webrsync durchführen.

Gruß,
Tobias
_________________
Wer Rechtschreibfehler findet, darf sie behalten und auf DVD brennen!
Back to top
View user's profile Send private message
gwion
Apprentice
Apprentice


Joined: 15 May 2003
Posts: 212
Location: Helsinki

PostPosted: Wed Jan 14, 2004 10:06 am    Post subject: Reply with quote

tobimat80 wrote:
Du könntest dir den aktuellsten portage snapshot von gentoo.org besorgen und den dann in /usr entpacken - emerge sync und alles müsste wieder laufen.
Oder ein emerge-webrsync durchführen.

Gruß,
Tobias


beides gestern nacht probiert, ohne erfolg. allerdings funktionierts heute wieder.

komisch ist allerdings der output von emerge -up world...

Code:
gwion root # emerge -up system && emerge -up world

These are the packages that I would merge, in order:

Calculating system dependencies ...done!


These are the packages that I would merge, in order:

Calculating world dependencies |
!!! all ebuilds that could satisfy ">=sys-devel/automake-1.7.8" have been masked.
!!!    (dependency required by "net-im/sim-0.9.1" [ebuild])

!!! Problem with ebuild net-im/sim-0.9.1
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.
gwion root #


naja, mal sehen was da dahinter steckt... hinweise werden dankend angenommen :wink:

danke jedenfalls für deine vorschläge...

lg,

gwion
_________________
But the best thing about being an older goth? The fact that no one tries to tell you "It's a phase!" anymore.
--
gwion@jabber.org
Back to top
View user's profile Send private message
amne
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6377
Location: Graz / EU

PostPosted: Wed Jan 14, 2004 10:54 am    Post subject: Reply with quote

Dieses Problem tritt anscheinend immer wieder mal auf, siehe hier. Bitte gegebenenfalls auch dort zu DEPEND/*DEPEND Problemen weiterposten.
Back to top
View user's profile Send private message
gwion
Apprentice
Apprentice


Joined: 15 May 2003
Posts: 212
Location: Helsinki

PostPosted: Wed Jan 14, 2004 11:32 am    Post subject: Reply with quote

amne wrote:
Dieses Problem tritt anscheinend immer wieder mal auf, siehe hier. Bitte gegebenenfalls auch dort zu DEPEND/*DEPEND Problemen weiterposten.


:oops: vielen dank für den link... war scheinbar zu blöd den zu finden.

lg,

gwion
_________________
But the best thing about being an older goth? The fact that no one tries to tell you "It's a phase!" anymore.
--
gwion@jabber.org
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum