Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6 Kernel and RTC
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 5:03 am    Post subject: 2.6 Kernel and RTC Reply with quote

Anyone else seeing this during startup or shutdown:

Code:
modprobe: FATAL module rtc not found


Doesn't seem to be affecting anything 'yet'. The funny thing is, in my 2.4 kernel I have RTC compiled in the kernel also and it doesn't give this error. Just with the 2.6 kernel. So reluctant to remove any aliases in /etc.

I wonder if it might be cause not using devfs with the 2.6? Doubt it.
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.
Back to top
View user's profile Send private message
_danno
n00b
n00b


Joined: 08 Nov 2003
Posts: 17
Location: Michigan, USA

PostPosted: Fri Dec 12, 2003 5:42 am    Post subject: Reply with quote

hey,

i get the same sort of message, flashes by during bootup,
under several versions and compilations of the 2.6 kernel,
but everything seems to be fine....


Last edited by _danno on Fri Dec 12, 2003 5:48 am; edited 1 time in total
Back to top
View user's profile Send private message
sr20seth
n00b
n00b


Joined: 04 Nov 2003
Posts: 55
Location: Carrollton, VA

PostPosted: Fri Dec 12, 2003 5:44 am    Post subject: Reply with quote

Did you build rtc into the kernel, or not include it as a module? It sounds like rtc is in your /etc/modules/autoload.d/kernel-2.6, and there is no real time clock module available.
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 6:16 am    Post subject: Reply with quote

Nope. Not in /etc/modules.autoload.d/kernel-2.6

Code:

tulip
snd_ens1371
sg
nvidia
i2c-isa
via686a


It is though in /etc/modules.d/i386, /etc/modprobe.conf, modules.conf (which the last two are generated files).

Code:
alias char-major-10-135 rtc


also, /etc/modprobe.devfs (also generated)

Code:
alias /dev/rtc rtc


Tried removing it from /etc/modules.d/i386 but still got it. Come to think of it when uncommented it got it twice, when commented out think got the error once, each time.

Like said, have it compiled in the kernel in the 2.4 and doesn't give the errors. And 2.6 test11 doesn't allow you to choose module anyway. You can only put it in the kernel.

Doesn't seem to be causing a problem right now, might during daylight savings time?
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.
Back to top
View user's profile Send private message
_danno
n00b
n00b


Joined: 08 Nov 2003
Posts: 17
Location: Michigan, USA

PostPosted: Fri Dec 12, 2003 6:27 am    Post subject: Reply with quote

sr20seth: yes, that was it... thanks

i have the rtc compiled in the kernel, got rid of the module from the modules.autoload.d
and the problem has cleared up.

also -- the mm-sources 2.6 test 10 i am using lets you compile as a module
Back to top
View user's profile Send private message
sr20seth
n00b
n00b


Joined: 04 Nov 2003
Posts: 55
Location: Carrollton, VA

PostPosted: Fri Dec 12, 2003 6:44 am    Post subject: Reply with quote

No problem, _danno.
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 2:44 pm    Post subject: Reply with quote

Found the problem. After checking on my 2.4 system found that modprobe.conf is part of module-init-tools, which comes with the 2.6 kernel.

Modules.conf changed if edited /etc/modules.d/i386, but it didn't.
Had module-init-tools-0.9.12-r1, so upgraded to module-init-tools-0.9.15_pre1 and fixed the problem.

Note: that is with: alias char_major-10-135 rtc
back in /etc/modules.d/i386 . I put it back.
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.
Back to top
View user's profile Send private message
at_chaos
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 149
Location: EU|Austria

PostPosted: Fri Dec 12, 2003 3:27 pm    Post subject: Reply with quote

hi guys,

I have the same problems with rtc and devfs but i cannot find the options in menuconfig. Can you please tell me how I get those 2 things working?

thxal

andy
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 3:39 pm    Post subject: Reply with quote

Do you mean in the 2.4 or 2.6 kernel?

2.6 Kernel (I'm not using devfs in this one. Using udev and sysfs)
Code:
# Power management options (ACPI, APM)
#
# APM (Advanced Power Management) BIOS Support
#
CONFIG_APM=y
CONFIG_APM_RTC_IS_GMT=y
#
# File systems
#
# Pseudo filesystems
#
# CONFIG_DEVFS_FS is not set


2.4 Kernel
Code:
#
# General setup
#
# PCI Hotplug Support
#
CONFIG_APM=y
CONFIG_APM_RTC_IS_GMT=y
#
# File systems
#
CONFIG_DEVFS_FS=y
CONFIG_DEVFS_MOUNT=y

_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.


Last edited by Decibels on Fri Dec 12, 2003 3:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
sr20seth
n00b
n00b


Joined: 04 Nov 2003
Posts: 55
Location: Carrollton, VA

PostPosted: Fri Dec 12, 2003 3:41 pm    Post subject: Reply with quote

I was under the impression that Gentoo needed devfs compiled in with 2.6.0!
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 3:50 pm    Post subject: Reply with quote

According to what I have read on google and the forums and in the kernel descriptions while setting it up. Devfs in the 2.6 kernel is rudimentary, just enough for compatibility (think I have the correct). That is if you want it all, it is just for naming schemes.

I don't have it compiled in, using udev and sysfs, which probably isn't ready for prime time, but they seem to have it working pretty good, cause I'm using it.

I just posted a thread on how I got it working:
http://forums.gentoo.org/viewtopic.php?t=100173&highlight=
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.
Back to top
View user's profile Send private message
at_chaos
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 149
Location: EU|Austria

PostPosted: Fri Dec 12, 2003 3:59 pm    Post subject: Reply with quote

Hi Decibels,

thanks for that great help.

Sorry, I am trying to use the 2.6.0-test11. I found the RTC option.

How can I understand devfs? Am I right if there is no devfs option in the 2.6 config? And is now sysfs used?

I read that i should make a /sys directory to get it working, I did it added your options and now I am compiling and I will see if I get error msgs :oops:

I'm now running 2.4.20-gentoo-r8 and the latest 2.6 betakernel. I will switch to 2.6 if everything is running as I want ;).

Only with ppp and pptp I don't know how to solve the problem ;)

Thanks a lot!

andy
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 4:07 pm    Post subject: Reply with quote

Your welcome!

No, devfs is there just rudimentary though. If you look at my config above you will see it.

See if can find a couple or so articles about it:

From the 2.6 kernel help on devfs:
Quote:
Note that devfs no longer manages /dev/pts! If you are using UNIX98
ptys, you will also need to enable (and mount) the /dev/pts
filesystem (CONFIG_DEVPTS_FS).

Note that devfs has been obsoleted by udev,
<http://www.kernel.org/pub/linux/utils/kernel/hotplug/>.
It has been stripped down to a bare minimum and is only provided for
legacy installations that use its naming scheme which is
unfortunately different from the names normal Linux installations
use.


http://lwn.net/Articles/50731/

http://lwn.net/Articles/28526/

http://kerneltrap.org/node/view/1668

http://kernel.org/pub/linux/utils/kernel/hotplug/udev-FAQ
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.


Last edited by Decibels on Fri Dec 12, 2003 7:30 pm; edited 1 time in total
Back to top
View user's profile Send private message
at_chaos
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 149
Location: EU|Austria

PostPosted: Fri Dec 12, 2003 4:42 pm    Post subject: Reply with quote

hi!

ok I know did some configs you suggested. Also thanks for the links.

I don't know what udev does but i already made the settings in the kernel to set it up when it is working properly.

If I solve the issue with ppp i will try it out.

Sorry for my dumb questions :lol:


thx!

andy
Back to top
View user's profile Send private message
at_chaos
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 149
Location: EU|Austria

PostPosted: Fri Dec 12, 2003 5:31 pm    Post subject: Reply with quote

hi,

me again *g*

the RTC error is still there. But I think because I compiled it static and it is called via modprobe in some start-script. Which one can this be?

The other thing is that samba is starting up but I do not get a connection from my win pc :x

I didn't know that switching from 2.4 to 2.6 is so difficult ;)

Perhaps the errors come up because I have still the 2.4 kernel ? or is this impossible?

thx!

andy
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 6:48 pm    Post subject: Reply with quote

Hmmm, let me see what I can do.

1) I moved my system over to another partition to play with the 2.6,.... and still have 2.4 there. Ya, there are some errors when booting up to 2.4 but it works fine. Haven't traced down the reason it does some complaining about modules, I think input and mousedev modules, think it is because of some mixer of the 2.6 and 2.4 script and it already loaded them and sees them again. Not worrying about that though. oops got long winded again.

Anyway, if you read above I have rtc also static in the kernel, it isn't a module. That is for both 2.4 and 2.6. 1st one never complained, the second (2.6) complained because of /etc/modprobe.conf which isn't in the 2.4 hierarchy, it is put there because of module-init-tools for the 2.6 kernel.
Had version 0.9.12-r1, upgraded to 0.9.15_pre1 and took care of the problem. What version of module-init-tools are you using??

I also took care of alsa complaining about not finding the extra soundcards that don't have.

2) Samba, don't have a clue. Helped my Dad install it, he figured out the rest and wrote the tutorial on my website. I would try and start samba from command line if possible and see if something crops up, or start it with strace and see if get more details. That might lead you to something. It might be something to do with the udev you setup, so might be as simple as when I had to create the new /dev/hdc in my /dev folder to get the burner working. Just a few hints for ya.

3) Read part 1 for the 2.4 and 2.6 errors. Also, I don't see anything except it seeing the /dev/.devfsd file so mounting read only or something when booting to 2.6. Haven't deleted the file cause still have 2.4 on there.
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.
Back to top
View user's profile Send private message
at_chaos
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 149
Location: EU|Austria

PostPosted: Fri Dec 12, 2003 7:38 pm    Post subject: Reply with quote

omg -> kernel panic :twisted:

Decibels wrote:

Anyway, if you read above I have rtc also static in the kernel, it isn't a module. That is for both 2.4 and 2.6. 1st one never complained, the second (2.6) complained because of /etc/modprobe.conf which isn't in the 2.4 hierarchy, it is put there because of module-init-tools for the 2.6 kernel.

Ok, forgot that the solution is already here *g*

Quote:
Had version 0.9.12-r1, upgraded to 0.9.15_pre1 and took care of the problem. What version of module-init-tools are you using??

i use module-init-tools 0.9.12-r1 -> I will upgrade ;)

-> 2) Samba
I didn't install udev but i did the kernel config for that. I will try to fix this after the kernel is properly running.

Quote:

3) Read part 1 for the 2.4 and 2.6 errors. Also, I don't see anything except it seeing the /dev/.devfsd file so mounting read only or something when booting to 2.6. Haven't deleted the file cause still have 2.4 on there.

Sorry, didn't copy that :oops:
I have also still 2.4 running therfore the devfs message does not hurt me until 2.6 is ready to be used ;)

hm.. hope that I will get it running some day *lol*

greets,
andy
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Fri Dec 12, 2003 7:48 pm    Post subject: Reply with quote

at_chaos wrote:

hm.. hope that I will get it running some day *lol*


I'm sure you will! :wink: You seem to have the determination it requires.
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.
Back to top
View user's profile Send private message
at_chaos
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 149
Location: EU|Austria

PostPosted: Sun Dec 14, 2003 5:11 pm    Post subject: Reply with quote

Hi Decibels,

now my 2.6.0-test11 is running fine. Solved the issues with Samba, ppp, pptp and iptables.

I also pointed /usr/src/linux to the 2.6-test11 and now I want solve the issue with the devfs warning. (I don't need devfs anymore, don't use 2.4.20)

Should I edit grub.conf to not boot gentoo with devfs? or is there another solution to solve this?

thx in advance!

greets,
andy

PS: Your site is very useful ;)
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1559
Location: U.S.A.

PostPosted: Sun Dec 14, 2003 6:55 pm    Post subject: Reply with quote

Due to some things recently discovered, I wouldn't do away with devfs just yet. Unless you want to run a 'unstable' system. Seems pretty stable to me so far though.

Yes. I use lilo, but removed the mounting option for devfs. That is probably why it is complaining. So just remove it from your grub bootloader.

If you want to use udev instead of devfs, then you will also need baselayout-1.8.6.12-r2 or probably at least anything 1.8.6.12 (haven't checked r1 or so). It won't work without it properly. Cause it needs to have the init.d scripts to mount ramfs at /dev, there is also a tar file /lib/udev-state/devices.tar.bz2 that is will use. So needs the new baselayout. When you reboot you will see this, goes real fast on my system so hard to see:

'mounting sysfs at /sys'
'mounting ramfs at /dev'
'configuring system to use udev'
'populating /dev with device nodes'
'using /sbin/hotplug for udev management'

Without this, it is really just like the old way before devfs, that is why I said what I did at the beginning. If your not having any problems, like me, than go for it. Not using it for my main system though till know it is stable (mostly).

I emerged that with --nodeps flag. Everything seems to be working pretty good as far as starting. Konsole for kde says 'Unable to open a suitable terminal device' (my fault, troubleshooting and took myself out of tty group). So fixed.

*Probably ought to start another thread instead of using this one also. It started out about something else and is moving in a different direction. Or just send me a private message.
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.


Last edited by Decibels on Thu Dec 18, 2003 1:50 am; edited 1 time in total
Back to top
View user's profile Send private message
at_chaos
Tux's lil' helper
Tux's lil' helper


Joined: 09 Nov 2003
Posts: 149
Location: EU|Austria

PostPosted: Sun Dec 14, 2003 9:27 pm    Post subject: Reply with quote

New topic about udev startet at http://forums.gentoo.org/viewtopic.php?t=115096
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum