Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 2.5.0 is out!
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3, 4, 5, 6, 7  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Lin_Matt
Guru
Guru


Joined: 23 Jun 2002
Posts: 581
Location: TechWasteland (Mississippi)

PostPosted: Sat Nov 29, 2003 8:33 am    Post subject: Gnome 2.5.0 is out! Reply with quote

Yup... The first Gnome development release is out the door and you can find nice, fresh ebuilds at www.breakmygentoo.net. There are some issues with gstreamer-0.7.2 right now so, altho the ebuilds are in the tarball, they are masked as are any packages that depend on em.

As usual, any attempts to report bugs with these ebuilds anywhere other than bugs.breakmygentoo.net will result in a very unhappy Lovechild, so please be careful... ;)

Release Notes
_________________
[urlhttp://www.breakmygentoo.net]BreakMyGentoo[/url] - Unstable Gnome and more...
Back to top
View user's profile Send private message
Lovechild
Advocate
Advocate


Joined: 17 May 2002
Posts: 2858
Location: Århus, Denmark

PostPosted: Sat Nov 29, 2003 9:13 am    Post subject: Reply with quote

xvideo and oss plugins doesn't compile with a similar problem, I reported bugs with gnome's bugzilla on those problems.

alsa doesn't seem to output sound since gnome-media's mixer atm seems to be oss only (and that plugin doesn't work - what kind of genius makes a oss only mixer in these kernel 2.6 days?).

Foser informed me that the speed of his seperated plugin compile structure will be improved since we apparently can save time on the autoconf/automake stage so it might help my testing that it no longer will take an evening to test every plugin.
Back to top
View user's profile Send private message
dabooty
Guru
Guru


Joined: 15 May 2003
Posts: 482
Location: Belgium

PostPosted: Sat Nov 29, 2003 11:30 am    Post subject: Reply with quote

how risky is it still to install this?

it's itching to check this release out, but i really don't want a fubared system. I ran gnome current from 2.3.somethinglater and it was stable enough, but the .0 worries me :)
_________________
registered user #284425
get yourself counted
http://counter.li.org
------
#emerge -pv solves a lot of questions beforehand
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Sat Nov 29, 2003 12:26 pm    Post subject: Reply with quote

dabooty wrote:
how risky is it still to install this?


In the words of Jeff Waugh: "It's very slick, and stable enough for your day-to-day desktop (which won't be a surprise to anyone who's been using GARNOME or jhbuild since 2.0). Come and get it!"

Of course "stable enough" is something very subjective ;-)

If you really need something dead stable, don't touch development snapshots at all, try to resist the itching and wait for the next stable release.
Back to top
View user's profile Send private message
Anime_Fan
Guru
Guru


Joined: 01 Jul 2003
Posts: 366
Location: Linköping, Sweden

PostPosted: Sat Nov 29, 2003 12:45 pm    Post subject: Reply with quote

Hmmm... Gnome 2.5? Now when I have a perfectly fine 2.4 running...

Then again, I installed Gnome 2.2 and was disappointed by the features at the time. 2 days later 2.4 was released and all thing I wanted fixed were fixed...

Bah.. Let's install it. I can always fall back on fluxbox should something bork.

I wonder if I should use expocity along with it. It's quite nice, albeit slow.
Back to top
View user's profile Send private message
julienp
n00b
n00b


Joined: 25 Nov 2003
Posts: 10

PostPosted: Sat Nov 29, 2003 1:29 pm    Post subject: Reply with quote

libgnomeprintui fails with:
Code:
../libgnomeprintui/.libs/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_entry_new_with_model'
../libgnomeprintui/.libs/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_new_with_model'
collect2: ld returned 1 exit status
Compilation of scanner failed
make[2]: *** [scan-build.stamp] Error 1
make[2]: Leaving directory `/var/tmp/portage/libgnomeprintui-2.5.0.1/work/libgnomeprintui-2.5.0.1/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libgnomeprintui-2.5.0.1/work/libgnomeprintui-2.5.0.1'
make: *** [all] Error 2
 
!!! ERROR: gnome-base/libgnomeprintui-2.5.0.1 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Sat Nov 29, 2003 1:35 pm    Post subject: Reply with quote

Lovechild wrote:
what kind of genius makes a oss only mixer in these kernel 2.6 days?


I bet this genius is a Red Hat/Fedora user ;-)

But there is already someone working on an ALSA mixer for Gnome.
Back to top
View user's profile Send private message
julienp
n00b
n00b


Joined: 25 Nov 2003
Posts: 10

PostPosted: Sat Nov 29, 2003 1:48 pm    Post subject: Reply with quote

julienp wrote:
libgnomeprintui fails with:
Code:
../libgnomeprintui/.libs/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_entry_new_with_model'
../libgnomeprintui/.libs/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_new_with_model'
collect2: ld returned 1 exit status
Compilation of scanner failed
make[2]: *** [scan-build.stamp] Error 1
make[2]: Leaving directory `/var/tmp/portage/libgnomeprintui-2.5.0.1/work/libgnomeprintui-2.5.0.1/doc'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/libgnomeprintui-2.5.0.1/work/libgnomeprintui-2.5.0.1'
make: *** [all] Error 2
 
!!! ERROR: gnome-base/libgnomeprintui-2.5.0.1 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure

Don't know what the problem is, but is seems to be related to the package documentation, so compiling with USE="-doc" worked...
Back to top
View user's profile Send private message
swat
Tux's lil' helper
Tux's lil' helper


Joined: 21 Jul 2002
Posts: 144

PostPosted: Sat Nov 29, 2003 2:22 pm    Post subject: Reply with quote

AFter an emerge -up --deep world:

These are the packages that I would merge, in order:

Calculating world dependencies -
!!! all ebuilds that could satisfy ">=gnome-base/gdm-2.4.4.5" have been masked.
!!! (dependency required by "gnome-base/gnome-2.5.1_pre1" [ebuild])

!!! Problem with ebuild gnome-base/gnome-2.5.1_pre1
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.

I can't work out what it is complaining about. Any suggestions?

EDIT: Idiot. Unmask gdm.

Simon


Last edited by swat on Sat Nov 29, 2003 2:42 pm; edited 1 time in total
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Sat Nov 29, 2003 2:42 pm    Post subject: Reply with quote

swat wrote:
!!! Problem with ebuild gnome-base/gnome-2.5.1_pre1
!!! Possibly a DEPEND/*DEPEND problem.


gdm is masked in /usr/portage/profiles/packages.mask, so unmask gdm, for example with
Code:

mkdir /etc/portage; echo "gnome-base/gdm" >> /etc/portage/package.unmask
Back to top
View user's profile Send private message
asimon
l33t
l33t


Joined: 27 Jun 2002
Posts: 979
Location: Germany, Old Europe

PostPosted: Sat Nov 29, 2003 5:07 pm    Post subject: Reply with quote

julienp wrote:

Don't know what the problem is, but is seems to be related to the package documentation, so compiling with USE="-doc" worked...


That doesn't really help. In this case libgnomeprintui builds but linking of applications which link against this lib (for example gedit) fails because of the same missing symbols.
Back to top
View user's profile Send private message
sonicpling
n00b
n00b


Joined: 22 Feb 2003
Posts: 5
Location: Texas, USA

PostPosted: Sat Nov 29, 2003 9:24 pm    Post subject: Reply with quote

I'm having a the same problem..

/usr/lib/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_entry_new _with_model'
/usr/lib/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_new_with_ model'
collect2: ld returned 1 exit status

libgnomeprintui merged correctly, but now, everyting that links against it fails.

Any Idea's??

TIA
Back to top
View user's profile Send private message
Lin_Matt
Guru
Guru


Joined: 23 Jun 2002
Posts: 581
Location: TechWasteland (Mississippi)

PostPosted: Sat Nov 29, 2003 10:52 pm    Post subject: Reply with quote

sonicpling wrote:
I'm having a the same problem..

/usr/lib/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_entry_new _with_model'
/usr/lib/libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_new_with_ model'
collect2: ld returned 1 exit status

libgnomeprintui merged correctly, but now, everyting that links against it fails.

Any Idea's??

TIA


I've downgraded the versions of libgnomeprint* to 2.5.0 and the problem goes away. After checking the ChangeLog for libgnomeprintui, it seems some changes were made to compile against gtk+ HEAD...

Also, the version of the gnome metabuild is wrong in the 2.5.0 tarball from this morning. It should have been gnome-2.5.0, not 2.5.1_pre1. Go ahead and remove that ebuild to make sure any updates get seen correctly.
_________________
[urlhttp://www.breakmygentoo.net]BreakMyGentoo[/url] - Unstable Gnome and more...
Back to top
View user's profile Send private message
julienp
n00b
n00b


Joined: 25 Nov 2003
Posts: 10

PostPosted: Sat Nov 29, 2003 11:19 pm    Post subject: Reply with quote

Thanks, everything seems to build now.
Back to top
View user's profile Send private message
hjlane3
Guru
Guru


Joined: 22 Feb 2003
Posts: 377
Location: Wilmington, DE USA

PostPosted: Sun Nov 30, 2003 5:07 am    Post subject: Reply with quote

I notice in the gtk+ ebuild supplied, the code in the ebuild for the shadow and menuselect patches are commented out. Is this because they don't work with that gtk+ version?
_________________
I wish hell would freeze over already. :-(
EDIT: w00t, it has!
Back to top
View user's profile Send private message
Lin_Matt
Guru
Guru


Joined: 23 Jun 2002
Posts: 581
Location: TechWasteland (Mississippi)

PostPosted: Sun Nov 30, 2003 6:28 am    Post subject: Reply with quote

hjlane3 wrote:
I notice in the gtk+ ebuild supplied, the code in the ebuild for the shadow and menuselect patches are commented out. Is this because they don't work with that gtk+ version?


I haven't tested em myself, but as gtk+ is in very heavy development right now, I didn't think applying em by default to be a very good choice... I did leave the patches in the tarball tho so feel free to try em out.
_________________
[urlhttp://www.breakmygentoo.net]BreakMyGentoo[/url] - Unstable Gnome and more...
Back to top
View user's profile Send private message
modal
Apprentice
Apprentice


Joined: 02 Oct 2002
Posts: 277

PostPosted: Sun Nov 30, 2003 8:57 am    Post subject: Reply with quote

I built it, and so far it works great, no problems, but i've been running 2.5pre for quite a while now.
running a revdep-rebuild on some packages seems to help every once in a while for these beta gnome builds, i always tend to mess up packages when i use the dev ebuilds.
Back to top
View user's profile Send private message
dabooty
Guru
Guru


Joined: 15 May 2003
Posts: 482
Location: Belgium

PostPosted: Sun Nov 30, 2003 1:27 pm    Post subject: Reply with quote

eog fails
it seems to have something to do with libgnomeprintui.

Code:
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/../../../libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_entry_new_with_model'
/usr/lib/gcc-lib/i686-pc-linux-gnu/3.3.1/../../../libgnomeprintui-2-2.so: undefined reference to `gtk_combo_box_new_with_model'
collect2: ld gaf exit-status 1 terug
make[2]: *** [test-gpi] Fout 1
make[2]: Leaving directory `/var/tmp/portage/eog-2.5.0.1/work/eog-2.5.0.1/libgpi'
make[1]: *** [all-recursive] Fout 1
make[1]: Leaving directory `/var/tmp/portage/eog-2.5.0.1/work/eog-2.5.0.1'
make: *** [all-recursive-am] Fout 2
 
!!! ERROR: media-gfx/eog-2.5.0.1 failed.
!!! Function gnome2_src_compile, Line 39, Exitcode 2
!!! compile failure


EDIT: I am trying to install gnome-current, not gnome-2.5, i'll try emerging libgnomeprintui from 2.5
_________________
registered user #284425
get yourself counted
http://counter.li.org
------
#emerge -pv solves a lot of questions beforehand
Back to top
View user's profile Send private message
dabooty
Guru
Guru


Joined: 15 May 2003
Posts: 482
Location: Belgium

PostPosted: Sun Nov 30, 2003 1:52 pm    Post subject: Reply with quote

it builds cleanly with libgnomeprint & ui 2.5.0
maybe it would be nice to include them as default in current for the time being.
_________________
registered user #284425
get yourself counted
http://counter.li.org
------
#emerge -pv solves a lot of questions beforehand
Back to top
View user's profile Send private message
loseruser
Tux's lil' helper
Tux's lil' helper


Joined: 27 May 2003
Posts: 110
Location: Seattle,WA

PostPosted: Sun Nov 30, 2003 5:14 pm    Post subject: Reply with quote

I've got it building everything (after fixing the ebuilds to install libgnomeprint* 2.5.0's. However every time I try to start nautilus it dies.

here's a backtrace - any ideas or should I just submit a bug?

Code:

Using host libthread_db library "/lib/libthread_db.so.1".
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 22559)]
[New Thread 32769 (LWP 22560)]
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 22559)]
[New Thread 32769 (LWP 22560)]
[Thread debugging using libthread_db enabled]
[New Thread 16384 (LWP 22559)]
[New Thread 32769 (LWP 22560)]
[New Thread 16386 (LWP 22561)]
0x409ffa4b in waitpid () from /lib/libpthread.so.0
#0  0x409ffa4b in waitpid () from /lib/libpthread.so.0
#1  0x4023ea98 in ?? () from /usr/lib/libgnomeui-2.so.0

Thread 3 (Thread 16386 (LWP 22561)):
#0  0x40cf3caa in poll () from /lib/libc.so.6
No symbol table info available.
#1  0x40a8a6a3 in g_main_context_poll (context=0x8167020, timeout=-1,
    priority=2147483647, fds=0x8185010, n_fds=7) at gmain.c:2699
   poll_func = 0x40cf3c30 <poll>
#2  0x40a89dc6 in g_main_context_iterate (context=0x8167020, block=1,
    dispatch=1, self=0x8165590) at gmain.c:2376
   max_priority = 2147483647
   timeout = -1
   some_ready = 0
   nfds = 7
   allocated_nfds = 7
   fds = (GPollFD *) 0x8185010
#3  0x40a8a3d3 in g_main_loop_run (loop=0x8184f08) at gmain.c:2601
   self = (GThread *) 0x8165590
#4  0x409743b6 in link_io_thread_fn (data=0x0) at linc.c:342
No locals.
#5  0x40a9b607 in g_thread_create_proxy (data=0x8165590) at gthread.c:601
No locals.
#6  0x409f9031 in pthread_start_thread () from /lib/libpthread.so.0
No symbol table info available.
#7  0x40cfc2fa in clone () from /lib/libc.so.6
No symbol table info available.

Thread 2 (Thread 32769 (LWP 22560)):
#0  0x40cf3caa in poll () from /lib/libc.so.6
No symbol table info available.
#1  0x409f8b7a in __pthread_manager () from /lib/libpthread.so.0
No symbol table info available.
#2  0x40cfc2fa in clone () from /lib/libc.so.6
No symbol table info available.

Thread 1 (Thread 16384 (LWP 22559)):
#0  0x409ffa4b in waitpid () from /lib/libpthread.so.0
No symbol table info available.
#1  0x4023ea98 in ?? () from /usr/lib/libgnomeui-2.so.0
No symbol table info available.
#0  0x409ffa4b in waitpid () from /lib/libpthread.so.0
Back to top
View user's profile Send private message
snutte
Apprentice
Apprentice


Joined: 24 Apr 2002
Posts: 181
Location: Sweden, Malmö

PostPosted: Sun Nov 30, 2003 5:49 pm    Post subject: Reply with quote

I dont wanna take the risk without first seeing some screenshots of eyecandy. :)
Back to top
View user's profile Send private message
fsck!
n00b
n00b


Joined: 24 Oct 2003
Posts: 29

PostPosted: Sun Nov 30, 2003 5:55 pm    Post subject: Reply with quote

Screenshots anyone?
Back to top
View user's profile Send private message
dabooty
Guru
Guru


Joined: 15 May 2003
Posts: 482
Location: Belgium

PostPosted: Sun Nov 30, 2003 6:45 pm    Post subject: Reply with quote

a couple of shots (on request :))

there's a new "computer" icon on the desktop which shows all drives and such: http://users.pandora.be/tvrg/gnome-2.5/Computer(new).png

The old nautilus can be accessed from the gnome menu (browse filesystem): http://users.pandora.be/tvrg/gnome-2.5/browse-fs.png

nautilus cd burning includes music cd's: http://users.pandora.be/tvrg/gnome-2.5/burn-music.png
_________________
registered user #284425
get yourself counted
http://counter.li.org
------
#emerge -pv solves a lot of questions beforehand
Back to top
View user's profile Send private message
pens
Tux's lil' helper
Tux's lil' helper


Joined: 01 Jan 2003
Posts: 121
Location: Irvine, CA

PostPosted: Sun Nov 30, 2003 7:00 pm    Post subject: Reply with quote

Well, gnome-2.5.0.tar.bz2 seems to have really borked my system. First off, gdm doesn't work and gnome-panel seems to crash a lot.

EDIT: I downgraded gtk+ to 2.2.4 (I think) and everything works :)

EDIT: Scratch that, some ebuilds required 2.3.0 and some things break without it, specifically libglade...
Back to top
View user's profile Send private message
sisob
Apprentice
Apprentice


Joined: 28 Jun 2002
Posts: 274
Location: Ireland

PostPosted: Sun Nov 30, 2003 7:46 pm    Post subject: Reply with quote

Hey all,

Gnome 2.5 is going to get a lot better, there' sa lot of stuff still to land. So don't judge 2.6 by this :)

Off the top of my head there is evolution if it gets included, a nice new background chooser, nautilus plugin architecture and a cvs plugin, new network: and ssh:, password cacheing etc..
_________________
Mark Finlay - Gnome Hacker of Sorts
Come join me on the Gnome User's Forum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2, 3, 4, 5, 6, 7  Next
Page 1 of 7

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum