Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Maxima compile cuts out with a compile error...
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
phirkel
n00b
n00b


Joined: 13 Oct 2003
Posts: 14

PostPosted: Mon Nov 10, 2003 4:16 am    Post subject: Maxima compile cuts out with a compile error... Reply with quote

Howdy.
I was just emerging Maxima...and it started compiling and cut out with this:
Code:

;; Loading file /var/tmp/portage/maxima-5.9.0/work/maxima-5.9.0/src/maxima.system ...
;  - Compiling defsystem "maxima"
;    - Loading module "package"
;      - Loading source file "maxima-package.lisp"
;; Loading file maxima-package.lisp ...
*** - REGEXP:REGEXP-COMPILE: keyword arguments in (T) should occur pairwise
0 errors, 0 warnings
make[1]: *** [binary-clisp/maxima.mem] Error 1
make[1]: Leaving directory `/var/tmp/portage/maxima-5.9.0/work/maxima-5.9.0/src'make: *** [all-recursive] Error 1
 
!!! ERROR: app-sci/maxima-5.9.0 failed.
!!! Function src_compile, Line 19, Exitcode 2
!!! (no error message)


Now, to me, there is no error. But, maybe I am mistaken. Any ideas what's up?
Thanks
_________________
From IRIX to Solaris to Linux ... they always say the best comes last.
Back to top
View user's profile Send private message
phirkel
n00b
n00b


Joined: 13 Oct 2003
Posts: 14

PostPosted: Tue Nov 11, 2003 9:28 pm    Post subject: Reply with quote

Buuuuuuummmmp
_________________
From IRIX to Solaris to Linux ... they always say the best comes last.
Back to top
View user's profile Send private message
phirkel
n00b
n00b


Joined: 13 Oct 2003
Posts: 14

PostPosted: Thu Nov 13, 2003 10:40 pm    Post subject: Reply with quote

Bump
_________________
From IRIX to Solaris to Linux ... they always say the best comes last.
Back to top
View user's profile Send private message
alphatronics
Tux's lil' helper
Tux's lil' helper


Joined: 16 Apr 2003
Posts: 88
Location: Boston

PostPosted: Fri Nov 14, 2003 3:26 am    Post subject: Reply with quote

I second that bump.
Back to top
View user's profile Send private message
phirkel
n00b
n00b


Joined: 13 Oct 2003
Posts: 14

PostPosted: Fri Nov 14, 2003 10:13 pm    Post subject: Reply with quote

Bump...nobody has any ideas?
_________________
From IRIX to Solaris to Linux ... they always say the best comes last.
Back to top
View user's profile Send private message
phirkel
n00b
n00b


Joined: 13 Oct 2003
Posts: 14

PostPosted: Sun Nov 16, 2003 2:09 am    Post subject: Reply with quote

Getting bored of bumping it...
_________________
From IRIX to Solaris to Linux ... they always say the best comes last.
Back to top
View user's profile Send private message
phirkel
n00b
n00b


Joined: 13 Oct 2003
Posts: 14

PostPosted: Wed Nov 19, 2003 8:42 pm    Post subject: Reply with quote

Bummmmmp.
_________________
From IRIX to Solaris to Linux ... they always say the best comes last.
Back to top
View user's profile Send private message
ledskof
Apprentice
Apprentice


Joined: 22 Oct 2002
Posts: 209
Location: Atlanta, GA

PostPosted: Wed Nov 19, 2003 9:17 pm    Post subject: Reply with quote

this is probably useless but.. have you tried removing the related distfiles and emerging again?

You might try relaxing your compiler flags or something too, just to test this.
Back to top
View user's profile Send private message
shira
Tux's lil' helper
Tux's lil' helper


Joined: 27 Aug 2002
Posts: 122

PostPosted: Thu Dec 11, 2003 1:56 am    Post subject: Reply with quote

I'm getting this same error
Back to top
View user's profile Send private message
tlepo
Tux's lil' helper
Tux's lil' helper


Joined: 04 Sep 2003
Posts: 131
Location: Elouges (Belg.)

PostPosted: Fri Dec 12, 2003 9:44 pm    Post subject: Reply with quote

Hello,

Well...I have exactly the same error.

???
Back to top
View user's profile Send private message
tlepo
Tux's lil' helper
Tux's lil' helper


Joined: 04 Sep 2003
Posts: 131
Location: Elouges (Belg.)

PostPosted: Sat Dec 13, 2003 12:21 am    Post subject: Reply with quote

I checked /var/tmp/portage/maxima-5.9.0/work/maxima-5.9.0/src.

I suppose that in the Makefile, there is a problem with the pararagraph entitled" binary-clips/maxima.mem" (line 526 and others). However I do not see what should be modified in order to launch an efficient "make".

I also saw the note (5th. October 2003) in Changelog, but apparently nothing crucial for our problem.
Back to top
View user's profile Send private message
MathFreak
Apprentice
Apprentice


Joined: 07 Jul 2002
Posts: 217
Location: Bethlehem, PA

PostPosted: Sat Dec 13, 2003 12:26 am    Post subject: Reply with quote

Well, I unmasked maxima 5.9.0-r2 from package.mask and emerged it. This version uses CMUCL from source instead of CLISP. I had no problems merging this version (I didn't try plain old 5.9.0).
Back to top
View user's profile Send private message
tlepo
Tux's lil' helper
Tux's lil' helper


Joined: 04 Sep 2003
Posts: 131
Location: Elouges (Belg.)

PostPosted: Thu Dec 18, 2003 9:39 pm    Post subject: Reply with quote

Thanks!
cmucl and version-5.2.9-r2 emerged sucessfully.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum