Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dhcp server crashes after a while
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
-leliel-
Apprentice
Apprentice


Joined: 03 May 2003
Posts: 294
Location: Germany

PostPosted: Fri Nov 07, 2003 1:09 pm    Post subject: dhcp server crashes after a while Reply with quote

Hi,

my dhcp server crashes once or twice a day with the following message:

Nov 7 12:38:29 [kernel] grsec: signal 11 sent to (dhcpd:15836) UID(10009) EUID(10009), parent (init:1) UID(0) EUID(0)

there are also hundreds of messages like this in the syslog:

Nov 7 11:38:29 [dhcpd] Wrote 0 deleted host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 new dynamic host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 deleted host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 new dynamic host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 deleted host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 new dynamic host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 deleted host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 new dynamic host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 deleted host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 new dynamic host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 deleted host decls to leases file.
Nov 7 11:38:29 [dhcpd] Wrote 0 new dynamic host decls to leases file.

any idea what could happened to the server? worked fine last week and I've really changed nothing on the configs.

dhcpd --version is isc-dhcpd-V3.0pl2

thanks a lot
Back to top
View user's profile Send private message
evanduser
n00b
n00b


Joined: 09 Apr 2003
Posts: 22

PostPosted: Fri Nov 07, 2003 4:01 pm    Post subject: Reply with quote

This release runs as user dhcp, group dhcp. If you upgraded from previous release the owner of /var/lib/dhcp needs to be set to chown dhcp.dhcp :)
Back to top
View user's profile Send private message
-leliel-
Apprentice
Apprentice


Joined: 03 May 2003
Posts: 294
Location: Germany

PostPosted: Fri Nov 07, 2003 10:05 pm    Post subject: Reply with quote

thanks, but that doesn't fix the problem. :(

chmod is 770, user and group are dhcp, server itself is chroot'ed.

any ideas?
Back to top
View user's profile Send private message
joehni
Apprentice
Apprentice


Joined: 27 Jul 2003
Posts: 175

PostPosted: Fri Nov 07, 2003 11:15 pm    Post subject: Reply with quote

It's a known bug and fixed in the latest release.
http://bugs.gentoo.org/show_bug.cgi?id=31840
I just wonder, why they masked it ...
Back to top
View user's profile Send private message
joehni
Apprentice
Apprentice


Joined: 27 Jul 2003
Posts: 175

PostPosted: Fri Nov 07, 2003 11:32 pm    Post subject: Reply with quote

Grrr. They already removed the fixed version again, since they could not reproduce it after a remerge of -r2.
Back to top
View user's profile Send private message
braindead0
Tux's lil' helper
Tux's lil' helper


Joined: 29 Apr 2003
Posts: 144
Location: Ohio

PostPosted: Sat Nov 08, 2003 12:27 pm    Post subject: Reply with quote

Mine just seems to die after a bit, nothing odd in the logs that I can see. If I try to restart, when stopping it reports !!

go figure
Back to top
View user's profile Send private message
tam
Guru
Guru


Joined: 04 Mar 2003
Posts: 569
Location: freiburg.de

PostPosted: Mon Nov 17, 2003 10:07 am    Post subject: Reply with quote

I just have encountered the same problem:
Code:
root@serv4 ~ # dhcpd --verison
Internet Software Consortium DHCP Server V3.0pl2

After a while, dhcp server dies. It's very annoying, because I have ~50 samba users connected.

Any solution for this?
Back to top
View user's profile Send private message
ke.batty
n00b
n00b


Joined: 10 Nov 2003
Posts: 5

PostPosted: Mon Nov 17, 2003 12:42 pm    Post subject: Reply with quote

The workaround listed:
http://bugs.gentoo.org/attachment.cgi?id=20206&action=view
works for me, had 5 days up time so far
Back to top
View user's profile Send private message
woodm
Tux's lil' helper
Tux's lil' helper


Joined: 18 Jun 2002
Posts: 75

PostPosted: Mon Dec 08, 2003 10:17 pm    Post subject: It may be metalog Reply with quote

Quote:
Mine just seems to die after a bit, nothing odd in the logs that I can see. If I try to restart, when stopping it reports !!

go figure


Could this be from metalog caching it's output? Just a guess. There is a way to force it to dump and not cache, but I have NO experience with it.


For the record, I'm having a similar problem, but mine seems to be related to the leases renewing:

from /var/log/kernel/current:
Code:

Dec  7 22:51:44 [kernel] grsec: denied hardlink of /var/lib/dhcp/dhcpd.leases (owned by 0.0) to /var/lib/dhcp/dhcpd.leases~ for (dhcpd:17813) UID(1005) EUID(100
5), parent (init:1) UID(0) EUID(0)
Dec  7 22:52:08 [kernel] grsec: attempted resource overstep by requesting 8388608 for RLIMIT_STACK against limit 8388608 by (dhcpd:17813) UID(1005) EUID(1005),  parent (init:1) UID(0) EUID(0)
Dec  7 22:52:08 [kernel] grsec: attempted resource overstep by requesting 8392704 for RLIMIT_STACK against limit 8388608 by (dhcpd:17813) UID(1005) EUID(1005),  parent (init:1) UID(0) EUID(0)


_________________
There are thousands of types of people in this world:
The type that seperates people into two groups,
and the thousands of other types.
Back to top
View user's profile Send private message
Petyr
Guru
Guru


Joined: 08 Jan 2003
Posts: 471
Location: San Diego, CA, USA

PostPosted: Sun Dec 21, 2003 5:48 am    Post subject: Reply with quote

I'm having the exact same problem it seems, the wierd thing is my dhcp.leases file was owned by dhcp:dhcp the entire time, though I had to force the leases file to be owned by dhcp the first time around. I dunno, the damn thing just silently exits and/or crashes.

Petyr
Back to top
View user's profile Send private message
ARC2300
Apprentice
Apprentice


Joined: 30 Mar 2003
Posts: 256
Location: Odenton, MD

PostPosted: Tue Dec 23, 2003 1:54 am    Post subject: Reply with quote

Doing the fix listed makes it stay up.

Or, if you're too lazy to write a new line, just go to /etc/init.d/dhcp and delete where it says "-user dhcp -group dhcp" and it should work just fine.
Back to top
View user's profile Send private message
HoGiHung
n00b
n00b


Joined: 22 Dec 2003
Posts: 8

PostPosted: Tue Dec 23, 2003 4:47 pm    Post subject: Reply with quote

I'm having a bit of a time getting it to work also. I've downloaded the new dhcp script as posted above. Below is a snipet from my syslog:

Dec 23 11:04:18 kiragentoo dhcpd: For info, please visit http://www.isc.org/products/DHCP
Dec 23 11:04:18 kiragentoo dhcpd: Wrote 0 leases to leases file.
Dec 23 11:04:18 kiragentoo dhcpd: socket: Protocol not available - make sure
Dec 23 11:04:18 kiragentoo dhcpd: CONFIG_PACKET (Packet socket) and CONFIG_FILTER
Dec 23 11:04:18 kiragentoo dhcpd: (Socket Filtering) are enabled in your kernel
Dec 23 11:04:18 kiragentoo dhcpd: configuration!
Dec 23 11:04:18 kiragentoo dhcpd:

Anyone able to assist?

Ho...
Back to top
View user's profile Send private message
Psi15
Tux's lil' helper
Tux's lil' helper


Joined: 07 Jan 2003
Posts: 84
Location: Vienna

PostPosted: Tue Jan 06, 2004 5:03 pm    Post subject: Reply with quote

similar problem over here...

for testing puposes I had the dhcpcd server running for a while with the -d option, and after several hours it crashes with a 'segmentation fault' error - no interesting log entries at all, only debug output...

will try the workaround tonight - maybe it's getting better :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum