Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[localisation] problème d'accentuation (RESOLU)
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 11:11 am    Post subject: [localisation] problème d'accentuation (RESOLU) Reply with quote

Voici le problme, les accents dans la console ne passe pas mais la localisation marche.

cd test
-bash: cd: test: Aucun fichier ou r?pertoire de ce type
Tout le reste marche par exemple nano fichier :

^G Aide ^O Écrire ^R Lire fich.^Y Page préc.^K Couper ^C Pos. curs.
^X Quitter ^J Justifier ^W Où est ^V Page suiv.^U Coller ^T Orthograp.

Tout marche bien aussi sous mon interface graphique (fluxbox).
Donc il s'agit sans doute d'un problème de font, voici qques paramètres :
#locale
LANG=fr_FR@euro
LC_CTYPE="fr_FR@euro"
LC_NUMERIC="fr_FR@euro"
LC_TIME="fr_FR@euro"
LC_COLLATE="fr_FR@euro"
LC_MONETARY="fr_FR@euro"
LC_MESSAGES="fr_FR@euro"
LC_PAPER="fr_FR@euro"
LC_NAME="fr_FR@euro"
LC_ADDRESS="fr_FR@euro"
LC_TELEPHONE="fr_FR@euro"
LC_MEASUREMENT="fr_FR@euro"
LC_IDENTIFICATION="fr_FR@euro"
LC_ALL=fr_FR@euro

mon fichier /etc/rc.conf :
KEYMAP="fr-latin1"
EXTENDED_KEYMAP="windowkeys"
CONSOLEFONT="lat0-16" #j'ai essay aussi CONSOLEFONT="lat9w-16"
CONSOLETRANSLATION="8859-15_to_uni"
...

mon fichier /etc/env.d/02locales:
LANG="fr_FR@euro"
LANGUAGE="fr_FR@euro"
LC_ALL="fr_FR@euro"

J'ai rien mis dans /etc/profile

J'ai donc mis jour le systme :
/etc/init.d/consolefont
env-update
source /etc/profile (pas vraiment utile ici)

Mais rien y fait .
Si y en a qui ont des idées je suis preneur.


Last edited by Prodigy44 on Wed Dec 24, 2003 12:08 pm; edited 2 times in total
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Sun Nov 16, 2003 11:26 am    Post subject: Reply with quote

Je suis aussi entrain de chercher une solution au meme probleme que toi mais pour l'instant en vain :(
Peut-etre un module au noyau mais je vois pas vraiment lequel :cry:
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
sebbb
Guru
Guru


Joined: 08 Oct 2003
Posts: 400
Location: [FR] - Paris

PostPosted: Sun Nov 16, 2003 11:47 am    Post subject: Reply with quote

Si j'ai bien compris votre problème, je l'ai résolut en plaçant :
Code:
LANG=fr_FR@euro

dans le fichier /etc/env.d/02local

Mais je sais pas si c'est bien ça... :)
_________________
Sebbb

De tous les gens qui n'ont rien à dire,
les plus agréables sont ceux qui se taisent...
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Sun Nov 16, 2003 12:33 pm    Post subject: Reply with quote

Non sebbb j'ai bien cette variable sur mon systeme tout comme Prodigy44 si tu regarde ses locales ;)
Merci en tout cas :D
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 12:41 pm    Post subject: Reply with quote

Ben je pensais au noyau (2.4.22 que j'ai recompilé pour le portable) mais j'ai installer une gentoo sur un autre pc et la meme probleme (mais le noyau est un gentoo-source 2.4.20-r6 et conf par gentoo) donc je pense pas que ca vienne du noyau...
Aller en avant les recherches ...
Back to top
View user's profile Send private message
bouba
n00b
n00b


Joined: 03 Jun 2003
Posts: 40

PostPosted: Sun Nov 16, 2003 1:50 pm    Post subject: Reply with quote

Ca ne pourrait pas etre lie a l'oubli d'activation de ce qui va bien dans
File Systems -> Native Language Support des fois?
les modules qui sont presents dans cette section autorise une localisation pour la console donc les FS).

Vu qu'apparemment tout le reste de vos confs est correct.

Pas sur mais bon, on sait jamais. :)

A+

Bouba
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 2:16 pm    Post subject: Reply with quote

Je recompile ca de suite et je te dis
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 3:12 pm    Post subject: Reply with quote

Bon j'ai recompilé avec les paramètres suivant ;
File systems --->
Native Language Support --->
<*> Codepage 437 (United States, Canada)
<*> Codepage 863 (Canadian French)
<*> NLS ISO 8859-1 (Latin 1; Western European Languages)
<*> NLS ISO 8859-15 (Latin 9; Western European Languages with Euro)

Mais bon c'est toujours pareil..

toujours les accents remplacé par des ?
Back to top
View user's profile Send private message
bouba
n00b
n00b


Joined: 03 Jun 2003
Posts: 40

PostPosted: Sun Nov 16, 2003 3:20 pm    Post subject: Reply with quote

erf. :(
Pourtant a priori, c'est le seul diff de conf que j'ai vu entre toi et moi du point de vue localisation. J'ai active l'unicode sur mon noyau, a part ca, c'est la meme. :-?

Je vais regarder a nouveau la conf, mais la je seche. :-?
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 3:22 pm    Post subject: Reply with quote

J'essaye avec l'utf la :))
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 3:38 pm    Post subject: Reply with quote

bon j'ai recompiler avec l'utf :
<*> NLS UTF8
Mais rien y fait
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 4:03 pm    Post subject: Reply with quote

Y a un truc trop bizarre
le bug je l'ai pas sous X il met bien l'accentuation dans Eterm mais pas en mode console simple ...
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Sun Nov 16, 2003 4:56 pm    Post subject: Reply with quote

Nous avons donc bien le meme probleme tous les deux ;)
Pour ce qui est de UTF8 j'avais deja essaye et j'avais aussi fait choux blanc.
Ca fait un petit moment deja que je cherche d'ou cela peu venir ... et malheureusement je vois de moins en moins d'ou cela peu provenir :(
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Sun Nov 16, 2003 5:22 pm    Post subject: Reply with quote

Mort de rire je viens d'essayer sur ma slack, et malgre la localisation en francais j'ai le meme prob.
Dommage j'avais une mandrake cette semaine j'aurai pu regarder aussi
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Sun Nov 16, 2003 5:29 pm    Post subject: Reply with quote

Si cela peut servir :
/etc/profile wrote:
LANG=fr_BE
LC_ALL=fr_BE@euro
MM_CHARSET=ISO-8859-15
LANGUAGE=${LANG}
export LANG LC_ALL LANGUAGE MM_CHARSET

/etc/rc.conf wrote:
KEYMAP="be-latin1.map.gz"
SET_WINDOWKEYS="yes"
EXTENDED_KEYMAPS="backspace keypad"
#CONSOLEFONT="default8x16"
CONSOLETRANSLATION="8859-15_to_uni"

Jusqu'il y a peu, j'avais également ce problème d'accents mais il provenait de "CONSOLETRANSLATION" qui était commenté.
Back to top
View user's profile Send private message
bouba
n00b
n00b


Joined: 03 Jun 2003
Posts: 40

PostPosted: Sun Nov 16, 2003 6:02 pm    Post subject: Reply with quote

ghoti wrote:

Jusqu'il y a peu, j'avais également ce problème d'accents mais il provenait de "CONSOLETRANSLATION" qui était commenté.


Apparemment Prodigy44 l'a lui aussi positionne ce flag au vue de son premier post ... :-?

Est-ce que par hasard tu as modifie le default dans native language support de ton kernel?
Back to top
View user's profile Send private message
yuk159
Veteran
Veteran


Joined: 18 Apr 2003
Posts: 1801
Location: noumea ,nouvelle-caledonie

PostPosted: Sun Nov 16, 2003 6:05 pm    Post subject: Reply with quote

Je viens de positionner CONSOLETRANLATION (elle etais commente aussi)
Mais cela ne change rien
Code:
cd truc
-bash: cd: truc: Aucun fichier ou r?pertoire de ce type

Et le seule diff que je vois avec ton fichier c'est : LANG=fr_FR
Je commence a me demander si on devrais pas tous migrer en Belgique :mrgreen:
_________________
The box said: "Requires Windows 98/2000/XP/NT, or better."
So, I installed LINUX!
un blog de plus :)
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Sun Nov 16, 2003 6:49 pm    Post subject: Reply with quote

bouba wrote:
Est-ce que par hasard tu as modifie le default dans native language support de ton kernel?

Il est sur "iso8859-15"
Mais je doute que cela ait quelque-chose à voir.
Ces options ne concernent pas la console mais la manière dont sont traduits les noms de fichiers sur les filesystems ...
Back to top
View user's profile Send private message
bouba
n00b
n00b


Joined: 03 Jun 2003
Posts: 40

PostPosted: Sun Nov 16, 2003 6:52 pm    Post subject: Reply with quote

J'aurai tendance a dire que ca vient de la alors.
A priori par defaut il est sette a : iso8859-1 (en tout cas chez moi c'etait le cas), fallait juste que je m'en souvienne. :oops:
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 6:53 pm    Post subject: Reply with quote

Bon j'ai installer une mdk 9.2 cet apres midi sur un autre pc..
donc je viens d'essayer et ben la console est en anglais et quand je tappe #locale
j'obtiens tout fr_FR@euro sauf LC_ALL

Sinon je trouve la mdk bien réussit au premier abord, elle intègre bien lilo bootsplash et la suite, les mecs bossent bien ...

Bon le pire c'est que moi j'ai mes deux gentoos qui font ca :
Une avec un kernel configuré/ compilé maison et l'autre avec genkernel gentoo-source
et les deux me font le même problème à savoir les accents sont remplacés dans la console par des ? MAIS la console (Eterm) en graphique marche ...

Bizarre Bizarre serait-ce ma premiere publication a bugzilla, j'hesite ...
Back to top
View user's profile Send private message
bouba
n00b
n00b


Joined: 03 Jun 2003
Posts: 40

PostPosted: Sun Nov 16, 2003 6:57 pm    Post subject: Reply with quote

change le default des native support (la ligne du haut) et ca devrait rouler.
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 7:12 pm    Post subject: Reply with quote

j'ai pas compris
tu peux développer stp
Back to top
View user's profile Send private message
bouba
n00b
n00b


Joined: 03 Jun 2003
Posts: 40

PostPosted: Sun Nov 16, 2003 7:22 pm    Post subject: Reply with quote

En fait, dans la section native support, la premiere entree est le default utilise. (la toute premiere ligne de la section)
Si ton systeme est comme le mien a l'initial, il doit etre positionne a iso8859-1 (anglais sans accents donc).

change-le par iso8859-15 et tu devrais voir ton probleme resolu si je ne me plante pas. :)
Back to top
View user's profile Send private message
Prodigy44
Apprentice
Apprentice


Joined: 19 Sep 2003
Posts: 231
Location: Nantes, France

PostPosted: Sun Nov 16, 2003 8:15 pm    Post subject: Reply with quote

Je viens de recompiler le noyau en enlevant iso8859-1 rien a faire
c'est toujours le meme probleme
Back to top
View user's profile Send private message
ghoti
Advocate
Advocate


Joined: 30 Dec 2002
Posts: 3559
Location: Belgium

PostPosted: Sun Nov 16, 2003 9:44 pm    Post subject: Reply with quote

Prodigy44 wrote:
c'est toujours le meme probleme

Bon et bien j'ai été trop rapide : j'ai l'immense joie ( :( ) de vous annoncer que j'ai finalement la même maladie !
Apparemment, cela ne touche que la commande "cd" et uniquement en mode texte.
Ce qui est curieux, c'est que d'autres commandes affichent correctement le même message :
Quote:
bigben root # cd aaaaa
bash: cd: aaaaa: Aucun fichier ou r?pertoire de ce type
bigben root # ls aaaaa
ls: aaaaa: Aucun fichier ou répertoire de ce type
bigben root # find aaaaa
find: aaaaa: Aucun fichier ou répertoire de ce type

Au moins, ce n'est déjà pas un problème global mais d'un autre côté, c'est chercher une aiguille dans une botte de foin.
Seul indice : "cd" est une commande interne de bash tandis que les deux autres sont des commandes externes ...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum