Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Delete key now prints ~ in Bash prompt
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Inte
Veteran
Veteran


Joined: 15 Jul 2003
Posts: 1387
Location: Mannheim, GER

PostPosted: Tue Sep 14, 2004 8:54 pm    Post subject: Reply with quote

Hmmm ... splashutils ...

cat /etc/portage/package.keywords
Code:
=media-gfx/splashutils-0.9_pre07 ~x86
=sys-apps/baselayout-1.10.4 ~x86
=sys-apps/sysvinit-2.84 ~x86

I totally forgot that I installed the masked versions. :(

Maybe this behaviour will be fixed soon. :roll:

Fortunately my GTK apps do their job :wink:

thx, Inte.

EDIT: just4info http://forums.gentoo.org/viewtopic.php?p=1503509#1503509
_________________
Gentoo Linux - Die Metadistribution
Back to top
View user's profile Send private message
Anarky
n00b
n00b


Joined: 25 May 2003
Posts: 30
Location: France

PostPosted: Wed Sep 15, 2004 8:29 am    Post subject: Reply with quote

I may be off the wall, but
I'm using zsh and had the same problem.
I solved it in the shell by typing the command
Code:
bindkey "^[[3~" delete-char
but the problem is still here in login for exemple.
Before zsh is lauched, when I log in, if I use the "del" key, that's not a tilde that appear, but [3~. I don't know the solution.
Back to top
View user's profile Send private message
jewps
n00b
n00b


Joined: 29 Mar 2004
Posts: 74

PostPosted: Wed Sep 15, 2004 11:14 am    Post subject: Reply with quote

I think it's a problem with baselayout. I've had this problem for a while but I just couldn't be f*'d to do anything about it.
Back to top
View user's profile Send private message
graybeard
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2003
Posts: 118
Location: a blue state

PostPosted: Wed Sep 15, 2004 11:21 am    Post subject: Reply with quote

Well, here is a work around until you find the real cause. I opened gnome-terminal, click edit - profiles, select default, click edit. Select the compatibility tab. Change "Backspace key generates" to "Control-H". Change "Delete key generates" to "ASCII Delete". Save and close. Now it works on my machine in gnome at least. Obviously that won't affect other terminal types however.

:)

-dan
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5229
Location: France, Old Europe

PostPosted: Thu Sep 16, 2004 7:22 am    Post subject: Reply with quote

steveb wrote:
i did a diff of /etc/inputrc from one system where the del key works and from one where the del key prints a ~ and both inputrc files are the same. so it can't be the inputrc file.

cheers

SteveB


The more I look into this the more I am convinced it is a bug that has come into a package with recent update (last few weeks)

I dont let etc-update change things without looking what it does and so many of us are checking all sorts of config inits and god knows what else. All seems in order.

I think we need to look at package version.

SteveB . Could you compare baselayout and sysvinit for ex. on your two systems.

Thx 8)
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
onan
n00b
n00b


Joined: 27 Dec 2003
Posts: 5
Location: Terre.Canada.Quebec.Chicoutimi

PostPosted: Thu Sep 16, 2004 9:10 pm    Post subject: solved Reply with quote

I just unmerged sysvinit and re-emerged baselayout without any ACCEPT_KEYWORDS and it solved the problem immediately. (I also unmasked these packages to use splashutils but I don't use it anyway)

thanks Gentree for your help :) , but I don't know what is the exact problem, there is a big clue at least.
Back to top
View user's profile Send private message
Gentree
Watchman
Watchman


Joined: 01 Jul 2003
Posts: 5229
Location: France, Old Europe

PostPosted: Fri Sep 17, 2004 9:38 am    Post subject: Reply with quote

I found reverting baselayout did the trick as well.

Sorry I didnt post that here , I was following about 3 threads on this pb and missed this one.

baselayout did change a whole bunch of files through etc-update but even looking closely I could not see it revert anything like a keyboard setting.

It must be in the actual coding somewhere.

8)
_________________
Linux, because I'd rather own a free OS than steal one that's not worth paying for.

AthlonXP-M on A7N8X @ 2.6/2.4GHz (winter/summer)
2.6.32-hh1 : portage ~x86
Back to top
View user's profile Send private message
hiroki
Guru
Guru


Joined: 29 Jul 2003
Posts: 327
Location: @home in germany

PostPosted: Wed Sep 22, 2004 11:29 am    Post subject: Reply with quote

hm. i use bash-3.0-r5 and baselayout-1.10.4
i have the same problem as describes above, but what'sweird is, that this problem does not occur when using the pure bash, it only occurs when i use programs that run in a terminal like lftp or python. then i cannot delete (del) or use page-up/down.
i will give it a try and downgrade baselayout. i cannot remember when the problem appeared.
Back to top
View user's profile Send private message
blaster999
l33t
l33t


Joined: 09 May 2004
Posts: 902
Location: Between keyboard and chair

PostPosted: Wed Sep 22, 2004 1:19 pm    Post subject: Reply with quote

hiroki wrote:
it only occurs when i use programs that run in a terminal like lftp or python

Was python compiled with "readline" USE flag? If not, recompile it and it should be able to understand delete, pgUp and so on.
_________________
60s: sex, drugs, rock'n'roll
90s: sux, bugs, drag'n'drop
---
Some multimedia keys refuse to work? See my mini-howto:
http://forums.gentoo.org/viewtopic.php?p=1896734#1896734
Back to top
View user's profile Send private message
hiroki
Guru
Guru


Joined: 29 Jul 2003
Posts: 327
Location: @home in germany

PostPosted: Wed Sep 22, 2004 3:46 pm    Post subject: Reply with quote

blaster999 wrote:
hiroki wrote:
it only occurs when i use programs that run in a terminal like lftp or python

Was python compiled with "readline" USE flag? If not, recompile it and it should be able to understand delete, pgUp and so on.


python is already compiled with readline. and lftp does not have that USE-flag. i also recompiled readline and then python.. did not help.
any other suggestions?
please help!
it's very annoying...
Back to top
View user's profile Send private message
bennettp
Guru
Guru


Joined: 22 Feb 2004
Posts: 335
Location: on my back and tumbling

PostPosted: Wed Sep 22, 2004 6:21 pm    Post subject: Reply with quote

breakerfall wrote:
I no longer have this problem - most likely due to the upgrade of Bash to 3.0.0

See if that helps. :)
The problem is that baselayout-1.10 (approx) and newer move this sort of config out of /etc/profile and into /etc/bash/bashrc. However, only the bash-3.0.x and higher ebuilds reflect this change, so unless you emerge bash 3, you'll get strange non-coloured bash prompts and squiggly lines all over the place... This change was made so that the coloured PS1 would only be applied on an interactive terminal...

EDIT: bash-3 is still ~x86, so use at own risk! No problems here...
_________________
Registered Linux User #363420
Back to top
View user's profile Send private message
graybeard
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2003
Posts: 118
Location: a blue state

PostPosted: Thu Sep 23, 2004 1:59 am    Post subject: Reply with quote

That makes sense ... but shouldn't there be a dependency between the two packages? Might seem like a minor issue except for the 36 posts in just this one thread on the subject.

-dan
Back to top
View user's profile Send private message
marvin
n00b
n00b


Joined: 29 Jan 2003
Posts: 58

PostPosted: Thu Sep 23, 2004 8:33 am    Post subject: Reply with quote

Just put this in your /etc/bash/bashrc (create the file if it does not exist):
Code:
if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]
then
        export INPUTRC="/etc/inputrc"
fi


This should make the delete key work again. You can also put the line
Code:

export PS1='\[\033[01;32m\]\u@\h \[\033[01;34m\]\w \$ \[\033[00m\]'

in there, if you don't have a coloured prompt anymore.
_________________
Join the adopt an unanswered post initiative today!
Back to top
View user's profile Send private message
hiroki
Guru
Guru


Joined: 29 Jul 2003
Posts: 327
Location: @home in germany

PostPosted: Thu Sep 23, 2004 8:42 am    Post subject: Reply with quote

marvin wrote:
Just put this in your /etc/bash/bashrc (create the file if it does not exist):
Code:
if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]
then
        export INPUTRC="/etc/inputrc"
fi


This should make the delete key work again. You can also put the line
Code:

export PS1='\[\033[01;32m\]\u@\h \[\033[01;34m\]\w \$ \[\033[00m\]'

in there, if you don't have a coloured prompt anymore.


oooh, wow, that works!!!! now i have my favorite page-up/-down back!!!! works in python and lftp.. cool. many thanks!! :D
Back to top
View user's profile Send private message
thoughts
Apprentice
Apprentice


Joined: 15 Apr 2004
Posts: 153
Location: Pennsylvania

PostPosted: Tue Sep 28, 2004 12:17 am    Post subject: Reply with quote

marvin wrote:
Just put this in your /etc/bash/bashrc (create the file if it does not exist):
Code:
if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]
then
        export INPUTRC="/etc/inputrc"
fi


This should make the delete key work again. You can also put the line
Code:

export PS1='\[\033[01;32m\]\u@\h \[\033[01;34m\]\w \$ \[\033[00m\]'

in there, if you don't have a coloured prompt anymore.


SWEET, thank you. This bug was driving me crazy. Having your DEL key suddenly start printing tildes instead of deleting is like.... well, it's like having a DEL key that prints tildes. It's insanity.

-Anthony DiSante
http://nodivisions.com/
Back to top
View user's profile Send private message
fintux
n00b
n00b


Joined: 07 Feb 2004
Posts: 17
Location: Oulu, Finland

PostPosted: Mon Oct 18, 2004 1:58 pm    Post subject: Reply with quote

BTW, seems to require KDE/X11 restart for the changes to take effect (don't know which, because I zapped gdm with Ctrl-Alt-Backspace). Thank you very much for the tip, this was driving me nuts already.
Back to top
View user's profile Send private message
zaai
Apprentice
Apprentice


Joined: 24 Jul 2004
Posts: 175

PostPosted: Wed Oct 20, 2004 6:19 am    Post subject: Yes it works :) Reply with quote

Heh many thanks for posting this solution Marvin.
:D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum