Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
upgaded thunderbird to 0.8, now my stuff is gone [solved]
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Wed Sep 15, 2004 9:27 pm    Post subject: upgaded thunderbird to 0.8, now my stuff is gone [solved] Reply with quote

meh.
i upgraded from 0.7 to 0.8 with the ebuild from here. now, when starting, i get this message:
Code:
mq$ thunderbird
No running windows found

Extension System Warning: Failed to set up default extensions files probably because you do not have write privileges to this location. While you can run Firefox like this, it is recommended that you run it at least once with privileges that allow it to generate these initial files to improve start performance. Running from a disk image on MacOS X is not recommended.

this message does *not* disappear after having run TB as root, but it does not appear *when* i run TB as root.

my problem is that my mails (in inbox and various other folders) are all gone. my accounts are there and all. i can, apparently, even send mail (but not recieve any), but my stuff is gone. does this have anything to do with --enable-single-profile being in the ebuild? is it something else in the ebuild? am i forgetting something?
any help appreciated.
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word


Last edited by kamagurka on Thu Sep 16, 2004 12:39 pm; edited 1 time in total
Back to top
View user's profile Send private message
TommyB
n00b
n00b


Joined: 07 Feb 2004
Posts: 30
Location: Nuremberg, Germany

PostPosted: Wed Sep 15, 2004 9:46 pm    Post subject: Reply with quote

Hm, I also had some problems with that ebuild initially (no emails were displayed and a segfault), but after having it run as root once it seems to work now.
And did you try the binary ebuild?

Like mentioned here, I don't think --enable-single-profile is the reason for the problem, as it seems to be one of the standard configuration options also used for the official builds.

[edit] Have you copied the thunderbird-init-... tarball from the files directory into your overlay files directory? (you can also manually extract the file into /usr/lib/MozillaThunderbird after installation) [/edit]
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Wed Sep 15, 2004 10:31 pm    Post subject: Reply with quote

TommyB wrote:
Have you copied the thunderbird-init-... tarball from the files directory into your overlay files directory? (you can also manually extract the file into /usr/lib/MozillaThunderbird after installation)


why should i do that?
and, as i stated also on bugs.gentoo.org, running it as root (repeatedly) didn't fix it.
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
Rainmaker
Veteran
Veteran


Joined: 12 Feb 2004
Posts: 1650
Location: /home/NL/ehv/

PostPosted: Thu Sep 16, 2004 12:21 am    Post subject: Reply with quote

the build has hit portage, so it comes in while sysncing. You should not be required to copy any patches manually.

I can only find the 0.7 patch though...

*edit: manually extracting that init thingie to /usr/lib/ThunderBird makes my thunderbird carsh on startup...
_________________
If you can't dazzle them with brilliance, baffle them with bullshit.
Back to top
View user's profile Send private message
parsim
Guru
Guru


Joined: 12 Aug 2004
Posts: 347
Location: Melbourne, Australia

PostPosted: Thu Sep 16, 2004 1:17 am    Post subject: Reply with quote

Same problem here. Just did
Code:
emerge -vu world

and got an all-new Thunderbird 0.8 that doesn't display e-mails! Very unhelpful.

Tried running as root -- no difference.

When running as user I get:
Code:
$ thunderbird
fgrep: /usr/lib/MozillaThunderbird/defaults/pref/thunderbird.js: No such file or directory
No running windows found

Then it runs without any further messages, but doesn't display any e-mail. :?
Back to top
View user's profile Send private message
parsim
Guru
Guru


Joined: 12 Aug 2004
Posts: 347
Location: Melbourne, Australia

PostPosted: Thu Sep 16, 2004 1:27 am    Post subject: Reply with quote

Actually, I'm noticing various other weirdness, too... sometimes it's impossible to click Close or Exit on a dialog box, and in Compose, the keyboard's arrow keys don't work!
Back to top
View user's profile Send private message
paneb
n00b
n00b


Joined: 20 Mar 2004
Posts: 73

PostPosted: Thu Sep 16, 2004 1:43 am    Post subject: Reply with quote

i just had the same problem.
here is the way out:

1- backup you current .tbird to wherever you want(the one which actually should still contain you email data)..
2- delete the non-backup directory(~/.tbird), and start thunderbird.
3- follow the wizard for your account
4- once done, close tbird open up the backup, and the newly created ~/.tbird and go into the Mail folder and into the folder for your account.
5- copy whichver folder you want into the new ~/.tbird....then launch the prog and everything is back - or should

i hope this solves your problems :)
ohh and this is what i did for me; if something goes wrong when you do it, i am not responsible :)
Back to top
View user's profile Send private message
parsim
Guru
Guru


Joined: 12 Aug 2004
Posts: 347
Location: Melbourne, Australia

PostPosted: Thu Sep 16, 2004 2:54 am    Post subject: Reply with quote

That worked, thanks! :)
Back to top
View user's profile Send private message
chance2105
Tux's lil' helper
Tux's lil' helper


Joined: 10 Jun 2004
Posts: 112
Location: Norman, OK USA

PostPosted: Thu Sep 16, 2004 3:36 am    Post subject: Reply with quote

OUCH. This is gonna take awhile ...
Back to top
View user's profile Send private message
Quantum Skyline
n00b
n00b


Joined: 20 Apr 2003
Posts: 20

PostPosted: Thu Sep 16, 2004 3:44 am    Post subject: Reply with quote

If you follow paneb's instructions, here's some hints that you may find useful:

1) You have to recreate the email account in TB exactly as you did it the first time. If you get TB saying there's stuff in your inbox but the inbox looks empty, try again with the "Use global inbox" option turned off.

2) Your mail is probably in ~/.thunderbird/<default profile name>/Mail/<POP server name> and could probably import the files from that dir into another email program while you reconfigure TB.
_________________
Everybody has their moments of insanity. Some just have more than others.
Back to top
View user's profile Send private message
VortexMK
n00b
n00b


Joined: 23 Feb 2004
Posts: 13
Location: Macedonia

PostPosted: Thu Sep 16, 2004 4:35 am    Post subject: Reply with quote

The following has worked for me:

1. Move the .thunderbird directory to another place
2. Start Thunderbird (you don't have to make account just start it so it can create fresh new .thunderbird directory)
3. Go to the newly created .thunderbird directory and go to the new profile (it's the only one you won't miss it :))
4. Copy the following stuff from your old backuped .thunderbird directory
- Mail
- prefs.js
- <somenumber>.s (the number is different for each and every new installment of Thunderbird)

Well, that does it for me, don't try to copy other stuff because it's the very cause of the problem. I think something went wrong with the introducing of the new feature of global mail folder (all your mail goes to just one folder).
Back to top
View user's profile Send private message
parsim
Guru
Guru


Joined: 12 Aug 2004
Posts: 347
Location: Melbourne, Australia

PostPosted: Thu Sep 16, 2004 4:40 am    Post subject: Reply with quote

Copying .thunderbird/<default>/abook.mab (address book) works too.
Back to top
View user's profile Send private message
radonsg
Apprentice
Apprentice


Joined: 26 Jun 2004
Posts: 257
Location: Singapore

PostPosted: Thu Sep 16, 2004 5:06 am    Post subject: Reply with quote

VortexMK wrote:
The following has worked for me:

1. Move the .thunderbird directory to another place
2. Start Thunderbird (you don't have to make account just start it so it can create fresh new .thunderbird directory)
3. Go to the newly created .thunderbird directory and go to the new profile (it's the only one you won't miss it :))
4. Copy the following stuff from your old backuped .thunderbird directory
- Mail
- prefs.js
- <somenumber>.s (the number is different for each and every new installment of Thunderbird)

Well, that does it for me, don't try to copy other stuff because it's the very cause of the problem. I think something went wrong with the introducing of the new feature of global mail folder (all your mail goes to just one folder).


I couldn't find the
Quote:
- <somenumber>.s (the number is different for each and every new installment of Thunderbird)
. Is the file/folder important? What izzit for?
_________________
Athlon64 3000+ on a MSI Neo2 Platinum (nVidia nForce3)
1 Sata Hitachi (HGST) 7K250
1 Sata Samsung SpinPoint
2 x 512MB TwinMos DDR400 Dual Channel
Geforce 5200
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1246
Location: C.C.A.A., Germania

PostPosted: Thu Sep 16, 2004 6:39 am    Post subject: Reply with quote

For me deleting the compreg.dat in the profile dir was enough.
Back to top
View user's profile Send private message
Toomuch
n00b
n00b


Joined: 16 Mar 2004
Posts: 46

PostPosted: Thu Sep 16, 2004 8:22 am    Post subject: Reply with quote

PrakashKC wrote:
For me deleting the compreg.dat in the profile dir was enough.


Oh yeah, that was it! Now the 'About thunderbird' dialog not closing thing seems also gone.

Perhaps this may be marked as 'solved'?

t
Back to top
View user's profile Send private message
kamagurka
Veteran
Veteran


Joined: 25 Jan 2004
Posts: 1026
Location: /germany/munich

PostPosted: Thu Sep 16, 2004 12:36 pm    Post subject: Reply with quote

PrakashKC wrote:
For me deleting the compreg.dat in the profile dir was enough.


YESSS, you are my hero.
_________________
If you loved me, you'd all kill yourselves today.
--Spider Jerusalem, the Word
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1130

PostPosted: Thu Sep 16, 2004 12:38 pm    Post subject: Reply with quote

PrakashKC wrote:
For me deleting the compreg.dat in the profile dir was enough.


it works !

maybe there should be released
Code:
mozilla-thunderbird-0.8-r1

that would delete compreg.dat automaticly for all users...
Back to top
View user's profile Send private message
PrakashP
Veteran
Veteran


Joined: 27 Oct 2003
Posts: 1246
Location: C.C.A.A., Germania

PostPosted: Thu Sep 16, 2004 1:43 pm    Post subject: Reply with quote

Actually yesterday evening I was thinking about adding this to the bug as note, but then I thought, maybe I am the only one having such a bad luck of disappearing emails... ;)
Back to top
View user's profile Send private message
Timbers2k
Apprentice
Apprentice


Joined: 03 Oct 2003
Posts: 215

PostPosted: Thu Sep 16, 2004 8:53 pm    Post subject: Reply with quote

Don't you just love these forums? I had the problem, did a quick search and here is the solution. All in five minutes!

Thanks!
Back to top
View user's profile Send private message
MattSharp
Apprentice
Apprentice


Joined: 15 Aug 2003
Posts: 258

PostPosted: Fri Sep 17, 2004 3:21 pm    Post subject: Reply with quote

Bump for anyone who might miss this....

Deleting that file also worked for me. I'm surprised. Because using Mozilla upgrades take forever to get new ebuilds. Perhaps this is why.......
Back to top
View user's profile Send private message
malloc
l33t
l33t


Joined: 19 Sep 2003
Posts: 762

PostPosted: Fri Sep 17, 2004 4:32 pm    Post subject: Reply with quote

Here's another success story after deleting compreg.dat.
Everything went normal after that.
_________________
--> Linux ### 2.6.11-ck2 #1 Sat Mar 12 20:21:30 WET 2005 i686 GNU/Linux <--
Back to top
View user's profile Send private message
lduperval
Apprentice
Apprentice


Joined: 14 Jun 2003
Posts: 189

PostPosted: Fri Sep 17, 2004 4:39 pm    Post subject: Reply with quote

Maybe this should be sticky for a while.

L
Back to top
View user's profile Send private message
kc8tbe
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 135
Location: Cleveland, OH USA

PostPosted: Sat Sep 18, 2004 7:53 pm    Post subject: Reply with quote

Hooray! I had the same problems; deleting compreg.dat worked for me too! Thanks everybody!
Back to top
View user's profile Send private message
krdp
n00b
n00b


Joined: 27 Feb 2004
Posts: 41
Location: Newfoundland, Canada

PostPosted: Sat Sep 18, 2004 10:43 pm    Post subject: Reply with quote

Yeah deleting compreg.dat worked for me too, Thanks!! Again the Gentoo Forums are helpful
Back to top
View user's profile Send private message
manifest
n00b
n00b


Joined: 10 Oct 2003
Posts: 13

PostPosted: Sat Sep 18, 2004 11:55 pm    Post subject: Reply with quote

deleting comreg.dat worked for me aswell :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum