Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
bash-completion of environment variables annoyance
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
hippo
n00b
n00b


Joined: 28 Jan 2004
Posts: 17

PostPosted: Mon Aug 09, 2004 12:54 am    Post subject: bash-completion of environment variables annoyance Reply with quote

Hi,

When I tab out an environment variable during a cd, the $(dollar sign) sign is escaped so although the tab completion happens the cd doesn't work. e.g

cd $JA[hit tab] and this lines becomes
cd \$JAVA_HOME[hit enter] and I get
-bash: cd: $JAVA_HOME: No such file or directory

If I comment out the bash-completion line in .bashrc this doesn't happen - the tab completion works correctly.

I'm using
bash-2.05b-r9
bash-completion 20040526

As you might imagine, this is shitting me to tears so your help would be much appreciated. Thank you.

Hippo.
Back to top
View user's profile Send private message
JPMRaptor
Guru
Guru


Joined: 04 Oct 2002
Posts: 410
Location: Maryland

PostPosted: Mon Aug 09, 2004 1:01 am    Post subject: Reply with quote

Never noticed that before. It's doing the same thing for me. I poked around the bash-completion related config files. It looks like the "cd" related stuff is setup in /etc/bash_completion. You may be able to comment out the _cd() section to get it to stop mangling environment variables for the cd command (temporary solution, but better than nothing).

It looks like the real problem is with the bash-completion handling of environment variables. It shouldn't be escaping the $.
_________________
Underwater photo gallery
New pictures, Oct 2005
Back to top
View user's profile Send private message
mhodak
Veteran
Veteran


Joined: 15 Nov 2003
Posts: 1208

PostPosted: Mon Aug 09, 2004 7:15 am    Post subject: Reply with quote

I have even tried the latest version available 20040704-r1, but it is still doing it. I guess somebody should send bug report to Ian Macdonald.
Back to top
View user's profile Send private message
hippo
n00b
n00b


Joined: 28 Jan 2004
Posts: 17

PostPosted: Mon Aug 09, 2004 9:17 am    Post subject: Reply with quote

ok i'll him a bug report.
Thanks for trying the latest version. I'll quote you in the bug report.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum