Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Getting package conflict errors.
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
manu_leo
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2014
Posts: 111
Location: India

PostPosted: Tue Aug 26, 2014 6:18 am    Post subject: [SOLVED] Getting package conflict errors. Reply with quote

Hi Experts, I am getting this below error message when trying to install QT

Quote:
!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/openssl:0

(dev-libs/openssl-1.0.1i::gentoo, installed) pulled in by
>=dev-libs/openssl-0.9.6d:0[bindist=] required by (net-misc/openssh-6.6_p1-r1::gentoo, installed)

(dev-libs/openssl-1.0.2_beta2::gentoo, ebuild scheduled for merge) pulled in by
dev-libs/openssl:0[-bindist] required by (dev-qt/qtnetwork-5.3.1-r1::qt, ebuild scheduled for merge)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.


I am trying to fix this by :-

Quote:
emerge --ask --oneshot dev-libs/openssl-1.0.2_beta2

but this is not working. Could somehow help me how to get this fixed.

Appreciate all your help


Last edited by manu_leo on Tue Aug 26, 2014 7:51 am; edited 1 time in total
Back to top
View user's profile Send private message
jburns
l33t
l33t


Joined: 18 Jan 2007
Posts: 832
Location: Massachusetts USA

PostPosted: Tue Aug 26, 2014 6:45 am    Post subject: Reply with quote

dev-qt/qtnetwork wants dev-libs/openssl installed with the -bindist USE flag. net-misc/openssh wants dev-libs/openssl installed with the bindist USE flag set to match its value of the bindist USE flag. Emerge net-misc/openssh with the -bindist USE flag.
Back to top
View user's profile Send private message
manu_leo
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jan 2014
Posts: 111
Location: India

PostPosted: Tue Aug 26, 2014 6:59 am    Post subject: Reply with quote

Thanks jburns for your help.

Could you please help me with the command to emerge net-misc/openssh with the -bindist USE flag.

Is it done this way :-

Quote:
emerge net-misc/openssh -bindist


Appreciate all your help.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum