Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] failed to build libreoffice
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
AgBr
Apprentice
Apprentice


Joined: 06 Nov 2010
Posts: 190

PostPosted: Mon Aug 25, 2014 8:34 am    Post subject: [solved] failed to build libreoffice Reply with quote

I am lost on this one:
Code:
checking whether to build the MariaDB/MySQL Connector extension... yes
checking which MariaDB to use... external
checking for mysql_config... /usr/bin/mysql_config
checking MariaDB version... OK
checking for MariaDB Client library... includes '-I/usr/include/mysql -DNDEBUG', libraries '-L/usr/lib -lmysqlclient_r -lpthread -lz -lm -lssl -lcrypto -ldl'
checking whether to bundle the MySQL/MariaDB client library... no
checking MySQL Connector/C++... external
checking mysql_driver.h usability... yes
checking mysql_driver.h presence... yes
checking for mysql_driver.h... yes
checking for main in -lmysqlcppconn... yes
checking version... configure: error: not suitable, we need >= 1.0.6

!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-office/libreoffice-4.2.5.2/work/libreoffice-4.2.5.2/config.log
 * ERROR: app-office/libreoffice-4.2.5.2::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 7181:  Called econf '--docdir=/usr/share/doc/libreoffice-4.2.5.2/' '--with-system-headers' '--with-system-libs' '--with-system-jars' '--with-system-dicts' '--enable-cairo-canvas' '--enable-graphite' '--enable-largefile' '--enable-mergelibs' '--enable-python=system' '--enable-randr' '--enable-randr-link' '--enable-release-build' '--disable-hardlink-deliver' '--disable-ccache' '--disable-crashdump' '--disable-dependency-tracking' '--disable-epm' '--disable-fetch-external' '--disable-gnome-vfs' '--disable-gstreamer-0-10' '--disable-report-builder' '--disable-kdeab' '--disable-kde' '--disable-online-update' '--disable-systray' '--with-alloc=jemalloc' '--with-build-version=Gentoo official package' '--enable-extension-integration' '--with-external-dict-dir=/usr/share/myspell' '--with-external-hyph-dir=/usr/share/myspell' '--with-external-thes-dir=/usr/share/myspell' '--with-external-tar=/var/tmp/portage/app-office/libreoffice-4.2.5.2/distdir' '--with-lang=' '--with-parallelism=5' '--with-system-ucpp' '--with-vendor=Gentoo Foundation' '--with-x' '--without-afms' '--without-fonts' '--without-myspell-dicts' '--without-help' '--with-helppack-integration' '--without-sun-templates' '--enable-sdremote-bluetooth' '--enable-cups' '--disable-debug' '--enable-dbus' '--disable-evolution2' '--disable-firebird-sdbc' '--disable-gconf' '--disable-gio' '--disable-lockdown' '--disable-gstreamer' '--enable-gtk' '--disable-gtk3' '--enable-kde4' '--enable-ext-mariadb-connector' '--disable-odk' '--enable-opengl' '--disable-postgresql-sdbc' '--disable-telepathy' '--enable-vba' '--disable-vlc' '--enable-neon' '--with-java' '--with-system-mysql-cppconn' '--without-doxygen' '--without-system-sane' '--without-system-vigra' '--without-junit' '--without-system-hsqldb' '--with-ant-home=/usr/share/ant' '--with-jdk-home=/opt/icedtea-bin-6.1.13.3' '--with-jvm-path=/usr/lib/' '--disable-ext-nlpsolver' '--disable-scripting-beanshell' '--disable-scripting-javascript' '--disable-ext-wiki-publisher'
 *   phase-helpers.sh, line  584:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=app-office/libreoffice-4.2.5.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-office/libreoffice-4.2.5.2::gentoo'`.
!!! When you file a bug report, please include the following information:
GENTOO_VM=icedtea-bin-6  CLASSPATH="" JAVA_HOME="/opt/icedtea-bin-6.1.13.3"
JAVACFLAGS="-source 1.6 -target 1.6" COMPILER=""
and of course, the output of emerge --info =libreoffice-4.2.5.2
 * The complete build log is located at '/var/tmp/portage/app-office/libreoffice-4.2.5.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/libreoffice-4.2.5.2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/libreoffice-4.2.5.2/work/libreoffice-4.2.5.2'
 * S: '/var/tmp/portage/app-office/libreoffice-4.2.5.2/work/libreoffice-4.2.5.2'

>>> Failed to emerge app-office/libreoffice-4.2.5.2, Log file:

>>>  '/var/tmp/portage/app-office/libreoffice-4.2.5.2/temp/build.log'

 * Messages for package app-office/libreoffice-4.2.5.2:

 * ERROR: app-office/libreoffice-4.2.5.2::gentoo failed (configure phase):
 *   econf failed
 *
 * Call stack:
 *          ebuild.sh, line   93:  Called src_configure
 *        environment, line 7181:  Called econf '--docdir=/usr/share/doc/libreoffice-4.2.5.2/' '--with-system-headers' '--with-system-libs' '--with-system-jars' '--with-system-dicts' '--enable-cairo-canvas' '--enable-graphite' '--enable-largefile' '--enable-mergelibs' '--enable-python=system' '--enable-randr' '--enable-randr-link' '--enable-release-build' '--disable-hardlink-deliver' '--disable-ccache' '--disable-crashdump' '--disable-dependency-tracking' '--disable-epm' '--disable-fetch-external' '--disable-gnome-vfs' '--disable-gstreamer-0-10' '--disable-report-builder' '--disable-kdeab' '--disable-kde' '--disable-online-update' '--disable-systray' '--with-alloc=jemalloc' '--with-build-version=Gentoo official package' '--enable-extension-integration' '--with-external-dict-dir=/usr/share/myspell' '--with-external-hyph-dir=/usr/share/myspell' '--with-external-thes-dir=/usr/share/myspell' '--with-external-tar=/var/tmp/portage/app-office/libreoffice-4.2.5.2/distdir' '--with-lang=' '--with-parallelism=5' '--with-system-ucpp' '--with-vendor=Gentoo Foundation' '--with-x' '--without-afms' '--without-fonts' '--without-myspell-dicts' '--without-help' '--with-helppack-integration' '--without-sun-templates' '--enable-sdremote-bluetooth' '--enable-cups' '--disable-debug' '--enable-dbus' '--disable-evolution2' '--disable-firebird-sdbc' '--disable-gconf' '--disable-gio' '--disable-lockdown' '--disable-gstreamer' '--enable-gtk' '--disable-gtk3' '--enable-kde4' '--enable-ext-mariadb-connector' '--disable-odk' '--enable-opengl' '--disable-postgresql-sdbc' '--disable-telepathy' '--enable-vba' '--disable-vlc' '--enable-neon' '--with-java' '--with-system-mysql-cppconn' '--without-doxygen' '--without-system-sane' '--without-system-vigra' '--without-junit' '--without-system-hsqldb' '--with-ant-home=/usr/share/ant' '--with-jdk-home=/opt/icedtea-bin-6.1.13.3' '--with-jvm-path=/usr/lib/' '--disable-ext-nlpsolver' '--disable-scripting-beanshell' '--disable-scripting-javascript' '--disable-ext-wiki-publisher'
 *   phase-helpers.sh, line  584:  Called die
 * The specific snippet of code:
 *                      die "econf failed"
 *
 * If you need support, post the output of `emerge --info '=app-office/libreoffice-4.2.5.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=app-office/libreoffice-4.2.5.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/app-office/libreoffice-4.2.5.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/app-office/libreoffice-4.2.5.2/temp/environment'.
 * Working directory: '/var/tmp/portage/app-office/libreoffice-4.2.5.2/work/libreoffice-4.2.5.2'
 * S: '/var/tmp/portage/app-office/libreoffice-4.2.5.2/work/libreoffice-4.2.5.2'
 *
 * The following package has failed to build or install:
 *
 *  (app-office/libreoffice-4.2.5.2:0/0::gentoo, ebuild scheduled for merge), Log file:
 *   '/var/tmp/portage/app-office/libreoffice-4.2.5.2/temp/build.log'


Of cause, I can provide the full build.log if needed. But the issue seems to be in the last checking lines
Code:
checking for main in -lmysqlcppconn... yes
checking version... configure: error: not suitable, we need >= 1.0.6


I can not see the version of what is not suitable. It can not be this one:
Code:

[I] dev-db/mysql-connector-c++
     Available versions:  1.1.1{tbz2} ~1.1.3 {debug examples gcov static-libs}
     Installed versions:  1.1.1{tbz2}(16:10:15 21.12.2012)(-debug -examples -gcov -static-libs)
     Homepage:            http://dev.mysql.com/downloads/connector/cpp/
     Description:         MySQL database connector for C++ (mimics JDBC 4.0 API)


Any ideas would be appreciated


Last edited by AgBr on Mon Aug 25, 2014 5:16 pm; edited 1 time in total
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1668
Location: Berlin, Germany

PostPosted: Mon Aug 25, 2014 9:01 am    Post subject: Reply with quote

Code:
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-office/libreoffice-4.2.5.2/work/libreoffice-4.2.5.2/config.log
config.log will tell more about the check that failed. You can try to find the particular line of that check and post it here (or the entire config.log if you can't find it)
Back to top
View user's profile Send private message
AgBr
Apprentice
Apprentice


Joined: 06 Nov 2010
Posts: 190

PostPosted: Mon Aug 25, 2014 12:17 pm    Post subject: Reply with quote

chithanh wrote:
Code:
!!! Please attach the following file when seeking support:
!!! /var/tmp/portage/app-office/libreoffice-4.2.5.2/work/libreoffice-4.2.5.2/config.log
config.log will tell more about the check that failed. You can try to find the particular line of that check and post it here (or the entire config.log if you can't find it)


It seems to be this:

Code:

configure:23293: checking for main in -lmysqlcppconn
configure:23312: i686-pc-linux-gnu-g++ -o conftest -O2 -march=i686 -pipe -fomit-frame-pointer -ggdb  -Wl,-O1 -Wl,--as-needed conftest.cpp -lmysqlcppconn   >&5
configure:23312: $? = 0
configure:23321: result: yes
configure:23331: checking version
configure:23356: i686-pc-linux-gnu-g++ -o conftest -O2 -march=i686 -pipe -fomit-frame-pointer -ggdb  -Wl,-O1 -Wl,--as-needed conftest.cpp  -lmysqlcppconn >&5
configure:23356: $? = 1
configure: program exited with status 1
configure: failed program was:
configure:23360: error: not suitable, we need >= 1.0.6
configure: exit 1


Unfortunately it is not more enlightening to me
Back to top
View user's profile Send private message
gienah
Developer
Developer


Joined: 24 Nov 2010
Posts: 127
Location: AU

PostPosted: Mon Aug 25, 2014 1:59 pm    Post subject: Reply with quote

One thing to check is if this library is ok or broken by updates:
Code:
ldd -r /usr/lib64/libmysqlcppconn.so

If its broken you could try rebuilding it:
Code:
emerge -av -1 dev-db/mysql-connector-c++

Then see if that fixes it or not:
Code:
ldd -r /usr/lib64/libmysqlcppconn.so
Back to top
View user's profile Send private message
AgBr
Apprentice
Apprentice


Joined: 06 Nov 2010
Posts: 190

PostPosted: Mon Aug 25, 2014 5:15 pm    Post subject: Reply with quote

gienah wrote:
One thing to check is if this library is ok or broken by updates:
Code:
ldd -r /usr/lib64/libmysqlcppconn.so

If its broken you could try rebuilding it:
Code:
emerge -av -1 dev-db/mysql-connector-c++

Then see if that fixes it or not:
Code:
ldd -r /usr/lib64/libmysqlcppconn.so


That has done it. Thank you!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum