Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
perl-5.18, python 2.6 and lib64 problems
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 847
Location: Tri-Cities, WA USA

PostPosted: Sat Aug 23, 2014 4:53 pm    Post subject: perl-5.18, python 2.6 and lib64 problems Reply with quote

I'm really not sure what to do with the following problem.
I need to preserve the libraries below but there is no ebuild in my tree.
I'm not sure why perl 5.18 is pulling these libraries.
I really don't want to start removing things until I probe this forum.

Any ideas?
Code:

>>> Installing (1 of 1) sys-libs/gdbm-1.11
>>> needed    sym /usr/lib64/libgdbm.so.3
>>> needed    obj /usr/lib64/libgdbm.so.3.0.0
>>> needed    sym /usr/lib64/libgdbm_compat.so.3
>>> needed    obj /usr/lib64/libgdbm_compat.so.3.0.0

>>> Recording sys-libs/gdbm in "world" favorites file...
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * Regenerating GNU info directory index...
 * Processed 123 info files.

!!! existing preserved libs:
>>> package: sys-libs/gdbm-1.11
 *  - /usr/lib64/libgdbm_compat.so.3
 *  - /usr/lib64/libgdbm_compat.so.3.0.0
 *      used by /usr/lib64/perl5/5.18.2/x86_64-linux/auto/NDBM_File/NDBM_File.so (dev-lang/perl-5.18.2-r1)
 *      used by /usr/lib64/python2.6/lib-dynload/dbm.so (dev-lang/python-2.6.8-r3)
 *      used by /usr/lib64/python2.7/lib-dynload/dbm.so (dev-lang/python-2.7.7)
 *      used by 2 other files
 *  - /usr/lib64/libgdbm.so.3
 *  - /usr/lib64/libgdbm.so.3.0.0
 *      used by /usr/lib64/apr-util-1/apr_dbm_gdbm-1.so (dev-libs/apr-util-1.5.3-r2)
 *      used by /usr/lib64/libpulsecore-5.0.so (media-sound/pulseaudio-5.0-r2)
 *      used by /usr/lib64/perl5/5.18.2/x86_64-linux/auto/GDBM_File/GDBM_File.so (dev-lang/perl-5.18.2-r1)
 *      used by 19 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
azzerare ~ # emerge @preserved-rebuild
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/python:2.6".
(dependency required by "@preserved-rebuild" [argument])



Code:
azzerare ~ # emerge --info
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.19-r1, 3.12.21-gentoo-r1 x86_64)
=================================================================
System uname: Linux-3.12.21-gentoo-r1-x86_64-AMD_Athlon-tm-_64_Processor_3400+-with-gentoo-2.2
KiB Mem:     3309092 total,   1359000 free
KiB Swap:    8388812 total,   8256992 free
Timestamp of tree: Sat, 23 Aug 2014 13:00:01 +0000
ld GNU ld (GNU Binutils) 2.23.2
app-shells/bash:          4.2_p45
dev-java/java-config:     2.2.0
dev-lang/python:          2.6.8-r3, 2.7.7, 3.2.5-r6, 3.3.5-r1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.13.4
sys-devel/binutils:       2.23.2
sys-devel/gcc:            4.7.3-r1
sys-devel/gcc-config:     1.7.3
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           3.82-r4
sys-kernel/linux-headers: 3.13 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo floppym x-portage
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=native -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/gnupg/qualified.txt /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/php/apache2-php5.5/ext-active/ /etc/php/cgi-php5.5/ext-active/ /etc/php/cli-php5.5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-march=native -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--autounmask=n"
FCFLAGS="-O2 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -pipe"
GENTOO_MIRRORS="http://gentoo.osuosl.org/ "
LANG="en_US.utf8"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/floppym /usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa amd64 berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus dri dts dvd dvdr emboss encode eudev exif fam firefox flac fortran gdbm gif gpm gtk iconv ipv6 jpeg lcms ldap libnotify mad mmx mng modules mp3 mp4 mpeg multilib ncurses nls nptl ogg opengl openmp pam pango pcre pdf png policykit ppds qt3support readline sdl session spell sqlite sse sse2 ssl startup-notification svg tcpd threads tiff tk truetype udev udisks unicode upower usb vorbis wxwidgets x264 xcb xml xv xvid zlib" ABI_X86="64" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_2 python3_3" RUBY_TARGETS="ruby19 ruby20" USERLAND="GNU" VIDEO_CARDS="nouveau" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
USE_PYTHON="2.7 3.2 3.3"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, LC_ALL, MAKEOPTS, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4106
Location: USA

PostPosted: Sat Aug 23, 2014 5:27 pm    Post subject: Reply with quote

Perl isn't pulling them in, it's just old ebuilds that were installed and went away.
The question is if you need Python-2.6 anymore? If you don't need it, simply emerge --depclean =python-2.6 it, and the issue will go away.

I have a similar issue on my netbook where I refuse to upgrade openoffice 3.3.5 (because the newer ones are simply bigger)... I can't emerge @preserved-rebuild because it wants to upgrade openoffice which is referring to old library files.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 847
Location: Tri-Cities, WA USA

PostPosted: Sat Aug 23, 2014 11:21 pm    Post subject: Reply with quote

eccerr0r wrote:
Perl isn't pulling them in, it's just old ebuilds that were installed and went away.
The question is if you need Python-2.6 anymore? If you don't need it, simply emerge --depclean =python-2.6 it, and the issue will go away.

I have a similar issue on my netbook where I refuse to upgrade openoffice 3.3.5 (because the newer ones are simply bigger)... I can't emerge @preserved-rebuild because it wants to upgrade openoffice which is referring to old library files.


thanks for the lines:

I wonder if I should do s system --depclean ? After I backup my kernel sources,

No luck with :

azzerare python # emerge --depclean =python-2.6
--- Couldn't find '=dev-lang/python-2.6' to depclean.
>>> No packages selected for removal by depclean

Here's my python ebuilds.
azzerare python # pwd
/usr/portage/dev-lang/python
azzerare python # ls -l
total 236
-rw-r--r-- 1 portage portage 36164 Aug 18 14:01 ChangeLog
-rw-r--r-- 1 portage portage 100599 Jan 1 2012 ChangeLog-2011
-rw-r--r-- 1 portage portage 15060 Aug 18 14:01 Manifest
drwxr-xr-x 2 portage portage 4096 Jul 30 05:50 files
-rw-r--r-- 1 portage portage 661 Dec 6 2009 metadata.xml
-rw-r--r-- 1 portage portage 10506 Aug 9 04:01 python-2.7.7.ebuild
-rw-r--r-- 1 portage portage 10521 Jul 29 15:51 python-2.7.8.ebuild
-rw-r--r-- 1 portage portage 11164 Aug 9 04:01 python-3.2.5-r6.ebuild
-rw-r--r-- 1 portage portage 9522 Aug 9 04:01 python-3.3.5-r1.ebuild
-rw-r--r-- 1 portage portage 9308 May 9 19:01 python-3.4.0.ebuild
-rw-r--r-- 1 portage portage 9242 Jun 28 16:39 python-3.4.1.ebuild
azzerare python #
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4106
Location: USA

PostPosted: Sat Aug 23, 2014 11:32 pm    Post subject: Reply with quote

Actually you should emerge --depclean =dev-lang/python-2.6.8-r3 ... specifying an = will point at exact packages :oops:

Then emerge @preserved-rebuild should rebuild python 2.7.7, perl 5.18.2, and a whole bunch of other package that depend on gdbm.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 847
Location: Tri-Cities, WA USA

PostPosted: Sun Aug 24, 2014 2:23 pm    Post subject: Reply with quote

eccerr0r wrote:
Actually you should emerge --depclean =dev-lang/python-2.6.8-r3 ... specifying an = will point at exact packages :oops:

Then emerge @preserved-rebuild should rebuild python 2.7.7, perl 5.18.2, and a whole bunch of other package that depend on gdbm.


ouch:

* GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: sys-libs/gdbm-1.11
* - /usr/lib64/libgdbm_compat.so.3
* - /usr/lib64/libgdbm_compat.so.3.0.0
* used by /usr/lib64/perl5/5.18.2/x86_64-linux/auto/NDBM_File/NDBM_File.so (dev-lang/perl-5.18.2-r1)
* used by /usr/lib64/python2.6/lib-dynload/dbm.so (dev-lang/python-2.6.8-r3)
* used by /usr/lib64/python2.7/lib-dynload/dbm.so (dev-lang/python-2.7.7)
* used by 2 other files
* - /usr/lib64/libgdbm.so.3
* - /usr/lib64/libgdbm.so.3.0.0
* used by /usr/lib64/apr-util-1/apr_dbm_gdbm-1.so (dev-libs/apr-util-1.5.3-r2)
* used by /usr/lib64/libpulsecore-5.0.so (media-sound/pulseaudio-5.0-r2)
* used by /usr/lib64/perl5/5.18.2/x86_64-linux/auto/GDBM_File/GDBM_File.so (dev-lang/perl-5.18.2-r1)
* used by 15 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
* After world updates, it is important to remove obsolete packages with
* emerge --depclean. Refer to `man emerge` for more information.
azzerare ~ # emerge @preserved-rebuild
Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "dev-lang/python:2.6".
(dependency required by "@preserved-rebuild" [argument])
azzerare ~ # emerge --depclean --verbose =dev-lang/perl-5.18.2-r1

Calculating dependencies ^C

Exiting on signal 2
azzerare ~ # emerge @preserved-rebuild
Calculating dependencies... done!

!!! All ebuilds that could satisfy "app-admin/apache-tools:0" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-admin/apache-tools-2.4.10::gentoo (masked by: package.mask, ~amd64 keyword)
- app-admin/apache-tools-2.4.9-r1::gentoo (masked by: package.mask, ~amd64 keyword)
- app-admin/apache-tools-2.2.27-r1::gentoo (masked by: package.mask, ~amd64 keyword)
- app-admin/apache-tools-2.2.27::gentoo (masked by: package.mask)

(dependency required by "@preserved-rebuild" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

I use nginx and I've masked apache and apache-tools
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5674

PostPosted: Sun Aug 24, 2014 5:56 pm    Post subject: Reply with quote

:roll: So, did you or did you not unmerge python 2.6 ? Cause going by the output you didn't...
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 847
Location: Tri-Cities, WA USA

PostPosted: Mon Aug 25, 2014 3:48 am    Post subject: Reply with quote

VoidMage wrote:
:roll: So, did you or did you not unmerge python 2.6 ? Cause going by the output you didn't...


woops. I unmerged it just a few minutes ago. Thanks.

Code:

azzerare python # emerge -C =python-2.6.8-r3
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

 dev-lang/python
    selected: 2.6.8-r3
   protected: none
     omitted: 2.7.7 3.2.5-r6 3.3.5-r1

All selected packages: dev-lang/python-2.6.8-r3

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging (1 of 1) dev-lang/python-2.6.8-r3...
>>> needed   obj /usr/lib64/libpython2.6.so.1.0

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-lang/python-2.6.8-r3
 *  - /usr/lib64/libpython2.6.so.1.0
 *      used by /usr/lib64/python2.6/site-packages/uniconvertor/app/modules/_sketch.so (media-gfx/uniconvertor-1.1.5)
 *      used by /usr/lib64/python2.6/site-packages/uniconvertor/app/modules/_type1.so (media-gfx/uniconvertor-1.1.5)
 *      used by /usr/lib64/python2.6/site-packages/uniconvertor/app/modules/pstokenize.so (media-gfx/uniconvertor-1.1.5)
 *      used by 2 other files
>>> package: sys-libs/gdbm-1.11
 *  - /usr/lib64/libgdbm_compat.so.3
 *  - /usr/lib64/libgdbm_compat.so.3.0.0
 *      used by /usr/lib64/perl5/5.18.2/x86_64-linux/auto/NDBM_File/NDBM_File.so (dev-lang/perl-5.18.2-r1)
 *      used by /usr/lib64/python2.7/lib-dynload/dbm.so (dev-lang/python-2.7.7)
 *      used by /usr/lib64/python3.2/lib-dynload/_dbm.cpython-32.so (dev-lang/python-3.2.5-r6)
 *      used by /usr/lib64/python3.3/lib-dynload/_dbm.cpython-33.so (dev-lang/python-3.3.5-r1)
 *  - /usr/lib64/libgdbm.so.3
 *  - /usr/lib64/libgdbm.so.3.0.0
 *      used by /usr/lib64/apr-util-1/apr_dbm_gdbm-1.so (dev-libs/apr-util-1.5.3-r2)
 *      used by /usr/lib64/libpulsecore-5.0.so (media-sound/pulseaudio-5.0-r2)
 *      used by /usr/lib64/perl5/5.18.2/x86_64-linux/auto/GDBM_File/GDBM_File.so (dev-lang/perl-5.18.2-r1)
 *      used by 14 other files
Use emerge @preserved-rebuild to rebuild packages using these libraries
azzerare python #  emerge @preserved-rebuild
Calculating dependencies... done!

!!! All ebuilds that could satisfy "app-admin/apache-tools:0" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-admin/apache-tools-2.4.10::gentoo (masked by: package.mask, ~amd64 keyword)
- app-admin/apache-tools-2.4.9-r1::gentoo (masked by: package.mask, ~amd64 keyword)
- app-admin/apache-tools-2.2.27-r1::gentoo (masked by: package.mask, ~amd64 keyword)
- app-admin/apache-tools-2.2.27::gentoo (masked by: package.mask)

(dependency required by "@preserved-rebuild" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

azzerare python #



yikes
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 4106
Location: USA

PostPosted: Mon Aug 25, 2014 2:11 pm    Post subject: Reply with quote

Oh no... Never use emerge -C (or --unmerge) if you don't know what you're doing! Use --depclean. If it says it can't remove it, there's a reason behind it.

Now it says that media-gfx/uniconvertor-1.1.5 was "using" python 2.6 and you suddenly ... but this may be benign. Use "python-updater" to clean up python stuff (much like perl-cleaner). Hopefully this will clean up uniconvertor.
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum