Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201408-06 ] libpng: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Thu Aug 14, 2014 3:26 pm    Post subject: [ GLSA 201408-06 ] libpng: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: libpng: Multiple vulnerabilities (GLSA 201408-06)
Severity: normal
Exploitable: remote
Date: August 14, 2014
Bug(s): #503014, #507378
ID: 201408-06

Synopsis

Multiple vulnerabilities have been discovered in libpng which can
allow a remote attacker to cause a Denial of Service condition.


Background

libpng is a standard library used to process PNG (Portable Network
Graphics) images. It is used by several programs, including web browsers
and potentially server processes.


Affected Packages

Package: media-libs/libpng
Vulnerable: < 1.6.10
Unaffected: >= 1.6.10
Unaffected: < 1.3
Unaffected: >= 1.5.18 < 1.5.19
Architectures: All supported architectures


Description

The png_push_read_chunk function in pngpread.c in the progressive
decoder enters an infinite loop, when it encounters a zero-length IDAT
chunk. In addition certain integer overflows have been detected and
corrected.
The 1.2 branch is not affected by these vulnerabilities.

Impact

A remote attacker could entice a user to open a specially crafted PNG
file using an application linked against libpng, possibly resulting in
Denial of Service.


Workaround

There is no known workaround at this time.

Resolution

All libpng users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.6.10"
   
Users with current installs in the 1.5 branch should also upgrade this
using:
Code:
# emerge --sync
        # emerge --ask --oneshot --verbose ">=media-libs/libpng-1.5.18:1.5"
     
Packages which depend on this library may need to be recompiled. Tools
such as revdep-rebuild may assist in identifying these packages.


References


CVE-2013-7353


CVE-2013-7354


CVE-2014-0333
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum