Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problem po dzisiejszym emerge --oneshot portage
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish)
View previous topic :: View next topic  
Author Message
szpil
Tux's lil' helper
Tux's lil' helper


Joined: 09 Oct 2005
Posts: 79

PostPosted: Wed Aug 13, 2014 5:44 pm    Post subject: problem po dzisiejszym emerge --oneshot portage Reply with quote

Witam

Po dzisiejszym zaktualizowaniu portage, przy jakiej kolwiek próbie wywołania emerge dostaję taki błąd
Code:
HP thurston # emerge --sync
Traceback (most recent call last):
  File "/usr/bin/emerge", line 51, in <module>
    retval = emerge_main()
  File "/usr/lib/portage/pym/_emerge/main.py", line 1042, in emerge_main
    action=myaction, args=myfiles, opts=myopts)
  File "/usr/lib/portage/pym/portage/proxy/objectproxy.py", line 30, in __call__
    result = object.__getattribute__(self, '_get_target')()
  File "/usr/lib/portage/pym/portage/proxy/lazyimport.py", line 130, in _get_target
    __import__(name)
  File "/usr/lib/portage/pym/_emerge/actions.py", line 54, in <module>
    from portage.package.ebuild.doebuild import _check_temp_dir
  File "/usr/lib/portage/pym/portage/package/ebuild/doebuild.py", line 71, in <module>
    from _emerge.BinpkgEnvExtractor import BinpkgEnvExtractor
ValueError: bad marshal data (tuple size out of range)


eselect python list pokazuje
Code:
HP thurston # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.3
  [3]   python3.4


Jakieś pomysły co z tym zrobić?
Back to top
View user's profile Send private message
sebas86
Guru
Guru


Joined: 01 May 2005
Posts: 554
Location: Szczecinek / Szczecin

PostPosted: Wed Aug 13, 2014 7:23 pm    Post subject: Reply with quote

Jak dawno temu robiłeś ostatnią aktualizację?

U mnie:
Code:
# eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3 *


Próbowałeś ustawić wyższą domyślną wersję Pythona?
_________________
Nieważne jaka dystrybucja, ważne, że Linux!
Back to top
View user's profile Send private message
szpil
Tux's lil' helper
Tux's lil' helper


Joined: 09 Oct 2005
Posts: 79

PostPosted: Fri Aug 15, 2014 5:06 pm    Post subject: Reply with quote

sebas86 Nie wiem czy to już czas na przejscie na python 3.4.

Co do samego problemu chwilowo pomaga skasowanie oraz przekopiowanie katalogów pym i bin z rozpakowanej paczki do /usr/lib/portage.
Pomaga chwilowo, po restarcie systemu pojawia się ten sam błąd.
Back to top
View user's profile Send private message
sebas86
Guru
Guru


Joined: 01 May 2005
Posts: 554
Location: Szczecinek / Szczecin

PostPosted: Fri Aug 15, 2014 8:28 pm    Post subject: Reply with quote

To jeśli działa to wrzuć
Code:
emerge --info sys-apps/portage

Bez większej ilości informacji mogę powiedzieć tylko tyle, że u mnie działa - najnowsze stabilne (2.2.8-r1).
Na problemy z pythonem bez głębszego myślenia warto też odpalić python-updater.
_________________
Nieważne jaka dystrybucja, ważne, że Linux!
Back to top
View user's profile Send private message
szpil
Tux's lil' helper
Tux's lil' helper


Joined: 09 Oct 2005
Posts: 79

PostPosted: Sat Aug 16, 2014 9:39 pm    Post subject: Reply with quote

Proszę
Code:
HP thurston # emerge --info sys-apps/portage
Portage 2.2.12 (python 2.7.8-final-0, default/linux/x86/13.0/desktop, gcc-4.8.3, glibc-2.19-r1, 3.16.1-gentoo i686)
=================================================================
                         System Settings
=================================================================
System uname: Linux-3.16.1-gentoo-i686-Intel-R-_Core-TM-2_Duo_CPU_P8700_@_2.53GHz-with-gentoo-2.2
KiB Mem:     1994096 total,    784404 free
KiB Swap:    4942532 total,   4942532 free
Timestamp of tree: Sat, 16 Aug 2014 21:15:01 +0000
ld GNU ld (Gentoo 2.24 p1.4) 2.24
app-shells/bash:          4.2_p47
dev-java/java-config:     2.2.0
dev-lang/python:          2.7.8, 3.3.5, 3.4.1
dev-util/cmake:           2.8.12.2-r1
dev-util/pkgconfig:       0.28-r2
sys-apps/baselayout:      2.2
sys-apps/openrc:          0.12.4
sys-apps/sandbox:         2.6-r1
sys-devel/autoconf:       2.13, 2.69
sys-devel/automake:       1.11.6, 1.14.1
sys-devel/binutils:       2.24-r3
sys-devel/gcc:            4.8.3
sys-devel/gcc-config:     1.8
sys-devel/libtool:        2.4.2-r1
sys-devel/make:           4.0-r1
sys-kernel/linux-headers: 3.16 (virtual/os-headers)
sys-libs/glibc:           2.19-r1
Repositories: gentoo x-foo-overlay
ACCEPT_KEYWORDS="x86 ~x86"
ACCEPT_LICENSE="* -@EULA Broadcom"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/themes/oxygen-gtk/gtk-2.0"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/dconf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=core2 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
EMERGE_DEFAULT_OPTS="--quiet-build=n"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync metadata-transfer news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="rsync://gentoo.prz.rzeszow.pl/gentoo http://gentoo.prz.rzeszow.pl http://gentoo.po.opole.pl ftp://gentoo.po.opole.pl ftp://gentoo.chem.wisc.edu/gentoo/ rsync://gentoo.chem.wisc.edu/gentoo/ http://gentoo.chem.wisc.edu/gentoo/"
LANG="pl_PL.UTF-8"
LC_ALL="pl_PL.UTF-8"
LDFLAGS="-Wl,-O1 -Wl,--sort-common -Wl,--warn-once"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_EXTRA_OPTS="--progress"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/foo-overlay"
SYNC="rsync://rsync.pl.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bindist bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups curl cxx dbus dri dts dvd dvdr emboss encode exif fam ffmpeg firefox flac fortran gadu gdbm gif gimp gpm gsm gstreamer gtk iconv ipv6 jpeg lcms ldap libnotify mad mng modules mp3 mp4 mpeg musepack ncurses nls nptl ocr ogg opengl openmp pam pango pcre pdf png policykit ppds python qt3support qt4 rar readline sdl session sndfile spell sse2 ssl startup-notification svg symlink tcpd tiff truetype udev udisks unicode upower usb vorbis wavpack wifi wxwidgets x264 x86 xcb xml xmms2 xmpp xv xvid zlib" ABI_X86="32" ALSA_CARDS="hda-intel" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev keyboard mouse kbd" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="pl" LIRC_DEVICES="all" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_4" RUBY_TARGETS="ruby19 ruby20 ruby21" SANE_BACKENDS="brscan3" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, INSTALL_MASK, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, USE_PYTHON

=================================================================
                        Package Settings
=================================================================

sys-apps/portage-2.2.12 was built with the following:
USE="(ipc) -build -doc -epydoc (-pypy) -python2 -python3 (-selinux) -xattr" LINGUAS="-ru" PYTHON_TARGETS="python2_7 python3_4 (-pypy) -python3_2 -python3_3"
Back to top
View user's profile Send private message
sebas86
Guru
Guru


Joined: 01 May 2005
Posts: 554
Location: Szczecinek / Szczecin

PostPosted: Sat Aug 16, 2014 10:03 pm    Post subject: Reply with quote

szpil wrote:
pym i bin z rozpakowanej paczki do /usr/lib/portage.
szpil wrote:
Portage 2.2.12

Używasz niestabilnego portage, może masz pecha i trafiłeś na niedziałającą wersję, zdarza się. Nie chce mi się eksperymentować na własnym systemie, więc pozostaje tylko propozycja zainstalowania stabilnej wersji i zamaskowania pozostałych jeśli to rozwiąże problem. Możliwe też, że aktualne portage nie działa z pythonem 3.4 - masz takie cele ustawione dla tej paczki, możesz spróbować dorzucić flagi
Code:
python_targets_python3_3 -python_targets_python3_4

Niestety nie mam pojęcia czy to pomoże, najlepiej zacząć od instalacji wersji stabilnej.
_________________
Nieważne jaka dystrybucja, ważne, że Linux!
Back to top
View user's profile Send private message
lsdudi
Guru
Guru


Joined: 12 Nov 2006
Posts: 389
Location: Warsaw

PostPosted: Wed Aug 20, 2014 1:45 pm    Post subject: Reply with quote

wyglada na problem z niska wersja python podbuj sie eselectem do 3.4
_________________
RLU#416942
Back to top
View user's profile Send private message
szpil
Tux's lil' helper
Tux's lil' helper


Joined: 09 Oct 2005
Posts: 79

PostPosted: Wed Aug 20, 2014 5:09 pm    Post subject: Reply with quote

Code:
HP thurston # eselect python list
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.3
  [3]   python3.4
HP thurston # eselect python set 3
HP thurston # eselect python list
Available Python interpreters:
  [1]   python2.7
  [2]   python3.3
  [3]   python3.4 *
HP thurston # python-updater
 * Starting Python Updater...
 * Main active version of Python:    3.4
 * Active version of Python 2:       2.7
 * Active version of Python 3:       3.4
 * Globally supported Python ABIs in installed repositories:
 *   gentoo:                         2.4 2.5 2.6 2.7 3.1 3.2 3.3 2.5-jython 2.7-jython 2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0
 *   x-foo-overlay:                  2.4 2.5 2.6 2.7 3.1 3.2 3.3 2.5-jython 2.7-jython 2.7-pypy-1.7 2.7-pypy-1.8 2.7-pypy-1.9 2.7-pypy-2.0
 *   Adding to list: media-sound/xmms2:0
 *   Adding to list: net-misc/dropbox:0
 * emerge -Dv1 --keep-going media-sound/xmms2:0 net-misc/dropbox:0
Traceback (most recent call last):
  File "/usr/bin/emerge", line 51, in <module>
    retval = emerge_main()
  File "/usr/lib/portage/pym/_emerge/main.py", line 1042, in emerge_main
    action=myaction, args=myfiles, opts=myopts)
  File "/usr/lib/portage/pym/portage/proxy/objectproxy.py", line 30, in __call__
    result = object.__getattribute__(self, '_get_target')()
  File "/usr/lib/portage/pym/portage/proxy/lazyimport.py", line 130, in _get_target
    __import__(name)
  File "/usr/lib/portage/pym/_emerge/actions.py", line 40, in <module>
    from portage.cache.cache_errors import CacheError
  File "/usr/lib/portage/pym/portage/cache/cache_errors.py", line 29
    if exception == None:   exception =# Copyright: 2005 Gentoo Foundation
                                                                         ^
SyntaxError: invalid syntax
Back to top
View user's profile Send private message
halvmork
n00b
n00b


Joined: 17 Mar 2011
Posts: 33
Location: Warszawa

PostPosted: Thu Aug 21, 2014 7:38 am    Post subject: Reply with quote

Spróbuj tych komend:

Code:

 eselect python set 1
python-updater


Pozdrawiam
Back to top
View user's profile Send private message
lsdudi
Guru
Guru


Joined: 12 Nov 2006
Posts: 389
Location: Warsaw

PostPosted: Tue Aug 26, 2014 12:54 pm    Post subject: Reply with quote

wyglada to na sieczke w pliku:
Code:
 File "/usr/lib/portage/pym/portage/cache/cache_errors.py", line 29
    if exception == None:   exception =# Copyright: 2005 Gentoo Foundation


powinno byc
Code:
  if exception == None:   exception =''
w tej lini
_________________
RLU#416942
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum