Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HELP - can't read EDID from monitor - SOLVED
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Anon-E-moose
Advocate
Advocate


Joined: 23 May 2008
Posts: 2336
Location: Dallas area

PostPosted: Wed Aug 20, 2014 3:40 pm    Post subject: Reply with quote

Frankly I'm surprised that the nvidia fb worked, given that it's really designed for older nvidia chipsets and isn't to be used with the nvidia proprietary blob.

This looks like the latest (stable) for that chipset: x11-drivers/nvidia-drivers-340.24

It the ebuild installed properly and you tell X to use nvidia then it should just work.
---
If the nvidia fb worked and the only thing missing was edid info, there is an option in the config (at least in the 3.15 kernel series) designed for that.
FB_NVIDIA_I2C - This enables I2C support for nVidia Chipsets. This is used only for getting EDID information from the attached display
I have no idea if it will work for you.
_________________
Asus m5a99fx, FX 8320 - amd64-multilib, 3.15.9-zen, glibc-2.17, gcc-4.7.3-r1, eudev
xorg-server-1.16, openbox w/lxpanel, nouveau, oss4
Back to top
View user's profile Send private message
Moriah
Veteran
Veteran


Joined: 27 Mar 2004
Posts: 1907
Location: Kentucky

PostPosted: Wed Aug 20, 2014 3:44 pm    Post subject: Reply with quote

When I used nvidia_fb, the NVidia driver was not loading. Also, although get_edid | parse_edid did not work, the modelines were in the log, and xrandr worked to put it into hires mode.
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Moriah
Veteran
Veteran


Joined: 27 Mar 2004
Posts: 1907
Location: Kentucky

PostPosted: Fri Aug 22, 2014 4:16 am    Post subject: Reply with quote

SUCCESS!!! :D :D :D

I have it working. Can't say exactly what I changed, because I was in a "try this -- nope; thy that -- nope; try this other thing -- etc. Then suddenly, it started working.

What I can do is post my .config from the kernel build, and the /etc/X11/xorg.conf file.

It even swoitches back and forth between text console and X display mode, and I am running 5 concurrent X-servers with it on F7 thru F11.

Still a few rough edges.

1. The backlight dimmer doesn't work on the built-in laptop display.

2. There is a noticable delay when switching between X-servers.

3. Occasional;ly, the 3840x2160 Dell external monitor will flicker like the video is being blamnked for a fraction of the vertical sweep. The blanking seems to always be in the lower portion ofthe screen. This is not a problem unique to the Gentoo X-server, as I also saw this when I ran M$ w7-32 on this same laptop and display. I read something about this when first looking up how to configure Linux for the nvidia chips, and vaguely remmember seeing that a newer version of the driver was reported to have cure this problem. I do not know what version that was, or whether I am running that version, or a newer, or older version.

4. I have to change my display configuration in the BIOS depending on whether I am planning to use the external display or not, but I can live with that.

5. Sometimes, the external monitor goes black. If I power it off for a second, then power it back on, the picture is restored.

For the record, here are the changes to my .config file before and after getting the nvidia chipset to work. The *_wifi file was the before, when I was only using the laptop display with the intel drivers. The *_nvidia_vesa file is the config that works with my external monitor.
Code:

root@onesimus boot # diff config-3.12.21-gentoo-r1_wifi config-3.12.21-gentoo-r1_nvidia_vesa
1838,1841c1838,1841
< # CONFIG_FB_BOOT_VESA_SUPPORT is not set
< CONFIG_FB_CFB_FILLRECT=m
< CONFIG_FB_CFB_COPYAREA=m
< CONFIG_FB_CFB_IMAGEBLIT=m
---
> CONFIG_FB_BOOT_VESA_SUPPORT=y
> CONFIG_FB_CFB_FILLRECT=y
> CONFIG_FB_CFB_COPYAREA=y
> CONFIG_FB_CFB_IMAGEBLIT=y
1865c1865
< # CONFIG_FB_VESA is not set
---
> CONFIG_FB_VESA=y
root@onesimus boot #

And here is my xorg.conf file:
Code:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 331.20  (portage@onesimus)  Fri Aug  8 15:32:22 EDT 2014

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 340.24  (buildmeister@swio-display-x64-rhel04-07)  Wed Jul  2 15:50:44 PDT 2014

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from data in "/etc/conf.d/gpm"
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol"
    Option         "Device" "/dev/input/mice"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "AU Optronics Corporation"
    HorizSync       56.5 - 67.8
    VertRefresh     50.0 - 60.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "Quadro K1000M"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-4"
    Option         "metamodes" "LVDS-0: nvidia-auto-select +0+0, DP-3: 3840x2160 +0+0"
    Option         "SLI" "Off"
    Option         "MultiGPU" "Off"
    Option         "BaseMosaic" "off"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

Section "Extensions"
    Option         "Composite" "Disable"
EndSection

And lastly, here is the script I start my X-servers with:
Code:

#!/bin/bash

# start.sh -- laptop start-up script for host X-server


# this script is for desktop mode, with external monitor.
cp /etc/X11/xorg.conf.dell /etc/X11/xorg.conf

# start for user rj
su - rj -c '

X 2>/dev/null &
sleep 4
#DISPLAY=:0 xrandr --output DisplayPort-0 --mode 3840x2160
sleep 2
DISPLAY=:0 ctwm &
sleep 4
DISPLAY=:0 xset m 1
DISPLAY=:0 ./dash.sh
 
DISPLAY=:0 xterm -fa "Fixed:size=5" -geometry 65x9+1428+-23 /home/rj/cal.sh &
DISPLAY=:0 calcoo &

# left col
# rootxterm                             96x15+130+23
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x15+130+161 &
# rootxterm                             96x15+130+308
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x17+130+446 &
# rootxterm                             96x34+130+593
#DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x34+130+890 &
#DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x27+128-5 &

# mid col
# rootxterm                             96x34+670+23
# rootxterm                             96x34+670+308
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x17+670+446 &
# rootxterm                             96x34+670+593

# rite col
# rootxterm                             96x34+1217+23
# rootxterm                             96x15+1217+308
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x17+1217+446 &
# rootxterm                             96x34+1217+23 &
#DISPLAY=:0 xterm -sb -sl 1000 -geometry 80x17+1217+890 /usr/bin/alsamixer &
DISPLAY=:0 xterm -sb -sl 1000 -geometry 80x17+1217--7 /usr/bin/alsamixer &
'

# start for user root
# left col
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x15+130+23 &
# rjxterm                               96x15+130+161
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x15+130+308 &
# rjxterm                               80x17+130+446
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x34+130+593 &
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x65+669-4 &
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x27+128-5 &
# rjxterm                               80x17+130+890

# mid col
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x34+670+23 &
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x15+670+308 &
#DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x34+1217+593 &
#DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x82+670+593 &

# rite col
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x34+1217+23 &
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x15+1217+308 &
DISPLAY=:0 xterm -fa "Fixed:size=5" -sb -sl 1000 -geometry 96x34+1217+593 &
# rjxterm                               96x17+1217+446
# rjxterm                               96x34+1217+593
# rjxterm                               80x17+1217+890

# start other x_servers for vnc for vm's for user rj
su - rj -c '

X :1 2>/dev/null &
sleep 4
DISPLAY=:1 xterm &
sleep 4
DISPLAY=:1 xset m 1
DISPLAY=:1 xsetroot -solid "#403000"

X :2 2>/dev/null &
sleep 4
DISPLAY=:2 xterm -bg cyan &
sleep 4
DISPLAY=:2 xset m 1
DISPLAY=:2 xsetroot -solid "#600000"

X :3 2>/dev/null &
sleep 4
DISPLAY=:3 xterm -bg magenta &
sleep 4
DISPLAY=:3 xset m 1
DISPLAY=:3 xsetroot -solid "#a04800"

X :4 2>/dev/null &
sleep 4
DISPLAY=:4 xterm -bg yellow &
sleep 4
DISPLAY=:4 xset m 1
DISPLAY=:4 xsetroot -solid "#a88830"

'



I hope this helps other get similar setups working, and helps other people comment on way I can improve this setup. :D
_________________
The MyWord KJV Bible tool is at http://www.elilabs.com/~myword

Foghorn Leghorn is a Warner Bros. cartoon character.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum