Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201407-05 ] OpenSSL: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1567

PostPosted: Sun Jul 27, 2014 11:26 pm    Post subject: [ GLSA 201407-05 ] OpenSSL: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: OpenSSL: Multiple vulnerabilities (GLSA 201407-05)
Severity: high
Exploitable: remote
Date: July 27, 2014
Bug(s): #512506
ID: 201407-05

Synopsis

Multiple vulnerabilities have been found in OpenSSL, possibly
allowing remote attackers to execute arbitrary code.


Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.


Affected Packages

Package: dev-libs/openssl
Vulnerable: < 1.0.1h-r1
Unaffected: >= 1.0.1h-r1
Unaffected: >= 1.0.0m < 1.0.1
Unaffected: >= 0.9.8z_p1 < 0.9.9
Unaffected: >= 0.9.8z_p2 < 0.9.9
Unaffected: >= 0.9.8z_p3 < 0.9.9
Unaffected: >= 0.9.8z_p4 < 0.9.9
Unaffected: >= 0.9.8z_p5 < 0.9.9
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in OpenSSL. Please review
the OpenSSL Security Advisory [05 Jun 2014] and the CVE identifiers
referenced below for details.


Impact

A remote attacker could send specially crafted DTLS fragments to an
OpenSSL DTLS client or server to possibly execute arbitrary code with the
privileges of the process using OpenSSL.
Furthermore, an attacker could force the use of weak keying material in
OpenSSL SSL/TLS clients and servers, inject data across sessions, or
cause a Denial of Service via various vectors.


Workaround

There is no known workaround at this time.

Resolution

All OpenSSL users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.1h-r1"
   


References

CVE-2010-5298
CVE-2014-0195
CVE-2014-0198
CVE-2014-0221
CVE-2014-0224
CVE-2014-3470
OpenSSL
Security Advisory [05 Jun 2014]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum