Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201407-03 ] Xen: Multiple Vunlerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1564

PostPosted: Wed Jul 16, 2014 5:26 pm    Post subject: [ GLSA 201407-03 ] Xen: Multiple Vunlerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Xen: Multiple Vunlerabilities (GLSA 201407-03)
Severity: high
Exploitable: remote
Date: July 16, 2014
Bug(s): #440768, #484478, #486354, #497082, #497084, #497086, #499054, #499124, #500528, #500530, #500536, #501080, #501906, #505714, #509054, #513824
ID: 201407-03

Synopsis

Multiple vulnerabilities have been found in Xen, the worst of which
could lead to arbitrary code execution.


Background

Xen is a bare-metal hypervisor.

Affected Packages

Package: app-emulations/xen
Vulnerable: < 4.3.2-r4
Unaffected: >= 4.3.2-r4
Unaffected: >= 4.2.4-r4 < 4.2.5
Architectures: All supported architectures

Package: app-emulations/xen-tools
Vulnerable: < 4.3.2-r5
Unaffected: >= 4.3.2-r5
Unaffected: >= 4.2.4-r6 < 4.2.5
Architectures: All supported architectures

Package: app-emulations/xen-pvgrub
Vulnerable: < 4.3.2
Unaffected: >= 4.3.2 < 4.3.3
Unaffected: >= 4.2.4 < 4.2.5
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Xen. Please review the
CVE identifiers referenced below for details.


Impact

A remote attacker can utilize multiple vectors to execute arbitrary
code, cause Denial of Service, or gain access to data on the host.


Workaround

There is no known workaround at this time.

Resolution

All Xen 4.3 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-emulations/xen-4.3.2-r2"
   
All Xen 4.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-emulations/xen-4.2.4-r2"
   
All xen-tools 4.3 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=app-emulations/xen-tools-4.3.2-r2"
   
All xen-tools 4.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose
      ">=app-emulations/xen-tools-4.2.4-r2"
   
All Xen PVGRUB 4.3 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-emulations/xen-pvgrub-4.3.2"
   
All Xen PVGRUB 4.2 users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=app-emulations/xen-pvgrub-4.2.4"
   


References

CVE-2013-1442
CVE-2013-4329
CVE-2013-4355
CVE-2013-4356
CVE-2013-4361
CVE-2013-4368
CVE-2013-4369
CVE-2013-4370
CVE-2013-4371
CVE-2013-4375
CVE-2013-4416
CVE-2013-4494
CVE-2013-4551
CVE-2013-4553
CVE-2013-4554
CVE-2013-6375
CVE-2013-6400
CVE-2013-6885
CVE-2013-6885
CVE-2014-1642
CVE-2014-1666
CVE-2014-1891
CVE-2014-1892
CVE-2014-1893
CVE-2014-1894
CVE-2014-1895
CVE-2014-1896
CVE-2014-2599
CVE-2014-3124
CVE-2014-4021
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum