Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
forse [OT] barra di avvio nel 2.6.0
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano
View previous topic :: View next topic  
Author Message
DuDe
Guru
Guru


Joined: 04 Dec 2002
Posts: 314
Location: Roma Italy

PostPosted: Fri Oct 24, 2003 3:32 pm    Post subject: forse [OT] barra di avvio nel 2.6.0 Reply with quote

leggendo un post sulla lkml ( Linux kernel mailing List) ho beccato una patch che dovrebbe implementare la barra al boot coi nuovi kernel 2.6.0 a casa provolo, se va' vi racconto
_________________
mount -t brain /dev/brain /body/skull
Back to top
View user's profile Send private message
vargaso
n00b
n00b


Joined: 14 Oct 2003
Posts: 50

PostPosted: Fri Oct 24, 2003 4:42 pm    Post subject: Reply with quote

funza la barra?????


OT -> con il radeonfb c'e' l'hai fatta?
Back to top
View user's profile Send private message
DuDe
Guru
Guru


Joined: 04 Dec 2002
Posts: 314
Location: Roma Italy

PostPosted: Fri Oct 24, 2003 6:03 pm    Post subject: Reply with quote

macche, non ne vuole sapere di fungere porca paletta, la barra ci sto provando vediamo come va' OT per OT che scheda video hai te?
_________________
mount -t brain /dev/brain /body/skull
Back to top
View user's profile Send private message
vargaso
n00b
n00b


Joined: 14 Oct 2003
Posts: 50

PostPosted: Fri Oct 24, 2003 6:16 pm    Post subject: Reply with quote

OT ati radeon 9600 tu?
Back to top
View user's profile Send private message
DuDe
Guru
Guru


Joined: 04 Dec 2002
Posts: 314
Location: Roma Italy

PostPosted: Fri Oct 24, 2003 6:19 pm    Post subject: Reply with quote

9600 triplex redai dicono sia una 9600-pro con uscita tv, che funge pure bene sotto linux ma linux non me la riconosce infatti se do lspci mi dice unknown ATI device

Boooo!
_________________
mount -t brain /dev/brain /body/skull
Back to top
View user's profile Send private message
vargaso
n00b
n00b


Joined: 14 Oct 2003
Posts: 50

PostPosted: Fri Oct 24, 2003 6:20 pm    Post subject: Reply with quote

si neanche la mia viene riconosciuta :(
Back to top
View user's profile Send private message
DuDe
Guru
Guru


Joined: 04 Dec 2002
Posts: 314
Location: Roma Italy

PostPosted: Fri Oct 24, 2003 6:22 pm    Post subject: Reply with quote

ma non e' che hai icq? non vorrei ammorbare gli altri partecipanti del forum
_________________
mount -t brain /dev/brain /body/skull
Back to top
View user's profile Send private message
vargaso
n00b
n00b


Joined: 14 Oct 2003
Posts: 50

PostPosted: Fri Oct 24, 2003 6:24 pm    Post subject: Reply with quote

si hai ragione...su winzoz lo avevo spe che emergo licq
Back to top
View user's profile Send private message
alexbr
Apprentice
Apprentice


Joined: 06 Sep 2003
Posts: 221
Location: Treviso - Italy

PostPosted: Sat Oct 25, 2003 2:43 pm    Post subject: Reply with quote

conoscete un how-to per mettere la barra sul kernel 2.4?
_________________
Lizzie Borden with an axe
gave her father forty wakes
when she saw what she had done
she gave her mother forty one
Back to top
View user's profile Send private message
fedeliallalinea
Bodhisattva
Bodhisattva


Joined: 08 Mar 2003
Posts: 13200
Location: here

PostPosted: Mon Oct 27, 2003 1:34 pm    Post subject: Reply with quote

Che intendete la barra di boot... Se si perche' cambiare i bellissimi [ OK ] con una barra che fa
assomigliare la nostra linux box a win?

PS: Questa e' una mia opignome non voglio scatenare un flame :D
_________________
"aspetto un'emozione sempre più indefinibile"
- CCCP -
"la libertà un doveroso pericolo in verità"
- PGR -
Questions are guaranteed in life; Answers aren't.
Back to top
View user's profile Send private message
xlyz
Veteran
Veteran


Joined: 27 Oct 2002
Posts: 1470
Location: Italy

PostPosted: Mon Oct 27, 2003 1:57 pm    Post subject: Reply with quote

tanto più che è brevettata, e quindi non la potreste usare
_________________
wanna change how bootsplash or qingy look like? try here
Back to top
View user's profile Send private message
Sparker
l33t
l33t


Joined: 28 Aug 2003
Posts: 992

PostPosted: Mon Oct 27, 2003 3:40 pm    Post subject: Reply with quote

Nessun problema, in Italia non è un brevetto legale 8)

Comunque, un bootsplash come quello del livecd è fico, soprattutto se puoi premere ESC e vedere gli OK :wink:

Questo i windowsiani non possono farlo, possono vedere solo quello che il sistema permette loro di vedere.

Break the matrix (ehm :?)
Back to top
View user's profile Send private message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Fri Dec 05, 2003 7:02 pm    Post subject: Reply with quote

Io non so come, ma la barra all'avvio ce l'ho.
Vi spiego il non so come: c'è un grande thread (grande per le dimensioni) a riguardo in tips&triks (ao, vi metterei il link, ma nn so perchè il forum da casa mia è lentissimo e nn ho voglia di aspettare 5 min per vedere solo la home, scusate di nuovo) che dice di applicare una patch al base-layout. Bene, questa patch essendo vechcia manda tutto a farsi benedire, (in modo piuttosto lieve, nel senso che appaiono solo migliaia di errori, ma alla fine gentoo parte), quindi ho ri-emerso il base-layout.
A questo punto ho aggiunto alla linea
Code:
#kernel (hd0,0)/boot/bzImage root=/dev/hda3 ... vga=791

splash=silent in grub.
A questo punto dopo aver riavviato ho visto l'immagine
silent-1024x768.jpg che sta nella cartella /etc/bootsplash/default/images
al posto degli output normali del kernel, in + ha anche la barra vuota, ma non scorre. Non scorre perchè bisogna assegnare a mano a quali punti dell'avvio devono corrispondere gli stati d'avanzamento della barra. E' quello che sto cercando adesso. Cmq il sunto è: provate ad aggiungere il suddetto parametro (splash=silent) a Grub e vedete che fa, se funge, vuol dire che Gentoo è già pronta così com'è e non lo sapevo!!!
(ps, ovviamente prima avevo installato e fatto fungere il framebuffer con l'immagine di sfondo, come descritto su un altro topic sempre nel forum tips&trics).
Una controverifica al "Gentoo è già pronta" la farò quando mi arriverà il portatile nuovo (powerbook 12"!!!!!!!!!!), adesso me la tengo così com'è, nn ho voglia di indagare...
_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
jdoe
Tux's lil' helper
Tux's lil' helper


Joined: 02 Jun 2003
Posts: 122
Location: Italy - Florence - Empoli

PostPosted: Fri Dec 05, 2003 7:15 pm    Post subject: Reply with quote

anche a me funziona sotto 2.6.-test11
anche il 10 e il 9 andavano

John
_________________
me
Back to top
View user's profile Send private message
HexDEF6
Guru
Guru


Joined: 26 May 2003
Posts: 451
Location: Trento

PostPosted: Fri Dec 05, 2003 8:44 pm    Post subject: Reply with quote

jdoe wrote:
anche a me funziona sotto 2.6.-test11
anche il 10 e il 9 andavano

John


Funziona perfettamente anche a me, comprese le animazioni!

Per maggiori info:

http://forums.gentoo.org/viewtopic.php?t=49036&highlight=kernel+vga

http://forums.gentoo.org/viewtopic.php?t=57781&highlight=lilo+graphics

il tutto funziona dal kernel 2.6test9 in poi (testato personalmente)

Ciao!
_________________
Fa quel che te faresi!
Back to top
View user's profile Send private message
gatiba
Guru
Guru


Joined: 01 Sep 2002
Posts: 434

PostPosted: Sun Dec 07, 2003 12:17 pm    Post subject: Reply with quote

Io uso il 2.6.0-test11 e la barra funzia a meraviglia ...
Seguite gli How-to postati sopra ...
Back to top
View user's profile Send private message
bubble27
Guru
Guru


Joined: 07 Aug 2003
Posts: 365
Location: Campobasso

PostPosted: Sun Dec 07, 2003 12:54 pm    Post subject: Reply with quote

Sul 2.4 nessuno ha sperimentato ?????
Da quel che ho letto c'è bisogno di impartire a grub la stringa splash=silent, che non ha niente a che vedere con la splashimage giusto ??? :roll:
comunque proviamo un pò.......e che gentoo ce la mandi buona !! :wink:
_________________
Ciao Gentooaglia
Back to top
View user's profile Send private message
hardskin1
Tux's lil' helper
Tux's lil' helper


Joined: 08 Oct 2003
Posts: 82

PostPosted: Sun Dec 07, 2003 1:38 pm    Post subject: Reply with quote

fedeliallalinea wrote:
Che intendete la barra di boot... Se si perche' cambiare i bellissimi [ OK ] con una barra che fa
assomigliare la nostra linux box a win?

PS: Questa e' una mia opignome non voglio scatenare un flame :D


Bhe, e' una questione di "fa molto figo avere la barra che carica" se poi puoi farla come vuoi e premende ESC tornano gli OK ben venga :)
_________________
"Life 's a bitch / Life's a whore / Nothing less nothing more" Iced Earth

Se il destino ci e' avverso, peggio per lui.
Back to top
View user's profile Send private message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Sun Dec 07, 2003 2:44 pm    Post subject: Reply with quote

Quote:
Io uso il 2.6.0-test11 e la barra funzia a meraviglia ...
Seguite gli How-to postati sopra ...


Bene, io non ci ho capito una mazza circa la barra animata (progress bar), visto che sei riuscito a farla fungere, non è che posteresti un mini-how to??
Grassie...
_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
gatiba
Guru
Guru


Joined: 01 Sep 2002
Posts: 434

PostPosted: Sun Dec 07, 2003 2:52 pm    Post subject: Reply with quote

La prima cosa da leggere è:
http://forums.gentoo.org/viewtopic.php?t=49036&highlight=progress+bar

Fatto funzionare il framebuffer si passa a questo how-to:
http://forums.gentoo.org/viewtopic.php?t=105142&highlight=progress+bar


Se avete problemi ditelo che scrivo un How-To in italiano ...
Back to top
View user's profile Send private message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Sun Dec 07, 2003 2:55 pm    Post subject: Reply with quote

Sarebbe moolto bello, se quella maledetta patch al base-layout supportasse il MIO base-layout...
Cmq, la barra ce l'ho, l'unica cosa è che non "progredisce", quindi è piuttosto inutile...
Any ideas???
_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
albazeus
Tux's lil' helper
Tux's lil' helper


Joined: 03 Sep 2003
Posts: 81

PostPosted: Sun Dec 07, 2003 3:35 pm    Post subject: Reply with quote

Quote:
Se avete problemi ditelo che scrivo un How-To in italiano ...


E magari potresti fare un' immagine 1280x1024 del tema Linux, visto che ancora non esiste... :mrgreen:
Back to top
View user's profile Send private message
HexDEF6
Guru
Guru


Joined: 26 May 2003
Posts: 451
Location: Trento

PostPosted: Sun Dec 07, 2003 4:12 pm    Post subject: Reply with quote

stefanonafets wrote:
Sarebbe moolto bello, se quella maledetta patch al base-layout supportasse il MIO base-layout...
Cmq, la barra ce l'ho, l'unica cosa è che non "progredisce", quindi è piuttosto inutile...
Any ideas???


Ma che baselayout usi???
se usi il 1.8.6.10-r1 (insomma l'ultimo di "x86") patcha senza tanti problemi dicendo che hai l'1.8.6.10... se sei in "~x86" non so cosa dirti.... il lavoro giusto sarebbe quello di ricreare i .diff per anche quel baselayout dando un occhio a quello che fa lo scriptino e seguendo i consigli di www.bootsplash.org

Ciao!
_________________
Fa quel che te faresi!
Back to top
View user's profile Send private message
bubble27
Guru
Guru


Joined: 07 Aug 2003
Posts: 365
Location: Campobasso

PostPosted: Sun Dec 07, 2003 4:45 pm    Post subject: Reply with quote

Sono riuscito a far uscire la schermata per la progressione della barra xò senza la progressione della barra :D ........ e poi ho notato un'altra cosa che una volta arrivati al login nelle altre console rimane la schermata dell'immagine impostata per la progres bar !!!!

tutto questo provato con il kernel 2.4.22 !!
_________________
Ciao Gentooaglia
Back to top
View user's profile Send private message
stefanonafets
l33t
l33t


Joined: 10 Feb 2003
Posts: 644

PostPosted: Sun Dec 07, 2003 6:22 pm    Post subject: Reply with quote

LOOOOOOOL :D :D :D

La patch l'avevo messa tempo fa, ma nn mi dava altro che noie (fraccata di messaggi di errore), allora avevo ri-emerso il base-layout.
Evidentemente faceva così xchè gli avevo detto di installare la patch sbagliata...
Mo ho dato
Code:
PortatilOne root #emerge -eO baselayout
PortatilOne root #rm -r /sbin/*~ <--- per togliere i vecchi file di backup
PortatilOne root #rm -r /etc/*~   <-|
PortatilOne root #cd /root/bootsplash-patch
PortatilOne bootsplash-patch #./install.sh

Ho riavviato e la barra sale!!!!!!!
BEEELLOOOOOOOOO!!!!!!!!!!!!!!!!!!!!!

Mo cerco in giro un pò di wallpaper da mettere all'avvio e come sfondo...
Grassiee!!!!
_________________
registered Linux user number #411324
sed 's/ke/che/g'

<The Deployment Slave is initializing>
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) Forum di discussione italiano All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum