Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
не работают режимы работы процессора
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Russian
View previous topic :: View next topic  
Author Message
SmilePlz
n00b
n00b


Joined: 24 Jun 2014
Posts: 4

PostPosted: Thu Jun 26, 2014 1:13 pm    Post subject: не работают режимы работы процессора Reply with quote

Доброго времени суток, заметил не давно что перестали работать режимы работы процессора. пропали таки режимы как userspace ondemand conservative
Code:
uname -a
Linux Zzz 3.12.21-gentoo-r1 #7 SMP Wed Jun 25 14:32:51 MSK 2014 x86_64 Intel(R) Core(TM) i3-3217U CPU @ 1.80GHz GenuineIntel GNU/Linux

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_available_governors
performance powersave

cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor
powersave

grep MHz /proc/cpuinfo
cpu MHz      : 1744.875
cpu MHz      : 1799.929
cpu MHz      : 1615.078
cpu MHz      : 1800.000

настройки ядра:
Code:
541 # CPU Frequency scaling$
 542 #$
 543 CONFIG_CPU_FREQ=y$
 544 CONFIG_CPU_FREQ_TABLE=y$
 545 CONFIG_CPU_FREQ_GOV_COMMON=y$
 546 # CONFIG_CPU_FREQ_STAT is not set$
 547 # CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set$
 548 # CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE is not set$
 549 # CONFIG_CPU_FREQ_DEFAULT_GOV_ONDEMAND is not set$
 550 CONFIG_CPU_FREQ_DEFAULT_GOV_CONSERVATIVE=y$
 551 CONFIG_CPU_FREQ_GOV_PERFORMANCE=y$
 552 CONFIG_CPU_FREQ_GOV_POWERSAVE=y$
 553 # CONFIG_CPU_FREQ_GOV_USERSPACE is not set$
 554 CONFIG_CPU_FREQ_GOV_ONDEMAND=y$
 555 CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y$

решил сделать собрать acpi-cpufreq модулем, но тишина какая то
Code:
modprobe acpi_cpufreq
lsmod
Module                  Size  Used by
x86_pkg_temp_thermal     4725  0

подскажите что я делаю не так...
Back to top
View user's profile Send private message
Pinkbyte
Developer
Developer


Joined: 01 Jun 2012
Posts: 94
Location: Rostov-on-Don, Russia

PostPosted: Sat Jun 28, 2014 7:43 am    Post subject: Reply with quote

Что в dmesg при попытке загрузки модуля?
Back to top
View user's profile Send private message
SmilePlz
n00b
n00b


Joined: 24 Jun 2014
Posts: 4

PostPosted: Sat Jun 28, 2014 9:27 am    Post subject: Reply with quote

ничего не выводит
Code:

modprobe -v acpi_cpufreq
insmod /lib/modules/3.12.21-gentoo-r1/kernel/drivers/cpufreq/acpi-cpufreq.ko

[13599.981458] emerge (30910) used greatest stack depth: 3880 bytes left
[16317.863308] xhci_hcd 0000:00:14.0: ep 0x82 - asked for 20 bytes, 12 bytes untransferred
[16317.864292] xhci_hcd 0000:00:14.0: ep 0x82 - asked for 20 bytes, 15 bytes untransferred
[18585.796554] kworker/u8:0 (13501) used greatest stack depth: 3816 bytes left

это последние строки они не меняются
Back to top
View user's profile Send private message
Pinkbyte
Developer
Developer


Joined: 01 Jun 2012
Posts: 94
Location: Rostov-on-Don, Russia

PostPosted: Sun Jun 29, 2014 10:09 am    Post subject: Reply with quote

А собрано точно модулем? Покажите zgrep CPUFREQ /proc/config.gz
Back to top
View user's profile Send private message
SmilePlz
n00b
n00b


Joined: 24 Jun 2014
Posts: 4

PostPosted: Sun Jun 29, 2014 11:12 am    Post subject: Reply with quote

.config
Code:
 561 # x86 CPU frequency scaling drivers$
 562 #$
 563 CONFIG_X86_INTEL_PSTATE=y$
 564 # CONFIG_X86_PCC_CPUFREQ is not set$                                                                                                                                 
 565 CONFIG_X86_ACPI_CPUFREQ=m$
 566 # CONFIG_X86_ACPI_CPUFREQ_CPB is not set$
 567 # CONFIG_X86_POWERNOW_K8 is not set$
 568 # CONFIG_X86_AMD_FREQ_SENSITIVITY is not set$
 569 # CONFIG_X86_SPEEDSTEP_CENTRINO is not set$
 570 # CONFIG_X86_P4_CLOCKMOD is not set$
Back to top
View user's profile Send private message
Pinkbyte
Developer
Developer


Joined: 01 Jun 2012
Posts: 94
Location: Rostov-on-Don, Russia

PostPosted: Sun Jun 29, 2014 12:17 pm    Post subject: Reply with quote

Ну тогда у меня идей больше нет
Back to top
View user's profile Send private message
SmilePlz
n00b
n00b


Joined: 24 Jun 2014
Posts: 4

PostPosted: Sun Jun 29, 2014 5:21 pm    Post subject: Reply with quote

надо переустановить систему...

кстати не только у меня такая проблема http://gentoo.ru/node/28133. а что делать дальше... может я что сломал или кто то другой сломал? у тебя все работает? =)
Back to top
View user's profile Send private message
TigerJr
Tux's lil' helper
Tux's lil' helper


Joined: 19 Jun 2007
Posts: 78
Location: /dev/spb7

PostPosted: Thu Sep 11, 2014 6:11 pm    Post subject: Reply with quote

А случайно acpid этим не занимается?
_________________

gentoway or not gentoway?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Russian All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum