Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Solved]已添加USE ,但emerge vlc 无法安装
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese)
View previous topic :: View next topic  
Author Message
Heren
n00b
n00b


Joined: 19 May 2014
Posts: 27
Location: China

PostPosted: Wed Jun 18, 2014 2:28 pm    Post subject: [Solved]已添加USE ,但emerge vlc 无法安装 Reply with quote

已经添加USE标志 ,为什么无法EMERGE,请帮忙看看怎么回事。谢谢!
Code:
Gentoo tyler # emerge vlc
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'
--- Invalid atom in /etc/portage/package.use: USE="X

 * IMPORTANT: 6 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild  N     ] media-libs/libdvbpsi-0.2.2  USE="-doc -static-libs"
[ebuild   R    ] sys-libs/zlib-1.2.8-r1  USE="minizip*"
[ebuild  N     ] media-libs/libmpeg2-0.5.1  USE="X sdl"
[ebuild  N     ] net-dns/libidn-1.28  USE="nls -doc -emacs -java -mono -static-libs"
[ebuild  N    ~] media-video/vlc-2.1.4  USE="X a52 alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt libnotify mp3 mpeg ncurses ogg opengl png postproc qt4 sdl svg swscale truetype udev vorbis x264 xcb xml xv -aalib (-altivec) -atmo (-audioqueue) -avahi -bidi -bluray -cddb -chromaprint -dc1394 -debug -dirac -directfb (-directx) -dvb (-dxva2) -egl -faad -fdk -fluidsynth -fontconfig -gme -gnome -gnutls -growl -httpd -ieee1394 (-ios-vout) -jack -kate -kde -libass -libcaca -libsamplerate -libtar -libtiger -linsys -lirc -live -lua (-macosx) (-macosx-audio) (-macosx-dialog-provider) (-macosx-eyetv) (-macosx-qtkit) (-macosx-quartztext) (-macosx-vout) -matroska (-media-library) -mmx -modplug -mtp -musepack (-neon) -omxil -opencv -optimisememory -opus -projectm -pulseaudio (-qt5) -rdp -rtsp -run-as-root -samba -schroedinger -sdl-image -sftp -shout -sid -skins -speex -sse -taglib {-test} -theora -tremor -twolame -upnp -v4l -vaapi -vcdx -vdpau -vlm -vnc -wma-fixed -zvbi"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-video/vlc-2.1.4
# required by vlc (argument)
>=sys-libs/zlib-1.2.8-r1 minizip

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.


Gentoo tyler # cat /etc/portage/package.use
x11-base/xorg-server udev
USE="X sdl nlsa52 alsa avcodec avformat cdda dbus dts dvbpsi dvd encode ffmpeg flac gcrypt libnotify mp3 mpeg ncurses ogg opengl png postproc qt4 sdl skins svg swscale truetype udev vorbis x264 xcb xml xv"


Last edited by Heren on Sun Aug 03, 2014 1:28 am; edited 2 times in total
Back to top
View user's profile Send private message
druggo
Apprentice
Apprentice


Joined: 24 Sep 2003
Posts: 289
Location: Hangzhou, China

PostPosted: Mon Jun 23, 2014 1:45 pm    Post subject: Reply with quote

Quote:
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'

建议删掉/etc/make.conf,只使用/etc/portage/make.conf,前者如果有自定义内容可以写到后面那个文件里。
Quote:
--- Invalid atom in /etc/portage/package.use: USE="X

USE=“” 这种应该放到/etc/portage/make.conf里面
Quote:
The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by media-video/vlc-2.1.4
# required by vlc (argument)
>=sys-libs/zlib-1.2.8-r1 minizip

安装vlc需要把zlib的minizip打开,把下面这行加入到/etc/portage/package.use里。
Code:
>=sys-libs/zlib-1.2.8-r1 minizip

_________________
HighWayToHell(blog)
http://blog.druggo.org/
Back to top
View user's profile Send private message
Heren
n00b
n00b


Joined: 19 May 2014
Posts: 27
Location: China

PostPosted: Mon Jun 23, 2014 2:44 pm    Post subject: Reply with quote

druggo wrote:
Quote:
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'

建议删掉/etc/make.conf,只使用/etc/portage/make.conf,前者如果有自定义内容可以写到后面那个文件里。

我没有用这个文件 看了下里面有标识 是否可以清理掉

Code:
Gentoo tyler # cat /etc/make.conf
FETCHCOMMAND='/usr/bin/axel -a -S4 -o "${DISTDIR}/${FILE}" "${URI}"'
RESUMECOMMAND="${FETCHCOMMAND}"



Quote:
--- Invalid atom in /etc/portage/package.use: USE="X

USE=“” 这种应该放到/etc/portage/make.conf里面
Quote:
The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by media-video/vlc-2.1.4
# required by vlc (argument)
>=sys-libs/zlib-1.2.8-r1 minizip


已修改

安装vlc需要把zlib的minizip打开,把下面这行加入到/etc/portage/package.use里。
Code:
>=sys-libs/zlib-1.2.8-r1 minizip


谢谢!已装好,以为vlc播放不错,结果卡顿很严重。完全不能媲美Mplayer
Back to top
View user's profile Send private message
OwenJia
n00b
n00b


Joined: 02 Aug 2014
Posts: 4

PostPosted: Sat Aug 02, 2014 9:44 am    Post subject: Reply with quote

Heren wrote:
druggo wrote:
Quote:
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'

建议删掉/etc/make.conf,只使用/etc/portage/make.conf,前者如果有自定义内容可以写到后面那个文件里。

我没有用这个文件 看了下里面有标识 是否可以清理掉

Code:
Gentoo tyler # cat /etc/make.conf
FETCHCOMMAND='/usr/bin/axel -a -S4 -o "${DISTDIR}/${FILE}" "${URI}"'
RESUMECOMMAND="${FETCHCOMMAND}"



Quote:
--- Invalid atom in /etc/portage/package.use: USE="X

USE=“” 这种应该放到/etc/portage/make.conf里面
Quote:
The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by media-video/vlc-2.1.4
# required by vlc (argument)
>=sys-libs/zlib-1.2.8-r1 minizip


已修改

安装vlc需要把zlib的minizip打开,把下面这行加入到/etc/portage/package.use里。
Code:
>=sys-libs/zlib-1.2.8-r1 minizip


谢谢!已装好,以为vlc播放不错,结果卡顿很严重。完全不能媲美Mplayer


这里其实可以用 emerge 的 --autounmask-write 然后再 dispatch-conf 的,完全没必要手工去修改

另,不建议随便修改 make.conf 里的全局 USE, 单个包可以修改 package.use 的


还有如果已解决请修改标题标记为 Solved
Back to top
View user's profile Send private message
Heren
n00b
n00b


Joined: 19 May 2014
Posts: 27
Location: China

PostPosted: Sun Aug 03, 2014 1:26 am    Post subject: Reply with quote

Quote:

这里其实可以用 emerge 的 --autounmask-write 然后再 dispatch-conf 的,完全没必要手工去修改

另,不建议随便修改 make.conf 里的全局 USE, 单个包可以修改 package.use 的


还有如果已解决请修改标题标记为 Solved


谢谢提醒!
学习啦
一般也不会去修改make.conf[/quote]
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index 中文 (Chinese) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum