Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Nutzt schon jemand KDE5?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
schmidicom
l33t
l33t


Joined: 09 Mar 2006
Posts: 987
Location: Schweiz

PostPosted: Thu Jun 19, 2014 12:46 pm    Post subject: Reply with quote

Beim Wechsel von KDE 3 zu 4 war wohl nicht nur das Testing etwas "holprig" denn wirklich brauchbar war der KDE 4 meiner Meinung nach erst ab Version 4.6, was schon ziemlich heftig ist. Aber der KDE 5 (also das was man auf der Live-CD so ausprobieren kann) scheint im Vergleich zur Version 4 von damals um einiges stabiler und brauchbarer zu sein.

Naja ich vermute/hoffe mal das auch die KDE-Devs keine große Lust daran haben das Debakel von einst zu wiederholen.

@Finswimmer
Meine Installationen benutzen schon länger den GCC 4.8 und bis jetzt gabs deswegen noch keine Probleme.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Thu Jun 19, 2014 1:37 pm    Post subject: Reply with quote

Nun ja, gcc 4.8 ist ja im testing aktuell. Und ich denke mal, für solche Dinge ist es immer besser, von testing auszugehen und nicht von stable. Sonst ist die Diskrepanz einfach zu groß,

Und diese Aussage, dass KDE5 parallel zu KDE4 laufen soll, halte ich für sehr fragwürdig. Da es ja ein direktes KDE5 so in dieser Form nicht mehr gibt. Es wird ja erst mal das framework auf Version 5 gehoben. Und es laufen dann Anwendungen parallel, die auch noch die Version 4 vom framework nutzen. So habe ich das verstanden.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Thu Jun 19, 2014 1:45 pm    Post subject: Reply with quote

Josef.95 wrote:
/edit:
Wer es tatsächlich schon unter Gentoo versuchen möchte benötigt
Qt 5 --> ist im qt Overlay verfügbar
und
plasma 2 Ebuilds gibt es schon einige im kde Overlay.
Hmmm. Ich habe qt5 seit 5.0 drauf, da ich das per qt-creator hie und da nutze...

Vielleicht schaue ich es mir mal an...
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Thu Jun 19, 2014 3:10 pm    Post subject: Reply with quote

Also ich merge gerade (parallel zu KDE 4) @kde-frameworks-5.0. Außer kactivities (das von kde-frameworks/kactivities ersetzt wird) gabs keine Blocks.

Schauen wir mal, fehlen ja noch zwei sets. ;) Aber soweit ich das verstanden habe, würden einige Bestandteile des neuen Frameworks einfach die alten ersetzen, oder? (Egal, ich hab ja noch lxqt auf dem Lappie. Und zur not auch twm. Arbeiten kann ich immer. :D)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)


Last edited by Yamakuzure on Thu Jun 19, 2014 3:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Thu Jun 19, 2014 3:12 pm    Post subject: Reply with quote

Und wenn du durch bist und ein lauffähiges System hast, dann sagst du mir bitte ganz genau, was du getan hast.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Thu Jun 19, 2014 3:25 pm    Post subject: Reply with quote

Klaus Meier wrote:
Und wenn du durch bist und ein lauffähiges System hast, dann sagst du mir bitte ganz genau, was du getan hast.
Mein System ist immer lauffähig. ;)
Bisher habe ich folgendes:
  1. Neue Einträge in /etc/portage/package.unmask:
    Code:
    <kde-frameworks/attica-5.0.50
    <kde-frameworks/frameworkintegration-5.0.50
    <kde-frameworks/kactivities-5.0.50
    <kde-frameworks/kapidox-5.0.50
    <kde-frameworks/karchive-5.0.50
    <kde-frameworks/kauth-5.0.50
    <kde-frameworks/kbookmarks-5.0.50
    <kde-frameworks/kcmutils-5.0.50
    <kde-frameworks/kcodecs-5.0.50
    <kde-frameworks/kcompletion-5.0.50
    <kde-frameworks/kconfig-5.0.50
    <kde-frameworks/kconfigwidgets-5.0.50
    <kde-frameworks/kcoreaddons-5.0.50
    <kde-frameworks/kcrash-5.0.50
    <kde-frameworks/kdbusaddons-5.0.50
    <kde-frameworks/kdeclarative-5.0.50
    <kde-frameworks/kded-5.0.50
    <kde-frameworks/kdelibs4support-5.0.50
    <kde-frameworks/kdesignerplugin-5.0.50
    <kde-frameworks/kdesu-5.0.50
    <kde-frameworks/kdewebkit-5.0.50
    <kde-frameworks/kdnssd-5.0.50
    <kde-frameworks/kdoctools-5.0.50
    <kde-frameworks/kemoticons-5.0.50
    <kde-frameworks/kglobalaccel-5.0.50
    <kde-frameworks/kguiaddons-5.0.50
    <kde-frameworks/khtml-5.0.50
    <kde-frameworks/ki18n-5.0.50
    <kde-frameworks/kiconthemes-5.0.50
    <kde-frameworks/kidletime-5.0.50
    <kde-frameworks/kimageformats-5.0.50
    <kde-frameworks/kinit-5.0.50
    <kde-frameworks/kio-5.0.50
    <kde-frameworks/kitemmodels-5.0.50
    <kde-frameworks/kitemviews-5.0.50
    <kde-frameworks/kjobwidgets-5.0.50
    <kde-frameworks/kjs-5.0.50
    <kde-frameworks/kjsembed-5.0.50
    <kde-frameworks/kmediaplayer-5.0.50
    <kde-frameworks/knewstuff-5.0.50
    <kde-frameworks/knotifications-5.0.50
    <kde-frameworks/knotifyconfig-5.0.50
    <kde-frameworks/kparts-5.0.50
    <kde-frameworks/kplotting-5.0.50
    <kde-frameworks/kpty-5.0.50
    <kde-frameworks/kross-5.0.50
    <kde-frameworks/krunner-5.0.50
    <kde-frameworks/kservice-5.0.50
    <kde-frameworks/ktexteditor-5.0.50
    <kde-frameworks/ktextwidgets-5.0.50
    <kde-frameworks/kunitconversion-5.0.50
    <kde-frameworks/kwallet-5.0.50
    <kde-frameworks/kwidgetsaddons-5.0.50
    <kde-frameworks/kwindowsystem-5.0.50
    <kde-frameworks/kxmlgui-5.0.50
    <kde-frameworks/plasma-5.0.50
    <kde-frameworks/solid-5.0.50
    <kde-frameworks/sonnet-5.0.50
    <kde-frameworks/threadweaver-5.0.50
    =kde-base/libksysguard-4.96.0
    =kde-base/kde-cli-tools-4.96.0
    =kde-base/plasma-desktop-4.96.0
    =kde-base/kio-extras-4.96.0
    =kde-base/oxygen-4.96.0
    =kde-base/breeze-4.96.0
    =kde-base/milou-4.96.0
    =media-fonts/oxygen-fonts-0.3.96:kde
    <kde-base/baloo-5.0.50
    <kde-base/breeze-5.0.50
    <kde-base/kde-cli-tools-5.0.50
    <kde-base/khelpcenter-5.0.50
    <kde-base/khotkeys-5.0.50
    <kde-base/kinfocenter-5.0.50
    <kde-base/kio-extras-5.0.50
    <kde-base/kmenuedit-5.0.50
    <kde-base/ksysguard-5.0.50
    <kde-base/kwin-5.0.50
    <kde-base/kwrited-5.0.50
    <kde-base/libksysguard-5.0.50
    <kde-base/milou-5.0.50
    <kde-base/oxygen-5.0.50
    <kde-base/plasma-desktop-5.0.50
    <kde-base/plasma-workspace-5.0.50
    <kde-base/powerdevil-5.0.50
    <kde-base/systemsettings-5.0.50
    # Für workspaces
    =kde-frameworks/kwindowsystem-4.96.0
    =kde-frameworks/kservice-4.96.0
    =kde-frameworks/kconfig-4.96.0
    =kde-frameworks/kdbusaddons-4.96.0
    =kde-base/kfilemetadata-4.96.0
    =kde-frameworks/karchive-4.96.0
    =kde-frameworks/ki18n-4.96.0
    =kde-frameworks/kcoreaddons-4.96.0
    =kde-frameworks/kcrash-4.96.0
    =kde-frameworks/kdoctools-4.96.0
  2. Neue Einträge in /etc/portage/package.accept_keywords:
    Code:
    <kde-frameworks/attica-5.0.50
    <kde-frameworks/frameworkintegration-5.0.50
    <kde-frameworks/kactivities-5.0.50
    <kde-frameworks/kapidox-5.0.50
    <kde-frameworks/karchive-5.0.50
    <kde-frameworks/kauth-5.0.50
    <kde-frameworks/kbookmarks-5.0.50
    <kde-frameworks/kcmutils-5.0.50
    <kde-frameworks/kcodecs-5.0.50
    <kde-frameworks/kcompletion-5.0.50
    <kde-frameworks/kconfig-5.0.50
    <kde-frameworks/kconfigwidgets-5.0.50
    <kde-frameworks/kcoreaddons-5.0.50
    <kde-frameworks/kcrash-5.0.50
    <kde-frameworks/kdbusaddons-5.0.50
    <kde-frameworks/kdeclarative-5.0.50
    <kde-frameworks/kded-5.0.50
    <kde-frameworks/kdelibs4support-5.0.50
    <kde-frameworks/kdesignerplugin-5.0.50
    <kde-frameworks/kdesu-5.0.50
    <kde-frameworks/kdewebkit-5.0.50
    <kde-frameworks/kdnssd-5.0.50
    <kde-frameworks/kdoctools-5.0.50
    <kde-frameworks/kemoticons-5.0.50
    <kde-frameworks/kglobalaccel-5.0.50
    <kde-frameworks/kguiaddons-5.0.50
    <kde-frameworks/khtml-5.0.50
    <kde-frameworks/ki18n-5.0.50
    <kde-frameworks/kiconthemes-5.0.50
    <kde-frameworks/kidletime-5.0.50
    <kde-frameworks/kimageformats-5.0.50
    <kde-frameworks/kinit-5.0.50
    <kde-frameworks/kio-5.0.50
    <kde-frameworks/kitemmodels-5.0.50
    <kde-frameworks/kitemviews-5.0.50
    <kde-frameworks/kjobwidgets-5.0.50
    <kde-frameworks/kjs-5.0.50
    <kde-frameworks/kjsembed-5.0.50
    <kde-frameworks/kmediaplayer-5.0.50
    <kde-frameworks/knewstuff-5.0.50
    <kde-frameworks/knotifications-5.0.50
    <kde-frameworks/knotifyconfig-5.0.50
    <kde-frameworks/kparts-5.0.50
    <kde-frameworks/kplotting-5.0.50
    <kde-frameworks/kpty-5.0.50
    <kde-frameworks/kross-5.0.50
    <kde-frameworks/krunner-5.0.50
    <kde-frameworks/kservice-5.0.50
    <kde-frameworks/ktexteditor-5.0.50
    <kde-frameworks/ktextwidgets-5.0.50
    <kde-frameworks/kunitconversion-5.0.50
    <kde-frameworks/kwallet-5.0.50
    <kde-frameworks/kwidgetsaddons-5.0.50
    <kde-frameworks/kwindowsystem-5.0.50
    <kde-frameworks/kxmlgui-5.0.50
    <kde-frameworks/plasma-5.0.50
    <kde-frameworks/solid-5.0.50
    <kde-frameworks/sonnet-5.0.50
    <kde-frameworks/threadweaver-5.0.50
    >=dev-libs/extra-cmake-modules-0.0.12
    >=kde-frameworks/kf-env-1
    <kde-base/baloo-5.0.50 ~amd64
    <kde-base/breeze-5.0.50 ~amd64
    <kde-base/kde-cli-tools-5.0.50 ~amd64
    <kde-base/khelpcenter-5.0.50 ~amd64
    <kde-base/khotkeys-5.0.50 ~amd64
    <kde-base/kinfocenter-5.0.50 ~amd64
    <kde-base/kio-extras-5.0.50 ~amd64
    <kde-base/kmenuedit-5.0.50 ~amd64
    <kde-base/ksysguard-5.0.50 ~amd64
    <kde-base/kwin-5.0.50 ~amd64
    <kde-base/kwrited-5.0.50 ~amd64
    <kde-base/libksysguard-5.0.50 ~amd64
    <kde-base/milou-5.0.50 ~amd64
    <kde-base/oxygen-5.0.50 ~amd64
    <kde-base/plasma-desktop-5.0.50 ~amd64
    <kde-base/plasma-workspace-5.0.50 ~amd64
    <kde-base/powerdevil-5.0.50 ~amd64
    <kde-base/systemsettings-5.0.50 ~amd64
    =kde-base/libksysguard-4.96.0 ~amd64
    =x11-libs/libkscreen2-9999 **
    =kde-base/kde-cli-tools-4.96.0 ~amd64
    =kde-base/plasma-desktop-4.96.0 ~amd64
    =dev-libs/extra-cmake-modules-9999 **
    =kde-base/kio-extras-4.96.0 ~amd64
    =kde-base/oxygen-4.96.0 ~amd64
    =kde-base/breeze-4.96.0 ~amd64
    =kde-base/milou-4.96.0 ~amd64
    =dev-qt/designer-5.3.0::qt
    =dev-qt/linguist-tools-5.3.0::qt
    =dev-python/pystache-0.5.3::gentoo
    =dev-python/pystache-0.5.4::gentoo
    =media-fonts/oxygen-fonts-0_p20120917::gentoo
    =media-fonts/oxygen-fonts-0.3.96::kde
    =dev-libs/libdbusmenu-qt-9999::kde **
    # Für workspaces:
    =dev-qt/qdbus-5.3.0 ~amd64
    =app-text/poppler-0.26.1 ~amd64
    =dev-qt/qtpaths-5.3.0 ~amd64
    =kde-frameworks/kwindowsystem-4.96.0
    =kde-frameworks/kservice-4.96.0
    =kde-frameworks/kconfig-4.96.0
    =kde-frameworks/kdbusaddons-4.96.0
    =kde-base/kfilemetadata-4.96.0
    =kde-frameworks/karchive-4.96.0
    =kde-frameworks/ki18n-4.96.0
    =kde-frameworks/kcoreaddons-4.96.0
    =kde-frameworks/kcrash-4.96.0
    =kde-frameworks/kdoctools-4.96.0
  3. Neue Einträge in /etc/portage/package.use:
    Code:
    kde-base/kwin -gles2
    media-libs/phonon qt5
    media-libs/phonon-gstreamer qt5
    dev-libs/libdbusmenu-qt qt5
    media-gfx/graphviz python
    # Für workspaces:
    app-text/poppler qt5
    dev-qt/qtquickcontrols:5 widgets
    kde-base/kinfocenter -gles
  4. Bisher deinstallierte Pakete:
    Code:
    # Für frameworks:
    kde-base/kactivities
    # Für workspaces:
    kde-base/kwin:4
    kde-base/libkworkspace:4
    kde-base/kdebase-startkde:4
    kde-base/plasma-workspace:4
    kde-base/libtaskmanager:4
    kde-base/kuiserver:4
    kde-base/ksplash:4
    kde-base/kdebase-kioslaves:4
    kde-base/freespacenotifier:4
    kde-base/knetattach:4
    kde-base/kdebase-cursors:4
    kde-base/ksmserver:4
    kde-base/kcminit:4
    kde-base/kdebase-menu-icons:4
    kde-base/klipper:4
    kde-base/attica:4
    kde-base/systemsettings:4
    kde-base/baloo:4
    kde-base/kfilemetadata:4
    kde-base/krunner:4
    kde-base/ksysguard:4
    kde-base/kcontrol:4
    kde-base/khelpcenter:4
    kde-base/kmenuedit:4
    kde-base/kinfocenter:4
    kde-base/powerdevil:4
    kde-base/khotkeys:4
    kde-base/kwrited:4
    kde-base/khelpcenter:4
  5. Bisher installierte Sets:
    Code:
    @kde-frameworks-5.0
    @kde-workspaces-5.0 (merge läuft)
Sobald sich etwas ändert, aktualisiere ich die Listen. (Kann aber bis morgen dauern.)

Anmerkungen:
Editiert am: 20.06.2014 08:49 Uhr
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)


Last edited by Yamakuzure on Fri Jun 20, 2014 7:21 am; edited 2 times in total
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Thu Jun 19, 2014 6:20 pm    Post subject: Reply with quote

@Yamakuzure: Welches Profil nutzt du? Ich hatte hier gelesen, dass vom KDE-Profil abgeraten wurde.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Fri Jun 20, 2014 6:52 am    Post subject: Reply with quote

Klaus Meier wrote:
@Yamakuzure: Welches Profil nutzt du? Ich hatte hier gelesen, dass vom KDE-Profil abgeraten wurde.
Code:
 ~ $ eselect profile list | grep \*
  [6]   default/linux/amd64/13.0/desktop/kde *
Warum sollte davon abgeraten werden?

Kleine Anmerkung zu meinem Edit oben:
Jetzt ist es vollständig. Ich hatte gestern ein 'e' vergessen. ("merge läuft" statt "emerge läuft". Peinlich. Immerhin war emerge nur am Abhängigkeiten enträtseln, und noch nicht am Bauen, fehlte ja noch was.)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Fri Jun 20, 2014 6:55 am    Post subject: Reply with quote

Ich hab's noch mal versucht, ich komme an dem phonon nicht vorbei. Habe es manuell installiert so wie angegeben, trotzdem wird über das phonon-9999 gemeckert.
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Fri Jun 20, 2014 7:58 am    Post subject: Reply with quote

Klaus Meier wrote:
Ich hab's noch mal versucht, ich komme an dem phonon nicht vorbei. Habe es manuell installiert so wie angegeben, trotzdem wird über das phonon-9999 gemeckert.
Du brauchst:
Code:
 ~ $ grep phonon /etc/portage/package.use
media-libs/phonon qt5
media-libs/phonon-gstreamer qt5
und
Code:
 ~ $ grep qt5 /etc/portage/profile/*
/etc/portage/profile/use.mask:-qt5
dann klappt das und du bekommst: (Schau auf die USE-flags)
Code:
 ~ $ eix -I phonon -C media-libs
[I] media-libs/phonon
     Available versions:  4.6.0-r1 (~)4.7.1-r1 **9999 {aqua debug designer +gstreamer pulseaudio +qt4 qt5 vlc zeitgeist}
     Installed versions:  4.7.1-r1(17:18:19 19.06.2014)(designer gstreamer qt4 qt5 -aqua -debug -pulseaudio -vlc -zeitgeist)
     Homepage:            https://projects.kde.org/projects/kdesupport/phonon
     Description:         KDE multimedia API

[I] media-libs/phonon-gstreamer
     Available versions:  4.6.3 (~)4.7.1 **9999 {alsa debug +network +qt4 qt5}
     Installed versions:  4.7.1(17:18:52 19.06.2014)(alsa network qt4 qt5 -debug)
     Homepage:            https://projects.kde.org/projects/kdesupport/phonon/phonon-gstreamer
     Description:         Phonon GStreamer backend

2 Treffer.

_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Fri Jun 20, 2014 8:20 am    Post subject: Reply with quote

Ich bekomme aber bei meinem phonon kein qt5 aktiviert.

Ein
Code:
USE="qt5" emerge -pv phonon
ergibt:
Code:
media-libs/phonon-4.7.1-r1  USE="gstreamer pulseaudio qt4 vlc (-aqua) -debug -designer (-qt5) (-zeitgeist)"
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3897
Location: Irgendwo im Nirgendwo

PostPosted: Fri Jun 20, 2014 8:24 am    Post subject: Reply with quote

Klaus Meier wrote:
Ich bekomme aber bei meinem phonon kein qt5 aktiviert.

Ein
Code:
USE="qt5" emerge -pv phonon
ergibt:
Code:
media-libs/phonon-4.7.1-r1  USE="gstreamer pulseaudio qt4 vlc (-aqua) -debug -designer (-qt5) (-zeitgeist)"

In meinem letzten Post hier im Thread hab ich das doch geschrieben wie es gehen sollte.
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Fri Jun 20, 2014 8:25 am    Post subject: Reply with quote

Entschuldigung, war ich zu schnell, habe gerade gesehen, an was es liegt, sorry...
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Fri Jun 20, 2014 9:15 am    Post subject: Reply with quote

So. "KDE 5" mit den nicht-live-ebuilds ist gestorben, da die Bestandteile aus @kde-workspaces-5.0 nur in Version 4.96.0 vorliegen, und hier zu viel noch getan werden muss. baloo lässt sich zum Beispiel garnicht bauen.
Ich werde es also mal mit der Live Variante ausprobieren.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Hilefoks
l33t
l33t


Joined: 29 Jan 2003
Posts: 822
Location: Emden / Deutschland

PostPosted: Fri Jun 20, 2014 11:24 am    Post subject: Reply with quote

Moin,

ich würde allen Interessenten einmal einen Blick auf kdesrc-build empfehlen. Mit diesem Tool lässt sich KF5, Plasma5 und Co. deutlich einfacher und parallel zu KDE4 installieren. Ausserdem ist eine Aktualisierung deutlich schneller, da es im Gegensatz zu emerge nicht zwangsweise alles neu kompilieren muss.

http://kdesrc-build.kde.org/
http://community.kde.org/Frameworks/Building

MfG,
Hilefoks
_________________
- Der Computer rechnet vor allem damit, dass der Mensch denkt. -
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2275
Location: Germany

PostPosted: Fri Jun 20, 2014 11:33 am    Post subject: Reply with quote

Hilefoks wrote:
Ausserdem ist eine Aktualisierung deutlich schneller, da es im Gegensatz zu emerge nicht zwangsweise alles neu kompilieren muss.

Man muss mit emerge die Sets nicht zwangsweise komplett neu bauen - hierfür gibt es app-portage/smart-live-rebuild
Sofern installiert gibt es dann auch ein smart-live-rebuild Set
Damit lassen sich sehr bequem nur die Live-Pakete aktualisieren in dem es Änderungen gab :)
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Fri Jun 20, 2014 11:54 am    Post subject: Reply with quote

Installation von KDE-5-Live: (qt5 ist bei mir schon installiert!)

  1. Deinstallierte KDE-4 Pakete:
    Code:
    kde-base/attica:4
    kde-base/baloo:4
    kde-base/freespacenotifier:4
    kde-base/kactivities
    kde-base/kate:4
    kde-base/kcminit:4
    kde-base/kcontrol:4
    kde-base/kdebase-cursors:4
    kde-base/kdebase-kioslaves:4
    kde-base/kdebase-menu-icons:4
    kde-base/kdebase-startkde:4
    kde-base/kfilemetadata:4
    kde-base/khelpcenter:4
    kde-base/khotkeys:4
    kde-base/kinfocenter:4
    kde-base/klipper:4
    kde-base/kmenuedit:4
    kde-base/knetattach:4
    kde-base/konsole:4
    kde-base/krunner:4
    kde-base/ksmserver:4
    kde-base/ksplash:4
    kde-base/ksysguard:4
    kde-base/kuiserver:4
    kde-base/kwin:4
    kde-base/kwrite:4
    kde-base/kwrited:4
    kde-base/libkomparediff2:4
    kde-base/libkworkspace:4
    kde-base/libtaskmanager:4
    kde-base/plasma-workspace:4
    kde-base/powerdevil:4
    kde-base/systemsettings:4

  2. Neue Einträge in /etc/portage/profile/use.mask:
    Code:
    -qt5

  3. Neue Einträge in /etc/portage/package.use:
    Code:
    app-text/poppler qt5
    dev-libs/libdbusmenu-qt qt5
    dev-qt/qtquickcontrols:5 widgets
    media-gfx/graphviz python
    media-libs/phonon qt5
    media-libs/phonon-gstreamer qt5
    kde-base/kinfocenter -gles
    kde-base/kwin -gles2

  4. Neue Einträge in /etc/portage/package.unmask:
    Code:
    *keine*

  5. Neue Einträge in /etc/portage/package.accept_keywords: (Jetzt kommts)
    Code:
    =app-text/poppler-0.26.1 ~amd64
    >=dev-libs/extra-cmake-modules-0.0.12
    =dev-libs/extra-cmake-modules-9999 **
    =dev-libs/libdbusmenu-qt-9999::kde **
    =dev-python/pystache-0.5.3::gentoo
    =dev-python/pystache-0.5.4::gentoo
    =dev-qt/designer-5.3.0::qt
    =dev-qt/linguist-tools-5.3.0::qt
    =dev-qt/qdbus-5.3.0 ~amd64
    =dev-qt/qtpaths-5.3.0 ~amd64
    =kde-base/baloo-9999::kde **
    =kde-base/breeze-9999::kde **
    =kde-base/kate-9999::kde **
    =kde-base/kde-cli-tools-9999::kde **
    =kde-base/kfilemetadata-9999::kde **
    =kde-base/khelpcenter-9999::kde **
    =kde-base/khotkeys-9999::kde **
    =kde-base/kinfocenter-9999::kde **
    =kde-base/kio-extras-9999::kde **
    =kde-base/kmenuedit-9999::kde **
    =kde-base/konsole-9999::kde **
    =kde-base/ksysguard-9999::kde **
    =kde-base/kwin-9999::kde **
    =kde-base/kwrite-9999::kde **
    =kde-base/kwrited-9999::kde **
    =kde-base/libkomparediff2-9999::kde **
    =kde-base/libksysguard-9999::kde **
    =kde-base/milou-9999::kde **
    =kde-base/oxygen-9999::kde **
    =kde-base/plasma-desktop-9999::kde **
    =kde-base/plasma-workspace-9999::kde **
    =kde-base/powerdevil-9999::kde **
    =kde-base/systemsettings-9999::kde **
    =kde-frameworks/attica-9999::kde **
    =kde-frameworks/frameworkintegration-9999::kde **
    =kde-frameworks/kactivities-9999::kde **
    =kde-frameworks/kapidox-9999::kde **
    =kde-frameworks/karchive-9999::kde **
    =kde-frameworks/kauth-9999::kde **
    =kde-frameworks/kbookmarks-9999::kde **
    =kde-frameworks/kcmutils-9999::kde **
    =kde-frameworks/kcodecs-9999::kde **
    =kde-frameworks/kcompletion-9999::kde **
    =kde-frameworks/kconfig-9999::kde **
    =kde-frameworks/kconfigwidgets-9999::kde **
    =kde-frameworks/kcoreaddons-9999::kde **
    =kde-frameworks/kcrash-9999::kde **
    =kde-frameworks/kdbusaddons-9999::kde **
    =kde-frameworks/kdeclarative-9999::kde **
    =kde-frameworks/kded-9999::kde **
    =kde-frameworks/kdelibs4support-9999::kde **
    =kde-frameworks/kdesignerplugin-9999::kde **
    =kde-frameworks/kdesu-9999::kde **
    =kde-frameworks/kdewebkit-9999::kde **
    =kde-frameworks/kdnssd-9999::kde **
    =kde-frameworks/kdoctools-9999::kde **
    =kde-frameworks/kemoticons-9999::kde **
    >=kde-frameworks/kf-env-1
    =kde-frameworks/kglobalaccel-9999::kde **
    =kde-frameworks/kguiaddons-9999::kde **
    =kde-frameworks/khtml-9999::kde **
    =kde-frameworks/ki18n-9999::kde **
    =kde-frameworks/kiconthemes-9999::kde **
    =kde-frameworks/kidletime-9999::kde **
    =kde-frameworks/kimageformats-9999::kde **
    =kde-frameworks/kinit-9999::kde **
    =kde-frameworks/kio-9999::kde **
    =kde-frameworks/kitemmodels-9999::kde **
    =kde-frameworks/kitemviews-9999::kde **
    =kde-frameworks/kjobwidgets-9999::kde **
    =kde-frameworks/kjs-9999::kde **
    =kde-frameworks/kjsembed-9999::kde **
    =kde-frameworks/kmediaplayer-9999::kde **
    =kde-frameworks/knewstuff-9999::kde **
    =kde-frameworks/knotifications-9999::kde **
    =kde-frameworks/knotifyconfig-9999::kde **
    =kde-frameworks/kparts-9999::kde **
    =kde-frameworks/kplotting-9999::kde **
    =kde-frameworks/kpty-9999::kde **
    =kde-frameworks/kross-9999::kde **
    =kde-frameworks/krunner-9999::kde **
    =kde-frameworks/kservice-9999::kde **
    =kde-frameworks/ktexteditor-9999::kde **
    =kde-frameworks/ktextwidgets-9999::kde **
    =kde-frameworks/kunitconversion-9999::kde **
    =kde-frameworks/kwallet-9999::kde **
    =kde-frameworks/kwidgetsaddons-9999::kde **
    =kde-frameworks/kwindowsystem-9999::kde **
    =kde-frameworks/kxmlgui-9999::kde **
    =kde-frameworks/plasma-9999::kde **
    =kde-frameworks/solid-9999::kde **
    =kde-frameworks/sonnet-9999::kde **
    =kde-frameworks/threadweaver-9999::kde **
    =kde-misc/yakuake-9999::kde **
    =media-fonts/oxygen-fonts-0.3.96::kde
    =media-fonts/oxygen-fonts-0_p20120917::gentoo
    =net-libs/libbluedevil-9999::kde **
    =net-wireless/bluedevil-9999::kde **
    =x11-libs/libkscreen2-9999 **

  6. Installierte Sets: (Einzeln in dieser Reihenfolge)

    1. @kde-frameworks-live
    2. @kde-workspaces-live
    3. @kde-applications-live
Ich melde mich, wenn ich neu gestartet habe, was ich allerdings nicht jetzt sofort tun werden. ;-) (*zitter*)

Acja: Bei jedem Versuch @world oder @preserved-rebuild zu emergen bricht natürlcih die Hölle los. :D
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Fri Jun 20, 2014 12:35 pm    Post subject: Reply with quote

*lol*

Also das was ich sehen kann, ist ja ganz hübsch, nur viel ist das nicht.

Ich tippe mal darauf, dass ich statt auf OpenGL lieber auf GLES hätte setzen sollen. Oder der alte kdm kommt mit dem neuen Plasma nicht klar. Mal sehen, ob man das ohne kdm starten kann. das Meiste ist nämlich schwarz. Nicht mal eine Task-Leiste ist da (aber die Uhr ganz rechts wird angezeigt. *tehe*)
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Fri Jun 20, 2014 1:26 pm    Post subject: Reply with quote

Nun ja, eigentlich hatte ich es schon so weit, dass frameworks-5.0 durchlief. Dann bin ich im laufenden Betrieb von 5 auf live umgestiegen. Und jetzt geht es weder vor noch zurück... Also noch mal bei Null anfangen...
Back to top
View user's profile Send private message
Yamakuzure
Veteran
Veteran


Joined: 21 Jun 2006
Posts: 1374
Location: Bardowick, Germany

PostPosted: Fri Jun 20, 2014 2:27 pm    Post subject: Reply with quote

Also es ging garnichts. Was ich an Fenstern (die nicht voller schwarzer Felder waren) sah, war recht hübsch. Aber nutzbar war nichts.

Ich habe die Sets wieder runtergeworfen und aus /etc/portage/package.accept_keywords ausgetragen.

Mit Hilfe von SDDM (gefällt mir gut das Teil) bin ich jetzt in lxqt und baue mir die fehlenden Teile von KDE:4 nach.

Wie gesagt, was ich sah war hübsch und vor Allem flott. Ich bin auf jeden Fall auf den ersten echten Release gespannt.
_________________
I *do* know that I easily aggravate people due to my condensed writing. Rule of thumb: If I wrote anything that can be understood in two different ways, and one way offends you, then I meant the other! ;)
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Fri Jun 20, 2014 2:35 pm    Post subject: Reply with quote

Na prima.... Danke für deine Arbeit. Habe es gerade so weit, um es durchzuziehen. Kann ich mir also sparen...

Ja, der sddm ist cool. Na dann halt noch etwas warten.
Back to top
View user's profile Send private message
Hilefoks
l33t
l33t


Joined: 29 Jan 2003
Posts: 822
Location: Emden / Deutschland

PostPosted: Fri Jun 20, 2014 10:15 pm    Post subject: Reply with quote

Josef.95 wrote:
Hilefoks wrote:
Ausserdem ist eine Aktualisierung deutlich schneller, da es im Gegensatz zu emerge nicht zwangsweise alles neu kompilieren muss.

Man muss mit emerge die Sets nicht zwangsweise komplett neu bauen - hierfür gibt es app-portage/smart-live-rebuild
Sofern installiert gibt es dann auch ein smart-live-rebuild Set
Damit lassen sich sehr bequem nur die Live-Pakete aktualisieren in dem es Änderungen gab :)


smart-live-rebuild ist schon gut, aber nicht so gut wie kdesrc-build. Der Unterschied ist, das bei kdesrc-build das build-Verzeichnis erhalten bleibt. Ändern sich nur wenige Quelltextdateien beim Update, so werden auch nur diese neu kompiliert und gelinkt (vereinfacht ausgedrückt) und nicht zwangsweise das gesamte Projekt. Die KDE4 kdelibs baue ich z.B. mehrmals täglich neu und dies dauert normalerweise weniger als 1 Minute. Zugegeben, das Problem ist bei KF5 nicht mehr so groß, da es aus sehr vielen kleinen Projekten besteht. Aber bei KDevelop, DigiKam, Amarok und Co. merkt man es deutlich.
_________________
- Der Computer rechnet vor allem damit, dass der Mensch denkt. -
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2275
Location: Germany

PostPosted: Sat Jun 21, 2014 12:32 am    Post subject: Reply with quote

@Hilefoks
Danke für den Hinweis und die Erklärung dazu. Ich hab mir kdesrc-build ehrlich gesagt noch nicht genauer angesehen, da ich nur sehr ungern am Paketmanager portage vorbei installiere.

...................................................................................................
Yamakuzure wrote:
So. "KDE 5" mit den nicht-live-ebuilds ist gestorben, da die Bestandteile aus @kde-workspaces-5.0 nur in Version 4.96.0 vorliegen, und hier zu viel noch getan werden muss. baloo lässt sich zum Beispiel garnicht bauen.
Ich werde es also mal mit der Live Variante ausprobieren.

Deine Klagen wurden erhöht - nur wenige Stunden später wurde im kde Overlay auf die aktuellen KF5 beta 3 ([M](~)4.100.0) und Plasma Next beta 2 ([M](~)4.97.0) Version aktualisiert.
Zudem wurde seitens Upstream im plasma-workspace nun auch eine /usr/share/xsessions/plasma.desktop bereitgestellt, die sich mit gängigen DisplayManagern nutzen lässt :)

Noch mal an alle - erwartet bitte nicht zu viel von so einer experimentellen beta Version, plasma-2 ist noch lange nicht fertig, und zZt sicher noch kein vollwertiger Ersatz fürs gut funktionierende aktuelle kde4.
Back to top
View user's profile Send private message
Klaus Meier
Advocate
Advocate


Joined: 18 Apr 2005
Posts: 2266
Location: Bozen

PostPosted: Sat Jun 21, 2014 6:05 pm    Post subject: Reply with quote

So, jetzt ist Wochenende und ich bin da mal mit Zeit und Ruhe ran gegangen. Sieht soweit gut aus, aber jetzt kommt ein Fetch Error bei strigi-9999
Code:
 * Checking out kde:strigiclient to /var/tmp/portage/app-misc/strigi-9999/work/strigi-9999/strigiclient ...
git checkout --quiet 4ff3b6673e78fbcc2de1bd40114228082329f658
GIT update -->
   repository:               kde:strigiclient
   at the commit:            4ff3b6673e78fbcc2de1bd40114228082329f658
Entering 'libstreamanalyzer'
error: pathspec 'origin/master' did not match any file(s) known to git.
Stopping at 'libstreamanalyzer'; script returned non-zero status.

Mal sehen, wenn es weiter geht.
Back to top
View user's profile Send private message
franzf
Advocate
Advocate


Joined: 29 Mar 2005
Posts: 3897
Location: Irgendwo im Nirgendwo

PostPosted: Sat Jun 21, 2014 6:53 pm    Post subject: Reply with quote

kde:5 sollte doch gar kein strigi mehr brauchen...
_________________
"der mac dennoch wesen geil"
Wolfram von Eschenbach, Parzival (Buch 1, Z. 7).
Ein frühes Statement gegen Windows.

My overlay
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 2 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum