Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Riguardo sys-process/htop
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ciro64
Apprentice
Apprentice


Joined: 20 Jun 2009
Posts: 276

PostPosted: Tue Jun 03, 2014 4:37 pm    Post subject: [Risolto] Riguardo sys-process/htop Reply with quote

Ciao.
Installando htop ottengo questi (penso) warnings:

Code:

 *   CONFIG_TASK_XACCT:  is not set when it should be.
 *   CONFIG_TASK_IO_ACCOUNTING:  is not set when it should be.
 * Please check to make sure these options are set correctly.
 * Failure to do so may cause unexpected problems.


Questi parametri non sono a livello kernel..... mi chiedo come fare per "aggiustare le cose".
Comunque il programma sembra funzionare correttamente.

Ciao :)
_________________
Gentoo: il sistema più eclettico e geniale che abbia mai provato :)


Last edited by ciro64 on Tue Jun 03, 2014 9:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 434

PostPosted: Tue Jun 03, 2014 6:59 pm    Post subject: Reply with quote

Oh no, sono assolutamente parametri del kernel :P
Prima di compilare, lancia make xconfig/make gconfig e con lo strumento "cerca" vai ad abilitare l'opzione incriminata.

Considera anche che i parametri possono cambiare nome nel corso del tempo, quindi è possibile che tu abbia quei parametri abilitati ma con un nome diverso da quello previsto nell'ebuild. In tal caso puoi semplicemente ignorare l'avviso :wink:
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Apprentice
Apprentice


Joined: 20 Jun 2009
Posts: 276

PostPosted: Tue Jun 03, 2014 8:49 pm    Post subject: Reply with quote

Accidenti... quando ho controllato devo aver digitato in modo non corretto la query, in quanto se do:
Code:

# grep CONFIG_TASK /usr/src/linux/.config

Ottengo
Code:

CONFIG_TASKSTATS=y
CONFIG_TASK_DELAY_ACCT=y
CONFIG_TASK_XACCT=y
# CONFIG_TASK_IO_ACCOUNTING is not set

:oops:

____________________

edit: ho usato kate per editare il .config indi settato CONFIG_TASK_IO_ACCOUNTING=y (xconfig e gconfig non mi son serviti con la funzione "trova"....)

Comunque ora la compilazione di htop non riporta più errori.

Grazie 1000 Pierino_89
_________________
Gentoo: il sistema più eclettico e geniale che abbia mai provato :)
Back to top
View user's profile Send private message
pierino_89
Guru
Guru


Joined: 03 Oct 2009
Posts: 434

PostPosted: Tue Jun 03, 2014 10:51 pm    Post subject: Reply with quote

ciro64 wrote:
xconfig e gconfig non mi son serviti con la funzione "trova"

Beh con grep fai sicuramente prima :D gli altri due sono comodi perché hai lo spiegone sottomano, ma è anche vero che spesso non trovano il nome esatto riportato nel kernel (fanno la ricerca nello spiegone, suppongo).
Comunque, l'importante è che hai risolto! 8)
_________________
Linux registered user 461710
Back to top
View user's profile Send private message
ciro64
Apprentice
Apprentice


Joined: 20 Jun 2009
Posts: 276

PostPosted: Wed Jun 04, 2014 2:00 pm    Post subject: Reply with quote

Si si ... ho risolto e grazie a Te ..... Magico Pierino_89 :) :) Buon tutto :)
_________________
Gentoo: il sistema più eclettico e geniale che abbia mai provato :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum