Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
dev-libs/boost:0/1.52 und dev-libs/icu:0/52
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum
View previous topic :: View next topic  
Author Message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1010
Location: Schweiz

PostPosted: Tue May 27, 2014 11:33 am    Post subject: dev-libs/boost:0/1.52 und dev-libs/icu:0/52 Reply with quote

Als erstes vorweg, ich habe nicht die Absicht mich hier zu beschweren. Das soll eine Verständnisfrage werden bezüglich der Art und Weise wie Pakete freigegeben werden.

Mir ist gerade aufgefallen das sich "boost:0/1.52" nicht mit "icu:0/52" (welches erst kürzlich freigegeben wurde) bauen lässt wenn das USE-Flag "icu" aktiv ist, erst mit boost:0/1.53 klappte das bauen wieder einwandfrei. Und obwohl es dafür scheinbar auch einen Bugreport gibt wurde das neue icu trotzdem freigegeben.

Wurde der Bugreport beim freigeben von "icu:0/52" übersehen oder einfach als irrelevant angesehen?
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Fri Jun 06, 2014 9:40 am; edited 1 time in total
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 189
Location: GER / FFM

PostPosted: Wed May 28, 2014 11:14 am    Post subject: Reply with quote

Also hier gab es mit den beiden genannten Versionen keine Probleme. Hat alles sauber durch kompiliert. Wie man sehen kann, habe ich ebenfalls das icu USE Flag aktiviert.

Code:
[I] dev-libs/boost
     Available versions:  1.52.0-r6(0/1.52){tbz2} ~1.53.0-r1(0/1.53) ~1.54.0-r1(0/1.54) ~1.55.0-r1(0/1.55.0)^t {context debug doc icu mpi +nls python static-libs +threads tools PYTHON_TARGETS="python2_6 python2_7 python3_2 python3_3"}
     Installed versions:  1.52.0-r6{tbz2}(12:03:39 27.05.2014)(icu nls threads -debug -doc -mpi -python -static-libs -tools PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_2")
     Homepage:            http://www.boost.org/
     Description:         Boost Libraries for C++


Code:
[I] dev-libs/icu
     Available versions:  51.2-r1(0/51.2) 51.2-r2(0/51.2){tbz2} 52.1(0/52){tbz2} {debug doc examples static-libs ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
     Installed versions:  52.1{tbz2}(11:59:15 27.05.2014)(-debug -doc -examples -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
     Homepage:            http://www.icu-project.org/
     Description:         International Components for Unicode
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1010
Location: Schweiz

PostPosted: Wed May 28, 2014 11:32 am    Post subject: Reply with quote

Ich konnte dieses Problem inzwischen auf drei verschiedenen Installationen (Laptop, Arbeits-PC und Home-PC) beobachten und auch ein MAKEOPTS="-j1" half dann nicht mehr weiter.

Naja "boost" scheint ja schon öfters für das eine oder andere Mysterium gesorgt zu haben.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 189
Location: GER / FFM

PostPosted: Wed May 28, 2014 12:13 pm    Post subject: Reply with quote

Nur ein Schuss ins Blaue: Kann evtl. auch die Python Version eine Rolle spielen? Ich baue hier alles noch mit Python 2.7, da Python 3 eher mal Probleme macht. Das könnte zumindest einen Unterschied ausmachen.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1010
Location: Schweiz

PostPosted: Wed May 28, 2014 12:21 pm    Post subject: Reply with quote

Bei mir ist auch Python 2.7 als Default hinterlegt und das auf all meinen Installationen:
Code:
Available Python interpreters:
  [1]   python2.7 *
  [2]   python3.3

Code:
$ grep PYTHON /etc/portage/make.conf
PYTHON_SINGLE_TARGET="python2_7"

_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1010
Location: Schweiz

PostPosted: Fri Jun 06, 2014 7:46 am    Post subject: Reply with quote

@Fijoldar
Nur so aus neugier, was für eine Version vom GCC benutzt du?
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 189
Location: GER / FFM

PostPosted: Fri Jun 06, 2014 8:03 am    Post subject: Reply with quote

Ich nutze hier GCC 4.7.3 aus amd64 stable
Code:
Portage 2.2.8-r1 (default/linux/amd64/13.0/desktop, gcc-4.7.3, glibc-2.17, 3.13.11-ck x86_64)
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1010
Location: Schweiz

PostPosted: Fri Jun 06, 2014 8:13 am    Post subject: Reply with quote

Ich benutze den GCC 4.8.2 und das eigentlich fast überall.
Dann wird es wohl eher eine dreierkombi sein die das Problem verursacht.
dev-libs/boost:0/1.52 + dev-libs/icu:0/52 + sys-devel/gcc:4.8
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Fri Jun 06, 2014 9:39 am; edited 1 time in total
Back to top
View user's profile Send private message
Fijoldar
Apprentice
Apprentice


Joined: 10 Apr 2013
Posts: 189
Location: GER / FFM

PostPosted: Fri Jun 06, 2014 8:16 am    Post subject: Reply with quote

Teste es doch einfach mal mit der stabilen GCC Version ;-).
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1010
Location: Schweiz

PostPosted: Fri Jun 06, 2014 9:47 am    Post subject: Reply with quote

Gerade getestet und es bricht auch mit gcc 4.7 ab, also kann es das auch nicht sein.
Nicht das ich jetzt darauf angewiesen wäre immerhin lässt sich boost eine Version höher fehlerfrei kompilieren aber es würde mich trotzdem interessieren was der Grund dafür ist.
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)


Last edited by schmidicom on Sat Jun 07, 2014 9:09 am; edited 2 times in total
Back to top
View user's profile Send private message
ChrisJumper
Veteran
Veteran


Joined: 12 Mar 2005
Posts: 1815
Location: Germany

PostPosted: Fri Jun 06, 2014 7:54 pm    Post subject: Reply with quote

hi schmidicom,

also ich habe auch die beiden Packete buaen können:

Code:
[I] dev-libs/boost
     Available versions:  1.52.0-r6(0/1.52) ~1.53.0-r1(0/1.53) ~1.54.0-r1(0/1.54) ~1.55.0-r1(0/1.55.0)^t {context debug doc icu mpi +nls python static-libs +threads tools PYTHON_TARGETS="python2_6 python2_7 python3_2 python3_3"}
     Installed versions:  1.52.0-r6(00:46:12 04.06.2014)(icu nls python threads -debug -doc -mpi -static-libs -tools PYTHON_TARGETS="python2_7 python3_2 -python2_6 -python3_3")
     Homepage:            http://www.boost.org/
     Description:         Boost Libraries for C++


Code:
[I] dev-libs/icu
     Available versions:  51.2-r1(0/51.2) 51.2-r2(0/51.2) 52.1(0/52) {debug doc examples static-libs ABI_MIPS="n32 n64 o32" ABI_X86="32 64 x32"}
     Installed versions:  52.1(14:20:06 11.02.2014)(-debug -doc -examples -static-libs ABI_MIPS="-n32 -n64 -o32" ABI_X86="64 -32 -x32")
     Homepage:            http://www.icu-project.org/
     Description:         International Components for Unicode


Code:
x86_64-pc-linux-gnu-4.7.3 *


Ich habe auch keine Probleme. Du hast bei boost dein PYTHON Useflag deaktiviert. Vielleicht ist es das?

Python 2.7 Verwende ich übrigens auch.

Welche Fehlermeldung wird denn ausgespuckt? Vielleicht hilft das auch weiter.
Back to top
View user's profile Send private message
schmidicom
Veteran
Veteran


Joined: 09 Mar 2006
Posts: 1010
Location: Schweiz

PostPosted: Sat Jun 07, 2014 1:15 pm    Post subject: Reply with quote

So ich habe es jetzt auf dem Laptop (wo das USE Flag python aktiv ist) nochmal mit GCC 4.8 versucht und das build.log auf meine owncloud hochgeladen.
https://shschmid.dyndns.ch/owncloud/public.php?service=files&t=e5d90b8611bd2fdf6683f1631ed4ca91
_________________
Mich braucht jeder. Zumindest behaupten viele, ich hätte gerade noch gefehlt. ;)
GPG: 0x54A19454 - Download | (0x5E2B12A0 ist veraltet)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Diskussionsforum All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum