Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201405-12 ] Ettercap: Multiple vulnerabilities
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1571

PostPosted: Sat May 17, 2014 8:26 pm    Post subject: [ GLSA 201405-12 ] Ettercap: Multiple vulnerabilities Reply with quote

Gentoo Linux Security Advisory

Title: Ettercap: Multiple vulnerabilities (GLSA 201405-12)
Severity: normal
Exploitable: remote
Date: May 17, 2014
Bug(s): #340897, #451198
ID: 201405-12

Synopsis

Multiple vulnerabilities have been found in Ettercap, the worst of
which may allow execution of arbitrary code.


Background

Ettercap is a suite of tools for content filtering, sniffing and man in
the middle attacks on a LAN.


Affected Packages

Package: net-analyzer/ettercap
Vulnerable: < 0.7.5.2
Unaffected: >= 0.7.5.2
Architectures: All supported architectures


Description

Multiple vulnerabilities have been discovered in Ettercap:
  • Ettercap does not handle temporary files securely (CVE-2010-3843).
  • A format string flaw in Ettercap could cause a buffer overflow
    (CVE-2010-3844).
  • A stack-based buffer overflow exists in Ettercap (CVE-2013-0722).


Impact

A remote attacker could entice a user to load a specially crafted
configuration file using Ettercap, possibly resulting in execution of
arbitrary code with the privileges of the process or a Denial of Service
condition.
A local attacker could perform symlink attacks to overwrite arbitrary
files with the privileges of the user running the application.


Workaround

There is no known workaround at this time.

Resolution

All Ettercap users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=net-analyzer/ettercap-0.7.5.2"
   


References

CVE-2010-3843
CVE-2010-3844
CVE-2013-0722
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum