Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Systemd ne démmare pas
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
olive007BE
n00b
n00b


Joined: 21 May 2013
Posts: 2

PostPosted: Thu May 08, 2014 1:49 pm    Post subject: Systemd ne démmare pas Reply with quote

Bonjour,

J'ai déjà réussi a installer Gentoo l'année dernière. En Bref j'ai testé plusieurs distribution : ArchLinux, Ubuntu, Fedora, OpenSuse, Gentoo. Et je trouve que la plus stable est Gentoo.
Je voudrais utiliser Gnome 3 avec Systemd. Mais lorsque je lance ma distribution c'est OpenRc qui démarre. J'ai suivi les instruction du wiki : http://wiki.gentoo.org/wiki/Systemd.
Je n'ai pas tout compris. J'ai donc quelques questions ?

Je n'ai pas de partition /usr séparé, doit-je donc utilisé un initramfs ?
Doit-je unmerge OpenRc pour devoir utilisé Systemd ?

Merci d'avance
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 5623
Location: ~Brussels - Belgique

PostPosted: Thu May 08, 2014 1:58 pm    Post subject: Reply with quote

Message déplacé dans la section francophone du forum.
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
ruddy32
n00b
n00b


Joined: 07 May 2014
Posts: 35
Location: France

PostPosted: Fri May 09, 2014 9:04 am    Post subject: Reply with quote

Je rencontre un autre problème, démarrage de grub, suite à l'installation Gnome 3 & systemd - http://forums.gentoo.org/viewtopic-t-990504.html?sid=fa2bdcdf6f4b02bb9482c19038c152d6.
_________________
ruddy32
Back to top
View user's profile Send private message
DuF
Advocate
Advocate


Joined: 09 Dec 2002
Posts: 2647
Location: Paris

PostPosted: Fri May 09, 2014 3:23 pm    Post subject: Re: Systemd ne démmare pas Reply with quote

olive007BE wrote:
Bonjour,

J'ai déjà réussi a installer Gentoo l'année dernière. En Bref j'ai testé plusieurs distribution : ArchLinux, Ubuntu, Fedora, OpenSuse, Gentoo. Et je trouve que la plus stable est Gentoo.
Je voudrais utiliser Gnome 3 avec Systemd. Mais lorsque je lance ma distribution c'est OpenRc qui démarre. J'ai suivi les instruction du wiki : http://wiki.gentoo.org/wiki/Systemd.
Je n'ai pas tout compris. J'ai donc quelques questions ?

Je n'ai pas de partition /usr séparé, doit-je donc utilisé un initramfs ?
Doit-je unmerge OpenRc pour devoir utilisé Systemd ?

Merci d'avance


Bonjour,

Tu peux ne pas avoir de partition /usr séparée et pourtant avoir besoin d'utiliser un initramfs, à toi de savoir suivant ton usage et ton matériel ce dont tu as besoin pour que l'init se passe bien.

Conserves pour l'instant OpenRC même si tu ne l'utilises pas comme init. Je n'ai pas regardé récemment mais pour moi il y a des scripts utiles à gentoo globalement.

Pour ton problème au démarrage, peux-tu détailler comment ton système est configuré (grub, partition, version applicative, etc.)

NB : Ce serait sympa de suivre les règles du forum §3/3 sur la manière de poster.
Back to top
View user's profile Send private message
SirRobin2318
Apprentice
Apprentice


Joined: 24 Apr 2004
Posts: 213
Location: Strasbourg, france.

PostPosted: Fri May 16, 2014 10:54 am    Post subject: Reply with quote

Oui, on va avoir besoin de plus de détails. Genre ce que tu as mis comme init dans /etc/default/grub ?
Tu devrais avoir:
Code:
GRUB_CMDLINE_LINUX_DEFAULT="init=/usr/lib/systemd/systemd"


Quelqu'un a eu un problème similaire et l'a corrigé en donnant real_init en paramètre au kernel:
http://forums.gentoo.org/viewtopic-t-987146-highlight-.html
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum