Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Allow users to reboot/shutdown
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 762

PostPosted: Fri Apr 11, 2014 1:42 pm    Post subject: Allow users to reboot/shutdown Reply with quote

How can I allow users to reboot and shutdown the system? I use xfce4 and the reboot and shutdown buttons are grayed out. I use lightdm and nothing happens when I click the button in the upper-right hand corner which should bring up a reboot/shutdown menu.
Back to top
View user's profile Send private message
luna80
Veteran
Veteran


Joined: 01 Feb 2004
Posts: 1068
Location: switzerland

PostPosted: Fri Apr 11, 2014 4:41 pm    Post subject: Reply with quote

you can find here

http://forums.gentoo.org/viewtopic.php?t=1401
_________________
*** !f j00 c4n r34D tH15 tH3N j00 n33D t0 l0g Off ***
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5586

PostPosted: Fri Apr 11, 2014 5:26 pm    Post subject: Reply with quote

luna80 wrote:
you can find here

http://forums.gentoo.org/viewtopic.php?t=1401


That's actually off-topic.

That 'xfce' bit translates most likely to 'upower', which means either consolekit of systemd.
Back to top
View user's profile Send private message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 762

PostPosted: Fri Apr 11, 2014 6:46 pm    Post subject: Reply with quote

This has always "just worked" for me in the past. Any idea what needs to be straightened out?
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5586

PostPosted: Fri Apr 11, 2014 8:46 pm    Post subject: Reply with quote

...'always' worked...LOL

Anyway, as I said, first check if sys-apps/accountsservice is built for systemd or not.
If not, the first check is always ck-list-sessions (and obviously if sys-auth/consolekit[acl]).
Back to top
View user's profile Send private message
grant123
l33t
l33t


Joined: 23 Mar 2005
Posts: 762

PostPosted: Sat Apr 12, 2014 1:49 am    Post subject: Reply with quote

consolekit does have USE=acl.

accountsservice does not have USE=systemd. Should I change that?

I get no output from ck-list-sessions.

EDIT: You nailed it. Your clues lead me to re-emerge dbus which fixed it. I had lost the messagebus group somehow. Thank you!
Back to top
View user's profile Send private message
SDNick484
Tux's lil' helper
Tux's lil' helper


Joined: 05 Dec 2005
Posts: 144

PostPosted: Sat Apr 12, 2014 6:51 pm    Post subject: Reply with quote

I am having similar issues in Xfce with not just reboot, but everything except Log Out being greyed out. I believe it's consolekit related, but I'm not quite sure what I've missed. I have rebuilt & restarted, and I have the messagebus group so it's not the exact issue of the original poster. I posted details in this thread however I've been re-directed here so I'm reposting below:

<<<<<

An update has somehow broken my consolekit settings so that now I can't execute suspend or shutdown from Xfce as a non-privileged user anymore. I know this is a consolekit issue however I'm not sure how to correct it. It was working previously, and a major pain to get it right in the first place. I have tried re-following the steps in this thread however it doesn't seem to help.

So far I have the following:
[ebuild R ] sys-auth/pambase-20140313 USE="cracklib sha512 (-consolekit) -debug -gnome-keyring -minimal -mktemp -pam_krb5 -pam_ssh -passwdqc (-selinux) -systemd" 0 kB
[ebuild R ] dev-libs/glib-2.38.2-r1:2 USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="32 (64) (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 0 kB
[ebuild R ] sys-apps/shadow-4.1.5.1-r1 USE="acl cracklib nls pam -audit (-selinux) -skey -xattr" 0 kB
[ebuild R ] dev-libs/dbus-glib-0.102 USE="-debug -doc -static-libs {-test}" ABI_X86="32 (64) (-x32)" 0 kB
[ebuild R ] sys-fs/udisks-2.1.3:2 USE="gptfdisk introspection -cryptsetup -debug (-selinux) -systemd" 0 kB
[ebuild R ] gnome-extra/polkit-gnome-0.105-r1 304 kB
[ebuild R ] gnome-base/gvfs-1.18.3 USE="archive avahi bluetooth cdda fuse gdu gnome-online-accounts gphoto2 gtk http libsecret udev udisks -afp -bluray -ios -mtp -samba -systemd {-test}" 0 kB
[ebuild R ] sys-power/upower-0.9.23-r2 USE="introspection -doc -ios -systemd" 0 kB
[ebuild R ] sys-auth/consolekit-0.4.6 USE="acl pam policykit -debug -doc (-selinux) -systemd-units {-test}" 0 kB

I am running ~amd64 and have absolutely no interest in running systemd unless I absolutely have to.

My ~/.xinitrc looks like: exec ck-launch-session startxfce4

When I do a ck-list-sessions, I see only one session and [/url]both active & is-local are listed as FALSE (I recall they need to be TRUE, I just don't know what I need to do to fix them.

This is a single user laptop so I'm open to insecure polkit entries if that's an easier way to fix this problem.

Any help would be greatly appreciated.
>>>>>
Back to top
View user's profile Send private message
fenrirjk
n00b
n00b


Joined: 22 Mar 2013
Posts: 4

PostPosted: Sun Aug 24, 2014 10:20 am    Post subject: Reply with quote

Hi everybody,

I ran into the same problem and it took me a lot of time to fix it.
I tried many things, but I think that what worked for me is ... updating the config scripts.

maybe you should try

Code:
etc-update
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum