Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 201404-07 ] OpenSSL: Information Disclosure
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1563

PostPosted: Tue Apr 08, 2014 11:26 am    Post subject: [ GLSA 201404-07 ] OpenSSL: Information Disclosure Reply with quote

Gentoo Linux Security Advisory

Title: OpenSSL: Information Disclosure (GLSA 201404-07)
Severity: normal
Exploitable: remote
Date: April 08, 2014
Updated: July 07, 2014
Bug(s): #505278, #507074
ID: 201404-07

Synopsis

Multiple Information Disclosure vulnerabilities in OpenSSL allow
remote attackers to obtain sensitive information via various vectors.


Background

OpenSSL is an Open Source toolkit implementing the Secure Sockets Layer
(SSL v2/v3) and Transport Layer Security (TLS v1) as well as a general
purpose cryptography library.


Affected Packages

Package: dev-libs/openssl
Vulnerable: < 1.0.1g
Unaffected: >= 1.0.1g
Unaffected: >= 0.9.8y < 0.9.9
Unaffected: >= 0.9.8z_p1 < 0.9.9
Unaffected: >= 0.9.8z_p2 < 0.9.9
Unaffected: >= 0.9.8z_p3 < 0.9.9
Unaffected: >= 0.9.8z_p4 < 0.9.9
Unaffected: >= 0.9.8z_p5 < 0.9.9
Architectures: All supported architectures


Description

Multiple vulnerabilities have been found in OpenSSL:
  • OpenSSL incorrectly handles memory in the TLS heartbeat extension,
    leading to information disclosure of 64kb per request, possibly
    including private keys (“Heartbleed bug”, OpenSSL 1.0.1 only,
    CVE-2014-0160).
  • The Montgomery ladder implementation of OpenSSL improperly handles
    swap operations (CVE-2014-0076).


Impact

A remote attacker could exploit these issues to disclose information,
including private keys or other sensitive information, or perform
side-channel attacks to obtain ECDSA nonces.


Workaround

Disabling the tls-heartbeat USE flag (enabled by default) provides a
workaround for the CVE-2014-0160 issue.


Resolution

All OpenSSL users should upgrade to the latest version:
Code:
# emerge --sync
      # emerge --ask --oneshot --verbose ">=dev-libs/openssl-1.0.1g"
   
Note: All services using OpenSSL to provide TLS connections have to be
restarted for the update to take effect. Utilities like
app-admin/lib_users can aid in identifying programs using OpenSSL.
As private keys may have been compromised using the Heartbleed attack,
it is recommended to regenerate them.


References

CVE-2014-0076
CVE-2014-0160
Heartbleed bug website


Last edited by GLSA on Tue Jul 08, 2014 4:31 am; edited 4 times in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum