Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
istanbul fails to run
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
voncloft
n00b
n00b


Joined: 29 Jan 2014
Posts: 33

PostPosted: Fri Mar 21, 2014 2:49 am    Post subject: istanbul fails to run Reply with quote

I tried running istanbul and received the following - I have spent over an hour on google searching for an answer and so far no dice.

Code:

nick@gentoo-nick ~ $ istanbul
Traceback (most recent call last):
  File "/usr/bin/istanbul", line 24, in <module>
    import gobject
  File "/usr/lib64/python2.7/site-packages/gobject/__init__.py", line 26, in <module>
    from glib import spawn_async, idle_add, timeout_add, timeout_add_seconds, \
  File "/usr/lib64/python2.7/site-packages/glib/__init__.py", line 22, in <module>
    from glib._glib import *
ImportError: /usr/lib64/libpyglib-2.0-python2.72.7.so.0: undefined symbol: _Py_ZeroStruct
nick@gentoo-nick ~ $


Any ideas?
Back to top
View user's profile Send private message
voncloft
n00b
n00b


Joined: 29 Jan 2014
Posts: 33

PostPosted: Fri Mar 21, 2014 11:16 am    Post subject: Reply with quote

nobody?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7849
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Mar 21, 2014 1:35 pm    Post subject: Reply with quote

Well, it's a Python issue of some sort. The shotgun approach would be to run python-updater to see if it fixed the problem. Before you do that, though, could you post the output of
Code:
eselect python list
please?

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
voncloft
n00b
n00b


Joined: 29 Jan 2014
Posts: 33

PostPosted: Fri Mar 21, 2014 2:03 pm    Post subject: Reply with quote

It says python 3.3, and I tried the python-updater in the terminal as well.

I tried a full system update, and remerging istanbul.

I am still receiving the error.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 7849
Location: Somewhere over Atlanta, Georgia

PostPosted: Fri Mar 21, 2014 2:06 pm    Post subject: Reply with quote

In general, when someone asks for the output, it's better to post the actual output rather than an interpretation of it: you might miss some nuance. If all you have installed is Python 3.3, then that's a big part of the problem because, as you can see from the error messages, istanbul is trying to use Python 2.7. Could you post the output of
Code:
equery list -i python
please?

- John
_________________
This space intentionally left blank.
Back to top
View user's profile Send private message
voncloft
n00b
n00b


Joined: 29 Jan 2014
Posts: 33

PostPosted: Sat Mar 22, 2014 12:48 pm    Post subject: Reply with quote

I was busy yesterday, I ran the command and got:

Code:

nick@gentoo-nick /usr/lib64 $ equery list -i python
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'
 * Searching for python ...
[IP-] [  ] dev-lang/python-2.7.5-r3:2.7
[IP-] [  ] dev-lang/python-3.3.3:3.3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum