Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Samba doesn't work with wifi
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
piero.turra
n00b
n00b


Joined: 28 Nov 2006
Posts: 39

PostPosted: Mon Mar 17, 2014 7:44 pm    Post subject: Samba doesn't work with wifi Reply with quote

Hello, I have a file server with a wired network card and a wireless one. When I start only the wireless connection the samba server stops working and is no more possible to restart or stop the daemon:

This is the output trying to restart the daemon:

Code:
Orcrist ~ # /etc/init.d/samba restart
 * samba -> stop: smbd ...                                                [ ok ]
 * samba -> stop: nmbd ...
 * start-stop-daemon: 1 process refused to stop                           [ !! ]
 * samba -> start: smbd ...
* samba: caught SIGINT, abortingstart-stop-daemon: caught SIGINT, aborting
                                                                          [ !! ]
 * samba -> start: nmbd ...
 * start-stop-daemon: /usr/sbin/nmbd is already running                   [ !! ]
 * Error: starting services (see system logs)
 * samba -> stop: smbd ...                                                [ ok ]
 * samba -> stop: nmbd ...
 * start-stop-daemon: 1 process refused to stop               [ !! ]


This is the nmbd.log file:

Code:
[2014/03/17 20:25:27,  0] nmbd/nmbd_browsesync.c:351(find_domain_master_name_query_fail)
  find_domain_master_name_query_fail:
  Unable to find the Domain Master Browser name PTNET<1b> for the workgroup PTNET.
  Unable to sync browse lists in this workgroup.


This issue can be connected to the samba daemon dependencies, infact if I try to start the computer without the wired connection on the default rc, samba doesn't start.
Back to top
View user's profile Send private message
gerdesj
Guru
Guru


Joined: 29 Sep 2005
Posts: 559
Location: Yeovil, Somerset, UK

PostPosted: Fri Mar 21, 2014 6:14 pm    Post subject: Re: Samba doesn't work with wifi Reply with quote

piero.turra wrote:

This issue can be connected to the samba daemon dependencies, infact if I try to start the computer without the wired connection on the default rc, samba doesn't start.


Have a look in /etc/rc.conf change this: #rc_depend_strict="YES" to rc_depend_strict="NO". You can make it more fine grained just for net, read the comments in there.
Back to top
View user's profile Send private message
piero.turra
n00b
n00b


Joined: 28 Nov 2006
Posts: 39

PostPosted: Mon Mar 24, 2014 2:38 pm    Post subject: Reply with quote

I've already set to rc_depend_strict="NO", and during the boot phase everything seem to work correctly.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum