Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Trying to install wicd
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
mrfabiolo
n00b
n00b


Joined: 02 Jan 2011
Posts: 65

PostPosted: Sun Jan 05, 2014 9:57 pm    Post subject: [solved] Trying to install wicd Reply with quote

Code:
tux mrlogick # emerge --ask wicd

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N     ] dev-python/urwid-1.0.2  USE="-examples {-test}"
[ebuild  N     ] dev-python/pytz-2013b  PYTHON_TARGETS="python2_7 python3_3 (-pypy2_0) -python2_6 -python3_2"
[ebuild  N     ] dev-python/Babel-1.3  USE="-doc {-test}" PYTHON_TARGETS="python2_7 python3_3 (-pypy2_0) -python2_6"
[ebuild  N     ] dev-python/notify-python-0.1.1-r3  USE="-examples" PYTHON_TARGETS="python2_7 -python2_6"
[ebuild  N     ] dev-python/dbus-python-1.2.0  USE="-doc -examples {-test}" PYTHON_TARGETS="python2_7 python3_3 -python2_6 -python3_2"
[ebuild  N     ] x11-misc/ktsuss-2
[ebuild  N     ] net-misc/wicd-1.7.2.4-r2  USE="X gtk libnotify ncurses nls pm-utils -ambiance (-ioctl) -mac4lin"

Would you like to merge these packages? [Yes/No] Yes

>>> Verifying ebuild manifests

>>> Emerging (1 of 7) dev-python/urwid-1.0.2
 * urwid-1.0.2.tar.gz SHA256 SHA512 WHIRLPOOL size ;-) ...               [ ok ]
 * ERROR: dev-python/urwid-1.0.2::gentoo failed (setup phase):
 *   Active version of CPython 3 is not supported by dev-python/urwid-1.0.2
 *
 * Call stack:
 *       ebuild.sh, line  93:  Called pkg_setup
 *       ebuild.sh, line 317:  Called python_pkg_setup
 *   python.eclass, line 430:  Called _python_calculate_PYTHON_ABIS
 *   python.eclass, line 842:  Called die
 * The specific snippet of code:
 *                     die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
 *
 * If you need support, post the output of `emerge --info '=dev-python/urwid-1.0.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/urwid-1.0.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/urwid-1.0.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/urwid-1.0.2/temp/die.env'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/dev-python/urwid-1.0.2/work/urwid-1.0.2'

>>> Failed to emerge dev-python/urwid-1.0.2, Log file:

>>>  '/var/tmp/portage/dev-python/urwid-1.0.2/temp/build.log'

 * Messages for package dev-python/urwid-1.0.2:

 * ERROR: dev-python/urwid-1.0.2::gentoo failed (setup phase):
 *   Active version of CPython 3 is not supported by dev-python/urwid-1.0.2
 *
 * Call stack:
 *       ebuild.sh, line  93:  Called pkg_setup
 *       ebuild.sh, line 317:  Called python_pkg_setup
 *   python.eclass, line 430:  Called _python_calculate_PYTHON_ABIS
 *   python.eclass, line 842:  Called die
 * The specific snippet of code:
 *                     die "Active version of CPython 3 is not supported by ${CATEGORY}/${PF}"
 *
 * If you need support, post the output of `emerge --info '=dev-python/urwid-1.0.2::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=dev-python/urwid-1.0.2::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/dev-python/urwid-1.0.2/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-python/urwid-1.0.2/temp/die.env'.
 * Working directory: '/usr/lib64/portage/pym'
 * S: '/var/tmp/portage/dev-python/urwid-1.0.2/work/urwid-1.0.2'


Why does it fail?


Last edited by mrfabiolo on Fri Jan 17, 2014 9:03 am; edited 1 time in total
Back to top
View user's profile Send private message
megabaks
Apprentice
Apprentice


Joined: 22 Jan 2012
Posts: 253
Location: Russia && Saint-Petersburg

PostPosted: Sun Jan 05, 2014 10:11 pm    Post subject: Reply with quote

Quote:
Why does it fail?
Quote:
Active version of CPython 3 is not supported

_________________
sorry my bad english
Back to top
View user's profile Send private message
donpine
n00b
n00b


Joined: 02 Nov 2007
Posts: 6

PostPosted: Sun Jan 12, 2014 8:58 pm    Post subject: Reply with quote

I ran into the same problem. Seems dev-python/urwid-1.0.2 won't compile with Python3.3. I installed Python3.2

Code:
 emerge -va =dev-lang/python-3.2.5-r3


I was able to install wicd (urwid compiled OK) after that.
Back to top
View user's profile Send private message
Kerea09
n00b
n00b


Joined: 20 Dec 2013
Posts: 2

PostPosted: Tue Jan 14, 2014 5:50 pm    Post subject: Reply with quote

Don't forgot to do the

Code:
 eselect python set


as specified here: https://wiki.gentoo.org/wiki/Project:Python/PYTHON_TARGETS

I had issues getting this to install as well until I did a
Code:
 eselect python list
to find out what to set it to.
Hope this helps, happy compiling! :)
Back to top
View user's profile Send private message
Eistaucher
n00b
n00b


Joined: 21 Feb 2005
Posts: 59
Location: /home/eistaucher

PostPosted: Fri Jan 17, 2014 8:04 am    Post subject: Reply with quote

I reinstalled my system yesterday and ran into the same problem. So I did a
Code:
 emerge -va =dev-lang/python-3.2.5-r3

but nothing changed. Did you set your active version of python to 3.2 by using
Code:
eselect python set


Befor reinstalling my system It was set to python3 and it worked so I wonder whats wrong now...
_________________
"Nothing in life is to be feared, it is only to be understood" (Marie Curie)
Back to top
View user's profile Send private message
mrfabiolo
n00b
n00b


Joined: 02 Jan 2011
Posts: 65

PostPosted: Fri Jan 17, 2014 9:03 am    Post subject: Reply with quote

thank you all
Back to top
View user's profile Send private message
dencar
Tux's lil' helper
Tux's lil' helper


Joined: 23 Dec 2003
Posts: 108
Location: Noosa, Australia

PostPosted: Sun Jan 19, 2014 11:15 am    Post subject: Reply with quote

Many thanks from me also.
_________________
dencar
Back to top
View user's profile Send private message
beyondkmp
n00b
n00b


Joined: 14 Jan 2014
Posts: 28

PostPosted: Sun Feb 16, 2014 8:22 am    Post subject: Reply with quote

Thank you!!! I install python 3.2.5-r3,and I install wicd successfully!
Back to top
View user's profile Send private message
lutherush
n00b
n00b


Joined: 19 Mar 2012
Posts: 17

PostPosted: Mon Mar 17, 2014 6:02 am    Post subject: Reply with quote

Ok, i run into the same problem.
Tried to install python 3.2, same error. It does not work with python 3.3, python 3.2 and python 2.7.
urwid still fails with same error so I`m starting to thing that there is some bug in urwid.

EDIT

Ok, it seams to be fixed. I added sandbox and test features to make.conf and it seams to be compiling. But. Wicd crashes when starting, ignores connections ( wired and wireless ).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum