Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
How to enable upnp support in Amarok?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
samo
Guru
Guru


Joined: 13 Mar 2004
Posts: 444

PostPosted: Tue Mar 11, 2014 8:33 pm    Post subject: How to enable upnp support in Amarok? Reply with quote

Hello,

how can I enable upnp support in Amarok?

1. I can't see my media server in Amarok (upnp collection plugin is activated)

2. I can't choose kio upnp in dolphin.

upnp and upnp-av USE flags are enabled and net-libs/libupnp is already installed.

Regards
Back to top
View user's profile Send private message
samo
Guru
Guru


Joined: 13 Mar 2004
Posts: 444

PostPosted: Fri Mar 14, 2014 10:49 pm    Post subject: Reply with quote

When starting amarok in terminal I get the following error:
Code:
amarok(3956): couldn't create slave: "Unable to create io-slave:
klauncher said: Unknown protocol 'upnp-ms'.
Back to top
View user's profile Send private message
samo
Guru
Guru


Joined: 13 Mar 2004
Posts: 444

PostPosted: Sun Mar 16, 2014 12:32 am    Post subject: Reply with quote

Starting amarok with debug option brings the following info:
Code:
amarok:           [PluginManager] found plugin: "amarok_collection-upnpcollection" enabled: true
amarok:         [PluginManager] created factory for plugin "amarok_collection-upnpcollection" type: "Collection"
amarok:           [CollectionManager] initializing "amarok_collection-upnpcollection"
amarok:           BEGIN: virtual void Collections::UpnpCollectionFactory::init()
amarok:             [UpnpCollectionFactory] ERROR "The name org.kde.Cagibi was not provided by any .service files"
amarok:             [UpnpCollectionFactory] ERROR "No such interface 'org.kde.Cagibi' at object path '/org/kde/Cagibi'"
amarok:             [UpnpCollectionFactory] ERROR "The name org.kde.Cagibi was not provided by any .service files"
amarok:             [UpnpCollectionFactory] Maybe cagibi is not installed.
amarok:             [UpnpCollectionFactory] |||| DEVICE "uuid:75802409-bccb-40e7-8e6c-9CC7A66779C3" "urn:schemas-upnp-org:device:InternetGatewayDevice:1"
amarok:             [UpnpCollectionFactory] |||| DEVICE "uuid:fa095ecc-e13e-40e7-8e6c-9cc7a66779c3" "urn:schemas-upnp-org:device:MediaServer:1"
amarok:             [UpnpCollectionFactory] |||| Creating collection  "uuid:fa095ecc-e13e-40e7-8e6c-9cc7a66779c3"
amarok:             [UpnpCollectionFactory] Invalid reply from deviceDetails for "uuid:fa095ecc-e13e-40e7-8e6c-9cc7a66779c3" . Skipping
amarok:             [UpnpCollectionFactory] Error "Unexpected reply signature: got "a{ss}", expected "(ssssssssssis)" (DeviceInfo0_1_0)"
amarok:             [UpnpCollectionFactory] "UDN" "uuid:fa095ecc-e13e-40e7-8e6c-9cc7a66779c3"
amarok:             [UpnpCollectionFactory] "deviceType" "urn:schemas-upnp-org:device:MediaServer:1"
amarok:             [UpnpCollectionFactory] "friendlyName" "AVM FRITZ!Mediaserver"
amarok:             [UpnpCollectionFactory] "ipAddress" "192.168.178.1"
amarok:             [UpnpCollectionFactory] "ipPortNumber" "49000"
amarok:             [UpnpCollectionFactory] "manufacturer" "AVM Berlin"
amarok:             [UpnpCollectionFactory] "modelDescription" "FRITZ!Box Fon WLAN 7360"
amarok:             [UpnpCollectionFactory] "modelName" "FRITZ!Box Fon WLAN 7360"
amarok:             [UpnpCollectionFactory] "modelNumber" "avm"
amarok:             [UpnpCollectionFactory] "presentationURL" "http://fritz.box"
amarok:             [UpnpCollectionFactory] "serialNumber" ""
amarok:             [UpnpCollectionFactory] |||| Creating collection  "fa095ecc-e13e-40e7-8e6c-9cc7a66779c3"
amarok:             [UpnpCollectionFactory] |||| DEVICE "uuid:fa095ecc-e13e-40e7-8e6e-0024feb79696" "urn:schemas-upnp-org:device:MediaServer:1"
amarok:             [UpnpCollectionFactory] |||| Creating collection  "uuid:fa095ecc-e13e-40e7-8e6e-0024feb79696"
amarok:             [UpnpCollectionFactory] Invalid reply from deviceDetails for "uuid:fa095ecc-e13e-40e7-8e6e-0024feb79696" . Skipping
amarok:             [UpnpCollectionFactory] Error "Unexpected reply signature: got "a{ss}", expected "(ssssssssssis)" (DeviceInfo0_1_0)"
amarok:             [UpnpCollectionFactory] "UDN" "uuid:fa095ecc-e13e-40e7-8e6e-0024feb79696"
amarok:             [UpnpCollectionFactory] "deviceType" "urn:schemas-upnp-org:device:MediaServer:1"
amarok:             [UpnpCollectionFactory] "friendlyName" "Google Play Music"
amarok:             [UpnpCollectionFactory] "ipAddress" "192.168.178.1"
amarok:             [UpnpCollectionFactory] "ipPortNumber" "49000"
amarok:             [UpnpCollectionFactory] "manufacturer" "AVM Berlin"
amarok:             [UpnpCollectionFactory] "modelDescription" "FRITZ!Box"
amarok:             [UpnpCollectionFactory] "modelName" "FRITZ!Box"
amarok:             [UpnpCollectionFactory] "modelNumber" "avm"
amarok:             [UpnpCollectionFactory] "presentationURL" "http://fritz.box"
amarok:             [UpnpCollectionFactory] "serialNumber" ""
amarok:             [UpnpCollectionFactory] |||| Creating collection  "fa095ecc-e13e-40e7-8e6e-0024feb79696"
amarok:             [UpnpCollectionFactory] |||| DEVICE "uuid:75802409-bccb-40e7-8e6b-9CC7A66779C3" "urn:schemas-upnp-org:device:WANDevice:1"
amarok:             [UpnpCollectionFactory] |||| DEVICE "uuid:75802409-bccb-40e7-8e6a-9CC7A66779C3" "urn:schemas-upnp-org:device:WANConnectionDevice:1"
amarok:             [UpnpCollectionFactory] |||| DEVICE "uuid:95802409-bccb-40e7-8e6c-9CC7A66779C3" "urn:schemas-upnp-org:device:l2tpv3:1"
amarok:           END__: virtual void Collections::UpnpCollectionFactory::init() [Took: 0.024s]
klauncher said: Unknown protocol 'upnp-ms'.
klauncher said: Unknown protocol 'upnp-ms'.
Back to top
View user's profile Send private message
white_tiger
n00b
n00b


Joined: 04 Oct 2011
Posts: 33

PostPosted: Tue Mar 18, 2014 10:43 pm    Post subject: Reply with quote

The error says that it looks like cagibi is not installed, did you check that?

Although I think the problem is more the lack of upnp-ms. Since kio_upnp_ms is removed from the tree since UPnP support was disabled upstream in kdelibs.

See: https://bugs.gentoo.org/show_bug.cgi?id=442912

So I doubt that it will work even if you have ofr will install cagibi.
Back to top
View user's profile Send private message
samo
Guru
Guru


Joined: 13 Mar 2004
Posts: 444

PostPosted: Wed Mar 19, 2014 5:54 am    Post subject: Reply with quote

cagibi is already installed.
Code:
/usr/bin/cagibid start
Trying to find UPnP devices on the local network
LOCATION: "http://192.168.178.1:49000/MediaServerDevDesc.xml"
SERVER: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03"
CACHE-CONTROL: "max-age=1800"
ST: "upnp:rootdevice"
USN: "uuid:fa095ecc-e13e-40e7-8e6c-9cc7a66779c3::upnp:rootdevice"
Detected Device: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" UUID "fa095ecc-e13e-40e7-8e6c-9cc7a66779c3"
Downloading description from   QUrl( "http://192.168.178.1:49000/MediaServerDevDesc.xml" ) 
LOCATION: "http://192.168.178.1:49000/l2tpv3.xml"
SERVER: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03"
CACHE-CONTROL: "max-age=1800"
ST: "upnp:rootdevice"
USN: "uuid:95802409-bccb-40e7-8e6c-9CC7A66779C3::upnp:rootdevice"
Detected Device: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" UUID "95802409-bccb-40e7-8e6c-9CC7A66779C3"
Downloading description from   QUrl( "http://192.168.178.1:49000/l2tpv3.xml" ) 
LOCATION: "http://192.168.178.1:49000/igddesc.xml"
SERVER: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03"
CACHE-CONTROL: "max-age=1800"
ST: "upnp:rootdevice"
USN: "uuid:75802409-bccb-40e7-8e6c-9CC7A66779C3::upnp:rootdevice"
Detected Device: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" UUID "75802409-bccb-40e7-8e6c-9CC7A66779C3"
Downloading description from   QUrl( "http://192.168.178.1:49000/igddesc.xml" ) 
LOCATION: "http://192.168.178.1:49000/GPMDevDesc.xml"
SERVER: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03"
CACHE-CONTROL: "max-age=1800"
ST: "upnp:rootdevice"
USN: "uuid:fa095ecc-e13e-40e7-8e6e-0024feb79696::upnp:rootdevice"
Detected Device: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" UUID "fa095ecc-e13e-40e7-8e6e-0024feb79696"
Downloading description from   QUrl( "http://192.168.178.1:49000/GPMDevDesc.xml" ) 
Added: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" "95802409-bccb-40e7-8e6c-9CC7A66779C3"
Added: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" "fa095ecc-e13e-40e7-8e6c-9cc7a66779c3"
Added: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" "fa095ecc-e13e-40e7-8e6e-0024feb79696"
Added: "FRITZ!Box Fon WLAN 7360 UPnP/1.0 AVM FRITZ!Box Fon WLAN 7360 124.06.03" "75802409-bccb-40e7-8e6c-9CC7A66779C3"

According bugzilla they removed kio-upnp-ms from the tree. Is there an alternative way to support my media server in amarok?
Back to top
View user's profile Send private message
666threesixes666
Veteran
Veteran


Joined: 31 May 2011
Posts: 1241
Location: 42.68n 85.41w

PostPosted: Wed Mar 19, 2014 7:25 am    Post subject: Reply with quote

xbmc uses dlna, possibly minidlna, i dont know i haven't done MUCH research into that, but its a media server protocol that might be worth investigating (and documenting on the wiki for others to profit from) https://wiki.gentoo.org/wiki/Minidlna im pretty sure it does media server & media client all in one package.

sftp & ssh-fuse will mount remote computers directories as if they are local .... ie root@vegas / becomes /mnt/sshfs on client system.

wow you totally highlighted a major deficiency in https://wiki.gentoo.org/wiki/SSH
_________________
cat /etc/*-release
Funtoo Linux - baselayout 2.2.0
consider this warning no. 1
https://wiki.gentoo.org/index.php?title=Special:Contributions/666threesixes666&offset=&limit=500&target=666threesixes666
Back to top
View user's profile Send private message
samo
Guru
Guru


Joined: 13 Mar 2004
Posts: 444

PostPosted: Wed Mar 19, 2014 1:07 pm    Post subject: Reply with quote

666threesixes666: What do you mean with "major deficiency"?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum