Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] xdg-utils pulls in links (browser); thunderbird use
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
equaeghe
Apprentice
Apprentice


Joined: 22 Feb 2005
Posts: 273

PostPosted: Sat Mar 08, 2014 7:59 pm    Post subject: [solved] xdg-utils pulls in links (browser); thunderbird use Reply with quote

Hi,

today, upon updating, xdg-utils pulled in links, the browser. I do not understand why and would prefer it to not do that, but ok. However, I now notice that for opening linked webpages Thunderbird actually uses links now instead of Firefox, as before (and as is still the case for other programs, such as Okular).

Anybody know what is going on? A workaround for getting Thunderbird to use Firefox as before? (I guess this is a mistake and will be corrected in due time.)

Erik


Last edited by equaeghe on Sun Mar 09, 2014 8:07 pm; edited 1 time in total
Back to top
View user's profile Send private message
EvaSDK
Developer
Developer


Joined: 12 Jul 2003
Posts: 169
Location: France, Paris

PostPosted: Sun Mar 09, 2014 11:08 am    Post subject: Reply with quote

Somebody reported it in bugzilla but this is just a build dependency for man pages iirc. Building man pages is generally not optional per policy.
Back to top
View user's profile Send private message
equaeghe
Apprentice
Apprentice


Joined: 22 Feb 2005
Posts: 273

PostPosted: Sun Mar 09, 2014 1:04 pm    Post subject: Reply with quote

EvaSDK wrote:
Somebody reported it in bugzilla but this is just a build dependency for man pages iirc. Building man pages is generally not optional per policy.

Ah, this one. Ok. Then I need to find out why Thunderbird now uses Links and how I can change it.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Sun Mar 09, 2014 2:08 pm    Post subject: Reply with quote

It's because www-client/links has .desktop files with MimeType= lines for x-scheme-handler/http; and x-scheme-handler/https; and when you run the command `update-desktop-database`, the file mimeinfo.cache will get updated and the last .desktop installed providing the MimeType='s for those associations will get used, unless you override them yourself in ~/.local/share/applications/mimeapps.list

I'll paste examples from my system

Code:

$ grep MimeType /usr/share/applications/links_-g_%u-links-2.desktop
MimeType=x-scheme-handler/http;x-scheme-handler/https;


Code:

$ cat ~/.local/share/applications/mimeapps.list
[Added Associations]
x-scheme-handler/http=exo-web-browser.desktop
x-scheme-handler/https=exo-web-browser.desktop


Mine is saying 'exo-web-browser.desktop' because I'm using Xfce and Xfce has it's own GUI for changing these lines. However, you can create the file by hand too and set them to whatever .desktop file that provides
the required MimeType='s

That's how setting default apps work.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Sun Mar 09, 2014 2:20 pm    Post subject: Reply with quote

Plus, those browsers are only DEPEND in xdg-utils that can be safely --depclean'd after installation, but you should really set mimeinfo.list because this will just keep happening everytime something is installed
with those associations.
Back to top
View user's profile Send private message
equaeghe
Apprentice
Apprentice


Joined: 22 Feb 2005
Posts: 273

PostPosted: Sun Mar 09, 2014 8:06 pm    Post subject: Reply with quote

ssuominen wrote:
It's because www-client/links has .desktop files with MimeType= lines for x-scheme-handler/http; and x-scheme-handler/https; and when you run the command `update-desktop-database`, the file mimeinfo.cache will get updated and the last .desktop installed providing the MimeType='s for those associations will get used, unless you override them yourself in ~/.local/share/applications/mimeapps.list.

That works indeed. Thanks for the pointer and explicit illustration. (I was under the misguided impression that the *file* associatons in my KDE setup should handle this.)

So, thanks very much.
Back to top
View user's profile Send private message
lostinspace2011
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 192

PostPosted: Mon Mar 17, 2014 7:37 am    Post subject: Reply with quote

I created a user specific mimeapps.list file which contains the following:

Quote:
cat .local/share/applications/mimeapps.list
[Added Associations]
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop


However this did not resolve the problem.
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 414
Location: North~Sea~Coa~s~~t~~~

PostPosted: Mon Mar 17, 2014 7:40 am    Post subject: Reply with quote

lostinspace2011 wrote:
I created a user specific mimeapps.list file which contains the following:

Quote:
cat .local/share/applications/mimeapps.list
[Added Associations]
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop


However this did not resolve the problem.


How about using firefox-bin.desktop, if you have /usr/share/applications/firefox-bin.desktop ? and run update-desktop-database...
Back to top
View user's profile Send private message
lostinspace2011
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 192

PostPosted: Thu Mar 20, 2014 3:51 am    Post subject: Reply with quote

I only have firefox.desktop

Quote:
ls -l /usr/share/applications/firefox*
-rw-r--r-- 1 root root 286 Feb 18 14:58 /usr/share/applications/firefox.desktop


I ran "update-desktop-database" restarted my X session, however links in thunderbird still open up in link.
Back to top
View user's profile Send private message
RobPearce
n00b
n00b


Joined: 12 Jul 2005
Posts: 46
Location: Cambridge, England

PostPosted: Thu Mar 20, 2014 8:45 am    Post subject: Reply with quote

ssuominen wrote:
unless you override them yourself in ~/.local/share/applications/mimeapps.list

<snip>
Code:

$ cat ~/.local/share/applications/mimeapps.list
[Added Associations]
x-scheme-handler/http=exo-web-browser.desktop
x-scheme-handler/https=exo-web-browser.desktop



The local override doesn't work for me (it was already set like yours because I'm also using Xfce).

I ended up commenting the MimeType line in the links .desktop file
Back to top
View user's profile Send private message
lost+found
Guru
Guru


Joined: 15 Nov 2004
Posts: 414
Location: North~Sea~Coa~s~~t~~~

PostPosted: Thu Mar 20, 2014 10:21 pm    Post subject: Reply with quote

This is what Seamonkey does on first start (when setting it as default browser):

It creates an additional simplified local .desktop file without MimeTypes...
~/.local/share/applications/userapp-SeaMonkey-CH1SCX.desktop:
Code:
[Desktop Entry]
Encoding=UTF-8
Version=1.0
Type=Application
NoDisplay=true
Exec=/usr/lib64/seamonkey/seamonkey %u
Name=SeaMonkey
Comment=Custom definition for SeaMonkey


...and a ~/.local/share/applications/mimeapps.list with all MimeTypes:
Code:
[Default Applications]
text/html=userapp-SeaMonkey-CH1SCX.desktop
application/x-extension-htm=userapp-SeaMonkey-CH1SCX.desktop
application/x-extension-html=userapp-SeaMonkey-CH1SCX.desktop
application/xhtml+xml=userapp-SeaMonkey-CH1SCX.desktop
application/x-extension-xhtml=userapp-SeaMonkey-CH1SCX.desktop
message/rfc822=userapp-SeaMonkey-CH1SCX.desktop
application/x-extension-eml=userapp-SeaMonkey-CH1SCX.desktop
x-scheme-handler/http=userapp-SeaMonkey-CH1SCX.desktop
x-scheme-handler/https=userapp-SeaMonkey-CH1SCX.desktop
x-scheme-handler/mailto=userapp-SeaMonkey-CH1SCX.desktop

[Added Associations]
text/html=userapp-SeaMonkey-CH1SCX.desktop;
application/x-extension-htm=userapp-SeaMonkey-CH1SCX.desktop;
application/x-extension-html=userapp-SeaMonkey-CH1SCX.desktop;
application/xhtml+xml=userapp-SeaMonkey-CH1SCX.desktop;
application/x-extension-xhtml=userapp-SeaMonkey-CH1SCX.desktop;
message/rfc822=userapp-SeaMonkey-CH1SCX.desktop;
application/x-extension-eml=userapp-SeaMonkey-CH1SCX.desktop;
x-scheme-handler/http=userapp-SeaMonkey-CH1SCX.desktop;
x-scheme-handler/https=userapp-SeaMonkey-CH1SCX.desktop;
x-scheme-handler/mailto=userapp-SeaMonkey-CH1SCX.desktop;


Maybe something similar works for Firefox/Thunderbird. Haven't tried it though, because I'm not using Thunderbird.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Tue Apr 01, 2014 9:03 am    Post subject: Reply with quote

RobPearce wrote:
ssuominen wrote:
unless you override them yourself in ~/.local/share/applications/mimeapps.list

<snip>
Code:

$ cat ~/.local/share/applications/mimeapps.list
[Added Associations]
x-scheme-handler/http=exo-web-browser.desktop
x-scheme-handler/https=exo-web-browser.desktop



The local override doesn't work for me (it was already set like yours because I'm also using Xfce).

I ended up commenting the MimeType line in the links .desktop file


It might required a 'update-desktop-database ~/.local/share/applications' command to refresh if, for some reason, kernel's INOTIFY is missing, or GLIB/GIO's INOTIFY support is somehow not working, or ... well, number of race conditions could happen, manually refreshing the cache should get you past them
Back to top
View user's profile Send private message
lostinspace2011
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 192

PostPosted: Wed Jun 04, 2014 10:36 am    Post subject: Not much luck Reply with quote

The only way I could get this working was to comment out: /usr/share/applications/links_-g_%u-links-2.desktop

Quote:
cat /usr/share/applications/links_-g_%u-links-2.desktop
#[Desktop Entry]
#Name=Links
#Type=Application
#Comment=A fast and lightweight web browser running in both graphics and text mode
#Exec=links -g %u
#TryExec=links
#Icon=links
#Categories=Network;WebBrowser;
#MimeType=x-scheme-handler/http;x-scheme-handler/https;


I guess this is pretty much the same as removing it. I also added a user specific override

Quote:
cat .local/share/applications/mimeapps.list
[Added Associations]
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop


but I am not sure this is required.
Back to top
View user's profile Send private message
ssuominen
Developer
Developer


Joined: 30 Sep 2005
Posts: 2132
Location: Finland

PostPosted: Wed Jun 04, 2014 11:25 am    Post subject: Re: Not much luck Reply with quote

lostinspace2011 wrote:
The only way I could get this working was to comment out: /usr/share/applications/links_-g_%u-links-2.desktop

Quote:
cat /usr/share/applications/links_-g_%u-links-2.desktop
#[Desktop Entry]
#Name=Links
#Type=Application
#Comment=A fast and lightweight web browser running in both graphics and text mode
#Exec=links -g %u
#TryExec=links
#Icon=links
#Categories=Network;WebBrowser;
#MimeType=x-scheme-handler/http;x-scheme-handler/https;



That was unrequired.

lostinspace2011 wrote:

I guess this is pretty much the same as removing it. I also added a user specific override

Quote:
cat .local/share/applications/mimeapps.list
[Added Associations]
x-scheme-handler/http=firefox.desktop
x-scheme-handler/https=firefox.desktop


but I am not sure this is required.


If it's not working, it could be that you need to run `update-desktop-database ~/.local/share/applications` after creating the file to update mimeapps.cache

It could be that you need [Default Applications] instead of [Added Associations]
It could be that you need defaults.list instead of mimeapps.list
This all boils down to if you are running some outdated software, or not

But editing files in /usr/share/applications directly is never required
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum