Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dracut et initramfs qui ne boot plus
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
rhaamo
n00b
n00b


Joined: 20 Sep 2007
Posts: 17

PostPosted: Sat Mar 08, 2014 2:47 pm    Post subject: Dracut et initramfs qui ne boot plus Reply with quote

Bonjour,

Jusque la dracut me générais un initramfs qui fonctionnais bien, mais depuis quelques temps non, je ne me souviens plus si c'est suite a une maj ou pas.

J'ai dans ma conf dracut :

Code:
➜  ~  egrep -v '(^$|^#)' /etc/dracut.conf
add_dracutmodules+="crypt crypt-gpg lvm dm selinux dmraid"


Mon setup est un disque entièrement chiffré avec par dessus du LVM, mon /boot est sur un media externe.

Le seule vrai changement que je vois au démarrage est que j'ai maintenant :
Code:
device-mapper: table: 253:0: multipath: unknown target type
device-mapper: ioctl: error adding target to table


Et après avoir tapé la passphrase, je n'ai plus rien, ça reste dans le vide (attendu plusieurs minutes et rien).

Quelqu'un aurrais une idée pour ce problème ? Qui m’empêche du coup de mettre a jour mon kernel...
Back to top
View user's profile Send private message
Gordon-
n00b
n00b


Joined: 08 Mar 2014
Posts: 1

PostPosted: Sat Mar 08, 2014 2:53 pm    Post subject: Reply with quote

Dracut a changé de fonctionnement, et ne cherche plus à déchiffrer/monter les partitions spéciales (LUKS/LVM) automatiquement. Pour retrouver cette fonctionnalité, il faut ajouter « rd.auto=1 » aux options de montage du noyau.
Back to top
View user's profile Send private message
rhaamo
n00b
n00b


Joined: 20 Sep 2007
Posts: 17

PostPosted: Sat Mar 08, 2014 2:56 pm    Post subject: Reply with quote

J'ai déjà rd.auto=1 en place, et il me demande bien la passphrase.
Back to top
View user's profile Send private message
sebB
Apprentice
Apprentice


Joined: 02 Mar 2011
Posts: 215

PostPosted: Sat Mar 08, 2014 3:41 pm    Post subject: Reply with quote

Suite au passage à dracut > 0.36 la section "DRACUT_MODULES=" du make.conf n'est plus prise en compte.
Vérifie si tu n'a pas supprimé un paquet lors d'un depclean par exemple.
Back to top
View user's profile Send private message
rhaamo
n00b
n00b


Joined: 20 Sep 2007
Posts: 17

PostPosted: Sat Mar 08, 2014 3:53 pm    Post subject: Reply with quote

En effet, je viens d'emerger la 0.34 et l'initramfs est niquel, le > 0.36 semble prendre *tout* les modules en compte du coup... je vais regarder ce que je dois modifier dans la conf pour ça.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum