Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Cannot "emerge --sync" any more
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
l33tmmx
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2005
Posts: 80
Location: Tampere, Finland

PostPosted: Sat Mar 08, 2014 1:37 pm    Post subject: [solved] Cannot "emerge --sync" any more Reply with quote

I've used Gentoo since year 2005 and not once have had any problems with syncing. But recently something strange happened: last wednesday (5.3.2014) about 18.30 local time (Finland, +2 GMT) I "emerge --sync"ed my workstation as usual, no problems there. But, some three hours later, I had the idea of updating my two servers, a file- and a webserver, too, not having done that for +2 weeks. That's when the problems started:
Code:

wintermute madmax # emerge --sync
>>> Synchronization of repository 'gentoo' located in '/usr/portage'...
!!! getaddrinfo failed for 'rsync.europe.gentoo.org': [Errno -2] Name or service not known
>>> Starting rsync with rsync://rsync.europe.gentoo.org/gentoo-portage...
>>> Checking server timestamp ...
rsync: getaddrinfo: rsync.europe.gentoo.org 873: Name or service not known
rsync error: error in socket IO (code 10) at clientserver.c(128) [Receiver=3.1.0]
>>> Retrying...
!!! Exhausted addresses for rsync.europe.gentoo.org

After that, I've been unable to sync any of my Gentoo installations. I've tried different Gentoo rsync servers around the world, tried switching from my ISP's DNS servers to the public Google ones... No luck, I get every time the same error message!!! Everything else networking-related seems to continue to work as they should, from normal http to bittorrent traffic... AFAIK I haven't changed anything on the ADSL modem or the firewall machine which could affect this.

Any ideas what could be causing this???

BTW, should the rsync servers be reachable by ping or traceroute? I get this:
Code:

wintermute madmax # LC_ALL=C ping rsync.europe.gentoo.org
ping: unknown host rsync.europe.gentoo.org

_________________
"Trust me, I know what I'm doing!"
- Sledge Hammer

Follow me on Twitter


Last edited by l33tmmx on Sun Mar 09, 2014 7:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
eccerr0r
Advocate
Advocate


Joined: 01 Jul 2004
Posts: 3901
Location: USA

PostPosted: Sat Mar 08, 2014 4:17 pm    Post subject: Reply with quote

Check your /etc/resolv.conf for the proper nameserver, but then again it should affect other stuff not only Gentoo... Double check your lookups, are you sure just command line rsync isn't working? Yes, you should be able to ping or nslookup, something happened with your DNS resolution of the host. Rsync.europe.gentoo.org is a huge roundrobin DNS lookup, there is more than 20 hosts in it...
_________________
Intel Core i7 2700K@ 4.1GHz/HD3000 graphics/8GB DDR3/180GB SSD
What am I supposed to be advocating?
Back to top
View user's profile Send private message
l33tmmx
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2005
Posts: 80
Location: Tampere, Finland

PostPosted: Sun Mar 09, 2014 7:21 pm    Post subject: Reply with quote

It seems that my ISP was doing something stupid... The whole connection was down from Saturday evening to Sunday evening. Needed to reset the ADSL modem to factory settings, too, but finally got the internet connection working again a hour or so ago. And rsync works, too :D . Thanks for answering!
_________________
"Trust me, I know what I'm doing!"
- Sledge Hammer

Follow me on Twitter
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum