Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cant play sound with non-root user
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
Guest






PostPosted: Sat Jul 27, 2002 4:30 pm    Post subject: cant play sound with non-root user Reply with quote

with root ... all works perfectly
but with a non root-user xmms launch the mp3 .... it seem working but there is no sound

so, i try to set the volume up with kmix

but when i launch kmix, i ve got nothing in the kmix window ( with root i have many button )

my user is in the audio group.

how can i do kmix works fine ?
Back to top
bemixam
n00b
n00b


Joined: 03 Jul 2002
Posts: 62
Location: France (Paris)

PostPosted: Sat Jul 27, 2002 4:42 pm    Post subject: Reply with quote

i have to set the volume with root before loging with the non-root user
how can i make it easier ?

why alsa set the volume tu null automaticaly at boot ?
Back to top
View user's profile Send private message
nitro322
Guru
Guru


Joined: 24 Jul 2002
Posts: 553
Location: USA

PostPosted: Sun Jul 28, 2002 10:34 pm    Post subject: Reply with quote

Couple suggestions. First, make sure your user account is a member of the audio group. Second, 'chown root.audio /dev/dsp /dev/mixer'. Do a ls -l on this first to check if they're symlinks. If so, chown the file that the link points to. Next, 'chmod 660 /dev/dsp /dev/mixer' (same rules about symlinks applies). Relogin with your user account (to update your group membership) and try it - should work.

As for the default volume, make sure aumix is installed. Set the volume how you like it use aumix (probably works with KMix as well, but I'm not sure), and then click Save the settings as default. This should create a .aumixrc file in your home directory. Copy this to /etc/aumixrc. Next, 'rc-update add aumix default' should set the volume to these setting each time you boot. For extra insurance, launch the KDE Control Center and check Load volumes on login in Sound -> Mixer.

Hope this helps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum