Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
mesa / mesa-progs compile issue
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Cr0t
l33t
l33t


Joined: 27 Apr 2002
Posts: 882
Location: USA

PostPosted: Mon Mar 03, 2014 6:34 pm    Post subject: mesa / mesa-progs compile issue Reply with quote

I am trying to upgrade mesa, but i am having issues.
Code:
[ebuild   R    ] media-libs/mesa-9.2.5-r1  USE="classic egl gallium gles1 llvm-shared-libs nptl openvg vdpau xorg xvmc -bindist -debug -gbm -gles2 -llvm -opencl -osmesa -pax_kernel -pic -r600-llvm-compiler (-selinux) -wayland -xa" ABI_X86="(64) -32 (-x32)" VIDEO_CARDS="(-freedreno) -i915 -i965 -ilo -intel -nouveau -r100 -r200 -r300 -r600 -radeon -radeonsi -vmware" 0 kB
[ebuild   R    ] x11-apps/mesa-progs-8.1.0  USE="egl gles1* -gles2" 0 kB
Mesa compiles with the llvm-shared-libs enabled, but llvm disabled. mesa-progs, however, fails to compile.
Code:
libtool: link: x86_64-pc-linux-gnu-gcc -I/usr/include/libdrm -I/usr/include/GL -I/usr/include/libdrm -I/usr/include/libdrm -D_GNU_SOURCE -DPTHREADS -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -fno-strict-aliasing -Wbad-function-cast -Wold-style-definition -Wdeclaration-after-statement -I/usr/include/libdrm -I../../../src/egl/eglut -I../../../src/util -march=core2 -O2 -pipe -mfpmath=sse -Wl,-O1 -o eglinfo eglinfo.o  -lGLEW -lGLU -lGL -lm -lEGL -Wl,--as-needed
eglinfo.o: In function `PrintModes':
eglinfo.c:(.text+0x4bd): undefined reference to `eglGetScreensMESA'
eglinfo.c:(.text+0x506): undefined reference to `eglGetModesMESA'
eglinfo.c:(.text+0x568): undefined reference to `eglGetModeAttribMESA'
eglinfo.c:(.text+0x57d): undefined reference to `eglGetModeAttribMESA'
eglinfo.c:(.text+0x592): undefined reference to `eglGetModeAttribMESA'
eglinfo.c:(.text+0x5a7): undefined reference to `eglGetModeAttribMESA'
eglinfo.c:(.text+0x5b2): undefined reference to `eglQueryModeStringMESA'
collect2: error: ld returned 1 exit status
Makefile:511: recipe for target 'eglinfo' failed
make: *** [eglinfo] Error 1
make: Leaving directory '/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0/src/egl/opengl'
 * ERROR: x11-apps/mesa-progs-8.1.0::gentoo failed (compile phase):
 *   emake failed
 *
 * If you need support, post the output of `emerge --info '=x11-apps/mesa-progs-8.1.0::gentoo'`,
 * the complete build log and the output of `emerge -pqv '=x11-apps/mesa-progs-8.1.0::gentoo'`.
 * The complete build log is located at '/var/tmp/portage/x11-apps/mesa-progs-8.1.0/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/x11-apps/mesa-progs-8.1.0/temp/environment'.
 * Working directory: '/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0'
 * S: '/var/tmp/portage/x11-apps/mesa-progs-8.1.0/work/mesa-demos-8.1.0'

_________________
cya
    ©®0t
Back to top
View user's profile Send private message
Jaglover
Advocate
Advocate


Joined: 29 May 2005
Posts: 4635
Location: Saint Amant, Acadiana

PostPosted: Tue Mar 04, 2014 1:20 am    Post subject: Reply with quote

Did you check the bugs https://bugs.gentoo.org/show_bug.cgi?id=501328
_________________
Please learn how to denote units correctly!
Back to top
View user's profile Send private message
Cr0t
l33t
l33t


Joined: 27 Apr 2002
Posts: 882
Location: USA

PostPosted: Tue Mar 04, 2014 4:18 pm    Post subject: Reply with quote

Switching to xorg-x11 helped compiling gst-plugins-bad- and mesa-progs. A couple of weeks ago, I had to do the same for the webkit.
_________________
cya
    ©®0t
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum