Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
chromium fonts look fuzzy [solved]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 847
Location: Tri-Cities, WA USA

PostPosted: Thu Feb 27, 2014 12:46 pm    Post subject: chromium fonts look fuzzy [solved] Reply with quote

I've seen a few posts in reference to this build and wanted to see if there is an update on a solution.

azzerare ~ # uname -a
Linux azzerare 3.10.25-gentoo #3 SMP Sun Jan 19 07:56:12 PST 2014 x86_64 AMD Athlon(tm) 64 Processor 3400+ AuthenticAMD GNU/Linux

Version 33.0.1750.117 (252094)

http://96.41.200.95/gentoo/chromium-fonts-140227.png
_________________
Without diversity there can be no evolution:)


Last edited by cwc on Sun Mar 02, 2014 6:02 pm; edited 1 time in total
Back to top
View user's profile Send private message
SirRobin2318
Apprentice
Apprentice


Joined: 24 Apr 2004
Posts: 213
Location: Strasbourg, france.

PostPosted: Thu Feb 27, 2014 2:51 pm    Post subject: Reply with quote

Have you tried this already: http://forums.gentoo.org/viewtopic-t-984870.html
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 847
Location: Tri-Cities, WA USA

PostPosted: Sun Mar 02, 2014 6:01 pm    Post subject: solved Reply with quote

This did not help:
emerge arphicfonts bitstream-cyberbit droid ipamonafont ja-ipafonts takao-fonts wqy-microhei wqy-zenhei

But this did:
- Open in chromium
chrome://extensions/

- Enable Developer mode.

- Add the two files spelled correctly in a folder. I used: /home/cwc/chromium-extensions/
/home/cwc/custom-chromium/Custom.css
/home/cwc/custom-chromium/manifest.json


Custom.css
Code:

@font-face { font-family: 'Helvetica'; src: local('Arial')}


manifest.json
Code:

{
  "name": "Fix Helvetica",
  "description": "Fix Helvetica",
  "version": "0.1",

  "content_scripts": [ {
  "css": [ "Custom.css" ],
  "matches": [ "http://*/*", "https://*/*" ]
  } ],

  "manifest_version": 2
}


_________________
Without diversity there can be no evolution:)


Last edited by cwc on Sun Mar 02, 2014 8:40 pm; edited 1 time in total
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 120

PostPosted: Sun Mar 02, 2014 6:51 pm    Post subject: Reply with quote

I have the same issue. How can I add the font settings you posted to my chrome extentions?
Back to top
View user's profile Send private message
cwc
l33t
l33t


Joined: 20 Mar 2006
Posts: 847
Location: Tri-Cities, WA USA

PostPosted: Sun Mar 02, 2014 8:40 pm    Post subject: Reply with quote

katfish wrote:
I have the same issue. How can I add the font settings you posted to my chrome extentions?


Sorry for the lack of info. I was in a rush. Hope this helps.

- Open in chromium
chrome://extensions/

- Enable Developer mode.

- Add the two files spelled correctly in a folder. I used: /home/cwc/chromium-extensions/
/home/cwc/custom-chromium/Custom.css
/home/cwc/custom-chromium/manifest.json


Custom.css
Code:

@font-face { font-family: 'Helvetica'; src: local('Arial')}


manifest.json
Code:

{
  "name": "Fix Helvetica",
  "description": "Fix Helvetica",
  "version": "0.1",

  "content_scripts": [ {
  "css": [ "Custom.css" ],
  "matches": [ "http://*/*", "https://*/*" ]
  } ],

  "manifest_version": 2
}



Click "Load unpacked extensions . . ." and restart.

http://96.41.200.95/gentoo/chrome-extensions.png
_________________
Without diversity there can be no evolution:)
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 120

PostPosted: Sun Mar 02, 2014 10:25 pm    Post subject: Reply with quote

Thx cwc ;)
Back to top
View user's profile Send private message
alayim
n00b
n00b


Joined: 29 Mar 2014
Posts: 3

PostPosted: Sat Mar 29, 2014 1:09 pm    Post subject: Reply with quote

Overriding the fonts in chrome might work, but it doesen't necessarily solve the core problem.
It might happen in Firefox or other browsers and programs as well.

I found the problem to be that the system prefered the ugly bitmap-fonts to the TTF-fonts.
You can disable the bitmap-fonts by:
1. List font configs
Code:
eselect fontconfig list


2. Locate the 70-no-bitmaps.conf

3. Enable it to disable the bitmap fonts.
Also, if 70-yes-bitmaps.conf is enabled, disable it.
Code:
eselect fontconfig enable 70-no-bitmaps.conf
eselect fontconfig disable 70-yes-bitmaps.conf



4. Reboot your system, or if you're lazy, update your font cache
Code:
 fc-cache


5. Exit and start the program with the bad-looking fonts. See if the problem is gone
Back to top
View user's profile Send private message
twork
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2006
Posts: 119

PostPosted: Mon Mar 31, 2014 8:34 am    Post subject: Reply with quote

Hm. I'm having the same problem, or at least the same symptoms, but enabling no-bitmaps makes things worse.

It doesn't change the way my chromium renders some elements with ugly fonts, and it turns all my terminals (various fixed-width fonts) blurry.

I haven't tried the initially-posted "bandaid" fix yet, may try it later but yeah, would rather get at the root of the problem.

EDIT: Found this very similar thread, marked "solved", but I'm not sure it's the case there either:

http://forums.gentoo.org/viewtopic-t-984870-start-25-postdays-0-postorder-asc-highlight-.html

Some entries in that thread claim this is an upstream problem in Chrome...?
Back to top
View user's profile Send private message
alayim
n00b
n00b


Joined: 29 Mar 2014
Posts: 3

PostPosted: Wed Apr 09, 2014 1:16 pm    Post subject: Reply with quote

What's the output of your
Code:
eselect fontconfig list

?

Also, to get nice looking fonts, I've read you should have the following use-flags enabled:
Code:
truetype type1 cleartype corefonts


Try adding them to your useflags, and re-emerge your world.
Code:
emerge -uDNa world
Back to top
View user's profile Send private message
twork
Tux's lil' helper
Tux's lil' helper


Joined: 28 Jul 2006
Posts: 119

PostPosted: Thu Apr 10, 2014 12:55 am    Post subject: Reply with quote

alayim wrote:
What's the output of your
Code:
eselect fontconfig list

?

Patching output below.
alayim wrote:
Also, to get nice looking fonts, I've read you should have the following use-flags enabled:
Code:
truetype type1 cleartype corefonts


Haven't actually tired that yet, but a quick run of ''equery u'' shows that the only change would be to rebuild imagemagick, which currently has corefonts switched off. Otherwise there's no change.

Output from 'eselect fontconfig list' follows.
Code:
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-scale-bitmap-fonts.conf *
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf
  [9]   11-lcdfilter-default.conf
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf
  [12]  20-unhint-small-dejavu-sans-mono.conf
  [13]  20-unhint-small-dejavu-sans.conf
  [14]  20-unhint-small-dejavu-serif.conf
  [15]  20-unhint-small-vera.conf *
  [16]  25-unhint-nonlatin.conf
  [17]  30-metric-aliases.conf *
  [18]  30-urw-aliases.conf *
  [19]  31-cantarell.conf
  [20]  40-nonlatin.conf *
  [21]  42-luxi-mono.conf *
  [22]  45-latin.conf *
  [23]  49-sansserif.conf *
  [24]  50-user.conf *
  [25]  51-local.conf *
  [26]  57-dejavu-sans-mono.conf *
  [27]  57-dejavu-sans.conf *
  [28]  57-dejavu-serif.conf *
  [29]  59-google-droid-sans-mono.conf *
  [30]  59-google-droid-sans.conf *
  [31]  59-google-droid-serif.conf *
  [32]  60-latin.conf *
  [33]  62-croscore-arimo.conf
  [34]  62-croscore-cousine.conf
  [35]  62-croscore-symbolneu.conf
  [36]  62-croscore-tinos.conf
  [37]  65-fonts-persian.conf *
  [38]  65-khmer.conf
  [39]  65-nonlatin.conf *
  [40]  69-unifont.conf *
  [41]  70-no-bitmaps.conf
  [42]  70-yes-bitmaps.conf
  [43]  80-delicious.conf *
  [44]  90-synthetic.conf *
Back to top
View user's profile Send private message
alayim
n00b
n00b


Joined: 29 Mar 2014
Posts: 3

PostPosted: Thu Apr 10, 2014 7:58 pm    Post subject: Reply with quote

Here's my enabled list, which seems very smooth for my use.

Code:

  [1]   10-autohint.conf *
  [2]   10-no-sub-pixel.conf
  [3]   10-scale-bitmap-fonts.conf
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf *
  [9]   11-lcdfilter-default.conf
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf *
  [12]  20-unhint-small-dejavu-sans.conf
  [13]  20-unhint-small-dejavu-sans-mono.conf
  [14]  20-unhint-small-dejavu-serif.conf
  [15]  20-unhint-small-vera.conf
  [16]  25-ttf-arphic-ukai-render.conf *
  [17]  25-ttf-arphic-uming-bitmaps.conf
  [18]  25-ttf-arphic-uming-render.conf
  [19]  25-unhint-nonlatin.conf
  [20]  30-metric-aliases.conf
  [21]  30-urw-aliases.conf *
  [22]  35-ttf-arphic-ukai-aliases.conf
  [23]  35-ttf-arphic-uming-aliases.conf
  [24]  40-nonlatin.conf *
  [25]  41-ttf-arphic-ukai.conf
  [26]  41-ttf-arphic-uming.conf
  [27]  42-luxi-mono.conf *
  [28]  45-latin.conf *
  [29]  49-sansserif.conf *
  [30]  50-user.conf *
  [31]  51-local.conf
  [32]  57-dejavu-sans.conf *
  [33]  57-dejavu-sans-mono.conf *
  [34]  57-dejavu-serif.conf *
  [35]  60-latin.conf *
  [36]  60-liberation.conf
  [37]  64-ttf-arphic-uming.conf
  [38]  65-fonts-persian.conf *
  [39]  65-khmer.conf
  [40]  65-nonlatin.conf *
  [41]  69-unifont.conf *
  [42]  70-no-bitmaps.conf *
  [43]  70-yes-bitmaps.conf
  [44]  75-ttf-arphic-ukai-select.conf *
  [45]  80-delicious.conf *
  [46]  90-synthetic.conf *
  [47]  90-ttf-arphic-ukai-embolden.conf
  [48]  90-ttf-arphic-uming-embolden.conf *


I'm no guru on font selection, so I'm just doing guesswork,
but if you want to try to tweak your config to look more or less like this one, pay special attention to:
- the combination of the 70-no-bitmaps.conf and 70-yes-bitmaps.conf
- 10-unhinted.conf
- 11-lcdfilter-light.conf
- possibly 30-metric-aliases.conf
Remember to update your font cache as described above and restart the application in question. :o
If this doesen't help, I'm out of options
Back to top
View user's profile Send private message
disperato
Tux's lil' helper
Tux's lil' helper


Joined: 27 Apr 2004
Posts: 116

PostPosted: Thu Apr 17, 2014 12:11 am    Post subject: Reply with quote

hi, I was having the same issue, but a bit of investigation led me to conclude the problem was a bit wider, related to fonts rendering in certain programs, not fonts rendering in a one browser.

Basically I tried to install the few "western" fonts missing on my system that were suggested by the post-emerge message for chrome. No improvement.
Then I installed maxthon, nice browser under windows, with an ebuild in the gentoo-zh overlay. Yet, no improvement.
Maxthon is chromium based, but 32 bit, I'm on a 64 bit system. In short I have opera32, maxthon32, firefox64, chrome64.
My need for chrome is because it ships a properly working (out of the box) flash player that does not crash, whilst being the latest 12.xx bleeding-edge version (and too many so called web designer are monkeys uncapable to migrate to html5 instead of continuing the adobe flash nightmare).
Now you have the general picture. Let's see the main issue about fonts.

thanks to this post http://www.webupd8.org/2013/06/better-font-rendering-in-linux-with.html
I was lead to try infinality, that definitively solved the issue. It's in portage, thus just installed and configured as follows:

Code:
# emerge eselect-infinality fontconfig-infinality -p
Calculating dependencies... done!
[ebuild  N     ] app-admin/eselect-infinality-1
[ebuild  N     ] app-admin/eselect-lcdfilter-1
[ebuild  N     ] media-libs/fontconfig-infinality-20130404  USE="nyx"
[ebuild   R    ] media-libs/freetype-2.4.11  USE="infinality*"

The following USE changes are necessary to proceed:
 (see "package.use" in the portage(5) man page for more details)
# required by media-libs/fontconfig-infinality-20130404
# required by fontconfig-infinality (argument)
=media-libs/freetype-2.4.11 infinality


set the use flag for freetype, and went on:
Code:
# emerge eselect-infinality fontconfig-infinality -quiet-build


Code:
# eselect infinality list
Available styles:
  [1]   debug
  [2]   infinality
  [3]   linux
  [4]   nyx
  [5]   osx
  [6]   osx2
  [7]   win7
  [8]   win98
  [9]   winxp


Code:
# eselect infinality set 3


Code:
# eselect lcdfilter list
Available styles:
  [1]   custom
  [2]   default
  [3]   infinality
  [4]   infinality-classic
  [5]   infinality-nudge
  [6]   infinality-push
  [7]   infinality-sharpened
  [8]   infinality-shove
  [9]   linux
  [10]  nyx
  [11]  osx
  [12]  ubuntu
  [13]  vanilla
  [14]  windows-7
  [15]  windows-7-light
  [16]  windows-xp
  [17]  windows-xp-light


Code:
# eselect infinality set 9


started google-chrome and maxthon.. et voila', nice fonts on those failing pages.
Ironically a page that was failing before is http://en.wikipedia.org/wiki/Chromium 8O thus I used it as a test-page, along with a few others.
_________________
The free men's path is always obstructed by mediocrity.
Back to top
View user's profile Send private message
Blangero
n00b
n00b


Joined: 03 Aug 2014
Posts: 5

PostPosted: Tue Aug 05, 2014 11:30 am    Post subject: Reply with quote

alayim wrote:
What's the output of your
Code:
eselect fontconfig list

?

Also, to get nice looking fonts, I've read you should have the following use-flags enabled:
Code:
truetype type1 cleartype corefonts


Try adding them to your useflags, and re-emerge your world.
Code:
emerge -uDNa world



This helps!! Thanks very much!!
Back to top
View user's profile Send private message
filesyst3m
n00b
n00b


Joined: 29 Oct 2014
Posts: 1

PostPosted: Wed Oct 29, 2014 3:07 am    Post subject: Thanks Reply with quote

This help me !!



alayim wrote:
Overriding the fonts in chrome might work, but it doesen't necessarily solve the core problem.
It might happen in Firefox or other browsers and programs as well.

I found the problem to be that the system prefered the ugly bitmap-fonts to the TTF-fonts.
You can disable the bitmap-fonts by:
1. List font configs
Code:
eselect fontconfig list


2. Locate the 70-no-bitmaps.conf

3. Enable it to disable the bitmap fonts.
Also, if 70-yes-bitmaps.conf is enabled, disable it.
Code:
eselect fontconfig enable 70-no-bitmaps.conf
eselect fontconfig disable 70-yes-bitmaps.conf



4. Reboot your system, or if you're lazy, update your font cache
Code:
 fc-cache


5. Exit and start the program with the bad-looking fonts. See if the problem is gone
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum