Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gnome 3.8 and UTF8 charset
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
johnlu
Apprentice
Apprentice


Joined: 22 Aug 2004
Posts: 241
Location: Córdoba, España

PostPosted: Wed Feb 26, 2014 2:48 pm    Post subject: Gnome 3.8 and UTF8 charset Reply with quote

My gnome 3.8 has problems managing UTF8 charset, I also got it installed on my laptop and it is running perfectly. I don't know what to do as I did same procedures in both machines.

Gnome cannot handle files correctly in file manager because of this. Vídeos folder is represented as VA±deos. I can't use áéíóúñÁÉÍÓÚÑ in file names or in gnome-terminal.

Any ideas?
_________________
http://www.juanluperez.com
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5653

PostPosted: Wed Feb 26, 2014 3:17 pm    Post subject: Reply with quote

Is LANG set to an utf8 locale ?
What exactly do you mean by "I can't use" ?
Back to top
View user's profile Send private message
johnlu
Apprentice
Apprentice


Joined: 22 Aug 2004
Posts: 241
Location: Córdoba, España

PostPosted: Wed Feb 26, 2014 9:11 pm    Post subject: Reply with quote

VoidMage wrote:
Is LANG set to an utf8 locale ?

Normal user:
Code:
$ locale
LANG=es_ES.UTF-8
LC_CTYPE="es_ES.UTF-8"
LC_NUMERIC="es_ES.UTF-8"
LC_TIME="es_ES.UTF-8"
LC_COLLATE="es_ES.UTF-8"
LC_MONETARY="es_ES.UTF-8"
LC_MESSAGES="es_ES.UTF-8"
LC_PAPER="es_ES.UTF-8"
LC_NAME="es_ES.UTF-8"
LC_ADDRESS="es_ES.UTF-8"
LC_TELEPHONE="es_ES.UTF-8"
LC_MEASUREMENT="es_ES.UTF-8"
LC_IDENTIFICATION="es_ES.UTF-8"
LC_ALL=es_ES.UTF-8


Super user:
Code:
# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=en_US.UTF-8


VoidMage wrote:
What exactly do you mean by "I can't use" ?


I meant that those characters are not showed correctly.
_________________
http://www.juanluperez.com
Back to top
View user's profile Send private message
VoidMage
Watchman
Watchman


Joined: 14 Oct 2006
Posts: 5653

PostPosted: Thu Feb 27, 2014 10:58 pm    Post subject: Reply with quote

How were those files created ?
How are they printed by 'LC_ALL=C ls -b' ?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum