Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Packet blockt sich selbst bei emerge ?
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German)
View previous topic :: View next topic  
Author Message
lorschy
Apprentice
Apprentice


Joined: 16 Jul 2002
Posts: 177

PostPosted: Mon Feb 24, 2014 9:46 am    Post subject: Packet blockt sich selbst bei emerge ? Reply with quote

Hi Leute,

vielleicht kann mir einer von euch mal gegen den Kopf hauen.
Ich stehe grade auf dem schlauch.

Wie kann sich denn ein Packet selbst blocken ??

Code:

rder # emerge gobject-introspection-common
!!! Repository 'seden' is missing masters attribute in '/var/lib/layman/seden/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility

 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.


 * IMPORTANT: 6 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Calculating dependencies... done!
[ebuild  N     ] dev-libs/gobject-introspection-common-1.36.0
[blocks B      ] <dev-libs/gobject-introspection-1.36.0 ("<dev-libs/gobject-introspection-1.36.0" is blocking dev-libs/gobject-introspection-common-1.36.0)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-0.10.8::gentoo, installed) pulled in by
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.13-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.3 required by (media-libs/gstreamer-0.10.35::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.2 required by (dev-python/pygobject-2.28.6::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-2.32.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.2.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.24.0-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (x11-libs/libnotify-0.7.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.35::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.2 required by (sys-auth/polkit-0.102::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.1 required by (x11-libs/gtk+-3.2.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.5-r1::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-fs/udev-171-r5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (app-text/poppler-0.18.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.2 required by (gnome-extra/polkit-gnome-0.101-r1::gentoo, installed)

  (dev-libs/gobject-introspection-common-1.36.0::gentoo, ebuild scheduled for merge) pulled in by
    gobject-introspection-common


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):



Ich habe in letzter Zeit echt verdammt viele Probleme beim emergen, das System ist schon etwas aelter und es wird wohl zeit fuer eine komplette Neuinstallation, aber
das Problem mit dem Block wuerde ich echt gerne noch verstehen.
Back to top
View user's profile Send private message
aleph-muc
Apprentice
Apprentice


Joined: 23 Jun 2004
Posts: 205
Location: Auf dem Land

PostPosted: Mon Feb 24, 2014 12:43 pm    Post subject: Reply with quote

ich habe schn länger nicht mehr mit emerge gearbeitet, aber das eine Paket hat den Zusatz "-common". Also dem Namen nach sind das 2 unterschiedliche Pakete.

Grüße
aleph
Back to top
View user's profile Send private message
bell
Guru
Guru


Joined: 27 Nov 2007
Posts: 418

PostPosted: Mon Feb 24, 2014 1:43 pm    Post subject: Reply with quote

Code:
 * IMPORTANT: 6 config files in '/etc/portage' need updating.
 * See the CONFIGURATION FILES section of the emerge
 * man page to learn how to update config files.
Beachte als erstes dies. Anscheinend wurden da Pakete umbenannt oder verschoben. Aktualisiere die Config-Files, dann löst sich Dein Problem wahrscheinlich von alleine auf.

Code:
 * IMPORTANT: 23 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.
Solltest Du auch nicht vernachlässigen.
Back to top
View user's profile Send private message
Josef.95
Advocate
Advocate


Joined: 03 Sep 2007
Posts: 2254
Location: Germany

PostPosted: Mon Feb 24, 2014 2:45 pm    Post subject: Reply with quote

lorschy wrote:
Code:
rder # emerge gobject-introspection-common

Hehe, es ist vermutlich auch keine gute Idee auf einem veralteten System nur direkt einzelne Pakete ohne --deep (--newuse und --oneshot) aktualisieren zu wollen.
=dev-libs/gobject-introspection-1.36.0-r1 ist als stabile Version im Tree (für die meisten Architekturen) vorhanden, und sollte sich normal problemlos mergen lassen, sofern denn die Abhängigkeiten passen.
Vermutlich ist es besser einfach mal ein world Update (emerge -avuDN @world) zu nutzen. :)

lorschy wrote:
Code:
!!! Repository 'seden' is missing masters attribute in '/var/lib/layman/seden/metadata/layout.conf'
!!! Set 'masters = gentoo' in this file for future compatibility
Hier sollte ein synchronisieren des Overlays helfen, denn die bemängelte Datei wurde schon vor über einem halben Jahr hinzugefügt
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum