Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Chromium 33.0.1750.117 has jagged fonts
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
grumblebear
n00b
n00b


Joined: 26 Feb 2008
Posts: 41

PostPosted: Tue Mar 04, 2014 11:53 am    Post subject: Reply with quote

The 70-no-bitmaps.conf trick cannot be called a fix, because it disables all fixed size fonts. And those include ones I have explicitly chosen for my terminals and Emacs for example. I have also worked around it by replacing Helvetica with Arial with the help of the Stylish extension, which does essentially the same thing as lrbb's solution.

I still think this is a bug in Chromium. Until version 32 it worked right and Firefox still gets it right. It is not fixed in Chromium 34. Has anybody reported that upstream?
Back to top
View user's profile Send private message
mikegpitt
Advocate
Advocate


Joined: 22 May 2004
Posts: 3200

PostPosted: Tue Mar 04, 2014 4:16 pm    Post subject: Reply with quote

Pistos wrote:
One thing has been clear to me for years: On Windows and OSX, fonts Just Work. On Linux, we have to painstakingly set things up "just right", and re-set things up now and again due to "new" problems like this one. :(
Honestly, it's been maybe 10 years since I've had problems with Linux fonts. This is due to a bug in Chrome, and is affecting multiple OS's.

grumblebear wrote:
The 70-no-bitmaps.conf trick cannot be called a fix, because it disables all fixed size fonts. And those include ones I have explicitly chosen for my terminals and Emacs for example. I have also worked around it by replacing Helvetica with Arial with the help of the Stylish extension, which does essentially the same thing as lrbb's solution.

I still think this is a bug in Chromium. Until version 32 it worked right and Firefox still gets it right. It is not fixed in Chromium 34. Has anybody reported that upstream?
Yes, this changed my Firefox fonts to look different... not terrible, but not how I want them. We need to wait until Google fixes this. It has been reported upstream as far as I can tell, with a bunch of people grumbling about fonts in Chrome since version 32.
Back to top
View user's profile Send private message
heheman3000
n00b
n00b


Joined: 22 Oct 2006
Posts: 18

PostPosted: Mon Mar 10, 2014 4:25 pm    Post subject: Reply with quote

lrbb wrote:
I have no idea what's causing this, but the Helvetica font seems to be the only problem for me. Here's a little hack extension to load Arial instead of Helvetica, via CSS.


  • make the following files in some empty directory
  • go to chrome://extensions
  • check the developer mode box
  • Load unpacked extension
  • point to the new directory


manifest.json
Code:
{
  "name": "Fix Helvetica",
  "description": "Fix Helvetica",
  "version": "0.1",

  "content_scripts": [ {
  "css": [ "Custom.css" ],
  "matches": [ "http://*/*", "https://*/*" ]
  } ],

  "manifest_version": 2
}


Custom.css
Code:
@font-face { font-family: 'Helvetica'; src: local('Arial')}


Effects should take place immediately. Worked for me. Maybe some simpler way to do this, but this is the way it turned out.


This removes the ugliness, but makes fonts look differently than they did before. Also, someone posted your answer here: http://superuser.com/q/726132/32370

It's strange, but if on sites like GitHub (where this problem presents itself) I just uncheck the `font` declaration in Developer tools, the font shows up as normal. On inspection, the computed font is `Arial`, and it looks like the site before the bug (and as rendered on other computers.) However, this doesn't display in the same way as using `Arial` in the override. Super weird.

Additionally, on my computer, `Courier` fonts look blocky as well (such as the ones in this thread), and they would require additional tweaking. It seems like this is probably not the right way to solve the problem.

Moreover, I'm using ati-drivers and chrome (not chromium), so this definitely seems unrelated to video card drivers or a Gentoo-specific build.
Back to top
View user's profile Send private message
hkmaly
n00b
n00b


Joined: 13 Jul 2006
Posts: 20

PostPosted: Tue Mar 11, 2014 11:26 pm    Post subject: Application-specific solution Reply with quote

grumblebear wrote:
The 70-no-bitmaps.conf trick cannot be called a fix, because it disables all fixed size fonts. And those include ones I have explicitly chosen for my terminals and Emacs for example. I have also worked around it by replacing Helvetica with Arial with the help of the Stylish extension, which does essentially the same thing as lrbb's solution.

I still think this is a bug in Chromium. Until version 32 it worked right and Firefox still gets it right. It is not fixed in Chromium 34. Has anybody reported that upstream?


If you are worried about fixed fonts in other applications, then install fontconfig 2.10.something (50?60? ... 92 works for sure) and install following fontconfig configuration file (under name 70-no-bitmaps-chrome.conf, for example):

Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
    <match>
        <test name="prgname" compare="eq">
            <string>chrome</string>
        </test>
<!-- Reject bitmap fonts -->
 <selectfont>
  <rejectfont>
   <pattern>
     <patelt name="scalable"><bool>false</bool></patelt>
   </pattern>
  </rejectfont>
 </selectfont>
    </match>
</fontconfig>


... yup, exactly, fontconfig can have per-application configuration ...

EDIT: Sorry. Seems that this configuration is still applied to all applications, because the "match" only limits "edit" ... but "edit" seems to be unable to reject font ... and patelt doesn't accept prgname ... any idea?
Back to top
View user's profile Send private message
feiticeir0
Apprentice
Apprentice


Joined: 13 Jul 2005
Posts: 260
Location: Castelo Branco, Portugal

PostPosted: Thu Mar 13, 2014 9:06 pm    Post subject: Reply with quote

lrbb wrote:
I have no idea what's causing this, but the Helvetica font seems to be the only problem for me. Here's a little hack extension to load Arial instead of Helvetica, via CSS.


  • make the following files in some empty directory
  • go to chrome://extensions
  • check the developer mode box
  • Load unpacked extension
  • point to the new directory


manifest.json
Code:
{
  "name": "Fix Helvetica",
  "description": "Fix Helvetica",
  "version": "0.1",

  "content_scripts": [ {
  "css": [ "Custom.css" ],
  "matches": [ "http://*/*", "https://*/*" ]
  } ],

  "manifest_version": 2
}


Custom.css
Code:
@font-face { font-family: 'Helvetica'; src: local('Arial')}


Effects should take place immediately. Worked for me. Maybe some simpler way to do this, but this is the way it turned out.


That did the trick ! Thank you so much ! I was getting crazy because of this !

I'm using Chomium Version 33.0.1750.146 (254388)
_________________
Do It With Rhythm
Back to top
View user's profile Send private message
Tipped
n00b
n00b


Joined: 16 Jan 2010
Posts: 3

PostPosted: Wed Mar 19, 2014 4:06 am    Post subject: Reply with quote

dehpeh wrote:
Same font-problem here with Chromium 33.0.1750.117 (Gnome 2.32.1)

Solved, solution:

Code:
eselect fontconfig enable 70-no-bitmaps.conf

and if enabled:
Code:
eselect fontconfig disable 70-yes-bitmaps.conf


This solution (appears) to have worked for me. The solution involving the chrome extension worked on some sites, but not all (http://wiki.gentoo.org/wiki/Udev) for me.
Back to top
View user's profile Send private message
Physhi
n00b
n00b


Joined: 06 Aug 2006
Posts: 21
Location: TX

PostPosted: Fri Apr 18, 2014 4:05 pm    Post subject: Reply with quote

Speaking of weird fonts. My tabs, address bar/search bar, and visible bookmarks aren't able print any CJK. I'm using the current stable version of Chromium -- 34.0.1847.116.
Anyone else having this problem? I haven't found a fix for it yet.
Back to top
View user's profile Send private message
nickel
Tux's lil' helper
Tux's lil' helper


Joined: 21 Oct 2005
Posts: 148

PostPosted: Tue May 20, 2014 8:50 am    Post subject: Reply with quote

dehpeh wrote:
Same font-problem here with Chromium 33.0.1750.117 (Gnome 2.32.1)

Solved, solution:

Code:
eselect fontconfig enable 70-no-bitmaps.conf


It worked for me ,even in chhromium 34. Thx! :D
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 660

PostPosted: Fri Jul 25, 2014 6:20 am    Post subject: Cannot load unpacked extensions? Reply with quote

Hi Everyone:

Tried unmasking chromium-38.0.2101.0 but she would not build so went to chromium-38.0.2096.0 and it built fine.
The fonts were fugly so tried the Fix Helvetica hack mentioned above b ut this time cromium does not allow me to load the extension.

All files are greyed out.

Any hints.

Fonts are SUPER fugly.

Cheers,
john
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 108

PostPosted: Fri Jul 25, 2014 9:50 am    Post subject: Reply with quote

Switch back to firefox. SCNR.

With v33 they also introduced the new "new tab" page which loads an additional google search bar from google.com before displaying anything else.

That takes up to 2-3 seconds on older hardware or slow connections.
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 660

PostPosted: Fri Jul 25, 2014 10:06 am    Post subject: Reply with quote

katfish wrote:
Switch back to firefox. SCNR.

With v33 they also introduced the new "new tab" page which loads an additional google search bar from google.com before displaying anything else.

That takes up to 2-3 seconds on older hardware or slow connections.


I would but.....
Mozilla fires people depending upon which political party they contribute to, which is supposed to be a felony in CA but hey, the laws are only for one side now in America.

That's all a bit too Goebbels for me.

So I live without firefox.

Cheers,
John
Back to top
View user's profile Send private message
katfish
Tux's lil' helper
Tux's lil' helper


Joined: 14 Nov 2011
Posts: 108

PostPosted: Fri Jul 25, 2014 10:19 am    Post subject: Reply with quote

jserink wrote:

Mozilla fires people depending upon which political party they contribute to, which is supposed to be a felony in CA but hey, the laws are only for one side now in America...


Do you have sources for that?
Back to top
View user's profile Send private message
RazielFMX
l33t
l33t


Joined: 23 Apr 2005
Posts: 806
Location: NY, USA

PostPosted: Fri Jul 25, 2014 1:43 pm    Post subject: Reply with quote

I've been battling this for some time, as only Chrome has the font issues (everything else looks pretty darn good at this point). I even installed all the fonts the Chromium ebuild says I should install.

What does enabling 70-no-bitmaps.conf actually do?

For reference, my fontconfig (in case there is something obviously wrong here):

Code:
# eselect fontconfig list
Available fontconfig .conf files (* is enabled):
  [1]   10-autohint.conf
  [2]   10-no-sub-pixel.conf
  [3]   10-scale-bitmap-fonts.conf *
  [4]   10-sub-pixel-bgr.conf
  [5]   10-sub-pixel-rgb.conf *
  [6]   10-sub-pixel-vbgr.conf
  [7]   10-sub-pixel-vrgb.conf
  [8]   10-unhinted.conf
  [9]   11-lcdfilter-default.conf
  [10]  11-lcdfilter-legacy.conf
  [11]  11-lcdfilter-light.conf
  [12]  20-unhint-small-dejavu-sans.conf *
  [13]  20-unhint-small-dejavu-sans-mono.conf *
  [14]  20-unhint-small-dejavu-serif.conf *
  [15]  20-unhint-small-vera.conf *
  [16]  25-ttf-arphic-ukai-render.conf
  [17]  25-ttf-arphic-uming-bitmaps.conf
  [18]  25-ttf-arphic-uming-render.conf
  [19]  25-unhint-nonlatin.conf
  [20]  30-metric-aliases.conf *
  [21]  30-urw-aliases.conf *
  [22]  35-ttf-arphic-ukai-aliases.conf
  [23]  35-ttf-arphic-uming-aliases.conf
  [24]  40-nonlatin.conf *
  [25]  41-ttf-arphic-ukai.conf
  [26]  41-ttf-arphic-uming.conf
  [27]  42-luxi-mono.conf *
  [28]  44-wqy-zenhei.conf
  [29]  45-latin.conf *
  [30]  49-sansserif.conf *
  [31]  50-user.conf *
  [32]  51-local.conf *
  [33]  57-dejavu-sans.conf *
  [34]  57-dejavu-sans-mono.conf *
  [35]  57-dejavu-serif.conf *
  [36]  59-google-droid-sans.conf
  [37]  59-google-droid-sans-mono.conf
  [38]  59-google-droid-serif.conf
  [39]  60-latin.conf *
  [40]  60-liberation.conf
  [41]  64-ttf-arphic-uming.conf
  [42]  65-fonts-persian.conf *
  [43]  65-khmer.conf
  [44]  65-nonlatin.conf *
  [45]  66-ja-ipafonts.conf
  [46]  66-takao-fonts.conf
  [47]  66-wqy-zenhei-sharp.conf
  [48]  66-wqy-zenhei-sharp-no13px.conf
  [49]  69-unifont.conf *
  [50]  70-no-bitmaps.conf
  [51]  70-yes-bitmaps.conf
  [52]  75-ttf-arphic-ukai-select.conf
  [53]  80-delicious.conf *
  [54]  90-synthetic.conf *
  [55]  90-ttf-arphic-ukai-embolden.conf
  [56]  90-ttf-arphic-uming-embolden.conf
  [57]  99pdftoopvp.conf


These are the fonts I have specifically installed:

Code:
# grep -i font /var/lib/portage/world
media-fonts/arphicfonts
media-fonts/bitstream-cyberbit
media-fonts/dejavu
media-fonts/droid
media-fonts/ipamonafont
media-fonts/ja-ipafonts
media-fonts/liberation-fonts
media-fonts/oxygen-fonts
media-fonts/takao-fonts
media-fonts/wqy-microhei
media-fonts/wqy-zenhei
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 660

PostPosted: Fri Jul 25, 2014 2:09 pm    Post subject: Reply with quote

katfish wrote:
jserink wrote:

Mozilla fires people depending upon which political party they contribute to, which is supposed to be a felony in CA but hey, the laws are only for one side now in America...


Do you have sources for that?


http://www.reuters.com/article/2014/04/03/us-mozilla-ceo-resignation-idUSBREA321Y320140403
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 660

PostPosted: Fri Jul 25, 2014 2:16 pm    Post subject: Re: Cannot load unpacked extensions?[SOLVED] Reply with quote

jserink wrote:
Hi Everyone:

Tried unmasking chromium-38.0.2101.0 but she would not build so went to chromium-38.0.2096.0 and it built fine.
The fonts were fugly so tried the Fix Helvetica hack mentioned above b ut this time cromium does not allow me to load the extension.

All files are greyed out.

Any hints.

Fonts are SUPER fugly.

Cheers,
john

Ok, I feel dumb....
the extension was already installed, which is why it was greyed out.

I un-ticked it then re-ticked it and it cleaned up most of the font issues.

Cheers,
john
Back to top
View user's profile Send private message
jserink
l33t
l33t


Joined: 30 Jan 2004
Posts: 660

PostPosted: Sat Jul 26, 2014 2:57 pm    Post subject: Ok, not quite solved.... Reply with quote

Hey Lads:

Ok, Chromium V38 just could not sort out the fugly fonts....lets move it beyond fugly and state the broswer was almost unuseable th efonts were so bad.
After fighting with it for a few hours I went back and unmasked:
www-client/chromium-37.0.2062.35

Also uunmasked
www-plugins/chrome-binary-plugins-37.0.2062.44_beta1

Built these and chrome looks fine again.

Steer clear of the V38 for the moment until this is fixed. V37 is looking good.

Cheers,
John
Back to top
View user's profile Send private message
apetrov87
n00b
n00b


Joined: 21 Sep 2014
Posts: 1

PostPosted: Sun Sep 21, 2014 7:06 am    Post subject: Reply with quote

grumblebear wrote:
The 70-no-bitmaps.conf trick cannot be called a fix, because it disables all fixed size fonts. And those include ones I have explicitly chosen for my terminals and Emacs for example. I have also worked around it by replacing Helvetica with Arial with the help of the Stylish extension, which does essentially the same thing as lrbb's solution.

This problem is actually specific to the Helvetica font, which is becoming more popular on the internet. Linux lacks a TrueType version of Helvetica because it's proprietary, but it does include a bitmap version, which Chrome doesn't render well.
I managed to disable only the bitmap version of Helvetica, while allowing all other bitmaps.
Create a new file /etc/fonts/conf.avail/77-no-helvetica-bitmap.conf and paste the following:
Code:

<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
<!-- Reject the bitmap version of Helvetica, which Chrome can't render. -->
 <selectfont>
  <rejectfont>
   <pattern>
    <patelt name="scalable"><bool>false</bool></patelt>
    <patelt name="family"><string>Helvetica</string></patelt>
   </pattern>
  </rejectfont>
 </selectfont>
</fontconfig>

Make sure this new file is readable by all users (permissions 644), then enable it and also disable both 70-no-bitmaps and 70-yes-bitmaps:
Code:

eselect fontconfig disable 70-no-bitmaps.conf
eselect fontconfig disable 70-yes-bitmaps.conf
eselect fontconfig enable 77-no-helvetica-bitmap.conf

Now, because the Helvetica font is no longer available in any form, Chrome will substitute it with Arial or something, and everything looks fine.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum