Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED] Can't upgrade my system
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Sat Feb 22, 2014 5:40 pm    Post subject: [SOLVED] Can't upgrade my system Reply with quote

EDIT: It works now

Here is what I am trying to do
Code:
darkstar ~ # emerge -auDNv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libvpx-1.3.0 [1.1.0] USE="mmx sse sse2 sse3 sse4_1 ssse3 threads (-altivec) -avx% -avx2% -doc -postproc -static-libs {-test%} (-debug%)" ABI_X86="(64%*) (-32) (-x32)" 2,036 kB
[ebuild     U  ] dev-perl/HTML-Parser-3.710.0 [3.690.0] USE="{-test}" 89 kB
[ebuild     U  ] dev-util/gtk-doc-am-1.20 [1.19] 629 kB
[uninstall     ] dev-util/gtk-doc-1.19  USE="-debug -doc -emacs -highlight {-test} -vim" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[blocks b      ] <dev-util/gtk-doc-1.20 ("<dev-util/gtk-doc-1.20" is blocking dev-util/gtk-doc-am-1.20)
[ebuild     U  ] app-text/iso-codes-3.51 [3.45] 3,542 kB
[ebuild     U ~] dev-libs/glib-2.38.2:2 [2.36.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 6,561 kB
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0 [0.150.0] USE="{-test}" 35 kB
[ebuild     U  ] dev-libs/atk-2.10.0 [2.8.0] USE="introspection nls {-test}" 628 kB
[ebuild     U  ] app-accessibility/at-spi2-core-2.10.2:2 [2.8.0:2] USE="X%* introspection" 436 kB
[ebuild     U  ] dev-cpp/glibmm-2.38.1:2 [2.36.2:2] USE="-debug -doc -examples {-test}" 5,568 kB
[ebuild     U  ] app-accessibility/at-spi2-atk-2.10.2:2 [2.8.1:2] USE="{-test}" 266 kB
[ebuild     U  ] www-plugins/adobe-flash-11.2.202.341 [11.2.202.336] USE="sse2 (-debug) -kde (-selinux)" ABI_X86="64 -32 (-x32)" 7,067 kB
[ebuild     U ~] x11-libs/gtk+-3.10.7:3 [3.8.7:3] USE="X cups introspection (-aqua) -colord -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama" 14,028 kB
[ebuild     U  ] gnome-base/dconf-0.18.0 [0.16.1] USE="X {-test}" 370 kB
[ebuild     U  ] app-arch/file-roller-3.10.2.1 [3.8.4-r2] USE="-nautilus (-packagekit)" 1,361 kB
[blocks B      ] <dev-libs/gobject-introspection-1.38 ("<dev-libs/gobject-introspection-1.38" is blocking dev-libs/glib-2.38.2)

Total: 14 packages (14 upgrades, 1 uninstall), Size of downloads: 42,609 kB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed) pulled in by
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.21::gentoo, installed)
    dev-libs/gobject-introspection required by (dev-libs/keybinder-0.3.0-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (dev-python/pygobject-3.8.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.10.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.10.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)

  (dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.37.5:2 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.6 required by (dev-java/swt-3.7.2::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4ui-4.10.0::gentoo, installed)
    dev-libs/glib:2 required by (net-misc/dropbox-2.4.7::gentoo, installed)
    >=dev-libs/glib-2 required by (dev-libs/fribidi-0.19.5-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-settings-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-panel-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfdesktop-4.10.2::gentoo, installed)
    >=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4-r1::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (app-arch/file-roller-3.10.2.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.10.2::gentoo, ebuild scheduled for merge)
    dev-libs/glib:2 required by (www-plugins/adobe-flash-11.2.202.341::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.26:2 required by (x11-themes/gtk-engines-unico-1.0.3_pre20121212::gentoo, installed)
    >=dev-libs/glib-2:2 required by (sys-block/gparted-0.16.2::gentoo, installed)
    >=dev-libs/glib-2.14 required by (xfce-base/garcon-0.2.1::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-video/gnome-mplayer-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.24:2/2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.35.2:2 required by (gnome-base/dconf-0.18.0::gentoo, ebuild scheduled for merge)
    dev-libs/glib:2 required by (sci-calculators/galculator-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-appfinder-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-libs/gmtk-1.0.7::gentoo, installed)
    >=dev-libs/glib-2:2 required by (x11-libs/gtkglext-1.2.0-r1::gentoo, installed)
    >=dev-libs/glib-2.12 required by (app-editors/mousepad-0.3.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (mail-client/thunderbird-24.3.0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (x11-libs/pangox-compat-0.0.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-27.0::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4util-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.10.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/glib-2.10.1:2 required by (app-admin/syslog-ng-3.4.2::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-alsa-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfwm4-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-power/upower-0.9.21::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-power-manager-1.2.0-r2::gentoo, installed)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, installed)
    >=dev-libs/glib-2.6.0 required by (net-irc/irssi-0.8.15-r1::gentoo, installed)
    >=dev-libs/glib-2.30 required by (sys-fs/udisks-1.0.4-r5::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (dev-libs/dbus-glib-0.100.2::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-extra/thunar-volman-0.8.0::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfconf-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.5-r1::gentoo, installed)
    dev-libs/glib:2 required by (app-text/enchant-1.6.0::gentoo, installed)
    >=dev-libs/glib-2.24:2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/exo-0.10.2::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-extra/gnome-calculator-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-mixer-4.10.0::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libcroco-0.6.8::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libunique-1.1.6-r1::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/glib-2.16 required by (xfce-extra/xfce4-screenshooter-1.8.1::gentoo, installed)
    dev-libs/glib:2 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55::gentoo, installed)
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r300::gentoo, installed)
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/thunar-1.6.3::gentoo, installed)
    >=dev-libs/glib-2.34.2:2 required by (dev-python/pygobject-3.8.3::gentoo, installed)
    >=dev-libs/glib-2.29.15:2 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    >=dev-libs/glib-2 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/glib-2.38.0:2 required by (dev-cpp/glibmm-2.38.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r200::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (x11-wm/herbstluftwm-0.5.3::gentoo, installed)
    dev-libs/glib required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/glib-2.33:2 required by (app-text/evince-3.8.3::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-accessibility/at-spi2-atk-2.10.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.26 required by (x11-terms/xfce4-terminal-0.6.2-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (media-gfx/ristretto-0.6.3::gentoo, installed)
    >=dev-libs/glib-2.30 required by (app-cdr/xfburn-0.4.3_p20121021::gentoo, installed)
    >=dev-libs/glib-2.35:2 required by (gnome-base/gvfs-1.16.4::gentoo, installed)
    >=dev-libs/glib-2.35.8:2 required by (net-libs/glib-networking-2.36.2::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked

darkstar ~ # emerge --unmerge dev-libs/gobject-introspection
 * This action can remove important packages! In order to be safer, use
 * `emerge -pv --depclean <atom>` to check for reverse dependencies before
 * removing packages.

 dev-libs/gobject-introspection
    selected: 1.36.0-r1
   protected: none
     omitted: none

All selected packages: dev-libs/gobject-introspection-1.36.0-r1

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in:  5 4 3 2 1
>>> Unmerging (1 of 1) dev-libs/gobject-introspection-1.36.0-r1...
>>> needed   sym /usr/lib64/libgirepository-1.0.so.1
>>> needed   obj /usr/lib64/libgirepository-1.0.so.1.0.0
 * Updating desktop mime database ...
 * Updating shared mime info database ...

 * GNU info directory index is up-to-date.

!!! existing preserved libs:
>>> package: dev-libs/gobject-introspection-1.36.0-r1
 *  - /usr/lib64/libgirepository-1.0.so.1
 *  - /usr/lib64/libgirepository-1.0.so.1.0.0
 *      used by /usr/lib64/python2.7/site-packages/gi/_gi.so (dev-python/pygobject-3.8.3)
 *      used by /usr/lib64/python2.7/site-packages/gi/_gobject/_gobject.so (dev-python/pygobject-3.8.3)
 *      used by /usr/lib64/python3.3/site-packages/gi/_gi.so (dev-python/pygobject-3.8.3)
 *      used by /usr/lib64/python3.3/site-packages/gi/_gobject/_gobject.so (dev-python/pygobject-3.8.3)
Use emerge @preserved-rebuild to rebuild packages using these libraries
darkstar ~ # emerge -auDNv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libvpx-1.3.0 [1.1.0] USE="mmx sse sse2 sse3 sse4_1 ssse3 threads (-altivec) -avx% -avx2% -doc -postproc -static-libs {-test%} (-debug%)" ABI_X86="(64%*) (-32) (-x32)" 2,036 kB
[ebuild     U  ] dev-perl/HTML-Parser-3.710.0 [3.690.0] USE="{-test}" 89 kB
[ebuild     U  ] dev-util/gtk-doc-am-1.20 [1.19] 629 kB
[uninstall     ] dev-util/gtk-doc-1.19  USE="-debug -doc -emacs -highlight {-test} -vim" PYTHON_SINGLE_TARGET="python2_7 -python2_6" PYTHON_TARGETS="python2_7 -python2_6"
[blocks b      ] <dev-util/gtk-doc-1.20 ("<dev-util/gtk-doc-1.20" is blocking dev-util/gtk-doc-am-1.20)
[ebuild     U  ] app-text/iso-codes-3.51 [3.45] 3,542 kB
[ebuild     U ~] dev-libs/glib-2.38.2:2 [2.36.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 6,561 kB
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0 [0.150.0] USE="{-test}" 35 kB
[ebuild  N     ] dev-libs/gobject-introspection-1.36.0-r1  USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7" 0 kB
[ebuild     U  ] dev-cpp/glibmm-2.38.1:2 [2.36.2:2] USE="-debug -doc -examples {-test}" 5,568 kB
[ebuild     U  ] dev-libs/atk-2.10.0 [2.8.0] USE="introspection nls {-test}" 628 kB
[ebuild     U  ] app-accessibility/at-spi2-core-2.10.2:2 [2.8.0:2] USE="X%* introspection" 436 kB
[ebuild     U  ] app-accessibility/at-spi2-atk-2.10.2:2 [2.8.1:2] USE="{-test}" 266 kB
[ebuild     U ~] x11-libs/gtk+-3.10.7:3 [3.8.7:3] USE="X cups introspection (-aqua) -colord -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama" 14,028 kB
[ebuild     U  ] www-plugins/adobe-flash-11.2.202.341 [11.2.202.336] USE="sse2 (-debug) -kde (-selinux)" ABI_X86="64 -32 (-x32)" 7,067 kB
[ebuild     U  ] gnome-base/dconf-0.18.0 [0.16.1] USE="X {-test}" 370 kB
[ebuild     U  ] app-arch/file-roller-3.10.2.1 [3.8.4-r2] USE="-nautilus (-packagekit)" 1,361 kB
[blocks B      ] <dev-libs/gobject-introspection-1.38 ("<dev-libs/gobject-introspection-1.38" is blocking dev-libs/glib-2.38.2)

Total: 15 packages (14 upgrades, 1 new, 1 uninstall), Size of downloads: 42,609 kB
Conflict: 2 blocks (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r200::gentoo, installed)
    dev-libs/glib:2 required by (www-plugins/adobe-flash-11.2.202.341::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libunique-1.1.6-r1::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-power/upower-0.9.21::gentoo, installed)
    >=dev-libs/glib-2.6.0 required by (net-irc/irssi-0.8.15-r1::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-libs/gmtk-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-mixer-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28::gentoo, installed)
    >=dev-libs/glib-2.12 required by (app-editors/mousepad-0.3.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-accessibility/at-spi2-atk-2.10.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.33:2 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/thunar-1.6.3::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-settings-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-alsa-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22::gentoo, installed)
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.10.1:2 required by (app-admin/syslog-ng-3.4.2::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfdesktop-4.10.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (sys-fs/udisks-1.0.4-r5::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-video/gnome-mplayer-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/exo-0.10.2::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (x11-libs/pangox-compat-0.0.2::gentoo, installed)
    >=dev-libs/glib-2 required by (dev-libs/fribidi-0.19.5-r1::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/glib-2.29.15:2 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    >=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4-r1::gentoo, installed)
    >=dev-libs/glib-2.24:2/2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (mail-client/thunderbird-24.3.0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (dev-libs/dbus-glib-0.100.2::gentoo, installed)
    >=dev-libs/glib-2.37.5:2 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.14 required by (xfce-base/garcon-0.2.1::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-27.0::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.10.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.24:2 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, installed)
    dev-libs/glib:2 required by (app-text/enchant-1.6.0::gentoo, installed)
    >=dev-libs/glib-2:2 required by (x11-libs/gtkglext-1.2.0-r1::gentoo, installed)
    >=dev-libs/glib-2.38.0:2 required by (dev-cpp/glibmm-2.38.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-terms/xfce4-terminal-0.6.2-r1::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libcroco-0.6.8::gentoo, installed)
    dev-libs/glib required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r300::gentoo, installed)
    dev-libs/glib:2 required by (net-misc/dropbox-2.4.7::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    dev-libs/glib:2 required by (sci-calculators/galculator-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/glib-2.16 required by (xfce-extra/xfce4-screenshooter-1.8.1::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-extra/thunar-volman-0.8.0::gentoo, installed)
    >=dev-libs/glib-2.35:2 required by (gnome-base/gvfs-1.16.4::gentoo, installed)
    >=dev-libs/glib-2.6 required by (dev-java/swt-3.7.2::gentoo, installed)
    >=dev-libs/glib-2.24 required by (media-gfx/ristretto-0.6.3::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4ui-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-themes/gtk-engines-unico-1.0.3_pre20121212::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (app-arch/file-roller-3.10.2.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
    >=dev-libs/glib-2:2 required by (sys-block/gparted-0.16.2::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-extra/gnome-calculator-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (x11-wm/herbstluftwm-0.5.3::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-appfinder-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (app-cdr/xfburn-0.4.3_p20121021::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4util-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-panel-4.10.1::gentoo, installed)
    >=dev-libs/glib-2 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-power-manager-1.2.0-r2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.35.2:2 required by (gnome-base/dconf-0.18.0::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.34.2:2 required by (dev-python/pygobject-3.8.3::gentoo, installed)
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    dev-libs/glib:2 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfwm4-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.10.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.24:2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.35.8:2 required by (net-libs/glib-networking-2.36.2::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.5-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfconf-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/gobject-introspection-1.36.0-r1::gentoo, ebuild scheduled for merge)

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.21::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (dev-python/pygobject-3.8.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.10.0::gentoo, ebuild scheduled for merge)
    dev-libs/gobject-introspection required by (dev-libs/keybinder-0.3.0-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.10.2::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


Last edited by moisespedro on Sun Feb 23, 2014 12:31 pm; edited 1 time in total
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2725
Location: Hamburg/Germany

PostPosted: Sat Feb 22, 2014 6:02 pm    Post subject: Reply with quote

yeah - seems the gnome stabilization has some fall outs - file a bug for that - b/c the IRC (freenode) is currently unavailable - at least here.
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Sat Feb 22, 2014 6:05 pm    Post subject: Reply with quote

Damn, is it really a bug? Can't I solve it on my own? I mean, by using emerge.
Back to top
View user's profile Send private message
Greens
n00b
n00b


Joined: 23 Aug 2013
Posts: 27

PostPosted: Sat Feb 22, 2014 6:19 pm    Post subject: Reply with quote

Very similar issue.

A bunch of stuff was just added to the stable branch today and I'm having a headache trying to fix it.

First it told me I have to bump up two packages to ~amd64 in /etc/portage/package.accept_keywords (Why was all this stuff put in the stable branch if it's asking me to install unstable packages as dependencies?)

=dev-libs/glib-2.38.2 ~amd64
=x11-libs/gtk+-3.10.7 ~amd64

Said whatever and did, still a bunch of shit to work through. The thing is I don't even use gnome and don't even want it on my system. It's so hard to uninstall it though, you uninstall one thing but when you update it just keeps getting stuff pulled back in.

http://pastebin.com/uymjqfaU
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2725
Location: Hamburg/Germany

PostPosted: Sat Feb 22, 2014 6:20 pm    Post subject: Reply with quote

moisespedro wrote:
Damn, is it really a bug? Can't I solve it on my own? I mean, by using emerge.
wait and resync your tree and/or inform devs about the problem.
Back to top
View user's profile Send private message
Greens
n00b
n00b


Joined: 23 Aug 2013
Posts: 27

PostPosted: Sat Feb 22, 2014 6:40 pm    Post subject: Reply with quote

toralf wrote:
moisespedro wrote:
Damn, is it really a bug? Can't I solve it on my own? I mean, by using emerge.
wait and resync your tree and/or inform devs about the problem.


I'll keep syncing/retrying for the following days, hope it gets worked out.
Back to top
View user's profile Send private message
Captain Kirk
Tux's lil' helper
Tux's lil' helper


Joined: 16 Apr 2003
Posts: 140
Location: USA

PostPosted: Sat Feb 22, 2014 6:43 pm    Post subject: Reply with quote

Getting hit with this too, unfortunately. Guess I'll try and wait it out a few days.
Back to top
View user's profile Send private message
Atmmac
n00b
n00b


Joined: 17 Oct 2013
Posts: 45
Location: Watertown, MA

PostPosted: Sat Feb 22, 2014 6:45 pm    Post subject: Reply with quote

Having the same problem here. Gnome is such a disaster.

AmacGentoo andy # emerge -auD @world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] dev-util/gtk-doc-am-1.20 [1.19]
[ebuild U ] dev-perl/HTML-Parser-3.710.0 [3.690.0]
[ebuild U ] x11-libs/pango-1.36.2 [1.34.1]
[ebuild U ] dev-perl/File-MimeInfo-0.170.0 [0.150.0]
[ebuild NS ] app-text/docbook-xml-dtd-4.3-r1 [4.1.2-r6, 4.2-r2, 4.4-r2]
[ebuild U ] net-libs/telepathy-glib-0.22.1 [0.20.4]
[ebuild U ] dev-libs/atk-2.10.0 [2.8.0]
[ebuild U ~] dev-libs/glib-2.38.2 [2.36.4-r1]
[ebuild U ] app-text/iso-codes-3.51 [3.45]
[ebuild U ] app-accessibility/at-spi2-core-2.10.2 [2.8.0] USE="X%*"
[ebuild U ] dev-cpp/glibmm-2.38.1 [2.36.2]
[ebuild U ] app-accessibility/at-spi2-atk-2.10.2 [2.8.1]
[ebuild U ] net-libs/glib-networking-2.38.2 [2.36.2]
[ebuild U ] x11-libs/gdk-pixbuf-2.30.5 [2.28.2]
[ebuild U ] gnome-base/librsvg-2.40.1-r1 [2.39.0]
[ebuild U ] net-wireless/bluez-5.14-r1 [4.101-r8] USE="obex%* -systemd% {-test%}"
[ebuild U ] www-plugins/adobe-flash-11.2.202.341 [11.2.202.336]
[ebuild U ] net-libs/libsoup-2.44.2 [2.42.3.1]
[ebuild U ] gnome-base/dconf-0.18.0 [0.16.1]
[ebuild U ] net-libs/gssdp-0.14.7 [0.14.6]
[ebuild U ] net-libs/gupnp-0.20.10 [0.20.8]
[ebuild U ] gnome-base/gnome-keyring-3.10.1 [3.8.2]
[ebuild U ] gnome-base/libgnome-keyring-3.10.1 [3.8.0]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

(dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
>=dev-libs/glib-2.38.0:2 required by (dev-cpp/glibmm-2.38.1::gentoo, ebuild scheduled for merge)
(and 2 more with the same problem)

(dev-libs/glib-2.36.4-r1::gentoo, installed) pulled in by
(no parents that aren't satisfied by other packages in this slot)

net-wireless/bluez:0

(net-wireless/bluez-5.14-r1::gentoo, ebuild scheduled for merge) pulled in by
(no parents that aren't satisfied by other packages in this slot)

(net-wireless/bluez-4.101-r8::gentoo, installed) pulled in by
<net-wireless/bluez-5 required by (net-libs/libbluedevil-1.9.4::gentoo, installed)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following keyword changes are necessary to proceed:
(see "package.accept_keywords" in the portage(5) man page for more details)
# required by x11-libs/libfm-0.1.17-r1
# required by x11-misc/pcmanfm-0.9.10
# required by lxde-base/lxde-meta-0.5.5-r3
# required by @selected
# required by @world (argument)
=dev-libs/glib-2.38.2 ~amd64
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2725
Location: Hamburg/Germany

PostPosted: Sat Feb 22, 2014 7:08 pm    Post subject: Reply with quote

filed https://bugs.gentoo.org/show_bug.cgi?id=502160
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2582
Location: Oviedo, Spain

PostPosted: Sat Feb 22, 2014 9:01 pm    Post subject: Reply with quote

Sorry a lot to all, was an accident when I run the wrong script wanting to prepare a list for the future Gnome 3.10 stabilization. I am working on fixing it just now, I expect all is ok in some hours (when all is reversed and the changes spread in rsync)

Sorry
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Sat Feb 22, 2014 9:41 pm    Post subject: Reply with quote

Oh ok, will try again later
Glad to see it is going to be fixed, thought I was doing something wrong, I am a gentoo noob :oops:
Back to top
View user's profile Send private message
Greens
n00b
n00b


Joined: 23 Aug 2013
Posts: 27

PostPosted: Sat Feb 22, 2014 10:32 pm    Post subject: Reply with quote

pacho2 wrote:
Sorry a lot to all, was an accident when I run the wrong script wanting to prepare a list for the future Gnome 3.10 stabilization. I am working on fixing it just now, I expect all is ok in some hours (when all is reversed and the changes spread in rsync)

Sorry


Thank you very much.

EDIT:

> Pacho Ramos gentoo-dev 2014-02-22 23:25:30 UTC
> I think all is ok now

Just resynced and seems to be the only thing left causing issues is glibmm. Is this intentional?

https://packages.gentoo.org/package/dev-cpp/glibmm

Code:

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ~] dev-libs/glib-2.38.2:2 [2.36.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 6,561 kB
[ebuild     U  ] dev-cpp/glibmm-2.38.1:2 [2.36.2:2] USE="-debug -doc -examples {-test}" 5,568 kB

Total: 2 packages (2 upgrades), Size of downloads: 12,129 kB

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

dev-libs/glib:2

  (dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.38.0:2 required by (dev-cpp/glibmm-2.38.1::gentoo, ebuild scheduled for merge)

  (dev-libs/glib-2.36.4-r1::gentoo, installed) pulled in by
    (no parents that aren't satisfied by other packages in this slot)

The following keyword changes are necessary to proceed:
 (see "package.accept_keywords" in the portage(5) man page for more details)
# required by dev-python/pygobject-3.8.3
# required by dev-libs/libpeas-1.8.1[python]
# required by media-gfx/eog-3.8.2
# required by @selected
# required by @world (argument)
=dev-libs/glib-2.38.2 ~amd64
Back to top
View user's profile Send private message
voncloft
n00b
n00b


Joined: 29 Jan 2014
Posts: 33

PostPosted: Sun Feb 23, 2014 3:01 am    Post subject: I too am receiving this error Reply with quote

I have an alias named update (too lazy to manually type out "sudo emerge --update --deep --with-bdeps=y --newuse @world") and use the --color n flag because its too difficult to read navy blue text in a black background terminal.
Anyway i receive the following error:
Code:

nick@gentoo-nick /etc/portage $ update --color n
!!! Found 2 make.conf files, using both '/etc/make.conf' and '/etc/portage/make.conf'

 * IMPORTANT: 8 news items need reading for repository 'gentoo'.
 * Use eselect news to read news items.

Calculating dependencies... done!
[ebuild     U  ] dev-perl/IO-Socket-SSL-1.953.0 [1.840.0]
[ebuild     U ~] dev-libs/glib-2.38.2 [2.36.4-r1]
[ebuild     U  ] dev-cpp/glibmm-2.38.1 [2.36.2]
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0 [0.150.0]
[ebuild  N     ] dev-libs/gobject-introspection-1.36.0-r1  USE="cairo -doctool {-test}" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7"
[ebuild     U  ] www-plugins/adobe-flash-11.2.202.341 [11.2.202.336]
[blocks B      ] <dev-libs/gobject-introspection-1.38 ("<dev-libs/gobject-introspection-1.38" is blocking dev-libs/glib-2.38.2)


 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.4 required by (net-libs/gupnp-0.20.8::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10 required by (net-libs/gupnp-igd-0.2.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.11 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (net-libs/gssdp-0.14.6::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.8.7::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.0 required by (net-libs/webkit-gtk-2.0.4::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:0/0= required by (gnome-base/gconf-3.2.6-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30.0 required by (gnome-base/libgnome-keyring-3.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gstreamer-1.0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (media-libs/gst-plugins-base-1.0.10::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34 required by (app-crypt/gcr-3.8.2::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.21::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5:= required by (gnome-base/gconf-3.2.6-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (gnome-base/libgtop-2.28.5::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)

  (dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.6:2 required by (gnome-base/libgtop-2.28.5::gentoo, installed)
    dev-libs/glib:2 required by (kde-misc/kde-gtk-config-2.2.1::gentoo, installed)
    >=dev-libs/glib-2.4:2 required by (dev-libs/libIDL-0.8.14::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-mad-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-soup-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-xvid-0.10.23::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-ogg-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-vorbis-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (app-emulation/vmware-player-6.0.0.1295980::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-cdparanoia-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (app-mobilephone/obex-data-server-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (dev-libs/dbus-glib-0.100.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-resindvd-0.10.23::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (dev-util/gtk-doc-1.19::gentoo, installed)
    >=dev-libs/glib-2.32.0:2 required by (gnome-base/gnome-keyring-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-x-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-power/upower-0.9.21::gentoo, installed)
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-gconf-0.10.31::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.2-r1::gentoo, installed)
    >=dev-libs/glib-2:2 required by (sys-block/gparted-0.16.2::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112::gentoo, installed)
    dev-libs/glib required by (x11-drivers/nvidia-drivers-331.38::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.5-r1::gentoo, installed)
    >=dev-libs/glib-2.16 required by (net-im/pidgin-2.10.9-r1::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gconf-3.2.6-r1::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-24.3.0::gentoo, installed)
    dev-libs/glib:2 required by (x11-libs/wxGTK-2.8.12.1-r1::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/glib-2.30:2 required by (net-libs/farstream-0.1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.35.3:2 required by (x11-libs/gtk+-3.8.7::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-mobilephone/obexd-0.46::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (net-libs/gupnp-igd-0.2.2-r1::gentoo, installed)
    >=dev-libs/glib-2.4.0 required by (media-sound/pulseaudio-4.0::gentoo, installed)
    dev-libs/glib:2 required by (media-video/nvidia-settings-331.20::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libcroco-0.6.8::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-x264-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-good-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (net-libs/gupnp-0.20.8::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-bad-0.10.23-r1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/libcanberra-0.30-r1::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4::gentoo, installed)
    >=dev-libs/glib-2:2 required by (app-admin/gam-server-0.1.10-r1::gentoo, installed)
    >=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4-r1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-pulse-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-good-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-bad-0.10.23-r1::gentoo, installed)
    dev-libs/glib required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-a52dec-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/gssdp-0.14.6::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libgnomecanvas-2.30.3::gentoo, installed)
    >=dev-libs/glib-2.35.8:2 required by (net-libs/glib-networking-2.36.2::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    dev-libs/glib:2 required by (app-text/enchant-1.6.0::gentoo, installed)
    >=dev-libs/glib-2.38.0:2 required by (dev-cpp/glibmm-2.38.1::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/webkit-gtk-2.0.4::gentoo, installed)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (net-wireless/bluez-4.101-r8::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-ugly-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.18:2 required by (dev-lang/vala-0.22.1::gentoo, installed)
    dev-libs/glib:2 required by (kde-base/systemsettings-4.11.5::gentoo, installed)
    >=dev-libs/glib-2 required by (sys-fs/udev-208::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/phonon-4.6.0-r1::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dts-0.10.23::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    >=dev-libs/glib-2.34:2 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    dev-libs/glib:2 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-dvdread-0.10.19::gentoo, installed)
    dev-libs/glib:2 required by (kde-base/phonon-kde-4.12.2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-alsa-0.10.36::gentoo, installed)
    dev-libs/glib:2 required by (x11-themes/sound-theme-freedesktop-0.8::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (gnome-base/orbit-2.14.19-r3::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-accessibility/at-spi2-atk-2.8.1::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtwebkit-4.8.5::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-ugly-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-mpeg2dec-0.10.19::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gst-plugins-base-1.0.10::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-xvideo-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (media-libs/gstreamer-1.0.10::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/glib-2.13:2 required by (net-libs/libnice-0.1.4::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-flac-0.10.31::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-faad-0.10.23::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-1.0.10::gentoo, installed)
    dev-libs/glib:2 required by (sys-auth/polkit-qt-0.103.0::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/speech-dispatcher-0.8-r2::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (gnome-extra/zenity-3.8.0::gentoo, installed)
    dev-libs/glib:2 required by (www-plugins/adobe-flash-11.2.202.341::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (app-crypt/gcr-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/gobject-introspection-1.36.0-r1::gentoo, ebuild scheduled for merge)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


So my guess is I have to wait a few days to update successfully until glibc is no longer infected?
Back to top
View user's profile Send private message
Greens
n00b
n00b


Joined: 23 Aug 2013
Posts: 27

PostPosted: Sun Feb 23, 2014 3:16 am    Post subject: Re: I too am receiving this error Reply with quote

voncloft wrote:
I have an alias named update (too lazy to manually type out "sudo emerge --update --deep --with-bdeps=y --newuse @world") and use the --color n flag because its too difficult to read navy blue text in a black background terminal.
Anyway i receive the following error:

So my guess is I have to wait a few days to update successfully until glibc is no longer infected?


They already fixed most of it but glibmm. which is pulling in the newer unstable glib version, which is causing the block with gobject-introspection.

I assume they will take that out very soon, probably sometime tonight. They changed back everything pretty quickly except for glibmm. Point is once they do you won't get that error, just wait a while and resync, or after you see glibmm-2.38 not marked stable here: https://packages.gentoo.org/package/dev-cpp/glibmm
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Sun Feb 23, 2014 4:16 am    Post subject: Reply with quote

So is still broken? Cause I still can't upgrade
Back to top
View user's profile Send private message
Twist
Guru
Guru


Joined: 03 Jan 2003
Posts: 414
Location: San Diego

PostPosted: Sun Feb 23, 2014 4:18 am    Post subject: Reply with quote

If you absolutely must emerge tonight,

Code:

echo "=dev-cpp/glibmm-2.38.1" >> /etc/portage/package.mask


However I would not recommend this, unless you are sure you are going to remember to remove it later. The package will most likely be the version that goes stable eventually and you would be masking it.

Also the portage tree is in an unknown and potentially invalid state, so I would just wait a day.
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Sun Feb 23, 2014 4:41 am    Post subject: Reply with quote

Yes, that is what I am doing (waiting) and it is totally fine for me.
Back to top
View user's profile Send private message
pacho2
Developer
Developer


Joined: 04 Mar 2005
Posts: 2582
Location: Oviedo, Spain

PostPosted: Sun Feb 23, 2014 9:31 am    Post subject: Reply with quote

glibmm-2.38 should be ok again:
+ 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> glibmm-2.38.1.ebuild:
+ Revert wrong commit
+
Back to top
View user's profile Send private message
toralf
Advocate
Advocate


Joined: 01 Feb 2004
Posts: 2725
Location: Hamburg/Germany

PostPosted: Sun Feb 23, 2014 12:08 pm    Post subject: Reply with quote

These 3 packages can't be downgraded :
Code:
These are the packages that would be merged, in reverse order:

Calculating dependencies  ....... done!
[nomerge       ] app-office/lotus-meta-8.5.3
[nomerge       ]  gnome-base/gvfs-1.16.4
[ebuild     UD ]   net-libs/libsoup-gnome-2.42.3.1 [2.44.2]
[ebuild     UD ]  gnome-base/librsvg-2.39.0 [2.40.1-r1] USE="gtk%*"
[ebuild     UD ]   x11-libs/pango-1.34.1 [1.36.2]
due to
Code:
 * Running automake --add-missing --copy --force-missing ...
 [ !! ]

 * Failed Running automake !
 *
 * Include in your bugreport the contents of:
 *
 *   /var/tmp/portage/x11-libs/pango-1.34.1/temp/automake.out

 * ERROR: x11-libs/pango-1.34.1::gentoo failed (prepare phase):
 *   Failed Running automake !
:-(
Back to top
View user's profile Send private message
diablo465
Tux's lil' helper
Tux's lil' helper


Joined: 10 Sep 2013
Posts: 136

PostPosted: Sun Feb 23, 2014 12:23 pm    Post subject: Reply with quote

pacho2 wrote:
glibmm-2.38 should be ok again:
+ 23 Feb 2014; Pacho Ramos <pacho@gentoo.org> glibmm-2.38.1.ebuild:
+ Revert wrong commit
+




Thanks I have updated successfully!
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Sun Feb 23, 2014 12:26 pm    Post subject: Reply with quote

Still doesn't work
Code:
darkstar ~ # emerge -auDNv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libvpx-1.3.0 [1.1.0] USE="mmx sse sse2 sse3 sse4_1 ssse3 threads (-altivec) -avx% -avx2% -doc -postproc -static-libs {-test%} (-debug%)" ABI_X86="(64%*) (-32) (-x32)" 2,036 kB
[ebuild     U  ] dev-perl/HTML-Parser-3.710.0 [3.690.0] USE="{-test}" 89 kB
[ebuild     U  ] dev-perl/IO-Socket-SSL-1.953.0 [1.840.0] USE="-idn" 88 kB
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0 [0.150.0] USE="{-test}" 35 kB
[ebuild     U ~] dev-libs/glib-2.38.2:2 [2.36.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 6,561 kB
[ebuild     U  ] www-plugins/adobe-flash-11.2.202.341 [11.2.202.336] USE="sse2 (-debug) -kde (-selinux)" ABI_X86="64 -32 (-x32)" 7,067 kB
[ebuild     U ~] x11-libs/gtk+-3.10.7:3 [3.8.7:3] USE="X cups introspection (-aqua) -colord -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama" 14,028 kB
[blocks B      ] <dev-libs/gobject-introspection-1.38 ("<dev-libs/gobject-introspection-1.38" is blocking dev-libs/glib-2.38.2)

Total: 7 packages (7 upgrades), Size of downloads: 29,900 kB
Conflict: 1 block (1 unsatisfied)darkstar ~ # emerge -auDNv world

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U  ] media-libs/libvpx-1.3.0 [1.1.0] USE="mmx sse sse2 sse3 sse4_1 ssse3 threads (-altivec) -avx% -avx2% -doc -postproc -static-libs {-test%} (-debug%)" ABI_X86="(64%*) (-32) (-x32)" 2,036 kB
[ebuild     U  ] dev-perl/HTML-Parser-3.710.0 [3.690.0] USE="{-test}" 89 kB
[ebuild     U  ] dev-perl/IO-Socket-SSL-1.953.0 [1.840.0] USE="-idn" 88 kB
[ebuild     U  ] dev-perl/File-MimeInfo-0.170.0 [0.150.0] USE="{-test}" 35 kB
[ebuild     U ~] dev-libs/glib-2.38.2:2 [2.36.4-r1:2] USE="-debug (-fam) (-selinux) -static-libs -systemtap {-test} -utils -xattr" ABI_X86="(64) -32 (-x32)" PYTHON_TARGETS="python2_7 -python2_6" 6,561 kB
[ebuild     U  ] www-plugins/adobe-flash-11.2.202.341 [11.2.202.336] USE="sse2 (-debug) -kde (-selinux)" ABI_X86="64 -32 (-x32)" 7,067 kB
[ebuild     U ~] x11-libs/gtk+-3.10.7:3 [3.8.7:3] USE="X cups introspection (-aqua) -colord -debug -examples (-packagekit) {-test} -vim-syntax -wayland -xinerama" 14,028 kB
[blocks B      ] <dev-libs/gobject-introspection-1.38 ("<dev-libs/gobject-introspection-1.38" is blocking dev-libs/glib-2.38.2)

Total: 7 packages (7 upgrades), Size of downloads: 29,900 kB
Conflict: 1 block (1 unsatisfied)

 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed) pulled in by
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.21::gentoo, installed)
    dev-libs/gobject-introspection required by (dev-libs/keybinder-0.3.0-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (dev-python/pygobject-3.8.3::gentoo, installed)

  (dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r300::gentoo, installed)
    >=dev-libs/glib-2.37.5:2 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32:2 required by (app-accessibility/at-spi2-atk-2.8.1::gentoo, installed)
    >=dev-libs/glib-2.10.1:2 required by (app-admin/syslog-ng-3.4.2::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-power/upower-0.9.21::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-settings-4.10.1::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=dev-libs/glib-2.35.8:2 required by (net-libs/glib-networking-2.36.2::gentoo, installed)
    >=dev-libs/glib-2.24:2/2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-panel-4.10.1::gentoo, installed)
    dev-libs/glib:2 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/glib-2.34.2:2 required by (dev-python/pygobject-3.8.3::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4ui-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/exo-0.10.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-video/gnome-mplayer-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.35:2 required by (gnome-base/gvfs-1.16.4::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libunique-1.1.6-r1::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (dev-libs/dbus-glib-0.100.2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfwm4-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4util-4.10.1::gentoo, installed)
    dev-libs/glib:2 required by (www-plugins/adobe-flash-11.2.202.341::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.34:2 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/glib-2.12 required by (app-editors/mousepad-0.3.0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/glib-2.14 required by (xfce-base/garcon-0.2.1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    >=dev-libs/glib-2.16 required by (xfce-extra/xfce4-screenshooter-1.8.1::gentoo, installed)
    >=dev-libs/glib-2.6 required by (dev-java/swt-3.7.2::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/glib-2.33:2 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4-r1::gentoo, installed)
    >=dev-libs/glib-2:2 required by (sys-block/gparted-0.16.2::gentoo, installed)
    dev-libs/glib:2 required by (app-text/enchant-1.6.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, installed)
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r200::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-27.0::gentoo, installed)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    dev-libs/glib required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (mail-client/thunderbird-24.3.0::gentoo, installed)
    >=dev-libs/glib-2.6.0 required by (net-irc/irssi-0.8.15-r1::gentoo, installed)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    dev-libs/glib:2 required by (sci-calculators/galculator-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-power-manager-1.2.0-r2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-appfinder-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-alsa-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (x11-libs/pangox-compat-0.0.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/thunar-1.6.3::gentoo, installed)
    >=dev-libs/glib-2.30 required by (app-cdr/xfburn-0.4.3_p20121021::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-libs/gmtk-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-extra/thunar-volman-0.8.0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (sys-fs/udisks-1.0.4-r5::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfconf-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-themes/gtk-engines-unico-1.0.3_pre20121212::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/glib-2.29.14:2 required by (app-arch/file-roller-3.8.4-r2::gentoo, installed)
    dev-libs/glib:2 required by (net-misc/dropbox-2.4.7::gentoo, installed)
    >=dev-libs/glib-2 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/glib-2 required by (dev-libs/fribidi-0.19.5-r1::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-extra/gnome-calculator-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.29.15:2 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.5-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (media-gfx/ristretto-0.6.3::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-terms/xfce4-terminal-0.6.2-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-mixer-4.10.0::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libcroco-0.6.8::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (x11-wm/herbstluftwm-0.5.3::gentoo, installed)
    >=dev-libs/glib-2.36.1:2 required by (dev-cpp/glibmm-2.36.2::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/glib-2:2 required by (x11-libs/gtkglext-1.2.0-r1::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfdesktop-4.10.2::gentoo, installed)
    >=dev-libs/glib-2.35.2:2 required by (gnome-base/dconf-0.16.1::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
    >=dev-libs/glib-2.24:2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



 * Error: The above package list contains packages which cannot be
 * installed at the same time on the same system.

  (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed) pulled in by
    >=dev-libs/gobject-introspection-0.9.5 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/gobject-introspection-0.9.5 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.30 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    dev-libs/gobject-introspection required by (sys-power/upower-0.9.21::gentoo, installed)
    dev-libs/gobject-introspection required by (dev-libs/keybinder-0.3.0-r200::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32.1 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.0 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    >=dev-libs/gobject-introspection-0.10.8 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.6 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.0 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.8 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.12 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/gobject-introspection-1 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/gobject-introspection-1.32 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.14 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.3 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/gobject-introspection-0.9.5 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/gobject-introspection-1.31.1 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/gobject-introspection-0.6.7 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/gobject-introspection-1.34.2 required by (dev-python/pygobject-3.8.3::gentoo, installed)

  (dev-libs/glib-2.38.2::gentoo, ebuild scheduled for merge) pulled in by
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r300::gentoo, installed)
    >=dev-libs/glib-2.37.5:2 required by (x11-libs/gtk+-3.10.7::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.32:2 required by (app-accessibility/at-spi2-atk-2.8.1::gentoo, installed)
    >=dev-libs/glib-2.10.1:2 required by (app-admin/syslog-ng-3.4.2::gentoo, installed)
    >=dev-libs/glib-2.22 required by (sys-power/upower-0.9.21::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-settings-4.10.1::gentoo, installed)
    >=dev-libs/glib-2 required by (app-misc/geoclue-0.12.99::gentoo, installed)
    >=dev-libs/glib-2.35.8:2 required by (net-libs/glib-networking-2.36.2::gentoo, installed)
    >=dev-libs/glib-2.24:2/2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.30 required by (dev-util/pkgconfig-0.28::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-panel-4.10.1::gentoo, installed)
    dev-libs/glib:2 required by (app-text/poppler-0.24.5::gentoo, installed)
    >=dev-libs/glib-2.34.2:2 required by (dev-python/pygobject-3.8.3::gentoo, installed)
    >=dev-libs/glib-2.8:2 required by (dev-python/pygtk-2.24.0-r4::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4ui-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/exo-0.10.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-video/gnome-mplayer-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.35:2 required by (gnome-base/gvfs-1.16.4::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-libs/libunique-1.1.6-r1::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (dev-libs/dbus-glib-0.100.2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-auth/polkit-0.112::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfwm4-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/libxfce4util-4.10.1::gentoo, installed)
    dev-libs/glib:2 required by (www-plugins/adobe-flash-11.2.202.341::gentoo, ebuild scheduled for merge)
    >=dev-libs/glib-2.34:2 required by (x11-libs/gtk+-2.24.22::gentoo, installed)
    >=dev-libs/glib-2.36.0:2 required by (net-libs/libsoup-2.42.3.1::gentoo, installed)
    >=dev-libs/glib-2.12 required by (app-editors/mousepad-0.3.0::gentoo, installed)
    >=dev-libs/glib-2.16:2 required by (x11-libs/libwnck-2.31.0::gentoo, installed)
    >=dev-libs/glib-2.14 required by (xfce-base/garcon-0.2.1::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (net-libs/webkit-gtk-1.8.3-r201::gentoo, installed)
    >=dev-libs/glib-2.14:2 required by (x11-libs/gtksourceview-2.10.5-r2::gentoo, installed)
    >=dev-libs/glib-2.16 required by (xfce-extra/xfce4-screenshooter-1.8.1::gentoo, installed)
    >=dev-libs/glib-2.6 required by (dev-java/swt-3.7.2::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (x11-libs/gdk-pixbuf-2.28.2::gentoo, installed)
    >=dev-libs/glib-2.33:2 required by (app-text/evince-3.8.3::gentoo, installed)
    >=dev-libs/glib-2.36.4:2 required by (dev-util/gdbus-codegen-2.36.4-r1::gentoo, installed)
    >=dev-libs/glib-2:2 required by (sys-block/gparted-0.16.2::gentoo, installed)
    dev-libs/glib:2 required by (app-text/enchant-1.6.0::gentoo, installed)
    >=dev-libs/glib-2.32:2 required by (dev-java/icedtea-bin-6.1.12.7::gentoo, installed)
    >=dev-libs/glib-2.22:2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.24.0:2 required by (dev-python/pygobject-2.28.6-r55::gentoo, installed)
    >=dev-libs/glib-2 required by (x11-misc/shared-mime-info-1.2-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (x11-themes/gtk-engines-xfce-3.0.1-r200::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (www-client/firefox-27.0::gentoo, installed)
    >=dev-libs/glib-2.33.12:2 required by (x11-libs/pango-1.34.1::gentoo, installed)
    >=dev-libs/glib-2.32 required by (sys-fs/udisks-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.22:2/2= required by (sys-auth/consolekit-0.4.6::gentoo, installed)
    >=dev-libs/glib-2.28.6:2 required by (x11-libs/cairo-1.12.14-r4::gentoo, installed)
    dev-libs/glib required by (app-text/liblangtag-0.5.1::gentoo, installed)
    >=dev-libs/glib-2.34.0:2 required by (dev-libs/json-glib-0.16.2::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (mail-client/thunderbird-24.3.0::gentoo, installed)
    >=dev-libs/glib-2.6.0 required by (net-irc/irssi-0.8.15-r1::gentoo, installed)
    >=dev-libs/glib-2.16 required by (x11-libs/libxklavier-5.2.1::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-libs/vte-0.28.2-r206::gentoo, installed)
    dev-libs/glib:2 required by (sci-calculators/galculator-2.1.2::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (media-libs/gstreamer-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-power-manager-1.2.0-r2::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-libs/gst-plugins-base-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfce4-appfinder-4.10.1::gentoo, installed)
    >=dev-libs/glib-2.6:2 required by (media-plugins/gst-plugins-alsa-0.10.36::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-libs/libnotify-0.7.5-r1::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (x11-libs/pangox-compat-0.0.2::gentoo, installed)
    >=dev-libs/glib-2.30 required by (xfce-base/thunar-1.6.3::gentoo, installed)
    >=dev-libs/glib-2.30 required by (app-cdr/xfburn-0.4.3_p20121021::gentoo, installed)
    >=dev-libs/glib-2.30 required by (media-libs/gmtk-1.0.7::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-extra/thunar-volman-0.8.0::gentoo, installed)
    >=dev-libs/glib-2.28:2 required by (app-accessibility/at-spi2-core-2.8.0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (gnome-extra/polkit-gnome-0.105::gentoo, installed)
    >=dev-libs/glib-2.12:2 required by (dev-util/desktop-file-utils-0.22::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (gnome-base/librsvg-2.39.0::gentoo, installed)
    >=dev-libs/glib-2.30 required by (sys-fs/udisks-1.0.4-r5::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-base/xfconf-4.10.0::gentoo, installed)
    >=dev-libs/glib-2.26:2 required by (x11-themes/gtk-engines-unico-1.0.3_pre20121212::gentoo, installed)
    >=dev-libs/glib-2.31.2:2 required by (dev-libs/atk-2.8.0::gentoo, installed)
    >=dev-libs/glib-2.29.14:2 required by (app-arch/file-roller-3.8.4-r2::gentoo, installed)
    dev-libs/glib:2 required by (net-misc/dropbox-2.4.7::gentoo, installed)
    >=dev-libs/glib-2 required by (sys-fs/udev-208::gentoo, installed)
    >=dev-libs/glib-2 required by (dev-libs/fribidi-0.19.5-r1::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-extra/gnome-calculator-3.8.2::gentoo, installed)
    >=dev-libs/glib-2.29.15:2 required by (gnome-base/gnome-menus-3.8.1::gentoo, installed)
    dev-libs/glib:2 required by (dev-qt/qtcore-4.8.5-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (media-gfx/ristretto-0.6.3::gentoo, installed)
    >=dev-libs/glib-2.26 required by (x11-terms/xfce4-terminal-0.6.2-r1::gentoo, installed)
    >=dev-libs/glib-2.24 required by (xfce-extra/xfce4-mixer-4.10.0::gentoo, installed)
    dev-libs/glib:2 required by (dev-libs/libcroco-0.6.8::gentoo, installed)
    >=dev-libs/glib-2.24:2 required by (x11-wm/herbstluftwm-0.5.3::gentoo, installed)
    >=dev-libs/glib-2.36.1:2 required by (dev-cpp/glibmm-2.36.2::gentoo, installed)
    dev-libs/glib:2 required by (media-libs/harfbuzz-0.9.23::gentoo, installed)
    >=dev-libs/glib-2.31:2 required by (gnome-base/gsettings-desktop-schemas-3.8.2::gentoo, installed)
    >=dev-libs/glib-2:2 required by (x11-libs/gtkglext-1.2.0-r1::gentoo, installed)
    >=dev-libs/glib-2.20 required by (xfce-base/xfdesktop-4.10.2::gentoo, installed)
    >=dev-libs/glib-2.35.2:2 required by (gnome-base/dconf-0.16.1::gentoo, installed)
    >=dev-libs/glib-2.10:2 required by (gnome-base/libglade-2.6.4::gentoo, installed)
    >=dev-libs/glib-2.24:2= required by (xfce-extra/tumbler-0.1.29::gentoo, installed)
    >=dev-libs/glib-2.36:2 required by (dev-libs/gobject-introspection-1.36.0-r1::gentoo, installed)


For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


EDIT: Just found out what it was, I had
Code:
  GNU nano 2.3.2                                 Novo Buffer                                                              Modificado 

# required by sys-block/gparted-0.16.2
# required by @selected
# required by @world (argument)
=dev-libs/glib-2.38.2 ~amd64
# required by gnome-extra/gnome-calculator-3.8.2
# required by app-text/ghostscript-gpl-9.10-r2[gtk]
# required by app-text/libspectre-0.2.7
# required by app-text/evince-3.8.3[postscript]
# required by @selected
# required by @world (argument)
#=x11-libs/gtk+-3.10.7 ~amd64


On my /etc/portage/package.keywords, those were required on the previous update. Now it is fine.[/code]
Back to top
View user's profile Send private message
wfdawson
n00b
n00b


Joined: 05 Aug 2010
Posts: 8

PostPosted: Sun Feb 23, 2014 4:49 pm    Post subject: Reply with quote

Not fine. Stable dev-cpp/glibmm-2.38.1 is still depending on unstable >=dev-libs/glib-2.38.0:2.

Still waiting.
Back to top
View user's profile Send private message
figueroa
Apprentice
Apprentice


Joined: 14 Aug 2005
Posts: 221
Location: GA-USA

PostPosted: Sun Feb 23, 2014 7:55 pm    Post subject: Reply with quote

I just synced about 10 minutes ago, x86 stable, and problem resolved.
_________________
Andy Figueroa
andy@andyfigueroa.us
Back to top
View user's profile Send private message
-=GGW=- $ol!d $n4>|e
Veteran
Veteran


Joined: 12 Apr 2004
Posts: 1604
Location: USA

PostPosted: Sun Feb 23, 2014 8:14 pm    Post subject: Reply with quote

still broken for x86_64 :(
Back to top
View user's profile Send private message
moisespedro
n00b
n00b


Joined: 01 Jan 2014
Posts: 71

PostPosted: Sun Feb 23, 2014 8:25 pm    Post subject: Reply with quote

-=GGW=- $ol!d $n4>|e wrote:
still broken for x86_64 :(


It works here
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum