Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problems in the first update after install Gentoo Prefix
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures
View previous topic :: View next topic  
Author Message
natrix
Apprentice
Apprentice


Joined: 23 Aug 2013
Posts: 285

PostPosted: Mon Feb 17, 2014 10:38 pm    Post subject: Problems in the first update after install Gentoo Prefix Reply with quote

Hello:

I'm new to Gentoo Prefix. I installed Gentoo Prefix in SUA 6.1 on W7 but I have problems to update Gentoo.

I want to update Portage to rn “emerge –auD world” but I get this error and I can not get:


Code:

root gentoo $ emerge portage

* IMPORTANT: 5 news items need reading for repository 'gentoo_prefix'.
* Use eselect news to read news items.

Calculating dependencies... done!

!!! All ebuilds that could satisfy ">=dev-util/pkgconfig-0.27.1" have been maske
d.
!!! One of the following masked packages is required to complete your request:
- dev-util/pkgconfig-9999::gentoo_prefix (masked by: EAPI 5)
- dev-util/pkgconfig-0.28::gentoo_prefix (masked by: EAPI 5)

The current version of portage supports EAPI '4'. You must upgrade to a
newer version of portage before EAPI masked packages can be installed.
(dependency required by "virtual/pkgconfig-0" [ebuild])
(dependency required by "dev-lang/python-3.3.3" [ebuild])
(dependency required by "sys-apps/portage-2.2.8[python_targets_python3_3]" [ebui
ld])
(dependency required by "portage" [argument])
For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.

* IMPORTANT: 5 news items need reading for repository 'gentoo_prefix'.
* Use eselect news to read news items.



I tried "emerge --nodeps portage" but I can not install it without python3.3


When I run python "emerge --nodpes python", I get this error.

Code:

* configure has detected that the sem_open function is broken.
* Please ensure that /dev/shm is mounted as a tmpfs with mode 1777.
* ERROR: dev-lang/python-3.3.3 failed (configure phase):
* Broken sem_open function (bug 496328)


How I can fix it? Is there a more recent snapshot?

Thanks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Alternative Architectures All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum