Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Any workaround for nvidia-drivers on dom0 Xen Kernel ?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
wichtounet
n00b
n00b


Joined: 17 Mar 2012
Posts: 70

PostPosted: Mon Feb 17, 2014 9:40 pm    Post subject: Any workaround for nvidia-drivers on dom0 Xen Kernel ? Reply with quote

Hi,

I'm trying to run my Gentoo installation as dom0 kernel, but I'm experiencing issues with the nvidia-drivers. I know that they are not officially supported on dom0 kernel, but it seems that some people have been able to make them run. However, I haven't had any success :(

I've installed Xen 4.3.1.

I've tried the versions 331 and 334 of nvidia-drivers.

I've tried with the kernel 3.10.25 and the kernel 3.13.13. In both cases, the symptoms are the same, once I boot in dom0, once NVidia starts, the monitors go black.

I tried the procedure with building the nvidia drivers using IGNORE_XEN_PRESENCE=y, but it didn't seem to make any difference.

I know that I could use nouveau, but nouveau is not powerful enough to handle my three monitors. It takes several times longer to boot and I'm experiencing a lot of flickering. Moreover, it does not seem to like my 2560x1440 monitor. I've tried nouveau of 3.13.3, but with this version, I never succeeded to boot in graphics mode, I had issue with drm not detecting any device in dom0 mode.

Does anyone know of any workaround for this ?

Thanks for any suggestion
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum