Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
No USB devices in VMWare
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
bpaddock
Apprentice
Apprentice


Joined: 04 Nov 2005
Posts: 161
Location: Franklin, PA

PostPosted: Sat Feb 15, 2014 11:01 pm    Post subject: No USB devices in VMWare Reply with quote

I'm trying to run Windows 8.1 (don't ask) under VMWare Workstation 10.

VMWare is not finding USB devices like my webcam (Logitech C525).

I believe VMWare is trying to look in /proc/bus/usb that no longer exists.
I think I need to tell it to use /sys/bus/usb but I can't find any way to make that change; the documentation says /VM/Settings/USB nothing there lets me change the path.

Help?
Back to top
View user's profile Send private message
s4e8
Apprentice
Apprentice


Joined: 29 Jul 2006
Posts: 205

PostPosted: Sun Feb 16, 2014 11:36 am    Post subject: Reply with quote

start vmware-usbarbitrator and try again.
Back to top
View user's profile Send private message
bpaddock
Apprentice
Apprentice


Joined: 04 Nov 2005
Posts: 161
Location: Franklin, PA

PostPosted: Sun Feb 16, 2014 12:32 pm    Post subject: Reply with quote

s4e8 wrote:
start vmware-usbarbitrator and try again.


That worked. How do I get it to start when I start VMWare, seems like it should already be doing that?
Back to top
View user's profile Send private message
Maitreya
Apprentice
Apprentice


Joined: 11 Jan 2006
Posts: 217

PostPosted: Sun Feb 16, 2014 5:06 pm    Post subject: Reply with quote

It should have when installing vmware.
But you can run "services.msc" and then rightclick "VMware USB Arbitration Service" -> Properties -> set startup to Automatic if it not already is.

Edit: Herp derp forget what I wrote. Need to learn to read.
Back to top
View user's profile Send private message
bpaddock
Apprentice
Apprentice


Joined: 04 Nov 2005
Posts: 161
Location: Franklin, PA

PostPosted: Mon Feb 17, 2014 12:39 am    Post subject: Reply with quote

Maitreya wrote:
It should have when installing vmware.
But you can run "services.msc" and then rightclick "VMware USB Arbitration Service" -> Properties -> set startup to Automatic if it not already is.
.


On a Gentoo host?

In services.msc under the Windows 8.1 sercives.msc is VMware Snapshot Provier and VMware Tools.

Wonder if the USB issues not starting is also related to the network never starting correctly either?
I always have to delete net8 and put it back in VMware to get any Internet connection from Windows.
Back to top
View user's profile Send private message
s4e8
Apprentice
Apprentice


Joined: 29 Jul 2006
Posts: 205

PostPosted: Mon Feb 17, 2014 6:12 am    Post subject: Reply with quote

vmware, vmware-USBArbitrator, vmware-workstation-server should be placed under /etc/init.d. by the installer.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum