Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Intel graphic adapter - black screen [SOLVED]
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
piero.turra
n00b
n00b


Joined: 28 Nov 2006
Posts: 39

PostPosted: Mon Feb 10, 2014 10:20 am    Post subject: Intel graphic adapter - black screen [SOLVED] Reply with quote

Hello, I installed Gentoo on my new computer, my motherboard (ASROCK AD2550B-ITX) is equipped with an integrated graphic adapter (GMA3600), I included the support on the kernel, but just after the boot my monitor switch to powersave mode and I can use the computer only through an ssh client. When I try to start the X server it fails with the "no screens found" error.

lspci -v :
Code:
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 0b) (prog-if 00 [VGA controller])
        Subsystem: ASRock Incorporation Device 0be2
        Flags: bus master, fast devsel, latency 0, IRQ 42
        Memory at dfd00000 (32-bit, non-prefetchable) [size=1M]
        I/O ports at f0f0 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [d0] Power Management version 2
        Capabilities: [b0] Vendor Specific Information: Len=07 <?>
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Kernel driver in use: gma500



dmesg | grep gma :
Code:
[    1.042828] gma500 0000:00:02.0: setting latency timer to 64
[    1.042982] gma500 0000:00:02.0: irq 42 for MSI/MSI-X
[    1.116645] gma500 0000:00:02.0: trying to get vblank count for disabled pipe 1
[    1.116741] gma500 0000:00:02.0: trying to get vblank count for disabled pipe 1
[    1.301140] [drm] Initialized gma500 1.0.0 2011-06-06 for 0000:00:02.0 on minor 0


My kernel configuration:
Code:
Device Drivers -->
    Graphic Support -->
       <*> /dev/agpgart (AGP Support)  --->
            <*>   Intel 440LX/BX/GX, I8xx and E7x05 chipset support
       <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->
       <*> Intel GMA5/600 KMS Framebuffer
       [*]   Intel GMA3600/3650 support (Experimental)         


Have you any ideas how I can solve this problem?


Last edited by piero.turra on Sat Mar 01, 2014 6:53 pm; edited 1 time in total
Back to top
View user's profile Send private message
spike88
n00b
n00b


Joined: 16 Oct 2012
Posts: 17

PostPosted: Mon Feb 17, 2014 10:55 pm    Post subject: Reply with quote

try to boot with the this kernel arguement
Code:
 nomodeset

_________________
Gentoo Rocks thanks!
Back to top
View user's profile Send private message
Gusar
Advocate
Advocate


Joined: 09 Apr 2005
Posts: 2642
Location: Slovenia

PostPosted: Mon Feb 17, 2014 11:16 pm    Post subject: Reply with quote

spike88 wrote:
try to boot with the this kernel arguement
Code:
 nomodeset
Considering gfx_gma500 is a modesetting driver, this would effectively disable the entire driver. nomodeset is *never* a solution.

@piero.turra: I have only one piece of advice - sell that thing and buy something with a proper GPU. And I mean that fully seriously. The GMA3600 isn't an Intel GPU, it's a PowerVR one. There's no spec available for it, only a closed source driver that sorta, maybe could work with ancient kernels and X servers, but I don't know anyone who actually got it to work. The gfx_gma500 driver is modesetting-only, there's no acceleration whatsoever. If you want to know more, search around for CedarView. But again, get rid of this thing and buy something Haswell-based or BayTrail-based. Haswell and BayTrail are proper Intel GPUs with full open-source support.

PS. If you do get the gfx_gma500 driver running, it's meant to be used with the xf86-video-modesetting X driver.
Back to top
View user's profile Send private message
DaggyStyle
Advocate
Advocate


Joined: 22 Mar 2006
Posts: 4924

PostPosted: Tue Feb 18, 2014 6:17 am    Post subject: Re: Intel graphic adapter - black screen Reply with quote

piero.turra wrote:
Hello, I installed Gentoo on my new computer, my motherboard (ASROCK AD2550B-ITX) is equipped with an integrated graphic adapter (GMA3600), I included the support on the kernel, but just after the boot my monitor switch to powersave mode and I can use the computer only through an ssh client. When I try to start the X server it fails with the "no screens found" error.

lspci -v :
Code:
00:02.0 VGA compatible controller: Intel Corporation Atom Processor D2xxx/N2xxx Integrated Graphics Controller (rev 0b) (prog-if 00 [VGA controller])
        Subsystem: ASRock Incorporation Device 0be2
        Flags: bus master, fast devsel, latency 0, IRQ 42
        Memory at dfd00000 (32-bit, non-prefetchable) [size=1M]
        I/O ports at f0f0 [size=8]
        Expansion ROM at <unassigned> [disabled]
        Capabilities: [d0] Power Management version 2
        Capabilities: [b0] Vendor Specific Information: Len=07 <?>
        Capabilities: [90] MSI: Enable+ Count=1/1 Maskable- 64bit-
        Kernel driver in use: gma500



dmesg | grep gma :
Code:
[    1.042828] gma500 0000:00:02.0: setting latency timer to 64
[    1.042982] gma500 0000:00:02.0: irq 42 for MSI/MSI-X
[    1.116645] gma500 0000:00:02.0: trying to get vblank count for disabled pipe 1
[    1.116741] gma500 0000:00:02.0: trying to get vblank count for disabled pipe 1
[    1.301140] [drm] Initialized gma500 1.0.0 2011-06-06 for 0000:00:02.0 on minor 0


My kernel configuration:
Code:
Device Drivers -->
    Graphic Support -->
       <*> /dev/agpgart (AGP Support)  --->
            <*>   Intel 440LX/BX/GX, I8xx and E7x05 chipset support
       <*> Direct Rendering Manager (XFree86 4.1.0 and higher DRI support)  --->
       <*> Intel GMA5/600 KMS Framebuffer
       [*]   Intel GMA3600/3650 support (Experimental)         


Have you any ideas how I can solve this problem?

please post the output of emerge --info
_________________
Only two things are infinite, the universe and human stupidity and I'm not sure about the former - Albert Einstein
ProjectFootball
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1663
Location: Berlin, Germany

PostPosted: Tue Feb 18, 2014 7:09 pm    Post subject: Reply with quote

Ensure that you have CONFIG_FRAMEBUFFER_CONSOLE enabled in your kernel, and if it is built as module, that it is loaded during boot (via /etc/conf.d/modules).
Back to top
View user's profile Send private message
piero.turra
n00b
n00b


Joined: 28 Nov 2006
Posts: 39

PostPosted: Tue Feb 25, 2014 7:32 am    Post subject: Reply with quote

Thank you for the answers. I'm been away for a couple of days and I didn't check the forum, now I will follow your advices.
Back to top
View user's profile Send private message
piero.turra
n00b
n00b


Joined: 28 Nov 2006
Posts: 39

PostPosted: Tue Feb 25, 2014 12:02 pm    Post subject: Reply with quote

The CONFIG_FRAMEBUFFER_CONSOLE option is enabled and is not possible to change it (I'm using menuconfig).

this is the result of emerge --info

Code:
ACCEPT_KEYWORDS="x86"
ACCEPT_LICENSE="* -@EULA"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/config /usr/share/gnupg/qualified.txt"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/gentoo-release /etc/sandbox.d /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FCFLAGS="-O2 -march=i686 -pipe"
FEATURES="assume-digests binpkg-logs config-protect-if-modified distlocks ebuild-locks fixlafiles merge-sync news parallel-fetch preserve-libs protect-owned sandbox sfperms strict unknown-features-warn unmerge-logs unmerge-orphans userfetch userpriv usersandbox usersync"
FFLAGS="-O2 -march=i686 -pipe"
GENTOO_MIRRORS="http://gd.tuwien.ac.at/opsys/linux/gentoo/ ftp://gd.tuwien.ac.at/opsys/linux/gentoo/ http://mirrors.linuxant.fr/distfiles.gentoo.org/ ftp://mirrors.linuxant.fr/distfiles.gentoo.org/"
LANG="it_IT"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --omit-dir-times --compress --force --whole-file --delete --stats --human-readable --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY=""
SYNC="rsync://rsync.fr.gentoo.org/gentoo-portage"
USE="X a52 aac acl acpi alsa berkdb bluetooth branding bzip2 cairo cdda cdr cli consolekit cracklib crypt cups cxx dbus declarative dri dts dvd dvdr emboss encode exif fam firefox flac fortran gdbm gif gpm iconv ipv6 jpeg kde kipi lcms ldap libnotify mad mng modules mp3 mp4 mpeg ncurses nls nptl ogg opengl openmp pam pango pcre pdf phonon plasma png policykit ppds qt3support qt4 readline sdl semantic-desktop session spell ssl startup-notification svg tcpd tiff truetype udev udisks unicode upower usb vorbis wxwidgets x264 x86 xcb xcomposite xinerama xml xscreensaver xv xvid zlib" ABI_X86="32" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" APACHE2_MODULES="authn_core authz_core socache_shmcb unixd actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache cgi cgid dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CALLIGRA_FEATURES="kexi words flow plan sheets stage tables krita karbon braindump author" CAMERAS="ptp2" COLLECTD_PLUGINS="df interface irq load memory rrdtool swap syslog" ELIBC="glibc" GPSD_PROTOCOLS="ashtech aivdm earthmate evermore fv18 garmin garmintxt gpsclock itrax mtk3301 nmea ntrip navcom oceanserver oldstyle oncore rtcm104v2 rtcm104v3 sirf superstar2 timing tsip tripmate tnt ublox ubx" INPUT_DEVICES="evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LIBREOFFICE_EXTENSIONS="presenter-console presenter-minimizer" LINGUAS="it" OFFICE_IMPLEMENTATION="libreoffice" PHP_TARGETS="php5-5" PYTHON_SINGLE_TARGET="python2_7" PYTHON_TARGETS="python2_7 python3_3" RUBY_TARGETS="ruby19 ruby18" USERLAND="GNU" VIDEO_CARDS="intel" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, PORTAGE_BUNZIP2_COMMAND, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, USE_PYTHON
Back to top
View user's profile Send private message
mvaterlaus
Apprentice
Apprentice


Joined: 01 Oct 2010
Posts: 150
Location: Switzerland

PostPosted: Tue Feb 25, 2014 12:38 pm    Post subject: Reply with quote

hey,
I also strugled with a similar intel graphics card. Since I couldn't get a proper solution, I'm now using a console tool for waking up the display.

Code:

/usr/sbin/vbetool dpms on


Of course, you need to install vbetool. After that, try to log in via ssh and issue the above command. In my case, the display is "waking up".
_________________
For calming down your eyes or clearing your mind: www.patrickwehli.ch
Back to top
View user's profile Send private message
piero.turra
n00b
n00b


Joined: 28 Nov 2006
Posts: 39

PostPosted: Wed Feb 26, 2014 1:18 pm    Post subject: Reply with quote

mvaterlaus wrote:
hey,
I also strugled with a similar intel graphics card. Since I couldn't get a proper solution, I'm now using a console tool for waking up the display.

Code:

/usr/sbin/vbetool dpms on


Of course, you need to install vbetool. After that, try to log in via ssh and issue the above command. In my case, the display is "waking up".


Unfortunately this command doesn't work for me, the screen remains sadly black.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1663
Location: Berlin, Germany

PostPosted: Thu Feb 27, 2014 2:58 am    Post subject: Reply with quote

It is possible that the driver misdetects the supported resolution/refresh rate of your monitor. You can try passing video=1024x768 or similar kernel parameter in your boot loader.

About X, you need to have xf86-video-modesetting installed, or set VIDEO_CARDS="modesetting" in make.conf prior to emerging x11-base/xorg-drivers.
Back to top
View user's profile Send private message
piero.turra
n00b
n00b


Joined: 28 Nov 2006
Posts: 39

PostPosted: Sat Mar 01, 2014 6:52 pm    Post subject: Reply with quote

With the modesetting flag the X server starts correctly, and the monitor works when the X server is active. I tried some different video mode configurations but the screen remain black until the start of the X server. Anyway the system is usable so I will mark the discussion as solved.
Back to top
View user's profile Send private message
chithanh
Developer
Developer


Joined: 05 Aug 2006
Posts: 1663
Location: Berlin, Germany

PostPosted: Sun Mar 02, 2014 8:13 pm    Post subject: Reply with quote

You can try force enabling a particular output with the video= kernel parameter. See http://nouveau.freedesktop.org/wiki/KernelModeSetting/ at the bottom (applies to non-NVidia cards too). The list of outputs can be found in /sys/class/drm/card0/.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum