Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[solved] Dspam crash at startup
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 460
Location: Oslo, Norway

PostPosted: Sun Feb 02, 2014 2:56 pm    Post subject: [solved] Dspam crash at startup Reply with quote

I've emerged dspam and copied the config from a running server.
But I can't get the dspam service to run.

This is as far as I get:
Code:

/etc/init.d/dspam start
 * Starting dspam ...                                                                        [ ok ]


In /var/log/messages I get this line:
Code:

Feb  2 15:43:41 localhost dspam[23019]: Daemon process starting


But if I do rc-status I see this:
Code:

# rc-status
Runlevel: default
....
 dspam                                                                                  [  crashed  ]



There is nothing else showing up in any log file. Where do I start debugging this?

dspam --version returns:

Code:

DSPAM Anti-Spam Suite 3.10.2 (agent/library)

Copyright (C) 2002-2012 DSPAM Project
http://dspam.sourceforge.net.

DSPAM may be copied only under the terms of the GNU Affero General Public
License, a copy of which can be found with the DSPAM distribution kit.

Configuration parameters:  '--prefix=/usr' '--build=x86_64-pc-linux-gnu' '--host=x86_64-pc-linux-gnu' '--mandir=/usr/share/man' '--infodir=/usr/share/info' '--datadir=/usr/share' '--sysconfdir=/etc' '--localstatedir=/var/lib' '--libdir=/usr/lib64' '--disable-dependency-tracking' '--sysconfdir=/etc/dspam' '--with-dspam-home=/var/spool/dspam' '--with-dspam-home-group=dspam' '--with-dspam-mode=2510' '--with-dspam-group=dspam' '--with-logdir=/var/log/dspam' '--enable-external-lookup' '--enable-long-usernames' '--enable-split-configuration' '--enable-clamav' '--enable-daemon' '--disable-debug' '--disable-bnr-debug' '--disable-verbose-debug' '--enable-domain-scale' '--disable-large-scale' '--disable-static' '--enable-syslog' '--disable-homedir' '--enable-virtual-users' '--with-storage-driver=hash_drv,mysql_drv,hash_drv,mysql_drv' '--with-mysql-includes=/usr/include/mysql' '--enable-preferences-extension' 'build_alias=x86_64-pc-linux-gnu' 'host_alias=x86_64-pc-linux-gnu' 'CFLAGS=-O2 -pipe' 'LDFLAGS=-Wl,-O1 -Wl,--as-needed'


Last edited by petterg on Sun Feb 02, 2014 9:38 pm; edited 1 time in total
Back to top
View user's profile Send private message
petterg
Guru
Guru


Joined: 25 Mar 2004
Posts: 460
Location: Oslo, Norway

PostPosted: Sun Feb 02, 2014 9:37 pm    Post subject: Reply with quote

Turns out that just by removing the # from
#ServerPID /var/run/dspam.pid
in the default dspam.conf causes dspam to crash.

This is a 64bit installation. The server I copied the config from is 32bit and had this setting uncommented. I guess this is a 64-bit issue only.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum